14:00:00 <rosmaita> #startmeeting glance
14:00:01 <openstack> Meeting started Thu Jan  5 14:00:00 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:06 <openstack> The meeting name has been set to 'glance'
14:00:10 <rosmaita> #topic roll call
14:00:12 <sigmavirus> o/
14:00:20 <rosmaita> sigmavirus: you are too quick!
14:00:20 <abhishekk> o/
14:00:21 <sigmavirus> Happy New Year!
14:00:28 <sigmavirus> rosmaita: or am I QUIC?
14:00:35 <stevelle> o/
14:00:38 * sigmavirus hopes that joke doesn't go over anyone's TCP layer
14:00:38 <jokke_> o.
14:00:38 <abhishekk> Happy New Year..
14:00:42 <dharinic> \o
14:00:57 * sigmavirus is in a punnnchy mood
14:01:06 <rosmaita> well, happy new year, anyway
14:01:18 <jokke_> Happy New Year everyone!
14:01:29 <rosmaita> ok, we're expecting a light turnout today, so we can get started
14:01:50 <rosmaita> #topic priority item review
14:02:08 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2016-December/109375.html
14:02:23 <rosmaita> looks like not much action, but it was the holidays
14:02:38 <abhishekk> for request-id, I have added comment for sigmavirus, please have a look on the same
14:02:48 <rosmaita> abhishekk: ty
14:03:25 <sigmavirus> will do abhishekk
14:03:30 <abhishekk> also, I am working on member-id schema issue (oneOf implementation)
14:03:38 <rosmaita> great
14:03:40 <abhishekk> thank you sigmavirus
14:03:59 <abhishekk> soon propose a patch for same
14:04:05 <rosmaita> sounds good
14:04:32 <rosmaita> ok, let's move quickly to user survey question, then i want to update on the community images situation
14:04:41 <rosmaita> #topic user survey question
14:04:58 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2016-December/109376.html
14:05:22 <rosmaita> jokke_ had a suggestion on the ML
14:06:08 <rosmaita> I'd like to have question "Which Images Api Version are you using?
14:06:08 <rosmaita> Pick any that applies. a) v1 b) v2; If v1, Why?"
14:06:08 <rosmaita> Could help us prioritizing the work needed to get everybody off from
14:06:11 <rosmaita> v1 and it out of support.
14:06:16 <rosmaita> (that's a quote from jokke_ )
14:06:21 <jokke_> ++
14:07:04 <sigmavirus> I think more specifically "Why haven't you moved to v2?"
14:07:10 <rosmaita> ++
14:07:10 <sigmavirus> or "What prevents you from moving to v2?"
14:07:17 <rosmaita> sigmavirus: you're reading my mind
14:07:40 <rosmaita> let's ask it in a way that it's obvious that v1 has been deprecated and is being removed soon
14:07:52 <jokke_> for once I tried, I really tried to turn that question setting to positive tone ;)
14:08:06 <rosmaita> jokke_: your efforts are appreciated!
14:08:12 <sigmavirus> it's too opaque though
14:08:19 <sigmavirus> the effort was  good one though
14:08:27 <sigmavirus> it wasn't condescending ;)
14:08:32 <jokke_> :P
14:08:50 <rosmaita> we can have a "short answer" style question
14:09:16 <jokke_> we could also put there "Which Images API version is still supported? Pick one: a) v2" :P
14:09:22 <rosmaita> :)
14:09:33 <rosmaita> win fabulous prizes!
14:09:59 <rosmaita> ok, i'll put up an etherpad and we can refine the question along the lines sigmavirus suggests
14:10:16 <rosmaita> i think it's a good suggestion, so thanks jokke_
14:10:28 <jokke_> yeah ... I'm happy with that ... I'd just like to get everyone over with that specific topic :D
14:11:04 <rosmaita> #action rosmaita put up etherpad to revise survey question & send email to dev list to get comments
14:11:22 <rosmaita> ok, moving along
14:11:35 <rosmaita> next item isn't on the agenda, but what the heck
14:11:42 <rosmaita> #topic community images impasse
14:12:05 <jokke_> I was just gonna ask if we should discuss this as part of the priority or do we have own topic for it
14:12:21 <rosmaita> yeah, can be own topic
14:12:29 <rosmaita> the quick summary is
14:12:40 <rosmaita> stevelle explained this at the last meeting
14:12:56 <rosmaita> the qa team has a problem with a patch he proposed
14:13:11 <rosmaita> they don't like the backward-incompatibility in the workflow for image sharing
14:13:40 <rosmaita> the incompatibility is that now you get a 409 if you try to add a member to an image that is not in visibility == shard
14:14:00 <rosmaita> previously, the operation would succeed on an image with visibility==private
14:14:19 <rosmaita> we've discussed the heck out of this change and why it makes sense
14:14:23 <jokke_> I did not reply to the ML chain but I added my comment on the etherpad
14:14:49 <rosmaita> #link https://etherpad.openstack.org/p/glance-ocata-community-images-tempest-continued
14:14:57 <rosmaita> jokke_: thanks for the reminder
14:15:24 <jokke_> I'd also like to point out that the timeline was misleading and I took it wrong ... that test change has been inflight for months, it was not something super new that popped up conveniently just before we merged the change
14:15:37 <rosmaita> good to know
14:15:47 <sigmavirus> Yeah, the QA team is not out to get us
14:15:54 <rosmaita> that's a relief!
14:15:55 <sigmavirus> I can sympathize with both us and them
14:16:03 <jokke_> same here
14:16:37 <jokke_> and like I commented to the etherpad IMHO now we need to decide which one we disappoint. The QA team or users and the community
14:16:45 <stevelle> confessing I didn't read that etherpad yet
14:16:46 <sigmavirus> we dont' have time for microversioning so keeping private->shared auto-transition functionality seems like the best path forward
14:16:47 <rosmaita> my problem ATM is that if we take the api stability guidelines literally, this entire change cannot happen
14:17:02 <jokke_> rosmaita: ++
14:17:07 <rosmaita> i.e., we cannot even have 'community' visibility
14:17:10 <sigmavirus> I'm not sure I agree rosmaita
14:17:15 <stevelle> it could with microversioning
14:17:33 <jokke_> well microversioning is just excuse to break the rules
14:17:40 <sigmavirus> expansions of the API are okay, and as I understand this change, it's an expansion if we implement private -> shared transition for users
14:17:55 <jokke_> and I'm really not liking how it's treated ... not fond of us going there
14:18:04 <dharinic> agree with sigmavirus
14:18:07 <sigmavirus> I don't agree jokke_
14:18:30 <rosmaita> let's take a look at the docs
14:18:33 <rosmaita> #link http://specs.openstack.org/openstack/api-wg/guidelines/evaluating_api_changes.html
14:18:55 <rosmaita> under "The following types of changes are generally not considered acceptable:"
14:19:05 <rosmaita> "Changing or removing a property in a resource representation."
14:19:43 <sigmavirus> rosmaita: so the property in question is visibility which has possible values of {"private", "public"} yes?
14:19:44 <rosmaita> the guidelines mention "API extensions" which have been eliminated in favor of microversions (in nova, at least)
14:19:50 <rosmaita> sigmavirus: yes
14:19:53 <sigmavirus> extension != expansion
14:19:58 <rosmaita> right
14:20:05 <rosmaita> extensions are ok
14:20:18 <sigmavirus> rosmaita: and we're talking about adding states to "visibility" to make the possible values {"private", "shared", "public", "community"} yes?
14:20:29 <rosmaita> sigmavirus: yes
14:21:02 <jokke_> sigmavirus: and that changes the representation of the property, no?
14:21:19 <sigmavirus> so while the underlying semantics have changes, the representation contract hasn't strictly been broken, it's been expanded
14:21:48 <stevelle> this may fall under "Changing the semantics of a property in a resource representation which may be supplied by clients."
14:21:53 <sigmavirus> yes it's a change, but I think your interpretations (rosmaita & jokke_) are too literal
14:22:11 <rosmaita> stevelle: yes, which is also not allowed
14:22:16 <stevelle> but I don't think it violates the above meaningfully if we implement private -> shared
14:22:48 <rosmaita> sigmavirus: yes, my point is that the guidelines are probably not meant to be taken literally
14:23:00 <rosmaita> so the question is, who decides what is OK and what not?
14:23:01 <sigmavirus> stevelle++
14:23:22 <rosmaita> stevelle: you mean the automatic transition?
14:24:03 <stevelle> yes
14:24:26 <jokke_> the auto transition breaks actually two of the guidelines ... it breaks the representation and the semantics
14:24:32 <stevelle> rosmaita: I believe that question is legitimate, but not ultimately going to solve anything
14:25:11 <rosmaita> stevelle: you are probably correct
14:25:17 <rosmaita> but this is why i'm raising it
14:25:43 <rosmaita> although i am having trouble articulating it
14:25:44 <hemanthm> stevelle: I thought we didn't want to do automatic transitions. Also, if we are doing private->shared, what is the point of making shared as the default state?
14:25:53 <jokke_> rosmaita: wasn't API WG ok with the change already?
14:26:08 <rosmaita> jokke_: that was my understanding
14:26:10 <jokke_> rosmaita: and they are behind these guidelines?
14:26:21 <rosmaita> jokke_: well, that's an interesting question
14:26:29 <rosmaita> i think the guidelines predate the API-WG
14:26:46 <jokke_> well the guidelines lives under api-wg if you look the uri
14:26:48 <rosmaita> although, i am very possibly wrong about that
14:26:55 <rosmaita> was just noticing that!
14:27:50 <stevelle> API WG drafted that guideline
14:28:23 <rosmaita> does anyone know if there's an api-wg meeting this week?
14:28:28 <stevelle> hemanthm: we didn't originally, but if we did that state transition the Tempest cores don't currently have any way of stopping us from implementing the feature
14:28:32 <sigmavirus> rosmaita: it was last night
14:28:41 <sigmavirus> (if my calendar is still accurate)
14:28:47 <stevelle> I don't think that is correct
14:29:05 <sigmavirus> oh it's changed
14:29:09 <sigmavirus> it's in 2 hours
14:29:11 <stevelle> yes
14:29:15 <sigmavirus> http://eavesdrop.openstack.org/#API_Working_Group
14:29:24 <rosmaita> just not sure if it's cancelled for today
14:29:33 <rosmaita> i'm thinking it is, but can't find the email
14:29:34 <stevelle> I dont believe it is cancelled
14:29:35 <sigmavirus> hold, please
14:30:16 <sigmavirus> your call is important to us. A representative will be with you shortly ;)
14:30:32 <sigmavirus> There is
14:30:44 <sigmavirus> (from cdent in #openstack-sdks)
14:30:49 <rosmaita> great
14:31:13 <rosmaita> please scroll to the bottom of https://etherpad.openstack.org/p/glance-ocata-community-images-tempest-continued
14:31:23 <rosmaita> i put 3 questions in there
14:32:12 <rosmaita> just want to make sure these are the correct things to ask the API-WG
14:32:16 <stevelle> the way those are written, it doesn't prequalify that the minor api version is not a microversion
14:32:27 <stevelle> otherwise ++
14:33:04 <jokke_> rosmaita: A(4) very direct and blunt way :D
14:33:07 <jokke_> waait ....
14:33:52 <rosmaita> stevelle: would you suggest i preface this with, "given that glance currently doesn't do microversions ..."
14:34:30 <jokke_> rosmaita: you can even drop that 'currently'
14:34:34 <stevelle> maybe "doesn't adhere to the WG guideline for microversions"
14:34:53 <jokke_> rosmaita: as that is not even inflight condition
14:35:25 <rosmaita> stevelle: not so much "doesn't adhere" as "has not adopted microversions"
14:35:33 <stevelle> that works
14:35:41 <rosmaita> it isn't a requirement yet, though someone did propose it as a community goal
14:35:51 <rosmaita> (to implement micorversioning in all apis)
14:36:10 <jokke_> that is horrible idea ... do you have the review for that?
14:36:35 <stevelle> don't think it made it past an etherpad stage jokke_
14:36:43 <jokke_> pfeeew
14:36:45 <rosmaita> jokke_: i think it's on the etherpad
14:36:49 <rosmaita> what stevelle said
14:37:13 <stevelle> it is not in consideration for Pike
14:38:03 <rosmaita> ok, i'll put us on the API-WG agenda for today
14:38:18 <rosmaita> anyone who can make the meeting (1600 utc today), please do
14:38:43 <rosmaita> #action rosmaita put glance community images impasse on API-WG agenda
14:38:54 <rosmaita> any other comments?
14:39:59 <dharinic> here is the patch for the auto transition (the only way as of now that gets us past tempest) https://review.openstack.org/#/c/415306/
14:40:42 <rosmaita> dharinic: thanks for being on top of this
14:41:02 <dharinic> Sure rosmaita
14:41:27 <stevelle> comment: I'm not happy about the concern jokke_ raised, even if I don't feel it is a fight we should take right now
14:41:36 <dharinic> I know it kind of voids the purpose of "shared", but it does prevent the backward incompatibility as the qa team say.
14:41:47 <jokke_> stevelle: which one?
14:41:58 <stevelle> using the WG guideline as a cudgel
14:42:17 <rosmaita> stevelle: how do you mean?
14:43:14 <stevelle> rosmaita: it's related to the question you posed before: who decides what is OK and what not?
14:43:28 <rosmaita> here's my real worry about this.  we can make the change in dharinic 's patch, to pass the tempest tests.  but that doesn't necessarily mean that we are living the spirit of the api guidelines
14:43:51 <rosmaita> and i'm worried that if we do follow the guidelines, the entire CI patch is not allowable
14:44:19 <jokke_> rosmaita: we would not, we would be just working around what QA tests
14:44:32 <stevelle> the WG was chartered with a heavy emphasis on consensus and non-binding guidelines. I feel as if this issue with Tempest tests is against the spirit of that
14:44:50 <rosmaita> stevelle: that's well-put
14:45:07 <jokke_> and thus I'm against that approach. I was once convinced why the auto transform is not good idea. I don't think we should do it just because it gets us around what QA tests
14:45:12 <stevelle> but I know the WG internally struggled with that non-binding nature since the charter, so it's not an open-closed thing
14:46:02 <rosmaita> let's move to open discussion
14:46:13 <rosmaita> (we can continue this if there's nothing else)
14:46:17 <rosmaita> #topic open discussion
14:46:41 <rosmaita> i'll put a quick summary of the issue and our questions for the api-wg on an etherpad
14:47:21 <rosmaita> #link https://etherpad.openstack.org/p/glance-ocata-community-images-api-stability
14:47:24 <dharinic> rosmaita: How much time do we have with respect to CI getting in this cycle?
14:47:33 <rosmaita> dharinic: not much
14:47:44 <rosmaita> we need to decide this quickly
14:48:21 <rosmaita> like, within a few days
14:48:33 <dharinic> Yes. Re reading the 2 email responses we got from tempest on the ML, the 2 things they suggest are 1) microversioning 2)auto transition private->shared
14:48:43 <dharinic> okay
14:49:11 <dharinic> Hope the api-wg meeting helps us decide faster
14:50:45 <rosmaita> dharinic: ++
14:51:56 <hemanthm> We should probably involve tempest folks also when talking to API WG.
14:52:24 <stevelle> ++
14:52:33 <sigmavirus> hemanthm: good idea
14:53:40 <rosmaita> how should we notify them?
14:53:48 <sigmavirus> the QA folks?
14:53:54 <sigmavirus> Probably poke them in #openstack-qa
14:54:43 <rosmaita> #action rosmaita to poke tempest folks in #openstack-qa
14:56:57 <rosmaita> ok, guess there's nothing new to discuss?
14:57:42 <jokke_> Thanks all, good discussion again!
14:57:48 <jokke_> Starting the year strong
14:57:55 <jokke_> :)
14:58:50 <hemanthm> rosmaita: We aren't making much progress on the rolling upgrades front.
14:59:13 <rosmaita> hemanthm: what's the blocker? community images?
14:59:23 <stevelle> times up
14:59:24 <hemanthm> rosmaita: and reviews
14:59:42 <rosmaita> ok, will note in priority email
14:59:48 <stevelle> we should continue this topic in #openstack-glance
14:59:48 <rosmaita> ok, thanks everyone!
14:59:51 <rosmaita> and happy new year
14:59:59 <rosmaita> #endmeeting