14:00:08 <sigmavirus> #startmeeting glance
14:00:09 <openstack> Meeting started Thu Oct 20 14:00:08 2016 UTC and is due to finish in 60 minutes.  The chair is sigmavirus. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:12 <openstack> The meeting name has been set to 'glance'
14:00:18 <sigmavirus> #topic roll call
14:00:21 <tsymanczyk> \o
14:00:22 <sigmavirus> o/
14:00:35 <hemanth|away> o/
14:00:39 <alex_bash> o/
14:00:44 <dharinic> \o
14:01:03 <mfedosin> o/
14:01:40 <sigmavirus> I think today's going to be a light meeting and rosmaita is not around
14:01:54 <sigmavirus> Anyway, let's work through our agenda
14:01:57 <sigmavirus> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:03 <sigmavirus> #topic Updates
14:02:44 <sigmavirus> rosmaita: was going to talk about "Import Refactor" so, I'll copy their status updates from the agenda
14:03:06 <sigmavirus> #info Import Refactor - general strategy is to get the stage ("bikeshed") -> backend transition working, possibly also working on validation of the bikeshed content concurrently, saving the API facing stuff for later -- rosmaita
14:03:31 <sigmavirus> All y'all going to the summit next week who are working on the Import Refactor will be meeting there
14:03:50 <sigmavirus> #info Import Refactor -  weekly syncs are logged: http://eavesdrop.openstack.org/meetings/image_import_sync/
14:04:03 <sigmavirus> tsymanczyk: Can you talk about the Community Images work?
14:04:12 <tsymanczyk> sure
14:05:00 <tsymanczyk> so the one thing that i know is lacking in the now one-true-changeset is a set of unit tests to prove the accessibility of the new community visibility values. other than that i'm at a loss for what else to do.
14:05:14 <tsymanczyk> there's been some more great feedback, which i've tried to always respond to ASAP
14:05:42 <tsymanczyk> oh, a couple days ago i realized that the spec had called for protecting the community visibility value with a new policy item, so that's been added (as well as unit tests).
14:06:16 <nikhil> .\
14:06:21 <tsymanczyk> so yeah... the unfortunate news is that after this summit, my company is moving me to an entirely different openstack unrelated team, so finding any significant time for this is going to be a challenge.
14:06:34 <tsymanczyk> i intend to get the last known missing test in there today or tomorrow
14:06:43 <tsymanczyk> and spend work time at the summit just testing and doing whatever i can
14:06:59 <tsymanczyk> but i don't know what else to do to get this 'in'.
14:07:12 <nikhil> Ouch
14:07:22 <tsymanczyk> also jenkins seems to be failing right now, and if it's a legitimate failure i can't (yet) see how.
14:07:33 <tsymanczyk> i think that's all i have.
14:08:01 <nikhil> I am a bit caught up today but if the weekly sync happens tomorrow, I can be there to chat
14:08:03 <tsymanczyk> yeah it'd be a shame to get this far and then just have it rot / abandoned.
14:08:14 <tsymanczyk> i'll be there for the sync.
14:08:15 <hemanth> tsymanczyk: sound great, I'll commit to reviewing community images in the coming days
14:08:38 <tsymanczyk> any help or input is deeply appreciated.
14:08:45 <hemanth> tsymanczyk: also, dharinic has shown interest in helping with community images.
14:09:48 <dharinic> Yes. I would love to help.
14:10:23 <hemanth> maybe dharinic can help with any changes required after the summit when you can't work on community images any more
14:10:46 * nikhil &
14:10:55 <hemanth> I don't think it's going to rot :)
14:11:56 <tsymanczyk> i'll still go out of my way to find a few hours should something come up, but community images won't be a focus of mine anymore. not really sure what else i can do at this point but finish the last unit test and ocd manual test test test
14:13:13 <hemanth> tsymanczyk: looks like we just need reviews at this point. And, unfortunately the closer we get to the summit the reviews tend to dwindle
14:13:34 <hemanth> I think the initial goal was to get this merged before the summmit, right?
14:14:17 <tsymanczyk> that was rosmaita's plan after i pm'd him a month ago that i would need to be moving on after the summit. i'm not sure that really came together.
14:14:26 <tsymanczyk> but we haven't discussed it explicitly.
14:14:31 <Jokke_> o/
14:15:22 <tsymanczyk> oh i'll be missing the next two weeks of meetings (this irc meeting and the comm imgs sync)... fyi anyone who cares.
14:15:33 <sigmavirus> tsymanczyk: that bridges the gap nicely :)
14:15:33 <tsymanczyk> summit then vacation.
14:15:40 <sigmavirus> There is no meeting next week :)
14:15:45 <sigmavirus> #info No meeting on Oct 27
14:15:53 <tsymanczyk> phew, just the ones after that then. .
14:15:57 <sigmavirus> :)
14:16:01 <sigmavirus> o/ Jokke_
14:16:18 <sigmavirus> #info Reviewing the Community Images work is a priority
14:16:48 <sigmavirus> #action dharinic hemanth sigmavirus to review community images work by tsymanczyk
14:16:58 <sigmavirus> tsymanczyk: we good to move along?
14:17:02 <hemanth> aye
14:17:17 <tsymanczyk> i'm done, yeah, thanks for checking.
14:17:25 <sigmavirus> #topic  Glance core security team reorganization
14:17:33 <sigmavirus> #link http://lists.openstack.org/pipermail/openstack-dev/2016-October/105994.html
14:18:03 <sigmavirus> #action Glance team members (non-cores and cores) to respond before Wed 26 Oct 2016
14:19:35 <sigmavirus> #topic Glance Summit Planning
14:19:44 <sigmavirus> #info Ocata Design Summit planning etherpad now contains all session info, etherpad links
14:19:49 <sigmavirus> #link     https://etherpad.openstack.org/p/ocata-glance-summit-planning
14:20:24 <sigmavirus> #action Add points to be discussed at the summit for each session, whether you'll be at the summit or not
14:20:38 <sigmavirus> #action if you are going, look at the cross-project workshops listed at the etherpad, it would be good for Glance to be represented at as many as possible
14:21:12 <sigmavirus> #topic Open Discussion
14:21:18 <croelandt> Wed 26 5:55-5:35  hm
14:21:37 <rosmaita> sigmavirus: thanks for handling the meeting
14:21:38 <tsymanczyk> efficient!
14:22:08 <sigmavirus> rosmaita: no problem
14:22:11 <sigmavirus> #chair rosmaita
14:22:12 <openstack> Current chairs: rosmaita sigmavirus
14:22:20 <rosmaita> croelandt: guess it would be a good idea to verify the times of the sessions
14:22:55 <rosmaita> #action everyone attending the summit, use the official schedule, not the etherpad for times/locations
14:23:13 <Jokke_> indeed sigmavirus, we need to get you chairing our meetings more often (no offence to any previous chairs) ;)
14:23:34 <rosmaita> i agree, reading back, looks like it was smooth and efficient
14:24:00 * sigmavirus shrugs
14:24:09 * Jokke_ is currently too sick to interrupt
14:24:21 <nikhil> Ack to reviewing CI
14:25:13 <rosmaita> looks like no one has anything to discuss?
14:25:57 <Jokke_> I'm knee deep in taskflows
14:26:15 <rosmaita> guess i just want to toss out a reminder about the Project Team Gathering in February ... start bugging your managers about travel early
14:26:18 <nikhil> rosmaita: just to confirm..
14:26:24 <Jokke_> really haven't been able to focus anything else past week and trying to keep that focus on
14:26:25 <sigmavirus> rosmaita++
14:26:31 <nikhil> I won't be at Barcelona
14:26:38 <rosmaita> nikhil: bummer
14:26:49 <Jokke_> nikhil: damn
14:26:58 <nikhil> But positively yes for PTG
14:27:04 <rosmaita> excellent!
14:27:06 <stevelle> Jokke_: that's import related, isn't it?
14:27:13 <Jokke_> stevelle: yeah
14:27:19 <stevelle> how is that coming?
14:27:55 <rosmaita> (don't mean to interrupt, but here's the link to the PTG info)
14:27:58 <Jokke_> stevelle: bit by bit ... I'm trying to push the flow for review this week
14:27:59 <rosmaita> #link http://www.openstack.org/ptg/
14:28:24 <rosmaita> Jokke_: nice
14:28:37 <stevelle> ^
14:29:22 <stevelle> looking forward to having a review
14:30:09 <rosmaita> anything else anyone wants to discuss?
14:31:25 <nikhil> None from me
14:31:28 <rosmaita> ok, sounds like that's a "no".  No meeting next week, see you all back here on 3 November
14:31:33 <Jokke_> safe flights for everyone who is coming
14:31:39 <Jokke_> CU in Barcelona
14:31:39 <rosmaita> ++
14:31:50 <nikhil> Have a nice summit all
14:32:05 <tsymanczyk> safe travels!
14:32:05 <stevelle> \o
14:32:19 <rosmaita> #endmeeting