14:00:45 <nikhil_k> #startmeeting Glance
14:00:45 <openstack> Meeting started Thu Dec  4 14:00:45 2014 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:48 <openstack> The meeting name has been set to 'glance'
14:00:50 <ativelkov> o/
14:00:53 <nikhil_k> roll call
14:00:54 <kragniz> o/
14:01:11 <lakshmiS> o/
14:01:13 <stevelle> o/
14:01:35 <rosmaita> o/
14:01:39 <sigmavirus24> o/
14:02:09 <mclaren> o/
14:02:11 <nikhil_k> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:17 <jokke_> o/
14:02:21 <nikhil_k> #topic updates
14:02:46 <nikhil_k> we got confirmation about having the glance mid-cycle meet up alongside Nova
14:03:04 <nikhil_k> Was just curious how many want a 3 day meetup?
14:03:20 <nikhil_k> else will propose to keep Tues and Wed
14:03:48 <jokke_> are we fully overlapping with Nova?
14:03:49 <nikhil_k> i.e Jan 27, 28
14:03:56 <mclaren> For me two days sounds like plenty
14:04:08 <nikhil_k> in a separate room, parallel to nova sessions
14:04:09 <ativelkov> It depends on the number of topics we have to discuss, but 2 days should be probably enough
14:04:12 <lakshmiS> 2 days was good last time
14:04:25 <rosmaita> +1 to 2 days
14:04:43 <nikhil_k> cool - Jan 27, 28 (Tues/Wed) it is, then!
14:04:43 <jokke_> +1
14:05:17 <nikhil_k> will sync with Nova ptl and schedule common sessions
14:05:30 <nikhil_k> #action nikhil_k : sync with Nova ptl and schedule common sessions
14:05:33 <nikhil_k> next
14:06:01 <nikhil_k> #topic BP for tracking (besides creating a spec)
14:06:12 <jokke_> nikhil_k: quick one ... is it still @ VMWare Palo-Alto?
14:06:18 <nikhil_k> think most of us have probably got familiar with this by now
14:06:27 <nikhil_k> yes, to confim
14:06:35 <jokke_> yes
14:07:06 <nikhil_k> #info Glance kilo mid-cycle meetup to be at VMware office in Palo Alto on Jan 27, 28 (tentatively)
14:07:43 <nikhil_k> about the BP creation - there may be confusion that spec auto creates a BP
14:07:57 <nikhil_k> that is not the case as lp api does not support creating a blueprint
14:08:02 <jokke_> there is tool 'though to do that
14:08:26 <nikhil_k> this is relavant as we may want to schedule a feature for k-1, 2, 3 even before a spec is completely discussed approved
14:08:48 <nikhil_k> and this may get missed in communicating with release management - thus preventing landing of the code in the cycle
14:08:56 <ativelkov> What about blueprint dependency trees? Should we make the spec dependent in geerit for that?
14:09:14 <nikhil_k> ativelkov: that would be good
14:09:46 <lakshmiS> so creating spec on gerrit and lp are seperate process?
14:10:00 <sigmavirus24> lakshmiS: yes
14:10:16 <nikhil_k> not separate process per say - just manunal work in the same process
14:10:32 <jokke_> lakshmiS: Effectively yes, but as said there is a script to do it (need to dig out Tue cross project meeting logs where it is)
14:10:32 <lakshmiS> ok
14:10:33 <nikhil_k> basically - one feature proposal == creating a spec + bp
14:11:04 <nikhil_k> oh, one more thing
14:11:22 <kragniz> jokke_: is that a script to do both, or create blueprint from gerrit spec?
14:11:41 <nikhil_k> we are planning to enable a script which identifies inconsistency in the BPs and kick them out of schedule (k1, k2 etc)
14:12:05 <jokke_> kragniz: it's called spec2bp
14:12:15 <jokke_> it creates the bp out of the spec
14:12:16 <nikhil_k> insconsistencies like - priority not set, status not proper etc
14:13:02 <nikhil_k> am little dubious about it
14:13:26 <nikhil_k> having a api to create bp would mean potentially spamming the system, but anyways...
14:14:15 <nikhil_k> #info please sync with nikhil_k if you need to target a bp/spec to a milestone to keep it on schedule and avoid it getting kicked out by the script
14:14:25 <nikhil_k> next
14:14:30 <nikhil_k> #topic BPs for k1
14:14:42 <nikhil_k> #link https://launchpad.net/glance/+milestone/kilo-1
14:15:05 <nikhil_k> one BP merged, so yay!
14:15:23 <sigmavirus24> time to celebrate
14:15:23 <nikhil_k> we've 2 planned and many more to go in the cycle
14:15:59 <nikhil_k> the tentative schedule suggests that we'd at least complete 5 by k1 to be on track in this cycle
14:16:34 <nikhil_k> would like some volunteers here
14:17:11 <nikhil_k> may be specs like taskflow which have code submitted already
14:17:25 <lakshmiS> I would love to say yes but i think practically "catalog index service" bp would be k2 target
14:17:26 <ativelkov> Ш may split artifacts spec to some smaller parts
14:17:28 <sigmavirus24> nikhil_k: volunteers for?
14:17:30 <mclaren> volunteers for reviews or code nikhil_k ?
14:17:32 <ativelkov> I* may
14:17:38 <nikhil_k> what about your BP sigmavirus24 ? can we target it for k1?
14:17:55 <sigmavirus24> nikhil_k: I can work on a patchset for it the end of this week or start of next
14:17:58 <nikhil_k> mclaren: sigmavirus24 : atm volunteers for specs
14:18:02 <ativelkov> This will let us some code which is already completed (such as SemVer support) to be  landed in K1
14:18:16 <nikhil_k> and after that we can identify reviewer availability
14:18:29 <nikhil_k> ativelkov: that sounds good
14:18:33 <jokke_> nikhil_k: could we have a fast-track to copy the approved speks from previous release to new one if gets delayed. By the looks of it we did not have anything approved for Kilo thus far
14:18:57 <nikhil_k> ativelkov: please create a BP for it in that case and later on you can create a spec. so that we can get the ball rolling
14:19:03 <stevelle> I'm not sure if I can have a patchset for mine in the K-1 time frame but I could try
14:19:35 <nikhil_k> jokke_: sure, we can have a fast-track
14:20:01 <nikhil_k> it's not approved as things were in a bit of flux - the plan is to understand which ones to target for k1 and focus on them
14:20:08 <jokke_> nikhil_k: that would just help to keep track what we have going on
14:20:14 <nikhil_k> rather than spreading out thin on various specs
14:21:08 <nikhil_k> stevelle: sure, let's target it
14:21:14 <nikhil_k> at least we will get some momentum
14:21:40 <stevelle> nikhil_k: I'll sync with you after the meeting then on targeting, per above
14:21:41 <nikhil_k> early next week, I will try to circulate the proposed specs/BP for k1
14:21:59 <ativelkov> nikhil_k: here it is, https://blueprints.launchpad.net/glance/+spec/semver-support
14:22:05 <nikhil_k> and we can have a discussion between cores to pick and choose their options
14:22:13 <nikhil_k> ativelkov: awesome!
14:22:22 <nikhil_k> stevelle: sg
14:22:49 <ativelkov> will prepare and submit a spec today/tomorrow
14:23:00 <nikhil_k> #action: nikhil_k to find if we can have a fast-track
14:23:08 <nikhil_k> thanks :)
14:23:45 <nikhil_k> #topic core-reviewers
14:23:45 <jokke_> nikhil_k: would be great if we could agree/approve the specs for the release, targeting and changing them are easy, but I really dislike the idea of people writing tons of code for review at the point the big picture has not been agreed
14:24:20 <nikhil_k> that's a NP hard problem
14:24:33 <nikhil_k> and basically - life :)
14:24:56 <nikhil_k> new cores
14:25:10 <nikhil_k> #info Welcome to the core team Erno and Alex!
14:25:25 <nikhil_k> thanks for all the hard work and contributions, much appreciated :))
14:25:26 <lakshmiS> congrats!
14:25:28 <mclaren> добро пожаловать + tervetuloa
14:25:33 <jokke_> :)
14:25:34 <kragniz> congrats!
14:25:35 <jokke_> cheers
14:25:39 <ativelkov> Thanks! :) It's a honor to be with you, guys
14:25:59 <sigmavirus24> Conrats everyone!
14:26:07 <mfedosin_> ativelkov, cakes were tasty! congrats
14:26:16 <nikhil_k> heh
14:26:18 <stevelle> congrats
14:26:40 * sigmavirus24 will bake cakes in your honor and eat them for you =P
14:27:03 <nikhil_k> congratulations!
14:27:16 <nikhil_k> so we'd find some new energy in the reviews :)
14:27:17 <wayneo> congrats!
14:27:23 * jokke_ needs to bring something to the "usual place" @ Mon :P
14:27:49 <nikhil_k> be careful though
14:28:08 <nikhil_k> people might buzz you for reviewer assignment to their specs ;)
14:28:38 <nikhil_k> try to steer away from irc (just kidding)
14:28:48 <jokke_> nikhil_k: no worries, have had good mentors to deal with those buzzes :P
14:28:53 <ativelkov> A question: if I am a co-author of some change-request, is it fair to review patchsets submitted by my co-authers and +1/+2 them? Or, if I am part of the authors, then no reviews from me at all?
14:29:19 <mfedosin_> ativelkov, yes :)
14:29:24 <jokke_> ativelkov: IMO treat them as you authored them
14:29:46 <ativelkov> so, only -1s. got it )
14:29:49 <nikhil_k> ativelkov: please try to *avoid self-approvals* unless it's exceptional situation
14:29:51 <kragniz> ativelkov: I'd say you're a little close to the action
14:30:13 <nikhil_k> +1s are good too
14:30:35 <nikhil_k> to suggest that you've reviwed them and are okay with the changes proposed
14:30:39 <ativelkov> got it, thanks
14:30:59 <nikhil_k> #toic stable juno
14:31:05 <nikhil_k> #topic stable juno
14:31:13 <nikhil_k> :)
14:31:15 <nikhil_k> #link https://etherpad.openstack.org/p/StableJuno
14:31:34 <nikhil_k> seems like we got things resolved and/or clarified
14:31:39 <jokke_> somewhat
14:31:49 <nikhil_k> think we might have missed ativelkov's image update patches though
14:32:10 <nikhil_k> so what do our action items look like jokke_ ?
14:32:47 <nikhil_k> yt?
14:33:06 <ativelkov> Yup, I'd prefer the race condition to be fixed at some point, even if not backported to stable juno, but merged into K1
14:33:23 <jokke_> flaper blocking the glance_store bump&cap causes 2014.2.1 -> 2014.2.2 upgrades to fix the swift multi store issues, but other than that I think all tagged and implemented got in
14:33:45 <nikhil_k> ativelkov: can you mark those bugs to k-1 then ?
14:34:05 <ativelkov> nikhil_k: sure
14:34:48 <jokke_> so please, please tag any backport potential bugs you think with juno-backport-potential ... I'll be reviewing and tracking those
14:35:26 <nikhil_k> jokke_: umm, what do you mean "upgrades to fix the swift multi store issues" -> that's a good thing right
14:35:37 <jokke_> sorry on my previous one, flaper blocking the bump causes that the upgrades are still broken with swift multi store
14:35:43 <nikhil_k> ah ok
14:36:07 <nikhil_k> is that up for the next stable juno release then?
14:36:15 <jokke_> so new installs are ok or if the deployer upgrades glance_store manually
14:36:24 <mclaren> this is the patch https://review.openstack.org/#/c/137704/
14:36:36 <jokke_> but upgrade from previous Juno to latest does not fix the issue
14:37:01 <jokke_> mclaren: correct
14:37:06 <nikhil_k> yes, am curious if we can try to get that merged in (with whatever changes to the store) in the next release of stable juno ?
14:37:22 <ativelkov> nikhil_k: for some reason I cannot assign tag to https://bugs.launchpad.net/glance/+bug/1371728
14:37:41 <mclaren> the store changes are in, but making it mandatory to update to the fixed version of glance_store is not
14:38:06 <nikhil_k> huh, juno-backport-potential tag does not exist
14:38:16 <nikhil_k> may be we can create that
14:38:23 <ativelkov> nikhil_k: never mind, Works now. assigned "kilo-1"
14:38:40 <nikhil_k> mclaren: ah ok, so the decision to fix it is still not confimed
14:38:44 <nikhil_k> ok
14:38:47 <nikhil_k> ativelkov: ^
14:39:25 <jokke_> nikhil_k: I think there is common tag for *-backport-potential where you're supposed to replace the * with the release
14:39:26 <mclaren> nikhil_k: yeah this patch https://review.openstack.org/#/c/137704/ would mean you'd be certain to get a working version of the store
14:39:51 <mclaren> but I think there are questions from flaper87 about the mechanics
14:40:04 <jokke_> nikhil_k: sorry SERIES-backport-potential it is
14:40:17 <nikhil_k> ok, was trying to confirm the stance - we can decide later as well
14:40:23 <nikhil_k> jokke_: ah ok thanks
14:40:35 <nikhil_k> #topic Artifacts
14:41:12 <TravT> jokke_: so we should use juno-backport-potential for bugs that should be backported?
14:41:20 <nikhil_k> for the past few days there have been some concerns about the issue of Glance not including artifacts by a sub set of the group
14:41:21 <jokke_> TravT: correct
14:41:38 <mfedosin_> I like this topic :)
14:42:00 <nikhil_k> the request is to keep image and registry only in the program
14:42:02 <jokke_> nikhil_k: would you mind to open that statement up?
14:42:08 <jokke_> ah
14:42:40 <nikhil_k> to let everyone know that am trying to get some feedback from variety of people and more importantly from the TC
14:43:15 <nikhil_k> there is not much to tell at this point and  just this small piece of imformation - as it was sincerely requested by some to do so
14:43:28 <ativelkov> what does it mean to us?
14:43:41 <nikhil_k> will post some concrete comments next week
14:44:03 <nikhil_k> ativelkov: we can sycn up outside of the meeting if that helps
14:44:05 <jokke_> nikhil_k: does that mean that there is concerns it not being there yet or concerns to include artifacts to glance?
14:44:46 <ativelkov> nikhil_k: yes, I'd like some more details please. Outside the meeting is fine
14:44:49 <nikhil_k> to clarify - "concern to include it/such features in Glance"
14:45:18 <nikhil_k> #topic osprofiler
14:45:20 <jokke_> nikhil_k: thnx
14:45:29 <nikhil_k> kragniz: think that's you
14:45:43 <nikhil_k> we've some time so figured we can quickly see what's the status
14:45:46 <kragniz> yeah, I'm going to talk about this in the cross project meeting
14:45:51 <nikhil_k> cool
14:45:53 <kragniz> we can probably skip it
14:46:06 <nikhil_k> kragniz: you can discuss if you want
14:46:20 <mclaren> kragniz: is this about some of the pipeline etc stuff?
14:46:40 <kragniz> okay, so basically we're the odd ones out in terms of the option name for enabling/disabling osprofiler
14:47:01 <kragniz> I'm proposing we adopt profiler_enabled instead of enabled
14:47:22 <mclaren> ah, ok, so not about loading or not based on whether it's in the pipeline...
14:47:30 <nikhil_k> #link http://www.mail-archive.com/openstack-dev@lists.openstack.org/msg41298.html
14:47:38 <kragniz> this aligns with what cinder folk want, since iirc they already have an option named 'enabled'
14:47:47 <kragniz> mclaren: no, just deprecating this option
14:47:55 <mclaren> ok
14:49:01 <kragniz> that's pretty much all the status is
14:49:07 <nikhil_k> cool
14:49:10 <nikhil_k> thanks kragniz
14:49:14 <kragniz> it would be nice if we all used the same option
14:49:33 <nikhil_k> #topic Reviews to catch up
14:49:43 <nikhil_k> #link https://review.openstack.org/#/c/123722/
14:49:50 <nikhil_k> ativelkov: ?
14:50:19 <ativelkov> This is one of the ways to solve race conditions
14:51:17 <ativelkov> So, I just wanted some more reviews on this
14:51:54 <nikhil_k> #help https://review.openstack.org/#/c/123722/ needs some attention
14:51:58 <ativelkov> BTW, jokke_, you could update your +1 there with +2
14:52:01 <mclaren> I can take a peek
14:52:23 <nikhil_k> #topic open discussion
14:52:45 <jokke_> Ref bug triage guidelines, I did not rewrite them
14:52:58 <nikhil_k> np
14:53:03 <jokke_> #link https://wiki.openstack.org/wiki/BugTriage
14:53:40 <jokke_> Please read through with thought ... if we need something more specific for ourselves, we can agree those point or see if we can include them to existing ones
14:54:20 <TravT> what are the guidelines on backport bugs?
14:54:29 <kragniz> jokke_: looks good
14:54:43 <TravT> IOW, what qualifies a bug as backport?
14:55:18 <TravT> Actually, I'd like to hear more about the artifacts discussion from TC.
14:55:19 <nikhil_k> #liink https://wiki.openstack.org/wiki/StableBranch#Stable_branch_policy
14:55:22 <nikhil_k> TravT: ^
14:55:26 <TravT> th
14:55:28 <TravT> thx
14:55:42 <jokke_> ah nikhil_k was faster :D
14:56:25 <jokke_> TravT: if unsure, tag the bug and I have a look/consult with the stable-maintainers
14:56:45 <TravT> jokke_: ok
14:57:02 <nikhil_k> #info flaper87 is a stable-maint*
14:58:24 <nikhil_k> if there's nothing else
14:58:36 <kragniz> can I request some eyes on this? https://review.openstack.org/#/c/135267/
14:58:51 <kragniz> before the next client release
14:59:01 <nikhil_k> #help https://review.openstack.org/#/c/135267/ before the next client release
14:59:04 <nikhil_k> ok
14:59:10 <kragniz> cool
14:59:35 <nikhil_k> Thanks all!
14:59:37 <TravT> i've got something i need in next client release
14:59:40 <TravT> when will it be?
14:59:46 <nikhil_k> link please
14:59:59 <nikhil_k> may be Dec 9
15:00:04 <TravT> https://review.openstack.org/#/c/128791/
15:00:13 <TravT> needed to land Horizon k1 patch
15:00:21 <nikhil_k> ok
15:00:29 <nikhil_k> we need to log off
15:00:31 <TravT> michal -1'd it only because I didn't yet get the pagination support in cli as well as api
15:00:34 <jokke_> yeah, thanks all
15:00:34 <sigmavirus24> Thanks everyone
15:00:36 <TravT> i'll look at adding that today
15:00:37 <kragniz> thanks
15:00:42 <nikhil_k> #endmeeting