20:02:03 <nikhil_k> #startmeeting Glance
20:02:04 <openstack> Meeting started Thu Oct  2 20:02:03 2014 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:05 <kragniz> \o
20:02:07 <openstack> The meeting name has been set to 'glance'
20:02:09 <ativelkov> o/
20:02:18 <TravT> o/
20:02:21 <jbernard> o/
20:02:21 <flaper87> o/
20:02:52 <nikhil_k> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
20:03:00 <rosmaita> kragniz: i need to think through the "discovery" aspects (or lack thereof) on your spec, should have an answer tomorrow
20:03:07 <arnaud> o/
20:03:20 <kragniz> rosmaita: sounds good!
20:03:23 <kragniz> rosmaita: thanks
20:03:52 <rosmaita> nikhil_k: sorry to interrupt, you were starting the meeting
20:04:04 <nikhil_k> np
20:04:11 <nikhil_k> was thinking..
20:04:14 <nikhil_k> Let's dedicate this meeting to Juno stuff
20:04:20 <nikhil_k> seems like we've a lot
20:04:50 <nikhil_k> who has posted point#1 ?
20:04:59 <nikhil_k> if you want to take over?
20:05:02 <TravT> me
20:05:09 <nikhil_k> please go ahead
20:05:15 <TravT> just saw the revised agenda...
20:05:16 <TravT> so the end of RC1 left us with several bugs on metadefs that we really thought should land in Juno RC1.
20:05:25 <TravT> a few of them have effects that potentially are reason enough for RC2
20:05:32 <TravT> others we think should at least be backported to the first bug fix release of Juno
20:05:42 <TravT> after talking with nikhil a couple days ago, I put together an etherpad listing them.
20:05:48 <TravT> he wanted to share it in this meeting and ask if there are others for consideration
20:05:55 <TravT> #link: https://etherpad.openstack.org/p/glance-juno-release-bugs
20:07:14 <TravT> so, nikhil_k: let me know how you want to handle it from here.
20:07:16 <ativelkov> I am pretty sure that the race condition-related bugs are quite serious. I am ok if we drop them from Juno, but they definetely should be fixed early in K and backported as soon as possibility arises
20:07:19 <nikhil_k> yes, and if anyone had ideas for any other important stuff we might want to priorotize them
20:08:07 <mfedosin_> and i think incorrect status update should be there too
20:08:08 <nikhil_k> I'm planning to send an email to ttx tomorrow and think that we can have 3-4 bugs requested at most (for rc1 backport)
20:09:03 <kragniz> so those will be backported to rc1, or make rc2?
20:09:12 <nikhil_k> rc2 seems unlikely however, that could be another point of discussion
20:09:25 <ativelkov> what is the difference?
20:09:39 <nikhil_k> at this point, I think we should go with "just rc1" for juno
20:09:47 <ativelkov> I mean, are there any criterias for having another iteration?
20:10:16 <nikhil_k> so, https://launchpad.net/glance/juno/juno-rc1
20:10:39 <nikhil_k> this page is used as reference to identify all the bugs that need to be there in a release candidate
20:11:10 <nikhil_k> there were prolly none when ttx saw this page hence, we stopped at rc1
20:11:19 <TravT> yeah, I think that we probably should have had this meeting last week or the week before.
20:11:37 <kragniz> okay, that makes sense
20:11:46 <nikhil_k> based on the # and level of difficulty, the releases might be staggered (that's a speculation though)
20:12:10 <TravT> nikhil_k: not sure I follow...
20:12:32 <nikhil_k> TravT: I was trying to answer ativelkov's question about rc1/2
20:12:58 <nikhil_k> of couse, the likeliness of rc2 is still less
20:13:32 <ativelkov> so, unless we discover something really severe and complicated, rc2 will not be allowed.
20:13:57 <nikhil_k> the reason is - as we've the patch merged for "open kilo" development
20:14:15 <nikhil_k> juno "like" work is officially stopped
20:14:21 <TravT> so, when you say "backported" to rc1, do you mean that those would still get the 2014.2 designation?
20:14:35 <TravT> And the rest of these we could backport to 2014.2.1?
20:14:46 <nikhil_k> TravT: that is my understanding
20:14:55 <nikhil_k> ok, so that's a possibility
20:15:05 <nikhil_k> I can try to confirm the same with release team then
20:15:52 <TravT> ativelkov: is there already a fix for the race condition one?  is it really complicated?
20:16:02 <nikhil_k> #action (nikhil_k) to clarity on 2014.2 and 2014.2.1. Consider possibility of rc2 if needed
20:16:17 * nikhil_k ignores the typo
20:16:23 <ativelkov> TravT: yes, even two different fixes, both quite simple
20:17:15 <ativelkov> https://review.openstack.org/#/c/122814/  - simpler but with some limitatations, https://review.openstack.org/#/c/123722/ - more complicated but still <150 lines
20:17:55 <ativelkov> They just lack some more reviews
20:17:59 <TravT> ativelkov, can you add to that etherpad?
20:18:07 <ativelkov> TravT: sure
20:18:18 <nikhil_k> seems stuart is not here
20:18:49 <jbernard> ativelkov: im happy to help review, if needed
20:18:51 <TravT> yeah, he had one... but I couldn't tell from his add to the agenda if his patch he wanted in RC2, RC1, or future backport
20:19:20 <nikhil_k> true
20:19:26 <nikhil_k> let's get that clarified too
20:19:59 <nikhil_k> #action (nikhil_k) find if https://review.openstack.org/#/c/107383/ needs to be in rc1/2/future backport
20:20:30 <TravT> So, two of the patches I put on that page have now landed on kilo master.
20:20:41 <TravT> the rest all have 1 +2
20:21:10 <nikhil_k> TravT: can you please mark those are "merged in kilo" or something similar?
20:21:10 <TravT> so, in any event, we need these on master and so they can be backported.
20:21:25 <TravT> yeah, there is a little parenthesis
20:21:28 <TravT> i'll highlight it
20:21:47 <nikhil_k> ah great
20:22:49 <nikhil_k> ok, so that seems to be it!
20:23:47 <nikhil_k> unless someone sends me an email about another possible backport tonight
20:23:52 <TravT> nikhil_k, what status should we mark the bugs in launchpad?
20:24:08 <nikhil_k> TravT: I think leaving them as is should be fine
20:24:30 <TravT> ok
20:24:36 <nikhil_k> I can take care of them if a link is available or can be found easily :))
20:25:06 <TravT> well, i think they are linked.... ;-)
20:26:03 <nikhil_k> just a general guideline if anyone else wanted to add bug to it
20:26:06 * nikhil_k blushes
20:27:16 <nikhil_k> #topic Bug: https://review.openstack.org/#/c/66386
20:27:33 <nikhil_k> can anyone represent this?
20:27:45 <jbernard> i can
20:28:11 <jbernard> the patch seemed reasonable to me, but it breaks tempest
20:28:27 <jbernard> and im not sure what else depends on this behaviour
20:28:34 <nikhil_k> ah
20:28:54 <flaper87> I think it makes sense to
20:28:55 <jbernard> im happy to revisit if you think it's valuable
20:29:41 <flaper87> I mean, it's a small fix but it definitely solves an inconsistency in our API
20:30:05 <nikhil_k> hmm
20:31:03 <jbernard> flaper87: for v2 only?
20:31:28 <flaper87> mmh, I don't think this problem exists in v2
20:31:38 <flaper87> btw, for how long are we planning to support v1?
20:31:46 * flaper87 wants v1 deprecated NOW!
20:31:53 <nikhil_k> heh, good question
20:31:58 * jbernard rummages through the codes
20:32:04 <flaper87> my personal goal for K is to make all services in openstack use v2
20:32:17 <flaper87> then we'll be free to mark it as deprecated
20:32:18 <nikhil_k> I guess we will have to find what the nova v1/v2 patch status is
20:32:38 <kragniz> flaper87: that would be lovely
20:32:39 <nikhil_k> flaper87: does that mean you'r signing up for nova using v2?
20:32:42 <nikhil_k> jk
20:32:44 <flaper87> nikhil_k: nova still uses v1, there's a bp for v2 and I'm planning to make sure that gets done
20:32:47 <flaper87> or do it myself
20:32:52 <flaper87> nikhil_k: oh yes
20:32:57 <nikhil_k> perfect!
20:33:02 <ativelkov> sounds very good
20:33:06 <jbernard> then perhaps its okay to leave this as is, in hopes of a soon deprecated v1
20:33:15 <kragniz> flaper87: can the client move over to using v2 by default?
20:33:21 <kragniz> what's blocking that?
20:33:28 <flaper87> kragniz: just when v2 will be our default
20:33:37 <flaper87> we need to give a deprecation period
20:33:45 <flaper87> Here's what I think will/should happen
20:33:47 <kragniz> flaper87: okay, makes sense
20:33:47 <nikhil_k> jbernard: yeah, we can revisit in mid-kilo
20:33:59 <mfedosin_> client doesn't fully support v2
20:34:10 <flaper87> K we mark v1 as deprecated, L (L comes after K, right? right?) we remove it and make client use v2 by default
20:34:13 <kragniz> mfedosin_: do you know if there are bugs for that?
20:34:30 <mfedosin_> i don't see them
20:34:34 <flaper87> mfedosin_: it does, the missing pieces are optional (?) and should be implemented in K
20:34:48 <flaper87> I think it is lacking support for tasks
20:34:55 <flaper87> and few other things that landed in Juno
20:35:08 <flaper87> but support for images is there for sure
20:35:13 <flaper87> (last famous words)
20:35:17 <mfedosin_> for example client doesn't support sort-key for images
20:35:25 <TravT> actually, one of our bugs listed on that etherpad is to fix some issues using v2 api
20:35:26 <kragniz> okay, we should raise bugs for the missing parts
20:35:37 <mfedosin_> and sort-dir as well
20:35:47 <TravT> v2 image-update does not handle some schema properties properly  -  https://bugs.launchpad.net/glance/+bug/1371559
20:35:48 <uvirtbot> Launchpad bug 1371559 in python-glanceclient "v2 image-update does not handle some schema properties properly" [Undecided,In progress]
20:36:00 <jokke_> my 2 euro cents ... we want to have client using v2 default for 1 cycle and keep v1 available?
20:36:41 <kragniz> jokke_: won't the v1 client still exist for a while after the switch to v2 anyway?
20:36:42 <ativelkov> btw, v1 CLI allows to use image name instead of id in case if names are unambiguous, but that does not work in v2. Is is a CLI or API issue?
20:37:02 <jokke_> kragniz: no if we move the client default same time we remove v1
20:37:32 <jokke_> ativelkov: I think that was intentional smart decision iirc
20:38:08 <flaper87> client v1 will stay there longer than v1, I think
20:38:33 <jokke_> there has been couple of times discussions about that delete with name and each time decided not to be implemented
20:38:38 <jokke_> flaper87: +1
20:39:28 <jokke_> kragniz: ah you were talking about client ... sorry
20:39:40 <TravT> flaper87: that makes sense to me re client
20:39:55 <kragniz> jokke_: that's okay!
20:40:54 <jokke_> I just have my fears what happens if we remove v1 api in L and postpone until that before defaulting v2 in client ... that does not leave too much room for errors
20:41:12 <TravT> This sounds like maybe a dedicated bug day on the client and v2.
20:41:21 <kragniz> TravT: +1
20:42:26 <TravT> does it warrant time at the summit?  or just a bug day on it.
20:42:55 <nikhil_k> at this point, let's stick to bug day
20:43:17 <TravT> if flaper87 is going to make it his goal to get Nova switched over, we want to make sure its ready to go.
20:43:42 <jokke_> +1
20:45:07 <nikhil_k> Think proposing summit topic is fine, though we get few slots for glance.
20:45:15 <jokke_> nikhil_k: would it be worth to propose TC having cross-project slot reserved for Nova, Cinder & Glance to discuss about the deprecation & migration plans?
20:45:31 <jokke_> Horizon as well
20:45:38 <nikhil_k> jokke_: that's a good idea
20:45:55 <jokke_> having everyone in the same room so the plan would be clear
20:45:57 <nikhil_k> can someone bring this up in the next meeting?
20:46:15 <TravT> bring what up?  The v2 client?
20:46:20 <nikhil_k> need a volunteer
20:46:35 <kragniz> nikhil_k: I'll add it to agenda
20:47:04 <nikhil_k> great. Thanks kragniz
20:47:17 <nikhil_k> guessing we will have more people in our earlier timeslot
20:48:11 <nikhil_k> jokke_: TravT : about summit topics - we can try to cover at least some if not all in the next meeting
20:48:27 <TravT> nikhil_k: Sounds good.
20:48:29 <jokke_> nikhil_k: do we have some plans already?
20:48:37 <jokke_> nikhil_k: etherpad or something?
20:48:41 <nikhil_k> not yet
20:49:08 <nikhil_k> is someone interested in creating a layout (in etherpad) for kilo summit topics?
20:49:13 <jokke_> k, will put etherpad ready for next meeting and link to the agenda so people can fill in their proposals
20:49:20 <TravT> we're supposed to create one and linke to it for here: #link: https://wiki.openstack.org/wiki/Summit/Planning
20:49:35 * nikhil_k high fives jokke_
20:49:43 <jokke_> o/
20:50:45 <nikhil_k> #action jokke_ to create summit topic etherpads and link it to https://wiki.openstack.org/wiki/Summit/Planning
20:50:48 <TravT> one quick question
20:50:53 <TravT> how many slots do we get?
20:50:57 <TravT> for glance
20:51:15 <jokke_> and do we have our own corner there?
20:51:31 <gokrokve> There should be PODs for projects
20:51:36 <jokke_> or how they called them
20:51:38 <jokke_> POD yeah
20:52:17 <gokrokve> And as I heard there will be the whole day for project sessions. Need to confirm this, though
20:52:25 <nikhil_k> TravT: usually, one day-ish. (lesser than a day)
20:52:33 <ativelkov> Yes, there should be something for "meetup"
20:52:35 <nikhil_k> all sequential =
20:53:18 <nitika_> nikhil_k: Hi, shall we move to the next topic as we have left only with few minutes for the meeting.
20:53:32 <nikhil_k> thanks for bringing that up nitika_
20:53:41 <nikhil_k> #topic Nitika:  Discuss about the Glance Project Ideas proposed for the upcoming OPW Program
20:53:46 <nitika_> Hello Everyone,
20:53:48 <nikhil_k> nitika_: go ahead
20:54:00 <nitika_> Firstly let me introduce myself.
20:54:30 <nitika_> I'm pursuing computer science and engineering and willing to participate in the upcoming OPW program
20:54:40 <nitika_> by contributing to the Glance project
20:54:47 <rosmaita> yay!
20:54:52 <kragniz> woop!
20:54:55 <gokrokve> ativelkov: meetup is on Friday. Just a room for half a day
20:54:56 <jokke_> sorry for my ignorance, but OPW?
20:55:20 <nitika_> I would like to discuss about the tasks related to the Glance projects mentioned
20:55:23 <nikhil_k> #link https://wiki.openstack.org/wiki/OutreachProgramForWomen
20:55:29 <TravT> Welcome!
20:55:32 <nitika_> # link https://wiki.openstack.org/wiki/OutreachProgramForWomen/Ideas#Glance_-_Implement_Tasks_scrubber
20:55:34 <jokke_> Ah that one, Cool!
20:55:42 <gokrokve> Great! Welcome!
20:55:50 <nitika_> jokke_: Outreach program for Women
20:55:56 <nitika_> gokrokve: thaks
20:56:01 <nitika_> thanks *
20:56:08 <nitika_> thanks everyone.
20:56:50 <rosmaita> +1 to tasks scrubber!
20:57:01 <nikhil_k> There is some time committment issues from my side on mentorship
20:57:12 <nikhil_k> and nitika_ seems really interested
20:57:23 <jokke_> nitika_: on which timezone you're at?
20:57:28 <nikhil_k> + I was really impressed with her diligence and clarity of thought
20:57:34 <nitika_> jokke_: UTC +5.5
20:57:44 <nitika_> nikhil_k: thanks.
20:57:58 <nikhil_k> So, if we can have around 2-3 developers who can mentor her (partly at least)
20:58:17 <nikhil_k> and one of them can be me 0:-)
20:58:31 <jokke_> nitika_: ok ... well feel free to poke me on afternoons if you need something ... I'll be online for you by around 13:00 daily basis
20:58:37 <exploreshaifali> hello everyone, I am also pursuing computer science engineering and want to contribute for glance project
20:58:37 <exploreshaifali> I want to know more about scrubber implementation project
20:58:53 <nikhil_k> we would need a official metor who can conduct office hours and meet with her on irc to very least (often)
20:59:17 <jokke_> nikhil_k: what are the commitment needs?
20:59:19 <nikhil_k> exploreshaifali: nitika_ : so, seems like we may have some interest
20:59:19 <nitika_> jokke_: ok, thanks.
20:59:35 <nikhil_k> mind sending email to ML about this?
20:59:44 <nikhil_k> unless you can find someone on openstack-glance
20:59:46 <jokke_> let's continue this discussion on -glance, we're out of time
20:59:51 <nikhil_k> yep
20:59:59 <nikhil_k> no room for open discussion
21:00:03 <nitika_> ok
21:00:05 <nikhil_k> we can have that early next meeting
21:00:14 <nikhil_k> #endmeeting Glance