14:11:46 <rosmaita> #startmeeting glance
14:11:46 <openstack> Meeting started Thu Aug 28 14:11:46 2014 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:11:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:11:49 <openstack> The meeting name has been set to 'glance'
14:12:04 <rosmaita> agenda is here: https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:12:15 <TravT> proposed agenda item 0: poke markwash with a stick.
14:12:21 <TravT> ;-)
14:12:29 <jcook> ^_^
14:12:36 <rosmaita> i wish that could be done
14:12:37 <jokke_> +1
14:12:39 <rosmaita> maybe in oslo
14:12:54 <rosmaita> abhishekk: looks like you have a bunch of agenda items
14:13:05 <abhishekk> rosemita:yes
14:13:36 <abhishekk> rosemita:two features, 1 restrict download and 2. use common service framework
14:13:39 * jcook lends abhishekk his tab key
14:14:04 <rosmaita> jcook: nice hint
14:14:14 <jcook> >_>
14:14:23 <rosmaita> abhishekk: looks like you need reviews again on the restrict download?
14:14:29 <abhishekk> yes
14:14:38 <abhishekk> just to have us on same page
14:15:03 <abhishekk> restrict download patch needs sync from oslo-incubator policy module
14:15:11 <rosmaita> zhiyan: did you get a chance to look at the oslo-sync?
14:15:24 <rosmaita> i noticed you were concerned about that on the fist patch
14:15:34 <rosmaita> first: https://review.openstack.org/#/c/98737/
14:15:44 <rosmaita> second: https://review.openstack.org/#/c/116978/
14:16:14 <abhishekk> rosemita:I have a oslo-sync patch but as of now some functional and unit tests are failing on it
14:16:34 <zhiyan> rosmaita: np. but actually i think the problem now is can we land it for download-restrict change as dependence before j-3?
14:17:36 <zhiyan> rosmaita: from the job result, i think the backward-compatibility issue of latest openstack.common.policy is a little heavy
14:18:09 <jokke_> that does not sound good
14:18:16 <rosmaita> so is the situation that we're dependent on something landing on oslo for J-3?
14:18:25 <zhiyan> so, imho, can we land #116978 first for #98737?
14:18:25 <rosmaita> or is it mostly us at this point?
14:18:41 <zhiyan> yes, i think it is rosmaita
14:18:44 <zhiyan> jokke_: nod
14:19:01 <zhiyan> abhishekk: would you mind show that change link for team?
14:19:15 <abhishekk> zhiyan:yes
14:19:19 <zhiyan> abhishekk: latest policy sync change
14:19:22 <zhiyan> abhishekk: thanks
14:19:25 <abhishekk> https://review.openstack.org/116836
14:19:51 <zhiyan> but, i see the plan seems not normal
14:20:18 <zhiyan> most time we do sync-up then land functional change
14:20:28 <abhishekk> This feature is really important
14:20:59 <abhishekk> and mark has suggested to have this workaround as of now
14:21:16 <zhiyan> or planb, just try our best for #116836, and (proabably need to) make this feature in ffe program
14:22:00 <jokke_> well by the quick look the test failures seems to be that it does not find policy.json file ... so it might be easy to fix
14:22:07 <zhiyan> abhishekk: correct. so I personally think if we can go #116978 way, and fix #116836 before k, and land it asap when k open
14:22:15 <jokke_> the 11836
14:23:08 <abhishekk> zhiyan:https://review.openstack.org/#/c/98737/ also need to be landed in J3
14:23:16 <zhiyan> jokke_: actually, yesterday i talked this with abhishekk. maybe abhishekk can give some updates?
14:23:53 <abhishekk> Jokke_:in local environment only 28 tests are failing
14:24:14 <abhishekk> jokke_:this policy.json file not found is not occuring locally
14:25:18 <jokke_> abhishekk: ah ok ... I was looking the python2.7 console logs and every single failure was with:
14:25:21 <jokke_> ConfigFilesNotFoundError: Failed to read some config files: policy.json
14:25:40 <abhishekk> jokke_:and my understanding is these tests are failing because policies are loading differently for property protection and normal policy.jsom
14:26:00 <jokke_> abhishekk: ah ok ... might be bit more problematic then
14:26:14 <abhishekk> jokke_:in my current environment I am running with python 2.7 only
14:26:31 <abhishekk> yes, this feature is very important
14:26:36 <zhiyan> anyway, if team ok, i'd like to support #116978+#98737 way as a sponsor. but, by this way, it will be great if abhishekk can make #116836 done before k open. i can help it.
14:27:07 <abhishekk> zhiyan:yes i will definately put my heart out on this
14:27:14 <jokke_> If that's viable path, sounds good to me
14:27:21 <zhiyan> iiuc flaper87 could support this as well
14:27:31 <abhishekk> yes
14:27:42 <rosmaita> ok, do we need to put dates on this help?
14:27:44 <zhiyan> abhishekk: thanks
14:27:53 <jokke_> he might be bit busy renaming glance.store :P
14:27:56 <rosmaita> ff is sept 4, i think?
14:27:56 <abhishekk> zhiyan:thak you
14:28:12 <abhishekk> yes
14:28:34 <rosmaita> abhishekk: zhiyan: do you have time to work on this today?
14:28:48 <zhiyan> jokke_: already done :)
14:29:07 <zhiyan> rosmaita: sorry what work?
14:29:14 <jokke_> zhiyan: ah cool
14:29:29 <rosmaita> zhiyan: to help the test pass so patch can land
14:29:48 <zhiyan> rosmaita: hmm, #116836?
14:29:51 <rosmaita> zhiyan: or was that not what you were volunteering help for?
14:30:06 <zhiyan> rosmaita: probably needs some dig
14:30:24 <abhishekk> rosemita:yes I am already digging it
14:30:42 <rosmaita> zhiyan: ok, to be clear, you are sponsoring the workaround for now, but will help get the non-workaround landed before K
14:30:42 <zhiyan> rosmaita: sorry for confusing, but i'm saying: i'd like to support #116978+#98737 way as a sponsor. but, by this way, it will be great if abhishekk can make #116836 done before k open. i can help it.
14:30:51 <zhiyan> rosmaita: yep
14:30:57 <rosmaita> ok
14:31:13 <rosmaita> sounds good to me, any objections?
14:31:14 <zhiyan> rosmaita: #116978 workaround
14:31:42 <jokke_> can I steal 2min before runing for logging? (Sorry for jumping in between)
14:31:53 <rosmaita> jokke_: sure
14:32:17 <rosmaita> zhiyan: can you talk to mark about this? your approach sounds OK, but he needs to approve
14:32:18 <jokke_> There is 2 changes from me and one from Christian I'd like to see landing
14:32:40 <jokke_> raising levels https://review.openstack.org/#/c/116626/
14:32:49 <jokke_> moving to i18n https://review.openstack.org/117204
14:32:51 <zhiyan> rosmaita: sure
14:33:07 <jokke_> Related work by Christian that would be great to see landing as well https://review.openstack.org/#/c/95662/
14:33:18 <jokke_> that would be closing https://blueprints.launchpad.net/glance/+spec/refactoring-glance-logging
14:33:36 <jokke_> So reviews are really welcome and ping me if any questions
14:33:44 <abhishekk> rosemita, zhiyan, jokke_:thank you
14:33:53 <jokke_> I'll be available on IRC most of the time
14:34:17 <jokke_> abhishekk: I'll try to have a look if I can help with that as well
14:34:42 <abhishekk> jokke_:thank you :)
14:34:45 <rosmaita> #action reviews on jokke_'s patches mentioned in the agenda
14:34:49 <zhiyan> jokke_: when i last review 116626 , it overall looks good to me
14:35:11 <jokke_> gr8
14:35:15 <zhiyan> jokke_: but probably you can put these two link to https://etherpad.openstack.org/p/j3-glance-patches
14:35:18 <rosmaita> #action zhi to talk to mark about whether his sponsorship plan for abhishekk's patches is ok
14:35:29 <jokke_> zhiyan: sure
14:35:32 <TravT> jokke_: thanks for reviews on the metadefs!
14:35:47 <jokke_> TravT: NP glad to help
14:36:19 <jokke_> need to go now ... thanks guys and give me a ping if something is needed.
14:36:57 <rosmaita> abhishekk: the common service framework is you, too, right?
14:37:01 <zhiyan> TravT: did you notice main ;)
14:37:02 <abhishekk> rosemita:yes
14:37:29 <zhiyan> mine*
14:37:49 <abhishekk> rosemita:I have submitted the patches for review
14:38:06 <zhiyan> but imo, it needs more discussion with pkoniszewski
14:38:10 <rosmaita> abhishekk: do you need discussion here, or just a call for reviews?
14:38:30 <abhishekk> rosemita:I need reviews for this patches as welll
14:38:33 <TravT> zhiyan: Yes! Thanks... was waiting for our agenda topic to thank you, but with jokke leaving wanted to say thanks before he dropped.
14:38:49 <abhishekk> rosemita:this feature is also important for us
14:38:56 <zhiyan> TravT: confused my point ;)
14:39:18 <rosmaita> zhiyan: say more about what discussion is needed
14:39:37 <rosmaita> zhiyan: you are talking about the common service framework, right?
14:39:38 <zhiyan> about metadata def one?
14:39:47 <zhiyan> rosmaita: ok, for this
14:40:01 <zhiyan> rosmaita: i believe stuart has some great inputs on it
14:40:18 <abhishekk> rosemita:yes, I have addressed his comments
14:40:25 <zhiyan> abhishekk: did you addressed that stuff? (but probably needs some update form you)
14:40:46 <abhishekk> zhiyan:yes, I have addressed that stuff
14:41:03 <abhishekk> currently analyzing why jenkins is failing on this
14:41:30 <abhishekk> rosemita:for this feature I have addressed all concerns raised by mark
14:42:04 <abhishekk> rosemita, zhiyan: mark is ok to remove use of default eventlet hub choice option
14:42:15 <zhiyan> abhishekk: yes noticed from irc
14:42:39 <abhishekk> zhiyan:so this patch is also good to go, but needs quick reviews
14:42:40 <zhiyan> abhishekk: so, anyway, https://review.openstack.org/#/c/117135/ is good to go right?
14:42:48 <abhishekk> yes
14:43:35 <rosmaita> second: https://review.openstack.org/#/c/116978/ ASAP
14:43:44 <abhishekk> rosemita:yes
14:43:51 <zhiyan> abhishekk: frankly, i'm a little worried if we can cover https://review.openstack.org/#/c/117191/ in j-3
14:44:15 <rosmaita> zhiyan: what problems do you see
14:44:32 <abhishekk> zhiyan:I have almost covered every thing
14:44:58 <abhishekk> zhiyan:testing for http, https etc all I have covered
14:45:03 <rosmaita> #action all reviewers please look at https://review.openstack.org/#/c/117135/ ASAP
14:45:08 <zhiyan> rosmaita: currently i see the functional code needs more review
14:45:17 <zhiyan> rosmaita: and test cases are still failing
14:45:45 <zhiyan> rosmaita: so it's really tight for j-3
14:45:47 <abhishekk> zhiyan:I will take care of that ASAP
14:46:09 <zhiyan> abhishekk: thanks
14:46:41 <abhishekk> zhiyan, rosemita:till then I need reviews on the coding part
14:46:54 <abhishekk> so that I can also address them
14:48:31 <abhishekk> any suggestions?
14:49:19 <rosmaita> abhishekk: not really, just that if you can get the tests to pass, people will be more likely to prioritize looking at the code part
14:49:29 <zhiyan> abhishekk: frankly i'd like to  help, but now i'm not sure i have time to cover that. sorry
14:49:44 <rosmaita> but i think we all iunderstand that these patches are a priority for you
14:49:45 <zhiyan> rosmaita: agreed
14:49:49 <abhishekk> rosemita:I will cover that on that top priority
14:50:01 <abhishekk> rosemita:tahnk you
14:50:10 <rosmaita> cool, feel free to send a note the the ML when they are fixed to remind people to look
14:50:33 <abhishekk> rosemita:surely :)
14:50:42 <rosmaita> ok, TravT
14:50:49 <rosmaita> you have the last item
14:50:55 <zhiyan> abhishekk: again, don't forget https://etherpad.openstack.org/p/j3-glance-patches
14:51:05 <TravT> ok
14:51:10 <TravT> re: metadefs...
14:51:15 <TravT> we've got a script at the bottom of #link: https://etherpad.openstack.org/p/j3-glance-patches
14:51:22 <TravT> this will pull all glance, glance client, and horizon patches onto a fresh devstack.  so you can try out.
14:51:37 <abhishekk> zhiyan:i will not
14:51:42 <TravT> been getting some reviews.. (thanks!)
14:51:51 <TravT> in addition to Glance, we've got 4 patches that we're going through core reviews on horizon, but they have no chance to land without getting glance and glance client release.
14:51:54 <dulek> Notice the git reset --hard in the script!
14:52:10 <TravT> YES, notice that!
14:52:21 <TravT> please take care when using it.  I suggest snapshotting
14:52:46 <TravT> at this point, can we get a check on external API and cli interaction and then we'll fix internal code issues post merge?
14:53:14 <TravT> i'm pretty sure i'm going to be begging for a horizon exception
14:53:42 <TravT> but will have low luck on that if we don't at least have glance code merging.
14:53:56 <rosmaita> that sounds reasonable because we are really tight for time, but that's something mark will have to OK
14:54:22 <TravT> yeah, was hoping for him to be here... (where's that poking stick - :)
14:55:15 <zhiyan> I will re-view api patch tomorrow
14:55:15 <rosmaita> TravT: that script is a good idea, thanks for putting that together
14:55:26 <TravT> zhiyan: Thank you!
14:55:39 <TravT> markwash and I chatted yesterday.  he was getting everything set up
14:55:44 <TravT> was going to review CLI
14:55:44 <zhiyan> TravT: thanks for working on this.
14:56:05 <TravT> if you get any issues with script let me know!
14:56:09 <rosmaita> ok, so with markwash and zhiyan , sounds like cli and api are covered
14:56:36 <zhiyan> iirc, arnaud review metadef as well
14:56:38 <TravT> yesterday, there was about a 20 minute period while it wouldn't have worked, because of updating the chain of dependencies in gerrit
14:56:46 <dulek> Noone looked at CLI patch (https://review.openstack.org/105231) yet, so if someone can cover this item also i would be great.
14:56:49 <zhiyan> not sure if he has some input...
14:56:49 <TravT> arnaud has given a fe comments.
14:57:04 <zhiyan> yep, i mean newer ones
14:57:30 <TravT> well, we're not going anywhere after FF, so def open to fixes post merge
14:57:44 <rosmaita> #action the cli patch needs some eyes: https://etherpad.openstack.org/p/j3-glance-patches
14:58:22 <rosmaita> TravT: that sounds like standard openstack practice
14:58:43 <rosmaita> open discussion? any items?
14:58:44 <TravT> rosmaita: thanks!
14:58:52 <zhiyan> may i have one?
14:59:08 <rosmaita> zhiyan: go ahead
14:59:29 <zhiyan> could we talk a look on https://bugs.launchpad.net/glance/+bug/1316234 due to it on the j-3 list
14:59:30 <uvirtbot`> Launchpad bug 1316234 in glance "Image delete calls slow due to synchronous wait on backend store delete" [Undecided,New]
14:59:38 <zhiyan> but i'm not sure it's a bug for us?
15:00:06 <zhiyan> we can talk it more in team irc room
15:00:09 <zhiyan> times up
15:00:29 <abhishekk> thank you all
15:00:37 <rosmaita> #endmeeting