14:00:54 <yushiro> #startmeeting fwaas
14:00:57 <openstack> Meeting started Thu Oct 12 14:00:54 2017 UTC and is due to finish in 60 minutes.  The chair is yushiro. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:01 <openstack> The meeting name has been set to 'fwaas'
14:01:17 <yushiro> #chair yushiro xgerman_
14:01:18 <openstack> Current chairs: xgerman_ yushiro
14:01:47 <yushiro> FYI: Sridar cannot attend this meeting.
14:01:57 <SarathMekala> hi all
14:02:05 <yushiro> SarathMekala, Hi
14:02:08 <yushiro> #topic Queens
14:02:23 <yushiro> 1. l2-support
14:02:38 <yushiro> #link https://review.openstack.org/#/c/323971/
14:03:40 <yushiro> I and annp just updated this patch.  Currently, I need cedric's reply.
14:04:21 <doude> hi
14:04:25 <yushiro> Now, we're ready for review.
14:04:26 <annp> yushiro, yeah!
14:05:08 <xgerman_> o/
14:05:16 <yushiro> #link https://etherpad.openstack.org/p/fwaas-v2-l2
14:05:29 <yushiro> ^^^ here is local.conf for testing L2-agent and OVS drier
14:05:38 <yushiro> Please review it :)
14:05:44 <yushiro> doude, hi :)
14:06:07 <yushiro> 2. OVS driver
14:06:11 <yushiro> #link https://review.openstack.org/#/c/447251
14:07:00 <xgerman_> Yeah, everything for Q-1 we need to have merged before Monday
14:07:14 <annp> Please help us to test and review it, folks.
14:07:34 <yushiro> Yes.
14:07:45 <ivasilevskaya> I'll definitely devote the rest of the week to l2 agent\ovs patch but Monday?
14:08:08 <yushiro> annp, Did you test in latest devstack with OVS driver?  I can work it with no error.
14:08:39 <yushiro> ivasilevskaya, It really helpful for us !!!
14:09:04 <annp> yushiro, sorry, I haven't had a chance to test it, yet.
14:09:05 <ivasilevskaya> if Monday deadline doesn't work can we ask for extension or anything?
14:09:36 <xgerman_> Likely not
14:10:11 <xgerman_> But I can try - armax is in charge
14:10:38 <yushiro> OK, I'll send e-mail to Sridar about that. ( Monday is deadline )
14:10:41 <annp> ivasilevskaya, Have you tested ovs driver patch yet?
14:11:03 <ivasilevskaya> as long as gate is in trouble now we might get some more days - many patched are blocked now
14:11:15 <ivasilevskaya> annp: not yet
14:11:24 <ivasilevskaya> but I will today
14:11:46 <xgerman_> I will test, too
14:11:49 <yushiro> ivasilevskaya, OK, thanks.  Here is local.conf : https://etherpad.openstack.org/p/fwaas-v2-l2
14:11:56 <yushiro> xgerman_, Thanks :)
14:11:57 <annp> ivasilevskaya, yeah. Thanks in advance. :)
14:11:59 <xgerman_> Let’s merge things
14:12:08 <yushiro> Yes..
14:12:17 <ivasilevskaya> annp: Do I get it right that 2 patches (l2 agent\ovs) have to be tested in a bundle? There is no way to meaningfully test just l2 agent?
14:12:55 <ivasilevskaya> xgerman_ I think we are blocked on gate too
14:13:32 <annp> ivasilevskaya, I think we can test l2 agent with loop driver first, then we can test with ovs.
14:13:46 <yushiro> Yes, gate job is quite serious issue.  As far as I know, there is migration period from zuul v2 to v3.
14:14:01 <xgerman_> Sadly, yes but we can +A to be ready
14:14:19 <annp> ivasilevskaya, we can validate functionality of l2 agent with noop driver, i think.
14:15:37 <ivasilevskaya> yushiro, at least default fwg seems to fail because of https://bugs.launchpad.net/tripleo/+bug/1722872
14:15:39 <openstack> Launchpad bug 1722872 in tripleo "Some packages are not installed in gate job" [High,Triaged]
14:16:18 <yushiro> ivasilevskaya, oh...
14:17:05 <ivasilevskaya> but good news are - it might give us more days to get the patches ready :)
14:17:09 <xgerman_> k, but once things have the right +2 we can babysit - so you please don’t hold back :-)
14:17:55 <yushiro> K
14:18:39 <yushiro> ivasilevskaya, about testing, you can easily modify firewall_l2_driver = noop  or ovs  by using above local.conf.
14:19:05 <ivasilevskaya> yushiro, got it
14:19:33 <yushiro> So, we need to merge L2 agent and OVS driver first.
14:20:28 <yushiro> BTW, SarathMekala , is chandan today?
14:21:43 <yushiro> 3. Default firewall group
14:21:45 <SarathMekala> no
14:21:51 <yushiro> SarathMekala, OK.  Thanks.
14:22:17 <yushiro> #link https://review.openstack.org/#/c/425769/
14:22:51 <yushiro> Thanks xgerman_ for +2.  ivasilevskaya , reedip Do you have any updates?
14:23:13 <ivasilevskaya> yushiro: lgtm
14:23:49 <yushiro> sounds good :)
14:24:25 <yushiro> I'm trying to test in my devstack today.
14:26:11 <yushiro> If it is good, I'll put +2(but I couldn't put +A because this is my patch :p
14:26:27 <xgerman_> Ok. I can do that
14:26:47 <xgerman_> After I test
14:27:07 <yushiro> I'll reach out to Sridar about it.
14:27:08 <yushiro> OK, anything else?
14:27:50 <xgerman_> Horizon?
14:28:05 <yushiro> xgerman_, Thanks.
14:28:17 <yushiro> Yes, let me jump into Horizon topic.
14:28:47 <yushiro> #topic Horizon support
14:29:11 <yushiro> #link https://review.openstack.org/#/c/475840/
14:30:18 <yushiro> hoangcx, I found 'endless loading' issue of 'Add policy' button.  Now, it is fixed.
14:30:36 <xgerman_> Ok, will test and comment
14:31:02 <yushiro> I added 'enable to handle L2 port' for 'Add/Remove port'  but it is not good.  So, I'll update this feature.
14:31:04 <SarathMekala> thanks.. it bugged me quite a bit.. is it due to the missing div closure?
14:31:56 <yushiro> SarathMekala, Yes.  <div> didn't close like </div>.  But I fixed it and removed script part.
14:32:36 <SarathMekala> ok
14:32:44 <SarathMekala> regarding the L2 port support..
14:32:51 <yushiro> In addition, I found 'Add port' and 'Remove port' behavior.  I wonder we've already tested this button...
14:33:09 <yushiro> I also fix it.
14:33:43 <SarathMekala> we need to provide more info to the user now so that he can under stand what type of port he is seeing on the UI
14:33:48 <yushiro> I think this v2 dashboard patch also need to merge during Q-1.
14:34:07 <xgerman_> Yes. That was our goal —
14:34:10 <SarathMekala> currently we show only the port-id... this needs some enhancement
14:34:39 <SarathMekala> are there any blockers you see?
14:34:44 <yushiro> SarathMekala, +1.  Like 'device_owner' information?  'router_interface' or 'VM port(compute:nova)' ...
14:34:45 <xgerman_> Yes, but would it delay merging? I think we can add that in Q-2
14:35:08 <amotoki> hi, the driver meeting was rescheduled. I am here.
14:35:08 <yushiro> xgerman_, Sure.
14:35:14 <xgerman_> I also like to see egress/ingress filtered better
14:35:25 <yushiro> amotoki, Good evening.
14:35:32 <xgerman_> amotoki Welcome
14:35:49 <SarathMekala> xgerman_, can you eloborate on the egress/ingress filtering
14:35:56 <amotoki> yushiro: it seems still evening in your timezone :p
14:36:36 <yushiro> xgerman_, You mean that filtering 'firewall rule' or 'firewall policy' ?
14:36:46 <yushiro> amotoki, yeah
14:37:02 <xgerman_> Policy. I got default, default before we made changes
14:37:16 <xgerman_> On Default FWG
14:37:37 <yushiro> xgerman_, Aha.  Yeah, your fix is reasonable I think.  It easy to understand what policy is for egress/ingress.
14:38:09 <SarathMekala> ah.. i see.. default-fwg for egress and ingress
14:38:24 <xgerman_> Yep.
14:38:46 <yushiro> #link https://etherpad.openstack.org/p/fwaas-v2-dashboard  Here is note for v2 dashboard.
14:39:16 <yushiro> Please free to write down in 'Future Improvements:' topic :)
14:39:33 <xgerman_> K
14:39:34 <amotoki> IMHO it is better to land the initial patch and add more features then.
14:39:41 <amotoki> are we discussing future improvements?
14:39:41 <xgerman_> Yes!
14:40:11 <SarathMekala> amotoki, I agree
14:40:15 <reedip_> hi
14:40:17 <xgerman_> I think we agreed there are no blockers but need to test more...
14:40:18 <yushiro> amotoki, Yes.  We should fix a few blocking issue and merge first.
14:40:27 <reedip_> sorry i am late :(
14:40:33 <xgerman_> +1
14:40:34 <yushiro> reedip_, hi.  No problem.
14:40:49 <amotoki> backlog topics (like future improvements) can be filed as bugs
14:41:12 <xgerman_> Yep.
14:41:27 <yushiro> xgerman_, SarathMekala 1 blocking point is 'Add port' / 'Remove port' behavior.
14:41:53 <amotoki> yushiro: what do you think are remaining blockers for the initial patch?
14:41:58 <xgerman_> Ouch :-(
14:42:37 <SarathMekala> yushiro, whats your observation on add/remove port?
14:43:01 <yushiro> amotoki, I'll fix only this bug until today.  Other topics will fix in Q-2.
14:43:27 <amotoki> so we have only one critical blocker
14:43:34 <yushiro> amotoki, Yes.
14:44:21 <yushiro> SarathMekala, Could you see my last comment in https://review.openstack.org/#/c/475840/
14:45:02 <yushiro> So, Please skip my concern which I sent you today with attached file(PNG)
14:45:11 <yushiro> Let's fix in Q-2.
14:45:37 <SarathMekala> yushiro, I havent implemented the drag and drop functionality for ports
14:45:56 <xgerman_> Yep. Let’s get it out of the door
14:46:09 <yushiro> SarathMekala, Oh, OK.  Anyway, let's keep on current implementation :)
14:46:20 <amotoki> that is just because generate_html('port') is not called, but you can fix it later
14:46:39 <SarathMekala> amotoki, yes
14:46:49 <SarathMekala> i did not want to g
14:47:09 <SarathMekala> waste cycles on it now
14:47:38 <yushiro> OK,  anything else for v2 dashboard?
14:48:03 <SarathMekala> so whats the final conclusion
14:48:40 <SarathMekala> are we pushing this patch to Q-1 after testing thoroughly?
14:49:12 <yushiro> #action yushiro will fix 'Add/Remove port' behavior during Q-1.
14:49:15 <amotoki> my understanding is to fix the remaining blocker yushiro pointed out for Q-1 and others are deferrred to Q-2
14:49:32 <yushiro> amotoki, That's right.
14:50:14 <SarathMekala> ok.. agreed
14:50:41 <yushiro> OK,
14:50:45 <yushiro> ah, 9 minutes left
14:50:57 <yushiro> but this channel is endless :)
14:51:21 <yushiro> #topic Stadium Compliance
14:51:36 <yushiro> reedip_, Is there any update?
14:51:54 <reedip_> Ok, I had a patch for it , but no update in the last few weeks. I will pull it up today. Can I share the update next week for it ?
14:52:55 <yushiro> reedip_, Yes, please.
14:53:59 <yushiro> #topic Open Discussion
14:55:06 <reedip_> any topics ?
14:55:19 <yushiro> 1 topic.
14:55:46 <yushiro> folks, please wish for zuul will smile(+1) for us :)
14:56:17 <xgerman_> :-)
14:56:18 <SarathMekala> :)
14:56:37 <reedip_> depends if rollback is complete or not ...
14:57:02 <reedip_> yushiro : 1 topic, we have some open bugs, someone needs to look into them. I can volunteer but need some help
14:57:28 <doude> Hi, I started a doc to explain what I proposed for the plugable backend driver
14:57:34 <yushiro> reedip_, I will help you.  You mean into launchpad?
14:57:42 <reedip_> yes ...
14:57:44 <yushiro> doude, OK, great.
14:57:48 <doude> https://bugs.launchpad.net/neutron/+bug/1702312
14:57:49 <openstack> Launchpad bug 1702312 in neutron "[FWaaS v2] Does not work with core plugin non based on Neutron DB model" [Undecided,In progress] - Assigned to Édouard Thuleau (ethuleau)
14:58:01 <doude> it's just some diagrams
14:58:03 <reedip_> doude : thanks, maybe you can add it as an API REF guide in your pluggable backend patch itself
14:58:10 <yushiro> Thanks for your link.
14:58:13 <reedip_> that would help understand the patch and the code
14:58:14 <doude> I used a google doc for that
14:58:22 <xgerman_> Ok. SridarK usually looks into bugs. Let’s have a bug scrub once he is back —
14:58:26 <doude> https://docs.google.com/presentation/d/1_9KkNgIbWYE6tucoym8N7J2xfcQ1XwN8Zuu-ALEUD3U/edit#slide=id.g27fa2ac987_0_66
14:58:31 <reedip_> hmm ... share the link please ?? :)
14:58:36 <doude> still in progress
14:58:51 <yushiro> Yes
14:59:39 <doude> https://docs.google.com/presentation/d/1_9KkNgIbWYE6tucoym8N7J2xfcQ1XwN8Zuu-ALEUD3U/edit?usp=sharing
14:59:56 <yushiro> doude, Thanks for your link.  I'll take a look.
15:00:06 <doude> ok
15:00:07 <yushiro> Ok, it's time now.  Thanks all!!
15:00:10 <yushiro> #endmeeting