14:00:13 <yushiro> #startmeeting fwaas
14:00:14 <openstack> Meeting started Tue May 16 14:00:13 2017 UTC and is due to finish in 60 minutes.  The chair is yushiro. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <openstack> The meeting name has been set to 'fwaas'
14:00:28 <xgerman> o/
14:00:37 <yushiro> #chair SridarK yushiro xgerman njohnston
14:00:41 <openstack> Warning: Nick not in channel: SridarK
14:00:42 <openstack> Warning: Nick not in channel: njohnston
14:00:43 <openstack> Current chairs: SridarK njohnston xgerman yushiro
14:01:01 <hoangcx> o/
14:01:24 <yushiro> SridarK is not here.  OK, let's start.
14:01:34 <xgerman> yep, let’s start
14:01:44 <yushiro> #topic Pike
14:02:02 <reedip_> yushiro : Reference page is the same ?
14:02:22 <xgerman> oh, let’s talk summit at the end then
14:02:28 <reedip_> https://etherpad.openstack.org/p/fwaas-meeting ??
14:02:38 <SridarK> Hi All sorry to be late
14:02:38 <xgerman> #chair SridarK_
14:02:39 <openstack> Warning: Nick not in channel: SridarK_
14:02:40 <openstack> Current chairs: SridarK SridarK_ njohnston xgerman yushiro
14:02:58 <reedip_> there is no Sridark  .... :)
14:02:58 <yushiro> reedip_, yes,
14:03:10 <yushiro> SridarK, Hi, good timing :)
14:03:15 <xgerman> +!
14:03:16 <SridarK> sorry
14:03:23 <SridarK> i forget who is to run today ?
14:03:38 <SridarK> *run the mtg
14:03:54 <yushiro> SridarK, xgerman I forgot :)
14:03:59 <xgerman> me, too
14:04:03 <SridarK> :-)
14:04:14 <SridarK> can one of u run today ?
14:04:20 <xgerman> sure
14:04:22 <SridarK> and we can start the sched with that
14:04:32 <SridarK> i am multitasking
14:04:40 <xgerman> who isn’t those days :-)
14:04:41 <yushiro> Currently I just moved 'Pike' topic.
14:04:44 <SridarK> :-)
14:05:00 <xgerman> ok, let’s talk Pike - summit at the end
14:05:07 <SridarK> sounds good
14:05:07 <yushiro> yes, please.
14:05:23 <SridarK> also we will be missing chandanc and SarathMekala today
14:05:33 <SridarK> chandanc is probab on a plane headed back
14:05:43 <SridarK> SarathMekala had a conflict
14:06:05 <SridarK> so possibly we can run thru quickly
14:06:14 <SridarK> reedip_: welcome back and congrats again
14:06:29 <reedip_> SridarK : Yesp and I missed you guys too :D
14:06:38 <SridarK> :-)
14:06:42 <yushiro> reedip_, meeee tooo :)
14:06:50 <xgerman> +1
14:08:08 <xgerman> Ok, so where are we with Pike?
14:08:32 <xgerman> We decided a few things:
14:08:48 <xgerman> - two RPC topics -> L2, L3
14:09:04 <SridarK> which we debugged for the demo :-
14:09:09 <SridarK> :-)
14:09:32 <reedip_> How was the demo ? Any videos on youtube?
14:09:42 <xgerman> yep, we have a video
14:09:53 <SridarK> reedip_: went well, we can discuss on that topic
14:10:08 <reedip_> k great
14:10:47 <xgerman> #decision to focus on L2 without SG co-exiatsnce for now
14:12:58 <xgerman> I don’t think with the summit we made much progress (other than that we got it to work)
14:13:37 <SridarK> yes we were defn busy with multiple things
14:13:57 <SridarK> but according to chandanc things are in decent shape
14:14:10 <SridarK> on the ovs transition
14:14:17 <SridarK> and target for Pike-2
14:15:26 <yushiro> yes
14:19:25 <xgerman> +1
14:19:33 <xgerman> anyhting else on that topic?
14:20:23 <SridarK> no i think thats all, with that and L2 Agent, DFWG changes we should be good
14:20:39 <SridarK> things do work - but some bugs and focus on UT needed
14:20:52 <yushiro> SridarK, indeed.
14:22:17 <xgerman> #topic FWaaS v2
14:22:48 <xgerman> I don’t think we have much to add what we didn;t already discuss in Pike
14:23:07 <SridarK> +1
14:23:25 <yushiro> xgerman, yes.  I should fix some minor bug about FirewallGroupPortAssociation control.
14:23:26 <reedip_> DId we drop the mail to deprecate fwaas V1 ?
14:24:08 <xgerman> it’s been deprecated for years
14:24:20 <reedip_> xgerman : you got what I meant :)
14:24:27 <yushiro> I'll update L2 agent patch tomorrow.(Now editting a little)
14:24:45 <xgerman> yep, we announced at summit - e-mail is still outstanding
14:24:56 <xgerman> we also had people ask us about migration strategy
14:25:07 <reedip_> xgerman  : and the response ?
14:25:40 <SridarK> yes we had a good discussion with some operators
14:26:00 <SridarK> they would like to see some help with the migration from v1 to v2
14:26:18 <SridarK> there was a neutron services pain points session
14:26:50 <SridarK> so tentatively the plan is to see if we can help them with some scripts to migrate
14:27:09 <SridarK> _not_ anything in terms of alembic but rather bash scripts
14:28:03 <yushiro> we've just been suggested to provide migration 'script' at that time.
14:28:15 <xgerman> yeah, they don’t like to recreate the FW; there is even an operator with a ton of FWaaS V1 firewalls and he is very keen on the migration scripts
14:29:38 <xgerman> but I think before we announce it officially we need to have more ducks in a row
14:30:01 <xgerman> because operators are quick with complaining on a ML
14:30:31 <reedip_> So I think this is something we need to track , fwaasv1 migration to v2
14:31:18 <SridarK> +1 in our discussion - we said we will help with scripts - i think they are fine with any help
14:31:37 <yushiro> +1+1
14:31:42 <xgerman> we don’t think FWaaS V1 and V2 can run on the same system so we need to have a migration strategy which doesn’t exposes the network…
14:31:44 <SridarK> but to xgerman - u are absolutely right we dont want to land up in a messy situation
14:32:15 <xgerman> yep, we should aim to have an announcement before the Pike release…
14:32:17 <reedip_> ok, lets discuss it on the fwaas channel/email/ML
14:32:47 <reedip_> yushiro /xgerman/SridarK : care to put out an action for this item"
14:32:50 <reedip_> ??
14:33:09 <xgerman> #action investigate FWaaS V1 -> V2 migration strategy
14:33:17 <SridarK> i will start a conversation with the operator
14:33:18 <yushiro> xgerman, reedip_ thanks :)
14:33:25 <SridarK> who brought it up
14:33:30 <xgerman> thanks
14:33:32 <SridarK> i will have u guys in the cc
14:33:38 <reedip_> Yeah  :)
14:33:53 <yushiro> yes, sounds good.
14:33:56 <SridarK> he mentioned they have a customer who is using it a lot
14:33:59 <SridarK> and they are quite happy
14:34:04 <SridarK> so that was the good news
14:35:26 <reedip_> :)
14:36:23 <xgerman> indeed
14:36:49 <xgerman> #topic Stadium Compliance
14:37:18 <xgerman> kevinb had a comment on our fullstack regarding us setting up a “test-gate”
14:39:03 <reedip_> Yeah, the one thing I was asking
14:39:08 <reedip_> was confused by the points
14:42:03 <xgerman> ok, probably best to ask in the Neutron channel somebody who knows gates better than me
14:42:15 <xgerman> #topic performance improvement
14:42:29 <xgerman> There was some discussion if we can backport to Ocata or not
14:43:13 <cuongnv> and what we got xgerman?
14:45:39 <xgerman> well, none of us has +2 on the old branches so we need to convicne the Neutron people
14:46:01 <cuongnv> I see..
14:46:46 <reedip_> hmm...
14:47:07 <cuongnv> xgerman, maybe i misunderstood, did you mean you had some discussion about the backport in Boston?
14:47:23 <cuongnv> or comment of Ihar on this ps https://review.openstack.org/#/c/458434/
14:47:34 <xgerman> yeah, I am referring to that comment
14:47:44 <cuongnv> okay
14:47:58 <xgerman> I didn’t discuss but maybe the others had a chance…
14:48:10 <cuongnv> I also replied what I and hoangcx discussed
14:49:27 <cuongnv> atm, i don't see any feedback from Ihar yet, let us try to ping him again
14:50:25 <cuongnv> we are also investigating solution for v2 and SG in neutron
14:50:30 <cuongnv> we will update later
14:50:37 <cuongnv> that's it for perf improvement
14:52:41 <cuongnv> if no one has any comment, we can move on
14:52:47 <reedip_> < 10 minutes left
14:52:48 <xgerman> ok, sounds good
14:53:03 <xgerman> #action cuongnv ping ihar about backport
14:53:10 <xgerman> #topic Summit
14:53:25 <vks1> hi folks
14:53:31 <xgerman> hi
14:53:36 <SridarK> hi
14:53:46 <vks1> sorry I missed this patch https://review.openstack.org/#/c/458723/
14:54:06 <vks1> please review this
14:54:10 <SridarK> Talk and demo went well - some good discussions post talk as well
14:54:12 <xgerman> k
14:54:26 <reedip_> aah, I was thinking about this vks1 , this needs to be tested once. I will test it tomorrow morning and get back to u
14:54:29 <yushiro> vks1, sure
14:54:42 <vks1> thanks
14:55:00 <xgerman> #link https://youtu.be/9Wkym4BeM4M
14:55:08 <xgerman> that’s the talk video
14:56:34 <xgerman> we also had a meeting and have a photo
14:56:51 <yushiro> :)
14:57:09 <SridarK> :-)
14:57:18 <reedip_> sheesh , missed
14:57:29 <yushiro> I will practice to speak English :-)
14:57:32 <reedip_> guys, as its almost time, I raised a request in the neutron-fwaas channel
14:57:34 <SridarK> reedip_: like u did not have something better to do
14:57:55 <reedip_> if someone has some time, please provide me some advice
14:58:11 <reedip_> SridarK : no comments ... she is behind me!
14:58:34 <SridarK> reedip_: sorry can u shoot me an email - i have to run to another mtg and will be offline for some time during the day
14:59:03 <reedip_> SridarK : for the patch, I will, no issues
14:59:11 <yushiro> reedip_, sure
14:59:15 <xgerman> 1 minute
14:59:25 <reedip_> thanks a lot for the time.. its been a long time since I attended the meeting... feels good to be back
14:59:38 <xgerman> glad to have you back ;-)
15:00:05 <reedip_> :)
15:00:08 <reedip_> time's up
15:00:39 <yushiro> seee youuu
15:00:42 <cuongnv> bye all
15:00:45 <SridarK> bye all
15:00:49 <SridarK> have a great week
15:00:52 <yushiro> #endmeeting