14:01:47 <yushiro> #startmeeting fwaas
14:01:48 <openstack> Meeting started Tue May  2 14:01:47 2017 UTC and is due to finish in 60 minutes.  The chair is yushiro. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:51 <openstack> The meeting name has been set to 'fwaas'
14:01:56 <yushiro> #chair SridarK yushiro xgerman njohnston
14:01:58 <openstack> Current chairs: SridarK njohnston xgerman yushiro
14:02:02 <yushiro> OK, let's begin :)
14:02:03 <SridarK> One quick thing b4 we get started
14:02:15 <SarathMekala> hi all O/
14:02:24 <yushiro> SridarK, Sure.  Please going on.
14:02:32 <SridarK> Reviewing the first round draft for the fwaas talk next week
14:03:01 <SridarK> will send out to the wider fwaas folks late today pls take a look and offer corrections and suggestions
14:03:02 <yushiro> cool.  Thanks for your great work!!
14:03:22 <SridarK> thats all - will need to log off shortly  - so wanted to say that quickly
14:03:28 <SridarK> thanks yushiro pls go ahead
14:03:33 <yushiro> I'll reply something with some slides.
14:03:39 <SridarK> yushiro: perfect
14:04:00 <yushiro> SridarK, Sure.  Please take care of yourself.
14:04:16 <SridarK> need to be out today so will see many of u next week at Boston
14:04:33 <yushiro> #action Yushiro will reply some comments for FWaaS slide
14:04:46 <xgerman> see ya
14:05:03 <yushiro> Yup.  Let's see in Boston.
14:05:07 <xgerman> we should start an etherpad listing all the people going to Boston
14:05:21 <SridarK> xgerman: +1
14:05:28 <yushiro> +1
14:05:37 <xgerman> #link https://etherpad.openstack.org/p/FWaaS_BOS
14:05:39 <SridarK> we can use that to coordinate meeting there as well
14:06:10 <yushiro> xgerman, Thanks for your link
14:06:23 <yushiro> wow, live editting :)
14:06:44 <yushiro> OK, let's continue today's discussion.
14:07:25 <yushiro> #topic Pike
14:07:44 <yushiro> L2 Support
14:07:59 <yushiro> 1. OVS driver
14:08:08 <yushiro> chandanc, Hi.  It's your turn :)
14:09:04 <chandanc> Not much progress this week, was busy in office, will push the initial patch for co existance though.  still WIP
14:09:53 <yushiro> chandanc, OK.
14:10:06 <yushiro> 2. L2-agent
14:10:11 <yushiro> with default fwg.
14:10:50 <yushiro> I'm updating these patches now.
14:12:09 <yushiro> First, in creating firewall_group with port, we should call update firewall_group in advance to dissociate port with previous fwg.
14:14:44 <yushiro> OK, I'll update something and please take a look.
14:15:16 <yushiro> next
14:15:21 <yushiro> Neutron-lib adoption: https://review.openstack.org/#/c/421472/
14:16:05 <yushiro> Reedip is not here today, so skip this patch.
14:16:27 <yushiro> Next: Horizon support
14:16:55 <yushiro> sarathmekala_, Is there some update?
14:17:04 <yushiro> about horizon patch?
14:17:11 <sarathmekala__> got some good news
14:17:33 <sarathmekala__> basic functionality is working
14:17:41 <sarathmekala__> take a look at the screen shots https://docs.google.com/document/d/1iZy3Kw-OCZk1VLj-pq3FOdV1-mXw2M0laGchCtMO8G0/edit?usp=sharing
14:18:27 <sarathmekala__> its in a very crude shape though
14:18:38 <sarathmekala__> i havent put in any validations yet
14:18:42 <yushiro> wow, it looks pretty good :)
14:18:54 <xgerman> +10
14:19:08 <sarathmekala__> thanks
14:19:13 <sarathmekala__> for the demo, I have a proposal
14:19:14 <xgerman> yeah,  use them in the presentation ;-)
14:19:44 <yushiro> sarathmekala__, good :)  Just 1 quick:  What is 'Enabled' check box in adding firewall group?
14:20:35 <sarathmekala_> sorry got disconnected
14:20:41 <yushiro> NP :)
14:21:01 <sarathmekala_> I will give you a zip file
14:21:07 <sarathmekala_> can you patch your system and show for the demo
14:21:15 <yushiro> Yes, please :)
14:21:27 <yushiro> I'll try to run it and give you some feedback.
14:21:31 <sarathmekala_> I dont think I can iron out the issues and checkin the code before that
14:21:40 <sarathmekala_> yeah.. sure..
14:21:55 <xgerman> as long as it demos well…
14:22:07 <yushiro> sarathmekala_, +1.  Please focus on 'demo' :)
14:22:27 <yushiro> refactoring/testing is not so urgent now.
14:22:42 <yushiro> sarathmekala_, Sorry for confusing
14:22:55 <SarathMekala> update is not implemented for FirewallGroup yet
14:23:14 <yushiro> OK
14:23:15 <SarathMekala> and the button functions on the table are not implemented as well
14:23:25 <SarathMekala> only create and delete are working as of now
14:23:44 <yushiro> SarathMekala, chandanc SridarK, Ah, I missed telling you about demo environment
14:24:28 <chandanc> yes, please
14:24:59 <yushiro> SarathMekala, chandanc SridarK, my laptop is quite weak(Celelon dual core + 2GB RAM)  I tried to deploy demo env but I couldn't because of lack of specs..
14:25:28 <SarathMekala> ohk..
14:25:31 <chandanc> oh, can you do a recording ?
14:26:45 <xgerman> recording is preferrable - you never know how Interbet. etc. shapes up
14:26:50 <chandanc> I am already running a demo for my other presentation
14:27:16 <SarathMekala> +1 for recording
14:27:42 <SarathMekala> have seem too many stage glitches in the previous summits
14:28:04 <chandanc> i agree
14:28:59 <yushiro> Yeah, it's more safety to record movie.
14:29:12 <xgerman> +1
14:29:36 <xgerman> also bring the presentatio on a USB stick in cas ethey can’t get the comuter to work on the projector
14:31:20 <yushiro> I'd like to do it but I have to do prepare something for another presentation in Boston...
14:32:04 <SarathMekala> I can do the recording and share it with you
14:32:09 <SarathMekala> you guys can use it
14:32:15 <SarathMekala> no need to do the setup :)
14:32:26 <yushiro> SarathMekala, Thank you so much!
14:32:32 <SarathMekala> but one issue is that the service will not get activated :(
14:32:41 <SarathMekala> i dont have the latest patches
14:32:48 <xgerman> people won’t see that in the video
14:32:59 <SarathMekala> ok.. cool
14:33:06 <SarathMekala> will share the video tomorrow
14:33:13 <xgerman> thx
14:33:13 <yushiro> xgerman, +1  I'm OK to pasting link into youtube or somewhere.
14:33:20 <yushiro> in presentation.
14:33:50 <SarathMekala> sure.. can do that
14:33:53 <yushiro> It's more kindness for pasting screen capture in your outstanding GUI :)
14:34:04 <yushiro> in slide.
14:34:22 <SarathMekala> :)
14:34:40 <yushiro> OK, anything else to discuss?
14:34:51 <yushiro> let's move on.
14:34:55 <SarathMekala> thats it from my side
14:35:18 <yushiro> #topic FWaaS v2
14:36:07 <yushiro> I was commented by Paddu about L2-agent. will update them.
14:37:04 <yushiro> #link https://review.openstack.org/#/c/425769/  neutron-fwaas: Generate default firewall group via project (Yushiro)
14:37:36 <yushiro> default fwg, we need testing/reviewing.
14:38:05 <yushiro> I'm focusing on L2-agent now, so, it will helpful for add UTs into default fwg or reviewing :)
14:38:30 <yushiro> next.
14:38:38 <yushiro> #topic Stadium Compliance
14:39:25 <yushiro> In this part, is there some update?  (fullstack, API definition..)
14:40:24 <yushiro> OK, will wait for reedip.  Skip it.
14:40:34 <yushiro> #topic performance improvement
14:41:00 <cuongnv> the code was merged into master about 2 weeks ago
14:41:20 <cuongnv> now, we're trying to make a backport to ocata
14:41:40 <yushiro> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron-fwaas+branch:stable/ocata+topic:bug/1664294
14:41:43 <cuongnv> here is the link for backport https://review.openstack.org/#/q/status:open+project:openstack/neutron-fwaas+branch:stable/ocata+topic:bug/1664294
14:41:48 <cuongnv> thanks yushiro
14:42:34 <cuongnv> also, we're investigating a solution for v2 and SG in Neutron, will update later
14:42:44 <cuongnv> that's all from my side
14:43:06 <yushiro> OK, will review for backported patch.  However, I can put only +1 for them.
14:43:12 <cuongnv> i see
14:43:28 <yushiro> #topic bugs
14:44:37 <yushiro> Launchpad(filtered by tag 'fwaas'): http://urx2.nu/C7UI
14:45:54 <yushiro> Hmm, there is no emergency bugs.
14:46:10 <yushiro> OK
14:46:10 <yushiro> #topic Open Discussion
14:46:52 <yushiro> 6 days left before Boston summit
14:47:16 <yushiro> I'll be in Boston in 7th evening.
14:47:34 <xgerman> yeah, I will arrives Sunday -> Thursday
14:47:40 <chandanc> I am starting on 4th
14:47:49 <chandanc> will be early
14:48:13 <yushiro> chandanc, aha, great :)
14:48:24 <xgerman> teah, BOS ia. fun city ;-)
14:48:41 <yushiro> xgerman, yeah, I'd like to :)
14:48:44 <xgerman> there might also be people staying from the RedHat summit
14:48:48 <chandanc> sure :)
14:49:11 <yushiro> yeah.
14:49:55 <yushiro> I wonder Boston's temparture is cold or not so cold..
14:50:08 <xgerman> I heard cold but haven’t checked
14:50:26 <yushiro> xgerman, yeah, it is colder than Japan.
14:50:59 <chandanc> oh good to know
14:51:24 <chandanc> yushiro, when is your other talk ?
14:53:03 <yushiro> chandanc, very early.  Mon 8, 2:00pm-2:40pm
14:53:05 <yushiro> https://www.openstack.org/summit/boston-2017/summit-schedule/global-search?t=yushiro
14:53:21 <chandanc> oh ok
14:53:40 <yushiro> My other session is logging API with Monasca.
14:53:41 <chandanc> i have it on the same day, 9th morning
14:54:00 <chandanc> sure, will be there
14:54:15 <yushiro> Aha, OK.  Please do your best :)
14:54:26 <yushiro> Ok, anything else??
14:54:39 <chandanc> thanks
14:54:50 <chandanc> nothing from my side
14:55:09 <yushiro> Currently, I just cought a cold now.  Please take care of yourself and enjoy flight time to Boston :)
14:55:53 <yushiro> OK
14:55:55 <yushiro> #endmeeting