16:00:12 <vkozhukalov> #startmeeting Fuel
16:00:13 <openstack> Meeting started Thu Jun 26 16:00:12 2014 UTC and is due to finish in 60 minutes.  The chair is vkozhukalov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:16 <openstack> The meeting name has been set to 'fuel'
16:00:19 <vkozhukalov> Hi everyone
16:00:22 <evgeniyl> Hi
16:00:23 <vkozhukalov> who is here?
16:00:28 <ikalnitsky|home> o/
16:00:29 <akasatkin1> Hi
16:00:31 <nurla> hi fuelers!
16:00:43 <christopheraedo> Hello!
16:00:59 <vkozhukalov> as usual agenda is here
16:01:05 <vkozhukalov> #link https://etherpad.openstack.org/p/fuel-weekly-meeting-agenda
16:01:16 <mattymo> I'm here
16:01:17 <vkozhukalov> #chair vkozhukalov
16:01:18 <openstack> Current chairs: vkozhukalov
16:01:26 <meow-nofer__> hi
16:01:36 <vkozhukalov> #topic blueprints process proposal
16:02:07 <vkozhukalov> #link http://lists.openstack.org/pipermail/openstack-dev/2014-June/038501.html
16:02:11 <asledzinskiy> hi
16:02:26 <izinovik> hi
16:02:39 <dpyzhov> hi
16:02:42 <vkozhukalov> dpyzhov has a series of suggestions about how to improve blueprints flow
16:02:50 <vkozhukalov> dpyzhov: around?
16:03:07 <xarses> hi
16:03:18 <dpyzhov> Yes, I send proposals, please review and respond
16:03:44 <dpyzhov> I need your opinion before updating our process
16:05:05 <dpyzhov> The main ideas are: do not track features as bugs and do not track future blueprints in current release
16:06:00 <vkozhukalov> you mean even very minor features must be treated as blueprints, right?
16:06:09 <vkozhukalov> dpyzhov: ok
16:06:09 <dpyzhov> Yep
16:06:16 <mattymo> but no spec
16:06:18 <angdraug> +1, the proposal needs a bit more clear-cut criteria to tell blueprints from bugs, and bluprints from work items, but I support the proposal itself
16:06:25 <dpyzhov> mattymo: exactly
16:06:30 <mattymo> +1
16:06:38 <meow-nofer__> +1
16:06:40 <vkozhukalov> so guys, please give your opinions in ML
16:06:46 <vkozhukalov> moving
16:07:01 <vkozhukalov> #topic bug squashing day results
16:07:31 <dpyzhov> angdraug: could you share status of bug squashing day, please?
16:08:16 <vkozhukalov> dpyzhov: angdraug: would you like to share any stats about how squashing day was this week
16:08:51 <angdraug> summary is: we've improved our process from last week, but we didn't catch up with new bugs opened during the week
16:09:08 <angdraug> we are also inflating bug priorities a little
16:09:19 <mattymo> angdraug, we've got everyone on feature work and still no dedicated bug team
16:09:27 <mattymo> it was proposed last cycle, but not actually implemented
16:10:17 <dpyzhov> mattymo: we will have feature freeze in a week. I hope we will have more free hands for bugfixing after it
16:10:38 <angdraug> #link https://docs.google.com/a/mirantis.com/spreadsheets/d/10mUeRwOplnmoe_RFkrUSeVEw-__ZMU2nq23BOY-gzYs/edit#gid=1683970476
16:10:39 <vkozhukalov> i believe it was much better than last week
16:10:39 <vkozhukalov> maybe we can expose stats in ML
16:10:39 <vkozhukalov> dpyzhov: will you share stats in ML?
16:10:54 <angdraug> stats are in the link ^
16:11:37 <xarses> angdraug: did adding 30K lines of code help or bugs per K?
16:11:50 <angdraug> marginally, we're still ways above 1.0
16:12:24 <angdraug> we should be more mindful of bug priorities, and we should look to make bug squashing day have more impact
16:12:28 <angdraug> moving on?
16:12:38 <dpyzhov> looks like vkozhukalov is offline
16:12:50 <dpyzhov> #topic 5.0.1 release schedule
16:13:01 <angdraug> I propose to set hard code freeze for 5.0.1 to 7/2 (day after next bug squashing day)
16:13:17 <angdraug> if all goes well, this will allow us to release 5.0.1 on 7/7
16:13:30 <dpyzhov> angdraug: actually, we depend on upgrade feature
16:13:35 <vkozhukalov1> #chair dpyzhov
16:13:43 <dpyzhov> #topic 5.0.1 release schedule
16:13:53 <vkozhukalov1> #topic 5.0.1 release schedule
16:14:02 <angdraug> dpyzhov: good point, what's the status of that?
16:14:36 <evgeniyl> we still don't have dedicated person to work on 5.0.1 upgrades
16:15:03 <dpyzhov> I suggest to move akasatkin1 back to upgrade team
16:15:21 <dpyzhov> in order to fix this asap
16:15:23 <evgeniyl> there should not be problems to backport upgrade system from 5.1 to 5.0.1
16:15:39 <evgeniyl> I'm agree
16:15:43 <angdraug> can be done by end of next week?
16:15:49 <angdraug> by 7/2?
16:15:58 <dpyzhov> I believe so
16:16:03 <dpyzhov> evgeniyl: ?
16:16:04 <angdraug> akasatkin1: can you confirm?
16:16:06 <evgeniyl> I think yes
16:16:07 <akasatkin1> no objections
16:16:25 <vkozhukalov1> ok, any other details?
16:16:38 <dpyzhov> angdraug: what about bugs status?
16:16:48 <dpyzhov> are we ok with 5.0.1 bugs?
16:17:13 <angdraug> we won't fix all of them, but the fixes we have so far are already enough to push out a release
16:17:27 <dpyzhov> nice
16:17:30 <angdraug> that's why I want to freeze after next bug squashing day, catch up even more
16:17:32 <vkozhukalov1> angdraug: great
16:17:51 <angdraug> moving?
16:17:57 <evgeniyl> there are several steps, 1. backport upgrade system, 2. fix UI to use latest version of openstack for new cluster (since we don't backport patching) 3. tesing
16:18:02 <vkozhukalov1> moving
16:18:20 <vkozhukalov1> #topic Features
16:18:32 <vkozhukalov1> #topic KVM+NSX
16:18:53 <AndreyDanin> izinovik, please, share your progress
16:19:41 <vkozhukalov1> izinovik: around?
16:19:46 <izinovik> most part of BP is implemented, except Testing section
16:19:51 <izinovik> yes, I'm here
16:20:00 <izinovik> right now I do manual tests
16:20:16 <vkozhukalov1> BP is
16:20:21 <vkozhukalov1> #link https://blueprints.launchpad.net/fuel/+spec/neutron-nsx-plugin-integration
16:21:02 <vkozhukalov1> izinovik: thanx
16:21:05 <vkozhukalov1> moving
16:21:09 <izinovik> ok
16:21:20 <vkozhukalov1> #topic vCenter HA
16:21:34 <vkozhukalov1> #link https://blueprints.launchpad.net/fuel/+spec/vcenter-hv-full-scale-support
16:21:46 <AndreyDanin> Implementation of nova-compute HA for vCenter will be started on the next week
16:22:31 <AndreyDanin> !
16:22:35 <vkozhukalov1> don't forget, next week is feature freeze
16:22:41 <dpyzhov> AndreyDanin: ha is out of scope for 5.1?
16:23:15 <AndreyDanin> We decided to keep nova-compute and nova-network on the controller nodes and move them under Pacemaker
16:23:17 <angdraug> it's a "should" priority, looks like it's not going to make it
16:23:49 <angdraug> AndreyDanin: if it's not merged by feature freeze, it's out
16:24:06 <vkozhukalov1> angdraug: exactly
16:24:41 <AndreyDanin> Ok. We will rearange tasks to people today.
16:24:59 <vkozhukalov1> ok, thanx
16:25:02 <vkozhukalov1> moving on
16:25:17 <vkozhukalov1> #topic Cinder VMware VMDK driver
16:25:25 <vkozhukalov1> again AndreyDanin
16:25:36 <igajsin> I checked VMDK driver for fuel. I can create and destroy volumes via VMDK manually also attach and detach their to/from instances. Therefore vmdk driver works good.
16:25:48 <igajsin> And next week I will modify fuel to make cinder.conf and nova.conf with support vmdk driver on deploying
16:26:47 <vkozhukalov1> igajsin: great, looks like we have good chance to see it in 5.1
16:27:02 <vkozhukalov1> any other details here?
16:27:41 <vkozhukalov1> moving on?
16:27:48 <alex_didenko> 1sec
16:28:51 <alex_didenko> igajsin: please take under consideration this https://review.openstack.org/101471 , upstream cinder module has a backend for vmdk
16:29:29 <vkozhukalov1> alex_didenko: good point
16:29:43 <angdraug> moving?
16:30:06 <vkozhukalov1> #topic vCenter+KVM
16:30:09 <AndreyDanin> We need a lab to start developing of vcenter+kvm. Unfortunately, we will get the lab on next week. It means, we won't provide any code before FF.
16:30:50 <xarses> I thought we had a vcenter env already?
16:31:10 <xarses> why cant we use virtual KVM like in devops?
16:31:10 <AndreyDanin> yes. we use it to test and develop other vcenter features
16:31:17 <vkozhukalov1> AndreyDanin: what about design? have you already designed feature?
16:31:36 <AndreyDanin> #link https://blueprints.launchpad.net/fuel/+spec/vcenter-nsx-support
16:31:56 <vkozhukalov1> AndreyDanin: thanx
16:32:11 <xarses> hrm, is topic wrong then, url is venter+nsx
16:32:16 <xarses> topic is vcenter+kvm
16:32:23 <vkozhukalov1> but it is nsx
16:32:44 <AndreyDanin> yes
16:32:45 * xarses was confused
16:32:50 <AndreyDanin> me too
16:32:52 <xarses> topic is vCenter+NSX
16:33:01 <AndreyDanin> topic should be vcenter+nsx
16:33:07 <vkozhukalov1> ok
16:33:24 <vkozhukalov1> moving
16:33:36 <vkozhukalov1> #topic Access control master node
16:34:10 <vkozhukalov1> dpyzhov: do you have any info about this feature?
16:34:22 <vkozhukalov1> or maybe mattymo has
16:34:32 <mattymo> salmon isn't here
16:34:37 <mattymo> I have an update I sent today to Fuel Dev
16:35:04 <mattymo> The short summary is nailgun work is proceeding well, but there are bugs in the UI and with nailgun-agent (bootstrap and deployed nodes) for unauthenticated requests
16:35:14 <vkozhukalov1> #link https://blueprints.launchpad.net/fuel/+spec/access-control-master-node
16:35:42 <mattymo> the fuelclient and fuel-ostf portion of the work is behind schedule and I'm nervous it won't make feature freeze without any help from Fuel Python team
16:36:05 <vkozhukalov1> mattymo: what is your estimate about those issues?
16:36:14 <mattymo> keystone implementation is ready and can be merged today
16:36:22 <vkozhukalov1> mattymo: is it going to be landed in 5.1
16:36:43 <mattymo> nailgun we can fix in 1-2 days. If we get help from python team, we'll meet the feature freeze date for sure
16:37:09 <mattymo> otherwise it will slip feature freeze and we'll see if it can be still included in 5.1
16:37:28 <vkozhukalov1> dpyzhov: do we have a person who can help here?
16:37:38 <meow-nofer__> mattymo: are guys from Poland working on nailgun side?
16:37:58 <mattymo> yes. Lukasz Oles and Kamil Sambor
16:38:23 <meow-nofer__> so, they need some help with it?
16:38:29 <mattymo> in addition, Bogdan D, Vitaly K, and Aleksandra M did UI work
16:38:32 <dpyzhov> mattymo: Ok, you can contact with a_teem, will see if he can halp
16:38:47 <vkozhukalov1> dpyzhov: thanx
16:38:47 <dpyzhov> *help
16:38:53 <mattymo> great
16:39:08 <vkozhukalov1> #topic Secure Fuel Master services
16:39:18 <mattymo> I have an update on that too :)
16:39:23 <vkozhukalov1> #link https://blueprints.launchpad.net/fuel/+spec/secure-fuel-master-services
16:39:35 <mattymo> Code is all QA'd and ready to merge. https://review.openstack.org/#/q/topic:bp/secure-fuel-master-services,n,z
16:39:36 <vkozhukalov1> mattymo: please share
16:39:48 <mattymo> I just need a generous core reviewer to push them all
16:40:39 <xarses> =)
16:40:46 <angdraug> mattymo: don't look at me, I'll only merge fuel-web commits that already have 2 +1's from fuel-web developers
16:41:09 <mattymo> angdraug, you can collaborate with dpyzhov
16:41:18 <vkozhukalov1> dpyzhov: any suggestions?
16:41:33 <vkozhukalov1> ok, guys, moving on
16:41:38 <dpyzhov> angdraug mattymo: I’m looking no your requests
16:41:43 <dpyzhov> move on
16:41:50 <vkozhukalov1> #topic Fuel Master firewall
16:42:10 <mattymo> all iptables rules have been refactored and is nearly ready for review, but I am still testing it.
16:42:25 <vkozhukalov1> #link https://blueprints.launchpad.net/fuel/+spec/master-node-iptables-ruleset
16:42:38 <mattymo> just a quick update. a single patch covers it all. I expect to be ready Monday for QA and merge
16:42:55 <vkozhukalov1> mattymo: great
16:43:00 <vkozhukalov1> moving on
16:43:19 <vkozhukalov1> #topic Nailgun ML2
16:43:31 <xarses> Neutron ML2 - Making good progress, nearly done re-patching upstream puppet-neutron into fuel. Should have reviews up for testing shortly(maybe tonight / tomorrow). Spec is still not approved. No QA is identified as lead for testing yet. Progress can be tracked at
16:43:31 <xarses> #link https://github.com/xarses/fuel-library/compare/bp/ml2-neutron?expand=1
16:43:41 <xarses> corosync HA composition appears to work well without cs_shadow (tested sandboxed since all of fuel isn't plugged in yet). We should consider using it to replace other corosync usage so we don't have to mingle the code into the upstream manifests.
16:43:41 <xarses> #link https://github.com/xarses/fuel-library/blob/bp/ml2-neutron/deployment/puppet/neutron/manifests/fuel_extras/corosync.pp
16:45:07 <vkozhukalov1> any questions here?
16:45:28 <vkozhukalov1> xarses: thanx for status
16:45:30 <dpyzhov> nurla: we need a qa here
16:45:48 <vkozhukalov1> #topic Nailgun plugins
16:45:49 <dpyzhov> move on
16:45:56 <nurla> dpyzhov: as i know - noqa
16:46:03 <vkozhukalov1> meow-nofer__: your turn
16:46:13 <meow-nofer__> so, on plugins there is a good progress
16:46:17 <vkozhukalov1> #link  https://blueprints.launchpad.net/fuel/+spec/nailgun-plugins
16:46:32 <meow-nofer__> but PR is kinda hard to review, so I arranged a meeting on tomorrow
16:46:52 <meow-nofer__> I’ll go through code and say why it’s how it’s done
16:47:10 <vkozhukalov1> meow-nofer__: good idea to have meeting to explain all that stuff to reviewers
16:47:24 <xarses> I don't see a meeting invite for that
16:47:26 <vkozhukalov1> it is a huge patch
16:47:40 <meow-nofer__> so, after that I’ll fix some comments and write a spec for 5.1
16:47:47 <meow-nofer__> not «
16:47:59 <meow-nofer__> not»support plugins», but experimental stuff
16:48:03 <vkozhukalov1> #action meow-nofer__ sends invite to xarses
16:48:28 <vkozhukalov1> meow-nofer__: thanx
16:48:45 <vkozhukalov1> #topic Image based provisioning
16:48:55 <vkozhukalov1> good progress here
16:48:55 <meow-nofer__> xarses: sent
16:49:18 <angdraug> moving on?
16:49:24 <vkozhukalov1> unfortunately agordeev is sick
16:49:47 <vkozhukalov1> so we have some delay in cloud-init stuff
16:50:09 <vkozhukalov1> but i believe we'll see this feature in 5.1
16:50:12 <vkozhukalov1> moving
16:50:25 <vkozhukalov1> #topic Mellanox
16:50:38 <vkozhukalov1> #link https://blueprints.launchpad.net/fuel/+spec/mellanox-features-support
16:50:43 <nuritv> Hi, Mellanox status is as follow:
16:50:52 <nuritv> Implementation of  Mellanox features over Centos are mostly done and working locally. Finalizing now the coding over Ubuntu. Local manual tests are in progress.
16:51:08 <nuritv> However, I have several questions and I hope this is the correct place: 1.	We are depending on the Ml2 package and the Qemu 2.0 upgrade. In our local code we are working with both, but since feature freeze is at 3/7, I wonder if there is a due date for uploading them upstream  2.	We have sent a Mellanox Centos required packages list to the dev-list. What is the process we should follow? Should we open a task / bug some
16:51:49 <nuritv> Mellanox drivers are enable in the webui). 3.	aviramb had committed our first change for the bootstrap  (added Mellanox support for recognizing our HW). What should we do in order to push it?
16:52:13 <nuritv> Our team is new with the processes here so I hope the questions are appropriate.
16:52:21 <xarses> nuritv: so far, for packages we have been creating a bug and it gets assigned to fuel-osci
16:52:53 <nuritv> Xarses: how can i follow?
16:53:28 <xarses> nuritv: lets go over the package needs after the meeting in #fuel
16:53:42 <nuritv> Xarses: ok. thanks
16:53:50 <vkozhukalov1> rvyalov: around?
16:54:15 <dpyzhov> nuritv: create a bug in fuel project and add fuel-osci as assignee
16:54:16 <xarses> nuritv: please paste reviews open so we can start chasing them
16:54:17 <vkozhukalov1> can you give comments about ml2 and qemu 2.0 packaging status?
16:54:40 <nuritv> Xarses: here?
16:54:46 <xarses> yes
16:54:58 <nuritv> #link https://review.openstack.org/#/c/101126/
16:55:39 <xarses> vkozhukalov1: neutron ml2 should be in fuel packages already. nuritv is this an issue with the code bits not being present, or the manifests dont configure ml2 plugin yet?
16:56:00 <vkozhukalov1> nuritv: it is better to discuss all those questions in #fuel-dev and ML
16:56:14 <rvyalov> yes, packages for qemu 2.0 building and they testing
16:56:17 <nuritv> Xarses: manifests
16:56:28 <nuritv> we are working locally with the packages
16:56:55 <nuritv> vkozhukalov1: ok
16:57:06 <vkozhukalov1> nuritv: ok
16:57:12 <rvyalov> for other packages please create bug on launchpad
16:57:22 <xarses> nuritv: That will be on me for ml2-neutron, we will need to discuss what entry points you need so that we can ensure it works together
16:57:25 <vkozhukalov1> looks like we have couple minutes for other questions
16:58:10 <vkozhukalov1> xarses: rvyalov: please stay in contact with nuritv
16:58:26 <vkozhukalov1> #topic Open discussion
16:58:31 <vkozhukalov1> 1 minute
16:59:27 <vkozhukalov1> ok guys, looks like no one has any questions here, if has, let's move in #fuel-dev
16:59:33 <vkozhukalov1> ending
16:59:43 <vkozhukalov1> #endmeeting Fuel
17:00:13 <rvyalov> nuritv:  we building neutron-ml2 packages, please create bug for add their for ISO
17:00:19 <vkozhukalov1> #endmeeting