15:00:32 <ad_ri3n_> #startmeeting fog-edge-massively-distributed-clouds
15:00:32 <openstack> Meeting started Wed Apr 11 15:00:32 2018 UTC and is due to finish in 60 minutes.  The chair is ad_ri3n_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:35 <openstack> The meeting name has been set to 'fog_edge_massively_distributed_clouds'
15:00:47 <ad_ri3n_> #chair  ad_ri3n_
15:00:48 <openstack> Current chairs: ad_ri3n_
15:00:54 <ad_ri3n_> #topic roll call
15:00:58 <ad_ri3n_> Hi guys ?
15:01:08 <jdandrea> o/
15:01:39 <dpertin> o/
15:02:24 <ad_ri3n_> ansmith:  kgiusti ?
15:02:27 <ad_ri3n_> parus ?
15:02:29 <kgiusti> o/
15:02:35 <ad_ri3n_> msimonin?
15:02:38 <jamemcc> hello
15:02:42 <eeiden> o/
15:02:44 <ad_ri3n_> hi jamemcc
15:02:47 <ansmith> o/
15:03:19 <ad_ri3n_> ok
15:03:27 <ad_ri3n_> I just read parus might be late
15:03:33 <ad_ri3n_> so let's start
15:03:43 <ad_ri3n_> #info agenda
15:03:44 <ad_ri3n_> #link https://etherpad.openstack.org/p/massivfbely_distributed_ircmeetings_2018 (line 391)
15:04:46 <ad_ri3n_> #topic news
15:05:30 <ad_ri3n_> so not so much from my side to be honest (attending a summer school last week on experimental testbeds for edge infrastructures: http://www.silecs.net/1st-grid5000-fit-school/)
15:05:59 <csatari> The correct #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2018
15:06:12 <ad_ri3n_> so I was expecting parus would give us a brief summary of what has been achieved during these two last weeks
15:06:38 <ad_ri3n_> thanks csatari  (I can fix the link at the top of the etherpad).
15:06:45 <ad_ri3n_> Thanks dpertin for the fix ;)
15:07:05 <ad_ri3n_> so as I wrote, not so much from my side.
15:07:21 <ad_ri3n_> Just that there will be a new SIG in the K8S community that will also discuss edge related challenges
15:08:29 <ad_ri3n_> and I didn't unfortunately attend the edge session meeting this morning (1 UTC)
15:09:05 <ad_ri3n_> csatari:  did you attend it?
15:09:17 <eeiden> WHAT
15:09:21 <eeiden> so sorry
15:09:24 <ad_ri3n_> maybe you can update us a bit regarding the different action?
15:09:25 <csatari> Nope, it was 4AM for me.
15:09:29 <ad_ri3n_> :-)
15:09:36 <ad_ri3n_> ok
15:09:54 <ad_ri3n_> csatari:  any news regarding the current discussion and the wiki page you consolidated?
15:10:19 <csatari> #link https://wiki.openstack.org/wiki/OpenStack_Edge_Discussions_Dublin_PTG
15:11:05 <csatari> Any comments are welcome :) We will have a specific meeting on #edge-computing-group to discuss comments and questions.
15:11:30 <ad_ri3n_> +1
15:11:34 <eeiden> Hey all -- just as a quick FYI I'm Elise Eiden, I'm transitioning into @jamemcc 's LCOO chair position. I've been working in the open source space for about four years, and as a developer on our OpenStack team for about two years.
15:11:37 <ad_ri3n_> actually we should propose a slot
15:11:46 <eeiden> Looking forward to working with you all :)
15:11:58 <ad_ri3n_> thanks eeiden and welcome ;)
15:12:05 <csatari> My main aim with this was 1) to summarize what happened for myself 2) have a place where we store the things what we agreed on. Something what is more stable than a bunch of etherpads.
15:12:16 <jdandrea> +1
15:12:17 <ad_ri3n_> csatari:  +1
15:12:34 <ad_ri3n_> I have a couple of comments/questions  I would like to discuss
15:12:44 <ad_ri3n_> it is still not clear from my side what is the main target
15:13:14 <ad_ri3n_> from our side, we (in particular dpertin) tries to identify what are the missing features in each key service (Keystone, Nova, Glance and Neutron)
15:13:31 <ad_ri3n_> based on the requirements/information we have gathered
15:14:05 <csatari> I think there are 2 targets:
15:14:06 <ad_ri3n_> The simplest ones: should keystone be revised/extended to be able to define different rights per region/site?
15:14:27 <ad_ri3n_> more complex: you want to boot a VM on site A but using a VMI stored on site B
15:14:28 <csatari> Collect the high level features of an edge cloud infrastructure.
15:14:55 <ad_ri3n_> the second feature may require more important changes on both Nova and Glance where as the simplest ones are only one single service based.
15:15:06 <csatari> And to collect  the requirements of the actual components of different open source projects to implement these features.
15:15:38 <ad_ri3n_> not sure I correctly understand your second point.
15:15:48 <ad_ri3n_> the first one is clear
15:15:50 <ad_ri3n_> ;)
15:15:56 <csatari> That is the same what you wrote.
15:16:05 <ad_ri3n_> ok
15:16:12 <csatari> Like things what we need to implement in Keystone for example.
15:16:18 <ad_ri3n_> so the second is diving into a particular components and try to identify what is missing?
15:16:21 <ad_ri3n_> ok
15:16:22 <ad_ri3n_> thanks
15:16:26 <csatari> Yes
15:16:37 <ad_ri3n_> so do you think there is a third step
15:16:50 <ad_ri3n_> identify what is not in the available components and that should be implemented outside
15:17:00 <ad_ri3n_> because it is not related to the components.
15:17:15 <csatari> Yes: The component specific design (blueprint creation in case of OpenStack) and implementaiton.
15:17:34 <ad_ri3n_> ok
15:17:47 <csatari> To decide the components relates to the 2nd step I believe.
15:17:52 <ad_ri3n_> On the ML I was a bit lost as I didn't know whether the two first steps were completed
15:17:55 <ad_ri3n_> from our side, not
15:18:21 <csatari> Not perfectly.
15:18:33 <csatari> But we have something achieved in both steps.
15:18:36 <ad_ri3n_> i.e. the gap analysis of the current mechanisms (at least major ones; keystone/Glance/Nova/Neutron) is not achieved yet
15:18:56 <ad_ri3n_> ok
15:19:22 <csatari> Yes, we should work on that and extend the requrements part of the wiki.
15:19:24 <ad_ri3n_> #action organize a dedicated meeting to go through the dublin wiki pge
15:19:33 <ad_ri3n_> can you take the action csatari?
15:19:37 <csatari> Yes
15:19:39 <ad_ri3n_> great
15:19:58 <ad_ri3n_> ok
15:20:06 <ad_ri3n_> parus is still not there so I propose to go on
15:20:19 <ad_ri3n_> #topic ongoing-action-gapanalysis
15:20:30 <ad_ri3n_> from our side, we are still waiting for the hotEdge notification
15:20:35 <ad_ri3n_> @dpertin date?
15:20:42 <dpertin> end of april i think
15:20:43 <ad_ri3n_> (by end of april if I'm corect)
15:20:45 <ad_ri3n_> ok thanks
15:20:53 <ad_ri3n_> so keep fingers crossed
15:21:19 <ad_ri3n_> maybe we can add the discussion regarding the page csatari consolidated on the wiki inside this action
15:21:23 <ad_ri3n_> it looks relevant
15:21:36 <ad_ri3n_> (at least from my side), unless someone disagrees I will take some notes in the pad
15:22:50 <csatari> ok for me
15:23:14 <ad_ri3n_> ok done
15:23:19 <ad_ri3n_> nothing more on that point
15:23:29 <ad_ri3n_> if there is no question, let's move to the next one
15:23:44 <ad_ri3n_> ah..
15:23:52 <ad_ri3n_> ok so maybe let's go back just a bit
15:23:56 <ad_ri3n_> hi parus
15:23:58 <ad_ri3n_> #chair parus
15:23:58 <openstack> Current chairs: ad_ri3n_ parus
15:24:01 <parus> hi.
15:24:06 <parus> Sorry to be late.
15:24:11 <ad_ri3n_> The floor is yours ;)
15:24:12 <ad_ri3n_> please
15:24:14 <dpertin> hey parus
15:24:28 <ad_ri3n_> we already discussed news and gap analysis discussions
15:24:30 <parus> Well I put some updates on the etherpad.
15:24:52 <parus> One was about the edgecomputing meeting yesterday night.
15:24:57 <ad_ri3n_> but it would be great if you can give us a short update regarding the current discussions (in particular none attended the meeting this morning)??
15:25:22 <parus> The bulk of the discussion was around Prakash' proposal.
15:26:03 <parus> He has rounded up a group of 4, 5 people to help with some proof of concept around cloudtle
15:26:11 <parus> He is looking for more help.
15:26:23 <ad_ri3n_> I know people form inwinstack are porting some codes
15:26:30 <ad_ri3n_> but it is related to live migration specifis
15:26:31 <ad_ri3n_> etc..
15:26:35 <ad_ri3n_> if I'm right
15:26:40 <ad_ri3n_> isn't it?
15:26:41 <parus> It is .
15:26:54 <parus> Live migrations of VMs that are stateful.
15:27:25 <parus> he had a diagram, where an application can request storage for state and get it allocated on the edge node.
15:27:35 <ad_ri3n_> I think we should give a look to this document
15:27:37 <ad_ri3n_> #link http://gabriel.cs.cmu.edu/DOCS/CMU-CS-15-123.pdf
15:27:58 <ad_ri3n_> do you a link toward such a diagram?
15:28:16 <parus> He was building on that, and he was building on the ETSI MEC architecture.
15:28:23 <ad_ri3n_> ok
15:28:32 <ad_ri3n_> they are implementing the OEC proposal
15:28:36 <parus> He is talking about creating a new API, for the application to request storage.
15:28:38 <ad_ri3n_> Rolf introduced to us
15:28:59 <parus> Yes.
15:29:01 <ad_ri3n_> at SF (during the opendev event)
15:29:04 <ad_ri3n_> ok
15:29:10 <ad_ri3n_> good to see things are progressing
15:29:16 <ad_ri3n_> If I'm right they are complementaries
15:29:20 <parus> The issue I see is that his proposal goes beyond Openstack.
15:29:41 <parus> but it includes some openstack features that extend openstack++ further.
15:29:53 <ad_ri3n_> ok
15:30:03 <parus> So expect a session on that when we are in Vancouver.
15:30:17 <ad_ri3n_> great
15:30:24 <parus> That is my update on the meeting this morning.
15:30:25 <ad_ri3n_> maybe this should be written somewhere here
15:30:30 <ad_ri3n_> https://etherpad.openstack.org/p/FEMDC_Vancouver_brainstorming
15:30:33 <ad_ri3n_> link https://etherpad.openstack.org/p/FEMDC_Vancouver_brainstorming
15:30:35 <ad_ri3n_> #link https://etherpad.openstack.org/p/FEMDC_Vancouver_brainstorming
15:30:36 <ad_ri3n_> sofry
15:30:42 <ad_ri3n_> can you please add something on that ?
15:30:48 <parus> 11:30 <ad_ri3n_> can you please add something on that ?
15:30:51 <parus> I did.
15:30:52 <ad_ri3n_> I would like to come back later
15:31:01 <ad_ri3n_> ok I just saw it now
15:31:01 <parus> line 14
15:31:02 <ad_ri3n_> thanks
15:31:05 <ad_ri3n_> ok
15:31:17 <ad_ri3n_> so if there is nothing more let's go back to the ongoing actions?
15:31:32 <parus> The other updates were related to ONS and the followups. Let me know if you hvave queestions.
15:31:49 <ad_ri3n_> ok thanks
15:31:54 <ad_ri3n_> 3:30
15:32:06 <ad_ri3n_> I propose to go on and come back later (just to be sure we can discuss all aspects)
15:32:25 <ad_ri3n_> #topic ongoing-action-cockroach
15:33:12 <ad_ri3n_> not sure Marie is there
15:33:25 <marie_> yep
15:33:29 <ad_ri3n_> (rcherreau is still on holidays, he will be back next monday)
15:33:31 <ad_ri3n_> ok sorry
15:33:32 <ad_ri3n_> yes?
15:33:49 <ad_ri3n_> so can you please let us know the current status of your experiments
15:34:08 <marie_> there is not much to say, still gathering results
15:34:10 * ad_ri3n_ is reading the pad
15:34:12 <ad_ri3n_> ok
15:34:25 <ad_ri3n_> maybe we can have first numbers for the next meeting ;)
15:34:42 <marie_> yep !
15:34:55 <ad_ri3n_> thanks
15:35:06 <ad_ri3n_> #topic ongoing-action-AMQP
15:35:21 <kgiusti> Hi
15:35:22 <ad_ri3n_> kgiusti: ansmith ?
15:35:27 <ad_ri3n_> msimonin?
15:35:48 <kgiusti> I've been investigating a reported slow memory creep on both the router and the ombt2 clients
15:36:12 <kgiusti> but have been unable to duplicate the issue as observed by msimonin
15:36:36 <kgiusti> we have a meeting tomorrow which we'll discuss this further
15:37:01 <kgiusti> that's about it for me this week.
15:37:31 <kgiusti> msimonin doesn't appear to be here today.
15:37:48 <kgiusti> and I don't have the latest news from the testing effort.
15:38:03 <ad_ri3n_> javier should be there also
15:38:12 <ad_ri3n_> ok let's open this point
15:38:20 <ad_ri3n_> ah msimonin ;)
15:38:23 <kgiusti> speak of the devil :)
15:38:29 <msimonin> o/
15:38:36 <kgiusti> Hi msimonin!
15:38:37 <msimonin> I heard some voices
15:38:43 <ad_ri3n_> ok so I think we are done with AMQP
15:38:46 <msimonin> Hi kgiusti
15:38:47 <ad_ri3n_> let's move to the next point :D
15:38:58 <ad_ri3n_> msimonin:  please ;)
15:39:15 <msimonin> What's next (sorry) ?
15:39:25 <ad_ri3n_> (BTW please let us know what is ombt-orchestrator with enoslib inside ;))
15:39:35 <ad_ri3n_> we are discussing AMQP evaluations
15:40:06 <ad_ri3n_> kgiusti just explained that he didn't succeed to reproduce the memory leaks you are facing
15:40:19 <msimonin> oh I see
15:40:36 <msimonin> kgiusti: are you able to use the orchestrator ?
15:40:46 <msimonin> javier made many changes lately
15:41:03 <msimonin> related to packaging the tool properly
15:41:21 <kgiusti> msimonin: not successful atm - tried some new hw today - see line 436
15:41:41 <kgiusti> msimonin: yes I've gotten much further today with the latest oo
15:42:50 <ad_ri3n_> msimonin:  kgiusti a few words on what is ombt-orchestrator please :-p?
15:43:44 <kgiusti> sorry - see line 438 - a tool for orchestrating the oslo.messaging scale tests
15:43:48 <msimonin> the orchestrator is an evaluation tool for testing oslo.messaging against various message bus
15:43:54 <msimonin> ::)
15:44:19 <msimonin> kgiusti: First time I see this error
15:44:23 <msimonin> interesting
15:44:31 <msimonin> Could you provide the the configuration ?
15:44:48 <kgiusti> msimonin: yeah - we should probably take this off line to discuss the details
15:44:54 <ad_ri3n_> yes
15:44:55 <ad_ri3n_> :D
15:44:59 <ad_ri3n_> xx:45
15:45:02 <kgiusti> msimonin: I'll IM you
15:45:16 <msimonin> kgiusti:  cool thanks
15:46:11 <ad_ri3n_> if there is no more information on that point I think we can move forward (I remind you that you have a few information on current results msimonin got a few lines above, please see the notes of the last discussion)
15:46:49 <msimonin> I'm ok from my side, I'll try to help kgiusti
15:47:03 <ad_ri3n_> #topic vancouver-summit
15:47:43 <ad_ri3n_> so we created a dedicated etherpad to prepare the vancouver summit
15:47:55 <ad_ri3n_> #link https://etherpad.openstack.org/p/FEMDC_Vancouver_brainstorming
15:48:08 <ad_ri3n_> and add topics you would like to discuss
15:48:26 <ad_ri3n_> brainstorming sessions you would like to propose to the forum.
15:48:27 <ad_ri3n_> etc.
15:48:44 <ad_ri3n_> for the moment parus and I added some contents
15:49:01 <ad_ri3n_> (and I added BTW a csatari proposal he pushed on the glance pad)
15:49:06 <ad_ri3n_> see line 25.
15:49:36 <parus> I think I saw an email for csatari about Keystone as well.
15:49:39 <ad_ri3n_> so please don't be shy
15:49:49 <parus> Should we add that here?
15:49:54 <ad_ri3n_> csatari:  maybe I miss your keystone email?
15:50:12 <ad_ri3n_> (I think it would be great if we can keep an eye of what has been proposed so far)
15:50:35 <csatari> In Keystone I'm not sure.
15:51:04 <csatari> I mean if we need the feature. Maybe a Forum session could clarify the fog in my head....
15:51:16 <parus> There was an exchange between Ildyko and you and setting a meeting with Keystone and reviewing NKB prosposals.
15:51:39 <csatari> parus: :)
15:51:49 <parus> "Maybe we can share our two architecture alternatives (1) syncronise Keystone data with the New Kingbird 2) Multi region Keystone) with Keystone people. And ask feedback."
15:52:04 <parus> Was that about Vancouver
15:53:11 <csatari> Now I remember. Yes, I can add it to the Keystone etherpad, however it is not clear for me how the proposals get to the tool from the etherpads....
15:54:03 <ad_ri3n_> the same
15:54:06 <ad_ri3n_> :-P
15:54:22 <ad_ri3n_> ok I will send an email on the ML to try to make progress on that point too
15:54:50 <parus> About my point on line 18 on the Vancouver Etherpad.
15:55:07 <ad_ri3n_> yes ?
15:55:10 <parus> I would like to have a whiteboard session maybe with a group.
15:55:28 <parus> There are architecture options emerging.
15:55:31 <ad_ri3n_> I know there will be one or two panels dealing with security aspects on edge infrastructures
15:55:49 <ad_ri3n_> parus :
15:55:51 <parus> It was not about security.
15:55:54 <parus> My bad.
15:55:55 <ad_ri3n_> Maybe it is a formatting
15:55:56 <ad_ri3n_> ok
15:56:01 <parus> Let me update formatting.
15:56:02 <ad_ri3n_> it is a formatting issue
15:56:04 <ad_ri3n_> ;)
15:56:13 <ad_ri3n_> thanks
15:56:18 <ad_ri3n_> 4 min lefts
15:56:30 <ad_ri3n_> I propose to move to open-discussions
15:56:41 <ad_ri3n_> #topic open-discussions
15:56:51 <ad_ri3n_> ansmith:  kgiusti thanks
15:57:03 <ad_ri3n_> first of all
15:57:04 <ad_ri3n_> ;)
15:57:20 <ad_ri3n_> so if I correctly understood : let's wait and see
15:57:49 <ansmith> every chance we get, we provide an overview of this wg and the analysis going on
15:57:50 <ad_ri3n_> ok regarding the pu/sub item?
15:57:57 <ad_ri3n_> ansmith:  great
15:57:59 <ad_ri3n_> and thanks
15:58:26 <parus> Has Pubnub ever been evaluated by this group?
15:58:37 <ad_ri3n_> AFAIK no?
15:58:41 <parus> Is there something clever they are doing that we could learn from?
15:58:53 <ad_ri3n_> msimonin:  javier maybe you can give it a look
15:59:04 <ad_ri3n_> to see theoretically speaking this may make sense?
15:59:04 <kgiusti> no - haven't heard of them b4 :)
15:59:21 <ad_ri3n_> ok one minute left
15:59:27 <ad_ri3n_> thanks you guys
15:59:35 <marie_> thanks
15:59:38 <ad_ri3n_> if you have comments, please feel free to add them into the pad
15:59:38 <parus> thx
15:59:41 <csatari> thanks
15:59:44 <dpertin> thx
15:59:46 <ad_ri3n_> #endmeeting