15:01:03 <ad_rien_> #startmeeting fog-edge-massively-distributed-clouds
15:01:04 <openstack> Meeting started Wed Sep 13 15:01:03 2017 UTC and is due to finish in 60 minutes.  The chair is ad_rien_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:07 <openstack> The meeting name has been set to 'fog_edge_massively_distributed_clouds'
15:01:21 <parus> Good Morning/Afternoon
15:01:22 <ad_rien_> #chair ad_rien_
15:01:22 <openstack> Current chairs: ad_rien_
15:01:26 <ad_rien_> #chair parus
15:01:27 <openstack> Current chairs: ad_rien_ parus
15:01:34 <ad_rien_> #topic roll call
15:01:38 <ad_rien_> Hi guys
15:01:44 <ansmith> o/
15:01:48 <dpertin> hi o/
15:02:03 <kgiusti> o/
15:02:05 <ad_rien_> So as usual please put your name on the etherpad line 1159
15:02:10 <msimonin> hey o/
15:02:22 <rcherrueau> o/
15:02:23 <ad_rien_> #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017 (Agenda line 1157)
15:02:24 <dancn> hi o/
15:02:41 <Joao_M_Soares> hi all
15:02:43 <reedip_> hi
15:02:56 <parus> Welcome Joao... is this your first meeting?
15:02:57 <ad_rien_> Hi reedip_ ?
15:03:20 <ad_rien_> reedip_:  Joao_M_Soares could you please introduce yourself please?
15:03:57 <reedip_> Hi , I am reedip banerjee, ( nick reedip, reedip_ ) working with NEC on Openstack since L release
15:04:11 <Joao_M_Soares> yes, first meeting for me. My name is João, researcher at Ericsson. Been working with OpenStack scalability, mostly exploring p2p approaches
15:04:20 <parus> Welcome reedip_
15:04:38 <ad_rien_> reedip_:  could you please elaborate a bit more on your interests w-r-t the FEMDC team/WG ?
15:04:45 <ad_rien_> Joao_M_Soares:  nice to see you there
15:05:27 <reedip_> I am currently researching on IoT and edge cloud, so this is my first meeting
15:05:32 <ad_rien_> ok cool
15:05:53 <ad_rien_> If you have a particular use-case in mind, it would be great to share it (but later in the meeting, thanks)
15:05:57 <ad_rien_> ok so let's start
15:06:09 <ad_rien_> #topic annoucement
15:06:33 <ad_rien_> parus:  can you please give a short summary of the last session of OpenDev (I was not able to attend it)
15:06:48 <parus> Sure.
15:06:53 <ad_rien_> I read the etherpad but maybe you can briefly let us know what are the key takeway messages
15:07:26 <parus> Last week in SF there was an openstack dev group meeting for two full days of sessions on Edge Computing.
15:08:10 <parus> There was a lot of interest. Many links have been posted on etherpad. Feel free to surf. This morning I even found some videos on you tube. so I made a playlist for your enjoyment.
15:08:28 <parus> In particular, you may be able to see me participating in a session on architecture.
15:08:41 <ad_rien_> ok do you know what will be the followup ?
15:08:59 <ad_rien_> I read in the pad that Michael (and probably you) will arrange additional discussions?
15:09:06 <ad_rien_> How this should be organized?
15:09:13 <parus> There will be follow-up sessions that on architecture that Verizon, AT&T and myself have volunteered for.
15:09:17 <ad_rien_> Should it occur through the FEMDC meetings?
15:09:20 <parus> I think Adrien did as well.
15:09:37 <parus> The immediate action is to plan for Sydney where there will be more meetings.
15:09:43 <ad_rien_> ok
15:09:43 <ad_rien_> thanks
15:09:54 <parus> From an FEMDC perspective,
15:10:06 <parus> We did some promoting of the work of the group.
15:10:09 <reedip_> is there a paper from FEMDC in Sydney ?
15:10:27 <msimonin> reed:
15:10:27 <parus> reedip_: There are two activities.
15:10:32 <ad_rien_> reedip_:  what kind of paper are you looking for ?
15:10:45 <ad_rien_> they will be two presentations and the F2F meeting
15:10:48 <msimonin> reedip_: there are presentations rether than "papers"
15:10:49 <reedip_> just asking if there is a session
15:10:53 <ad_rien_> ok
15:10:54 <ad_rien_> so yes
15:11:09 <reedip_> yeah sorry, I had a habit of saying papers :P , because its kind of a CFP
15:11:22 <msimonin> P stands for Presentation :)
15:11:23 <ad_rien_> as parus mentioned : two presentations (one on EnOS, a utility to perform performance campaign of openstack and the second one on use-cases)
15:11:25 <parus> There will be a presentation, and there will be a workgroup f2f. you will find links in earlier etherpads
15:11:39 <ad_rien_> ok
15:12:03 <ad_rien_> BTW I would like to thank parus for his involvements during thes two days in SF.
15:12:09 <ad_rien_> You did great job ;)
15:12:12 <ad_rien_> Thanks for your support !
15:12:20 <parus> Thank you for the opportunity!
15:12:35 <Joao_M_Soares> ad_rien_: +1 to that. Great job parus
15:13:00 <parus> Any more questions?
15:13:09 <ad_rien_> not from my side, let's wait and see
15:13:21 <ad_rien_> ok two other information to share
15:13:27 <ad_rien_> There should be two presentations:
15:13:37 <ad_rien_> one regarding the OpenStack ++ project
15:13:48 <ad_rien_> that is supported by the OpenEdgeComputing initiative
15:14:28 <ad_rien_> I do not have too much details but the presentation will be through a webex bridge
15:14:31 <ad_rien_> on Thursday 9/21.
15:14:46 <ad_rien_> at 14 UTC
15:15:02 <ad_rien_> I will confirm that by mail. If you are interested to attend it please add your email just below
15:15:11 <ad_rien_> (line 1177)
15:15:25 <ad_rien_> finally, We have to arrange another webconference with folks from Ericsson
15:15:45 <ad_rien_> Joao_M_Soares:  would you please open a doodle (or something similar) in order to arrange such a presentation?
15:15:57 <ad_rien_> The idea is that you give an overview of the work you did at Ericsson
15:16:00 <ad_rien_> and the motivation
15:16:01 <ad_rien_> thanks
15:16:07 <Joao_M_Soares> ad_rien_: sure! will do that
15:16:31 <ad_rien_> #action Joao_M_Soares Open a doodle to arrange a webconf on Ericsson P2P activities
15:16:34 <ad_rien_> thanks
15:17:02 <ad_rien_> Finally, we start to brainstorm with parus in particular on a possible roadmap for the next cycle (i.e. vancouver)
15:17:15 * ad_rien_ is looking for the link
15:17:50 <ad_rien_> #link roadmap proposal for Vancouver https://etherpad.openstack.org/p/FEDMC_OpenDev_WhatSNext
15:18:18 <ad_rien_> you can go through (ammend/complete/...)
15:18:19 <parus> ad_rien_: Thank you for putting that together.
15:18:20 <ad_rien_> Feel free
15:18:43 <reedip_> this is too much information :)
15:18:47 <ad_rien_> ok I think that's all from my side
15:18:54 <ad_rien_> Any other information/news to share?
15:18:58 <parus> Before vancouver... there will be sydney...
15:19:07 <ad_rien_> +1 ;)
15:19:17 <parus> There is an invitation to start brainstorming on sydney
15:19:22 <ad_rien_> We should see how progressing on the use-case question
15:19:42 <parus> #link https://wiki.openstack.org/wiki/Forum/Sydney2017
15:19:58 <ad_rien_> good point
15:20:03 <ad_rien_> thanks parus for highlighting that
15:20:21 <ad_rien_> do you know what is the deadline ?
15:20:34 <parus> I just saw it this very morning.
15:21:01 <ad_rien_> #action add to the agenda: discussion on possible forum sessions
15:21:11 <parus> I think we want to take the lead and set-up a session on edge.
15:21:34 <ad_rien_> yes
15:21:44 <ad_rien_> but we should consider that we also have our F2F meeting
15:21:59 <ad_rien_> so we should find enough materials to avoid redundancies
15:22:04 <ad_rien_> maybe we can have more specific sessions
15:22:25 <parus> Agreed: Maybe we want to make our meeting the session? or maybe we want to invite others to contribute in an open session?
15:22:31 <ad_rien_> (we have also to consider who already planned to go in Sydney, if I'm right most of us will not be able to attend this summit)
15:22:49 <parus> Good point. But at opendev many said they would
15:22:59 <parus> and Verizon and AT&T in particular
15:23:09 <ad_rien_> Ok
15:23:23 <ad_rien_> so I propose that we put that to our agenda next time as a priority point to discuss ?
15:23:24 <ad_rien_> ok ?
15:23:29 <parus> OK
15:23:46 <ad_rien_> ok
15:24:04 <ad_rien_> sorry one more point to announce
15:24:13 <ad_rien_> tomorrow 5 UTC there is the WG chairs meeting
15:24:56 <ad_rien_> I will attend it but it would be nice if we can turn ;)
15:24:59 <ad_rien_> next time
15:25:06 <ad_rien_> In particular when it is 5 UTC ;-)
15:25:19 <ad_rien_> ok
15:25:23 <ad_rien_> any thing else ?
15:25:31 <ad_rien_> so let's move on the ongoing activities
15:25:39 <ad_rien_> #topic ongoing activities
15:25:50 <ad_rien_> #topic AMPQ
15:25:59 <ad_rien_> ansmith:  msimonin kgiusti
15:26:06 <ad_rien_> please the floor is yours
15:26:09 <kgiusti> Hi
15:26:36 <kgiusti> Last two weeks were lots of distractions for me - so not much in the way of progress (epad updated)
15:26:56 <kgiusti> significant: vhost/cells issue for amqp1 fixed in pike stable (and master)
15:27:13 <kgiusti> so nova should Just Work with amqp1 now in pike
15:27:31 <msimonin> nice ! :)
15:27:32 <kgiusti> Some ombt2 work - not checked in yet - to gather better stats for fanout and cast
15:27:57 <msimonin> kgiusti: let me know if I can help on ombt (code/testing)
15:28:06 <kgiusti> but PTG prep, queens planning, and qpid release activities have swamped me last week
15:28:33 <kgiusti> msimonin: will do - once I get ombt2 changes finalized I'd like your review and any tests you might want to throw at it
15:28:57 <msimonin> kgiusti: ack
15:29:06 <ad_rien_> kgiusti:  are you attending the PTG in Denver?
15:29:08 <kgiusti> kolla-ansible still hasn't merged our patch - likely due to PTG work things have been quiet
15:29:30 <kgiusti> ad_rien_: not physically - oslo PTG has us in a video conf
15:29:47 <kgiusti> that's about it - questions?
15:29:53 <ad_rien_> great….
15:30:14 <ad_rien_> maybe we lost the slot… It would have been great to talk about the cockroach prototype.
15:30:22 <ad_rien_> with OSLO folks at least
15:30:39 <ad_rien_> no questions/comments?
15:30:45 <msimonin> regarding amqp I've put some info on the epad
15:31:07 <ad_rien_> #topic cockroach-db
15:31:13 <kgiusti> msimonin: nice - will check that topology out
15:31:25 <rcherrueau> hey
15:31:58 <rcherrueau> the POC is still available on GitHub. Feel free to give it a try :)
15:32:07 <rcherrueau> #link  https://github.com/BeyondTheClouds/openstack-cockroachdb-dev
15:32:39 <rcherrueau> I also made an email on OpenStack mailing list
15:32:45 <rcherrueau> #link  http://lists.openstack.org/pipermail/openstack-dev/2017-September/121779.html
15:33:00 <rcherrueau> If you have any comments, do not hesitate to contribute there
15:33:07 <msimonin> kgiusti: I've a pet project at https://github.com/msimonin/qpid-dispatch-generator
15:33:33 <rcherrueau> I'm currently addressing lbragstad request to push some code we made to gerrit
15:33:55 <kgiusti> ansmith: ^^^
15:34:00 <msimonin> Do you have a link to the review ?
15:34:08 <ad_rien_> maybe it makes sense to just send a reminder of the achieved work.
15:34:13 <rcherrueau> But it would be cool if some of you could help me on making cockroachdb supports sql migration
15:34:21 <ad_rien_> Just to try to get some feedbacks from core-devs (keystone, oslo, ...)
15:34:36 <rcherrueau> with either sqlalchemy-migrate or alembic
15:35:01 <rcherrueau> Next for me is writing a Testplan
15:35:29 <ad_rien_> just a question
15:35:36 <ad_rien_> we are currently writing testplan for AMQP
15:35:38 <rcherrueau> something similar to what ansmith kgiusti and msimonin are doing on amqp
15:35:40 <ad_rien_> for cockroach for ....
15:35:45 <parus> rcherrueau: is there a place where the usecase for cockroach is described?
15:35:56 <ad_rien_> does it make sense to define a testplan for fog/edge infrastructure?
15:36:16 <ansmith> msimonin: cool generator
15:36:27 <rcherrueau> parus: no
15:36:31 <ad_rien_> :-P
15:37:04 <parus> rcherrueau: can you try that? or if you give me some background I can attempt it.
15:37:07 <ad_rien_> the idea of investigating cockroach is related to the need to be able to distribute the SQL DB
15:37:21 <ad_rien_> this is suitable for several use-cases:
15:37:37 <ad_rien_> every control services in one DC and only compute nodes.
15:37:40 <rcherrueau> parus: OK
15:37:42 <parus> At Opendev, Ian Wells and I talked about distributing keystone.
15:37:48 <parus> Would that be the use case?
15:37:54 <ad_rien_> If you want to be able to scale you need to distribute your DBs
15:37:54 <rcherrueau> parus: yep
15:38:11 <rcherrueau> parus: One use case could be, several regions
15:38:13 <ad_rien_> either wirh Galera or other technologies. Galera does not scale, so we are looking to other solutions
15:38:18 <rcherrueau> parus: one keystone per region
15:38:34 <rcherrueau> parus: and they are all synchronized with cockroachdb
15:38:36 <ad_rien_> thanks to cockroach you can distribute services that relies on a SQL DB accross several regions
15:38:44 <ad_rien_> several geographical locations
15:39:09 <parus> OK. I will take an action to write up a description of that and run it by you for next meeting.
15:40:18 <parus> Unless you want to take first crack at it.
15:40:30 <msimonin> ansmith: thanks :)
15:41:50 <rcherrueau> that's all for me
15:41:53 <ad_rien_> thanks
15:41:58 <ad_rien_> #topic use-cases
15:42:13 <reedip_> have we considered the network security for fog/edge computing use cases ? just wanted to know...
15:42:28 <parus> Network Security was discussed last week.
15:42:36 <parus> There are many aspects.
15:42:42 <ad_rien_> reedip_:  could you please elaborate a bit?
15:42:50 <ad_rien_> just to know what you are considering ?
15:43:21 <reedip_> ad_rien_ I want to know , considering the rise in the current trneds of cyber issues
15:43:54 <ad_rien_> reedip_:  it looks to me that those security issues are already present in cloud computing infrastructures
15:43:56 <reedip_> fog/edge would be a good option with IoT. But if we need to provide network security, specially using openstack, then have we considered it ?
15:44:06 <ad_rien_> not sure how the fog/edge context will increase those issues
15:44:17 <reedip_> ad_rien_ yes, thats true
15:44:27 <ad_rien_> you mean : we need additional mechanisms (i.e. that are fog/edge specifics)
15:44:48 <ad_rien_> or existing mechanisms should deliver for instance encrypted channels, ....
15:44:59 <reedip_> so security in cloud can also be transferred to fog/edge , like port mirroring
15:45:35 <parus> Are you talking about Neutron or about Keystone?
15:45:49 <parus> Both are important.
15:45:55 <msimonin> does the google docs includes a security section, maybe reedip_ can contribute
15:45:57 <ad_rien_> ok I'm not an expert but you are probably right. I just do not see why it is related to fog/edge
15:45:57 <msimonin> ?
15:46:02 <ad_rien_> seems to be more general
15:46:10 <ad_rien_> msimonin:  good point +1
15:46:19 <msimonin> ad_rien_: :)
15:46:39 <reedip_> ad_rien_ probably, but considering that fog/edge would not be too heavy as a cloud infra is , so the requirements would change. just saying :)
15:46:57 <parus> reedip_: I agree requirements change.
15:47:05 <parus> but there are many aspects
15:47:13 <parus> Do you want to try to write up something?
15:47:44 <ad_rien_> maybe you can prepare a couple of slides as msimonin has proposed. What do you think reedip_ ?
15:47:52 <reedip_> parus : probably , I think I can
15:48:26 <parus> reedip_: please look up the etherpad from opendev on the topic.  This was discussed in the security section and also in the zero_touch_provisioning session.
15:48:59 <reedip_> parus : https://etherpad.openstack.org/p/opendev-sf-use-cases ?
15:49:10 <ad_rien_> parus:  12 minutes left. sorry do you want to discuss particular points? ask specific helps?
15:49:28 <parus> reed_Ip: I will send you links separately.
15:49:33 <reedip_> sorry for hijacking the conversation
15:49:36 <parus> ad_rien_: yes
15:49:58 <parus> I would like to see progress on testing use cases.
15:50:00 <ad_rien_> reedip_:  no no, that's the goal of the irc meeting.
15:50:00 <ad_rien_> ;)
15:50:20 <ad_rien_> And actually you are going to provide one contribution so that's great ;)
15:50:28 <ad_rien_> parus:  ?
15:50:34 <parus> yes
15:50:40 <ad_rien_> Which one?
15:51:02 <parus> Who can help running some enos use case that we could look at?
15:51:04 <ad_rien_> we did some preliminary test on the simple model: control services in one DC and remote nodes are just compute nodes
15:51:39 <parus> Could you share results?
15:51:47 <ad_rien_> msimonin with the support of a new engineer (he will start to work on that on Oct the 1st)
15:51:53 <ad_rien_> will focus on AMQ alternatives
15:52:04 <ad_rien_> rcherrueau will perform similar experiments but with cockroach
15:52:08 <ad_rien_> yes
15:52:16 <ad_rien_> see the boston presentation
15:52:31 <ad_rien_> and we are currently writing a research report (should be available by mid of october)
15:52:42 <parus> OK. I will look for that presentation and wait for mid-october.
15:52:49 <parus> How about the FBK use case?
15:52:51 <ad_rien_> #link https://www.google.fr/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&ved=0ahUKEwiz8aS0wqLWAhVJtBoKHfknCisQtwIIKDAA&url=https%3A%2F%2Fwww.openstack.org%2Fvideos%2Fboston-2017%2Ftoward-fog-edge-and-nfv-deployments-evaluating-openstack-wanwide&usg=AFQjCNEsozFpIU_qwzly1dcXtzPtDokLBg
15:53:25 <msimonin> I think dancn is around
15:53:25 <ad_rien_> I'm seeing them pushing some EnoS pull requests
15:53:45 <ad_rien_> but yes if dancn is there. He is definitely the best one to give some information
15:53:46 <ad_rien_> .
15:53:49 <ad_rien_> dancn:  ?
15:53:54 <dancn> yes, we just started with enos
15:54:14 <parus> dancn: When can we see results? Do you need help?
15:54:25 <dancn> so we are triyng to port some use case to enos
15:54:39 <ad_rien_> parus:  you told me that samP can help us ?
15:54:53 <ad_rien_> we started to give a look with rcherrueau and msimonin on cell v2
15:55:04 <ad_rien_> the idea is to segregate the openstack into several cells
15:55:08 <ad_rien_> each cell is a edge DC
15:55:13 <dancn> parus: no results for now, we are still learning and yes rcherrueau  and msimonin were a lot helpful in the past weeks
15:55:24 <ad_rien_> unfortunately Kolla does not support the cell V2.
15:55:46 <ad_rien_> If SamP has some time and he is interested by doing some investigations
15:55:49 <ad_rien_> it would be helpful
15:56:05 <dancn> no need for help right now, but as soon at we get stuck we will raise an hand
15:56:29 <ad_rien_> parus:?
15:56:36 <ad_rien_> you told me that you were looking for some actions?
15:56:37 <parus> OK. Please use the email list to discuss next steps offline.
15:56:40 <ad_rien_> just a proposal :-P
15:57:00 <ad_rien_> ok 3 min left
15:57:01 <parus> we are running out of time here. But we do need actions.
15:57:23 <ad_rien_> so anything else regarding the use-case
15:57:40 <ad_rien_> (parus by conducting experiments with CELL V2 it would enable to investigate another use-case-
15:57:41 <ad_rien_> )
15:57:53 <reedip_> parus : do send the links as discussed earlier :)
15:57:59 <ad_rien_> ok let's move to the open-discussion
15:58:15 <ad_rien_> #open discussion
15:58:21 <ad_rien_> #topic open-discusison
15:58:25 <parus> reedip_: please put your email address on etherpad
15:58:37 <ad_rien_> so from my side, I just want to discuss the cell V2…. but I just did it
15:58:38 <ad_rien_> so nothing more
15:58:45 <ad_rien_> the floor is yours
15:58:59 <reedip_> parus : done...
15:59:06 <ad_rien_> nothing ?
15:59:12 <parus> One item at Opendev was about ONAP vs Openstack
15:59:14 <ad_rien_> one minnute befoire ending the meeting
15:59:18 <ad_rien_> yes
15:59:25 <ad_rien_> parus?
15:59:37 <ad_rien_> the discussion I had with David from AT&T was positive
15:59:44 <parus> Just pointing this out, it maybe that some of the work is done a layer above openstack.
15:59:53 <ad_rien_> in the sense that both complement each other
15:59:58 <ad_rien_> ok
16:00:02 <ad_rien_> can you add it in the epad
16:00:05 <ad_rien_> we have to conclude
16:00:07 <parus> OK
16:00:08 <ad_rien_> thanks guys
16:00:09 <ad_rien_> #endmeeting