01:00:12 <diablo_rojo> #startmeeting fc_sig
01:00:13 <openstack> Meeting started Wed Apr 10 01:00:12 2019 UTC and is due to finish in 60 minutes.  The chair is diablo_rojo. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:00:16 <openstack> The meeting name has been set to 'fc_sig'
01:00:26 <diablo_rojo> gmann, mattoliverau, cmurphy, tonyb, spotz
01:00:52 <diablo_rojo> #link https://wiki.openstack.org/wiki/First_Contact_SIG#Meeting_Agenda Meeting Agenda
01:01:08 * diablo_rojo waits for people to appear
01:01:42 <spotz> \o/
01:01:45 <mattoliverau> o/
01:02:12 <mattoliverau> I'm free, but where did you send the new meeting time, I never saw anything.
01:02:36 <diablo_rojo> I sent it to the discuss list when I got the patch up and then just like a half hour ago.
01:02:44 <diablo_rojo> as a reminder
01:02:53 <spotz> Hence me:)
01:03:15 <mattoliverau> ahh fair enough, cool, somehow I missed it all. But cool, this is a great time, plus we get spotz!
01:03:46 <spotz> I don't know what day it is sometimes but I saw it come through and went ooohhh:)
01:03:50 <diablo_rojo> mattoliverau, exactly :) Much more rest of the US friendly.
01:04:16 <diablo_rojo> Anyone know if gmann is coming?
01:04:19 <diablo_rojo> I know cmurphy is not
01:04:31 <mattoliverau> and here. 11am during the day is great, no babies for me to get into bed :)
01:04:39 <tonyb[m]> \o/
01:04:56 <diablo_rojo> Oh hello tonyb[m] :)
01:05:21 <tonyb[m]> sorry I'm late
01:05:44 <diablo_rojo> tonyb[m], no worries, should we add your mobile irc nick to the ping list?
01:06:12 <diablo_rojo> #topic Announcements
01:06:36 * med_ looks around and
01:06:38 <med_> o/
01:06:38 <gmann> o/
01:06:43 <gmann> sorry for late
01:06:51 <diablo_rojo> med_, joining us?
01:06:58 <diablo_rojo> gmann,  no worries
01:07:00 <med_> investigating
01:07:16 <diablo_rojo> Its a new meeting time. I anticipated some lateness :)
01:07:37 <diablo_rojo> We should all look at and update our UTC offsets in the wiki now that we've all had DST
01:07:38 <gmann> yeah that's the reason :)
01:07:42 <diablo_rojo> Not really an announcement I guess, but a thing to note?
01:08:01 <diablo_rojo> I got to live through it twice..
01:08:06 <spotz> Announcement is new time!:)
01:08:15 * med_ suspects those in Australia are not on DST... like tonyb
01:08:42 <diablo_rojo> I thought they'd had theirs by now?
01:08:44 <mattoliverau> no, but we just turned back last weekend
01:08:48 <diablo_rojo> Maybe I'm wrong.
01:09:02 <diablo_rojo> Anywho, anything else to announce before we move onto the homework?
01:09:13 <mattoliverau> or which ever way it went, timezones and DST is hard :P
01:09:23 <tonyb[m]> med_ we did the switch off of DST last weekend so we're now AEST (UTC+1000)
01:09:47 <tonyb[m]> so the clocks are 'sane' for another 6 months
01:10:25 <med_> nods
01:10:36 * diablo_rojo guesses there nothing else to announce and is gonna move on :)
01:10:38 <diablo_rojo> #topic New Contributor Patches
01:11:16 <diablo_rojo> So, for new people to our meetings, med_ and spotz, we have two bits of homework we all try to get to in between meetings with varying degrees of succes.
01:11:19 <diablo_rojo> *success
01:11:32 <mattoliverau> there are alot of stackalytics ones this time
01:11:47 <mattoliverau> so that may be a bunch of new patches (which we don't really track)
01:11:52 <mattoliverau> soon
01:12:03 <mattoliverau> oh its all the same person
01:12:06 <mattoliverau> maybe not :P
01:12:11 <diablo_rojo> The first bit of homework is going through new contributor patches and reviewing or getting attention for at least two patches.
01:12:28 <mattoliverau> or rather a bunch of people to bocloud (me can read) :P
01:12:44 <diablo_rojo> mattoliverau, huh. Interesting.
01:13:21 <diablo_rojo> Even if it gets updated that I dont think that is being reflected in what exists on the stackalytics
01:13:21 <gmann> should we cleanup those patches which are too old like >1 year or 2 year ?
01:13:42 <diablo_rojo> gmann, that would be my preference..
01:13:59 <diablo_rojo> I'm the person that routinely zeroes out her email inbox though
01:14:05 <spotz> Yeah even in the project no way to merge extremely old patches safetly
01:14:06 <gmann> if author not active that can be the best case and that is reason for most of the old patches
01:14:45 <diablo_rojo> Sounds like we are okay with this then?
01:15:20 <diablo_rojo> spotz, med_ we have this link to all new contributor patches that arent in the sanbox related repos
01:15:29 <diablo_rojo> #link https://review.openstack.org/#/q/reviewedby:%22Welcome%252C+new+contributor!+(10068)%22+is:open+-project:+openstack-dev/sandbox+AND+-project:openstack-dev/ci-sandbox New Contrib Patches
01:16:23 <spotz> diablo_rojo: saved
01:16:29 <mattoliverau> Which also happens to be on our FC_SIG wiki page
01:16:37 <gmann> yeah
01:16:46 <diablo_rojo> Oh yeah its there if you need it.
01:17:48 <mattoliverau> There are some others, there.
01:17:54 <mattoliverau> patches I mean.
01:18:37 <mattoliverau> The idea is, if it's something you know about, go in and help, if not feel free to go in, say hi, and add the project liasion to the change.
01:18:41 <diablo_rojo> I've been drowning in new contributor/outreachy applicant patches in storyboard still
01:18:49 <mattoliverau> there is an etherpad with a nice message you can use.
01:18:58 <diablo_rojo> Well put mattoliverau
01:19:06 <diablo_rojo> much more eloquent
01:19:21 <mattoliverau> I also tend to mention it to the person I added (liason) in #openstack-dev if there around as a heads up
01:19:40 <gmann> +100
01:20:07 <diablo_rojo> Good practice
01:20:23 <mattoliverau> If there not, I still add them, they are signed up as a liason ;)
01:20:30 <mattoliverau> *they're
01:20:35 <diablo_rojo> Precisely :)
01:20:52 <diablo_rojo> Anything else on this topic before we move onto homework item #2?
01:21:22 <gmann> nothing from my side
01:22:27 <mattoliverau> let's move on :)
01:22:30 <cmurphy> o/
01:22:32 <diablo_rojo> #topic Ask.o.o
01:22:35 <mattoliverau> cmurphy: o/
01:22:51 <mattoliverau> I don't see anything new here
01:22:54 <diablo_rojo> mattoliverau, got an eloquent way to explain this homework to med_ and spotz ?
01:23:09 <mattoliverau> There is:
01:23:14 <mattoliverau> #link https://ask.openstack.org/en/question/120283/is-there-a-mentoring-program-for-openstack/
01:23:15 <mattoliverau> and
01:23:26 <mattoliverau> #link https://ask.openstack.org/en/question/120283/is-there-a-mentoring-program-for-openstack/
01:23:37 <diablo_rojo> I have two questions that I posted a while ago that I dont see responses from any of you on.
01:23:44 <mattoliverau> #link https://ask.openstack.org/en/question/120284/are-there-any-in-person-trainings/
01:23:50 <mattoliverau> opps ^ that one
01:24:01 <mattoliverau> which I believe are both from diablo_rojo ;)
01:24:03 <diablo_rojo> But you found both of them
01:24:04 <diablo_rojo> Yes
01:24:08 <diablo_rojo> got me :)
01:24:15 <diablo_rojo> Its like a game of hide and seek
01:24:16 <mattoliverau> but we need to make sure they are answered correctly
01:24:25 <mattoliverau> ok, so this homework
01:24:38 <med_> diablo_rojo was the anonymous poster/requestor?
01:24:40 <spotz> The mentoring one is a loaded question:(
01:24:45 <diablo_rojo> med_, correct
01:24:47 <mattoliverau> We try and keep an eye on any new contributor releated questions in ask.o.o
01:24:53 <diablo_rojo> trying to seed ask.o.o with good data
01:25:07 <mattoliverau> to make it easier we watch a bunch of topics that kinda make sense
01:25:23 <mattoliverau> You can see these, and links to them, on our wiki page
01:25:42 <mattoliverau> in the agenda in fact :)
01:25:56 <diablo_rojo> Yep. Always there as standing items
01:26:17 <mattoliverau> There is an etherpad for seeding ask.o.o and always on the look out for more tags to monitor :)
01:26:36 <mattoliverau> #link https://etherpad.openstack.org/p/ask.o.o-contribution
01:26:43 <mattoliverau> ^ is the seeding etherpad
01:27:02 <diablo_rojo> Currently the etherpad is empty but if there is data that you think should be more discoverable bring it up there or just go ask the question
01:28:19 <mattoliverau> annoytingly you cant search multiple tags as an OR, so we have one search link for each tag
01:29:18 <diablo_rojo> Yeah.. super obnoxious
01:29:21 <mattoliverau> so if anyone wants to go an anwer diablo_rojo's questions then go ahead ;)
01:29:37 <diablo_rojo> spotz, the mentoring one might be up your alley ;)
01:29:51 <med_> +1
01:29:54 <diablo_rojo> Anything else on this topic?
01:29:54 <gmann> and we almost cover the tag which newby use till now but if you find any other new tag used by them frequently we can start monitoring that too
01:29:56 <spotz> diablo_rojo: Please ask after Summit?:)
01:30:24 <mattoliverau> gmann: +1
01:31:14 <diablo_rojo> spotz, lol I suppose it can wait
01:31:42 <spotz> I can answer the training one though:)
01:31:52 <diablo_rojo> spotz, go for it :)
01:31:56 <mattoliverau> \o/
01:31:57 <diablo_rojo> Alright, moving on.
01:32:07 <diablo_rojo> #topic Sandbox Bot
01:32:15 <diablo_rojo> tonyb[m] ?
01:32:19 <med_> quick review: FC Sig members review / process / refer 2 of the new contrib patches (or more!) each bi-week and everyone reviews those tagged queries (the 2nd standing task)
01:32:20 * mattoliverau looks at tonyb[m]
01:32:41 <diablo_rojo> med_, yep you got it :)
01:32:58 <mattoliverau> tonyb[m]:  dont make me get out the gavel :P
01:33:10 <mattoliverau> ^ joke from last meeting
01:33:13 * diablo_rojo is guessing that tonyb[m] had to dip out to wherever he mentioned earlier
01:33:25 <diablo_rojo> mattoliverau, lol good to add context as that sounds really harsh]
01:33:46 <gmann> :)
01:33:53 <diablo_rojo> Its okay we can circle back to this later.
01:34:05 <diablo_rojo> #topic Summit + Forum planning
01:34:09 <mattoliverau> lol, tonyb[m] sent me an ebay link where I could buy one.. I didn't tho.
01:34:38 <diablo_rojo> mattoliverau, you should totally do it and carry it around at the summit
01:34:51 <diablo_rojo> #link https://www.openstack.org/summit/denver-2019/summit-schedule/events/23740/first-contact-sig-meet-and-greet Meet & Greet
01:35:02 <diablo_rojo> THat session is like.. right after keynotes on Monday.
01:35:07 <mattoliverau> lol, at least for fc sig sessions where people would get it. and a great segway ;)
01:35:38 <diablo_rojo> I tried to get it early on so that any new contributors could meet some friendly faces off the bat
01:35:55 <mattoliverau> great idea
01:36:04 <mattoliverau> I'll try and not look too scary
01:36:16 <diablo_rojo> I might be a little late to the session since I will likely get caught up waiting for the staff photo that happens after keynotes.
01:36:27 <mattoliverau> and obvously sprook it at OUI on the sunday
01:36:41 <diablo_rojo> sprook?
01:36:59 <mattoliverau> I'll make sure I'm there first thing
01:37:09 <diablo_rojo> mattoliverau, cool thanks :)
01:37:22 <diablo_rojo> spruik: verb (used without object) Australian Slang. to make or give a speech, especially extensively or elaborately; spiel; orate.
01:37:43 <mattoliverau> yeah that.. but I obviously spell if different.
01:37:54 <mattoliverau> didn't realise that was an Australianism
01:38:19 <mattoliverau> so there you go :P
01:38:28 <med_> OUI--Onboard Uni?
01:38:39 <diablo_rojo> #link https://www.openstack.org/summit/denver-2019/summit-schedule/events/23659/welcoming-new-contributors-state-of-the-union-and-deduplication-of-efforts Long titled other session to try to attend :)
01:38:40 <mattoliverau> you've all learnt a new word for the day.. excpet tonyb[m]
01:38:48 <diablo_rojo> med_, OpenStack Upstream Institute
01:38:56 <med_> gotcha.
01:38:59 <gmann> :), mattoliverau you will be there in denver right ?
01:39:06 <mattoliverau> yup.
01:39:12 <gmann> \o/
01:39:24 <mattoliverau> I'm flying in on Friday, so will be at OUI.
01:39:35 <gmann> nice
01:39:58 <diablo_rojo> So that second session is going to go through all the onboarding type activities/resources and hopefully we can figure out if there is duplication of efforts and stop that.
01:40:11 <spotz> I'll try to make it for atleast an hour or 2 between flight arrival and board meeting
01:40:48 <mattoliverau> spotz: great
01:40:51 <gmann> diablo_rojo: link?
01:41:12 <mattoliverau> diablo_rojo: good plan.
01:41:23 <diablo_rojo> ha ha gmann it was the link I just posted two messages ago :)
01:41:27 <spotz> Were we serious about brining old unused swag? Might have some t-shirts I can bring if room in suitcase
01:41:44 <diablo_rojo> spotz, for OUI?
01:41:56 * med_ has some train whistles he could bring or handoff.... kind of a PTG inside joke though
01:41:57 <gmann> ah got it. thanks
01:41:59 <spotz> yeah someone menitioned doing that in the meeting:)
01:42:01 <diablo_rojo> We can talk about that in the meeting next week.
01:42:07 <diablo_rojo> med_, I would love a train whistle
01:42:17 <med_> diablo_rojo, consider yours reserved.
01:42:30 <spotz> diablo_rojo: I'll be on European time at the office but will try to be there
01:42:33 <med_> they aren't robust nor branded.
01:42:57 <spotz> med_: With the release name train that'll be cool:)
01:42:57 <diablo_rojo> med_, do you also have a wood burner pen thing? we could put the OS logo on it
01:43:21 <med_> diablo_rojo, not currently presently and you need to lower your expectations on this whistle. :^)
01:43:25 <diablo_rojo> spotz, I'll take notes as best as I can
01:43:30 <mattoliverau> lol
01:43:57 <diablo_rojo> med_, ha ha I could do the wood burning if someone had the tool
01:43:58 * med_ had a wood burning tool and or soldering tool once upon a time but purged house a few years ago.
01:44:03 <diablo_rojo> Dang.
01:44:14 <diablo_rojo> Okay, back on topic :) Lol.
01:44:16 <diablo_rojo> As for the PTG we are scheduled for Friday afternoon.
01:44:27 <diablo_rojo> Anything else on Forum/PTG planning?
01:44:29 <med_> FC SIG Friday?
01:44:38 <med_> ^ or OUI team?
01:44:44 <spotz> SIG
01:44:50 * med_ thinks maybe they are one and the same
01:44:57 <spotz> there's just a lot of overlap:)
01:45:15 <med_> natch.
01:45:19 <diablo_rojo> med_, FC SIG
01:45:24 <med_> ack.
01:45:44 <diablo_rojo> there is a lot of overlap certainly, but no OUI meetings are scheduled. Just the training Sunday.
01:45:54 <med_> ack++
01:46:19 <diablo_rojo> Next topic?
01:46:36 <mattoliverau> next
01:46:39 <diablo_rojo> #topic Project Liaisons
01:46:46 * diablo_rojo looks at mattoliverau
01:46:53 <mattoliverau> oh, yeah, ahem..
01:46:54 * diablo_rojo raises an eyebrow
01:47:11 <mattoliverau> I might have forgotten to send the email
01:47:34 <mattoliverau> but now that all the new PTLs are in place I'll do that thing.
01:47:44 <diablo_rojo> #action mattoliverau will send an email to the discuss list reminding new PTLs of the project liaison list, but seriously this time..
01:47:54 <mattoliverau> lol
01:48:07 * diablo_rojo hammers gavel
01:48:15 <mattoliverau> nice use of an action item PLUS explaining why for spotz and med_
01:48:18 <mattoliverau> lol
01:48:33 * med_ thinks diablo_rojo is channeling patton.
01:48:36 <spotz> That's what you're going with mattoliverau?:)
01:48:42 <diablo_rojo> Might also want to mention updating UTC offsets for those on the list mattoliverau
01:49:19 <diablo_rojo> That's all I had for this topic :) Moving on.
01:49:21 <mattoliverau> ahh, yeah, I'll add that too.
01:49:23 <diablo_rojo> Last topic
01:49:29 * med_ is pondering the purpose and usage of the ethercalc sheet.... and wonders if it connects back to those new contrib patches
01:49:32 <diablo_rojo> #topic People to Reach out to
01:50:06 <mattoliverau> med_: ahh good pondering
01:50:18 <diablo_rojo> med_, so basically this ethercalc is a list of contributors that seem to not focus on a single project and just target easy changes across all repos
01:50:47 <diablo_rojo> We want to try to engage with them to make them more effective contributors and to help them find their place on a project team.
01:50:58 <diablo_rojo> (ten min left)
01:50:59 <mattoliverau> we want to harness their power and direct them at something "useful"(?)
01:51:08 <diablo_rojo> ^^yeah that
01:51:10 <diablo_rojo> what mattoliverau said
01:51:14 * med_ crawls under a rock to hide
01:51:47 * diablo_rojo wonders why med_ is hiding
01:52:14 <med_> onesy twosy contributions to 4-5 different projects, no meat. Hopeless wannabe.
01:52:14 <mattoliverau> We don't want to stifle their excitement, or encourage them to help make a difference in an area that really needs it.
01:52:32 <diablo_rojo> A while back I was given an item to look at if they were attending the summit so we could talk to them in person since our emails/patch reviews have largely gone unacknowledged.
01:52:36 <spotz> I think he's like me commits in multiple places (where friends are or bugs I found) plus OSA:)
01:52:47 <diablo_rojo> Unfortunately, none of them will be in Denver
01:53:01 <diablo_rojo> spotz, med_ its different than what they are doing though.
01:53:08 <cmurphy> med_: diablo_rojo and mattoliverau were tiptoeing around the word "spammers"
01:53:17 <spotz> hehe
01:53:19 <cmurphy> behavior that appears to be stats gaming
01:53:22 <mattoliverau> lol
01:53:24 <med_> so was their addition to this spreadsheet less automated than the tagging and queries earlier and more of a just I noticed while skimming the new contribs?
01:53:28 <diablo_rojo> Ha ha ha yeah basically.
01:53:47 <diablo_rojo> med_, a little bit of both I think
01:53:54 <cmurphy> a few useful patches here and there is good, spamming projects with near-useless changes is not as good
01:53:56 <med_> ah, I didn't think stats gaming was a thing any longer. (fewer free tickets, etc these days)
01:54:07 <mattoliverau> med_: and we also seem them in the projects we all review on. Not just first patches
01:54:22 <med_> nods.
01:54:39 <diablo_rojo> So, basically we want to engage with them somehow.
01:54:40 <gmann> and more coordination from them with community is the key.
01:54:49 <diablo_rojo> Hopefully they will be in shanghai?
01:54:55 <diablo_rojo> Since none of them will be in Denver
01:55:08 <gmann> yeah shanghai is good target.
01:55:49 <diablo_rojo> I could also see if Horace can reach out to them somehow as he's based over there and understands the culture better?
01:55:51 <diablo_rojo> idk
01:55:54 <diablo_rojo> just brainstorming
01:56:01 <diablo_rojo> (5 min left)
01:56:09 <mattoliverau> we want to always give people the benefit of the doubt. they could be new and nervous and want to help. So as diablo_rojo said, we want to try and nicely approach them, thank them and see if can help onboard into areas we need help.
01:56:38 <med_> there is a preponderance of references to the README files in the affiliated open reviews.
01:56:42 <diablo_rojo> +2
01:57:05 <diablo_rojo> Yeah the common denominators are small spelling fixes or url fixes across allllll the repos
01:57:23 <med_> sounds just like me. These are my people.
01:57:28 <spotz> Someone suggested they might have a 'quota' at work
01:58:13 <med_> possibly.
01:58:28 <diablo_rojo> Yeah. So still working on that front..
01:58:30 <mattoliverau> there is nothing wrong with fixing some spelling or grammer, but I'd rather it in large patches, Ie give me one that fixes a bunch as to not make rebasing headaches for everyone else.
01:58:30 <fungi> it was stated that at least one of the employers (i forget which one) was leveraging their overall stackalytics ranking in marketing to potential customers in their region
01:58:34 * med_ has no quota (currently/historically)
01:58:43 <diablo_rojo> fungi, I think it was inspur
01:58:46 <diablo_rojo> but I could be wrong
01:58:55 * diablo_rojo waves to fungi :)
01:59:04 <diablo_rojo> #topic Open Discussion
01:59:06 <med_> nod, gotcha. So stackalytics as marketeering.
01:59:10 <fungi> i'd rather not conjecture at this time of my night ;)
01:59:19 <diablo_rojo> You all have one min for open discussion :)
01:59:19 * mattoliverau wonders if fungi was trying not to use a company name in saved online logs
01:59:48 <fungi> also, how was the meeting time change announcement the first i'd found out about this channel?
01:59:52 <med_> \o
02:00:00 <diablo_rojo> mattoliverau, ha ha ha ha ha that could be
02:00:03 <med_> fungi, likewise
02:00:10 <fungi> but hey, at least now i can attend regularly, even if it does overlap with tc office hour
02:00:29 <gmann> +1
02:00:29 <diablo_rojo> Times up..
02:00:37 <fungi> thanks diablo_rojo!
02:00:42 <diablo_rojo> thank you med_ spotz and fungi for coming to our new time :)
02:00:51 <mattoliverau> +1
02:00:58 <mattoliverau> thanks diablo_rojo
02:01:01 <diablo_rojo> This new meeting time is awesome :)
02:01:01 <gmann> +1, doing in this channel work well
02:01:03 <spotz> You're welcome
02:01:04 * med_ saw the announcement hit discuss and had nothing going on...
02:01:23 <spotz> fungi this channel has been here since whatever summit was after Barcelona:)
02:01:27 <diablo_rojo> ANd not just because I don't have to run a meeting at 11PM/12AM my time.
02:01:36 <diablo_rojo> #endmeeting