12:59:55 <Liuqing> #startmeeting evoque
12:59:55 <openstack> Meeting started Wed Nov 18 12:59:55 2015 UTC and is due to finish in 60 minutes.  The chair is Liuqing. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:59:59 <gongysh__> hi
13:00:00 <openstack> The meeting name has been set to 'evoque'
13:00:14 <Liuqing> \o
13:00:30 <Liuqing> if you're here, please say hi
13:00:37 <sin_> hi
13:01:04 <Liuqing> let's know who're here :-)
13:01:27 <Liuqing> #topic dummy workflow engine
13:01:50 <gongysh__> why not start with  anouncement?
13:02:13 <Liuqing> as we talked offline in shanghai , we'll have a dummy workflow engine.
13:02:19 <gongysh__> ok
13:02:21 <Liuqing> do we have any anouncement?
13:03:07 <gongysh__> devstack plugin, test framework
13:03:10 <gongysh__> ...
13:03:20 <Liuqing> we will use stevedore to load dummy workflow engine driver
13:04:38 <Liuqing> we should add devstack plugin in this week?
13:05:10 <gongysh__> I think, sooner is better than later.
13:05:26 <gongysh__> let's others can play with the system.
13:05:47 <Liuqing> i thought that we could add devstack plugin in version 0.0.1 release cycle.
13:06:08 <EinstCrazy> well, we could write a plugin
13:06:18 <EinstCrazy> and guide
13:06:34 <gongysh__> EinstCrazy, +1
13:06:40 <sin_> we should think more about the engine,but not the devstack plugin.
13:06:44 <gongysh__> EinstCrazy, do u have time for it.
13:06:47 <gongysh__> ?
13:07:17 <gongysh__> why not let someone do what they want to do?
13:07:37 <Liuqing> now we haven't one complete  demo for evoque。
13:07:37 <gongysh__> if EinstCrazy wants to set the devstack up, he can do.
13:07:39 <EinstCrazy> well, I could do it. But may someone help me with how to install it?
13:07:46 <sin_> EinstCray can help is good
13:07:49 <gongysh__> It's my opinion.
13:07:58 <sin_> Do what you want
13:08:22 <Liuqing> #action EinstCray will help the evoque devstack plugin
13:09:13 <gongysh__> sorry, let's back to topic dummy workflow engine
13:09:25 <Liuqing> OK
13:09:39 <Liuqing> who will take the work ?
13:09:46 <Liuqing> sin_
13:10:05 <Liuqing> we have one initial devstack patch posted by zhurong: https://review.openstack.org/#/c/241923/
13:10:23 <Liuqing> EinstCrazy, that may help
13:11:03 <Liuqing> the dummy workflow will have following abstract methods
13:11:13 <Liuqing> 1. workflow-list
13:11:16 <Liuqing> 2. workflow-show
13:11:24 <zhurong> devstack plugin i will improve it, EinstCrazy
13:11:37 <Liuqing> 3. worflow-get-status
13:11:58 <Liuqing> 4. worflow-start-instance
13:12:12 <EinstCrazy> OK, zhurong can improve it
13:12:36 <Liuqing> #action zhurong will help the evoque devstack plugin
13:13:15 <Liuqing> #info https://github.com/knipknap/SpiffWorkflow/wiki
13:13:32 <gongysh__> Liuqing, do we have BP for workflow?
13:13:33 <Liuqing> #info workflow pattens http://www.workflowpatterns.com/
13:13:41 <Liuqing> not now
13:13:59 <gongysh__> I think we should first put it  into a BP, and review, and then work on codes.
13:14:02 <Liuqing> gongysh, we should register it in launchpad
13:14:43 <Liuqing> so who take the dummy workflow engine?
13:15:49 <Liuqing> if nobody take the work, i will
13:16:13 <Liuqing> #action  liuqing could help the dummy workflow engine
13:16:29 <Liuqing> move to the next topic
13:16:35 <Liuqing> #topic evoque dev mail list
13:16:55 <Liuqing> now we haven't any mail list in openstack dev ML
13:17:16 <Liuqing> any thoughts guys ?
13:17:16 <gongysh__> don't we just use [openstack-dev][eqvoque] in subject?
13:17:34 <Liuqing> in general, it is
13:17:45 <gongysh__> do other openstack projects have their own mail list?
13:17:50 <gongysh__> I don't think so.
13:18:39 <Liuqing> #info http://stackalytics.com/?project_type=all&module=evoque&metric=emails
13:18:48 <Liuqing> ML about evoque in stacjalytics.
13:19:58 <Liuqing> Contribution Summary is useful
13:20:19 <Liuqing> Draft Blueprints: 1
13:20:20 <Liuqing> Completed Blueprints: 0
13:20:21 <Liuqing> Filed Bugs: 0
13:20:23 <Liuqing> Resolved Bugs: 0
13:20:23 <Liuqing> Emails: 0
13:20:33 <gongysh__> yes
13:20:54 <Liuqing> those items is not very well, maybe bad.
13:22:51 <Liuqing> so in the next development, we should pay attention to our bad items.
13:24:37 <Liuqing> any thoughts? guys?
13:24:49 <gongysh__> currently, we have no bugs report?
13:25:10 <EinstCrazy> may we invite someone to test and use for it?
13:25:24 <gongysh__> any patchs should be under a bug or bp, I think.
13:25:51 <Liuqing> agree
13:26:11 <gongysh__> The core reviewers should have some rules, or 底线。
13:27:22 <gongysh__> and had better two core reviewers agree.
13:27:55 <Liuqing> gongysh__, it really
13:28:02 <zhangjn> register some BPs, for example:devstack plugin,:)
13:28:31 <gongysh__> zhangjn, welcome
13:29:36 <zhangjn> how to register BP?
13:30:42 <gongysh__> on launchpad, register a BP, and, if it is not too a big feature, just descript it in launchpad BP.
13:31:18 <gongysh__> otherwise we can have it under evoque/doc/specs
13:31:39 <gongysh__> and use the normal review process.
13:31:48 <Liuqing_> the wifi broken just now..
13:32:47 <Liuqing_> i thought it depends, we need move forward faster..
13:33:18 <zhangjn> evoque/doc/specs better than launchpad
13:33:57 <gongysh__> I said if the feature is obvious, we can just register it only on launchpad, describe it there.
13:34:33 <gongysh__> If the feature is big, besides the launchpad, we need put it under evoque/doc/specs and go through normal review process.
13:34:45 <gongysh__> Liuqing_, agree?
13:34:59 <zhangjn> This is rule, :)
13:35:17 <Liuqing_> do we have other topics?
13:35:44 <gongysh__> It seems Liuqing_  is gone with wind again.
13:36:41 <gongysh__> Liuqing_ I thought you should write some introduction article about the project, and then we promote it.
13:36:43 <Liuqing_> in this stage, maybe feature implement is the most import,
13:38:34 <zhurong> register a bp may not take much time, i think
13:38:52 <zhangjn> quick start guide maybe good start.
13:39:35 <Liuqing_> some introduction article for general user or develop?
13:41:04 <zhangjn> write some in wiki.openstack.org
13:41:38 <Liuqing_> so we should improve the evoque wiki? gongysh__?
13:42:09 <gongysh__> wiki, or in evoque doc
13:42:16 <gongysh__> we can put it in evoque doc.
13:42:22 <zhurong> i think evoque doc
13:43:29 <Liuqing_> wiki/doc
13:43:30 <Liuqing_> wiki and doc
13:43:40 <zhurong> i think we can show the doc in https://readthedocs.org/
13:43:56 <zhangjn> wiki/doc
13:44:10 <Liuqing_> yep,zhurong
13:44:20 <zhurong> something url like http://evoque.readthedocs.org/
13:45:00 <Liuqing_> wiki will have some introduction for user
13:45:00 <Liuqing_> just like other project's wiki
13:45:25 <Liuqing_> doc should contain details of evoque
13:45:41 <Liuqing_> zhurong, could you take the doc work?
13:46:31 <zhangjn> project's wiki is good window for user.
13:46:50 <Liuqing_> we can build the doc skeleton firstly.
13:47:09 <zhangjn> Agree
13:47:14 <zhangjn> Next Sprint
13:47:17 <zhangjn> :)
13:47:29 <Liuqing_> :--)
13:48:40 <Liuqing_> but who take the doc work?
13:49:28 <gongysh__> EinstCrazy?
13:49:39 <gongysh__> the devstack is taken by zhurong
13:50:05 <Liuqing_> i vote EinstCrazy:)
13:50:06 <gongysh__> EinstCrazy, what about the doc?
13:50:41 <EinstCrazy> I don't know rst format
13:50:41 <gongysh__> you can put the doc in evoque/doc, that is the same as we write codes.
13:51:22 <EinstCrazy> I known. But I have not write any rst doc before.
13:51:29 <gongysh__> It is easy. Just learn from other project and google
13:51:37 <Liuqing_> EinstCrazy, we can refer to other project , it's easy for you :)
13:51:49 <gongysh__> EinstCrazy, you can do it.
13:52:17 <gongysh__> and we will help to review.
13:52:33 <gongysh__> and even co-author to help
13:52:58 <EinstCrazy> OK, I do it.
13:53:16 <gongysh__> and it is *1, not *0.8.
13:53:16 <gongysh__> great.
13:53:26 <Liuqing_> thanks EinstCrazy
13:54:16 <Liuqing_> LOL
13:54:25 <gongysh__> #action EinstCrazy to start the doc job.
13:54:57 <EinstCrazy> I will write a quick start first
13:55:09 <gongysh__> Liuqing_, I am trying to help
13:55:13 <zhangjn> great
13:55:36 <Liuqing_> great
13:56:43 <Liuqing_> OK,so we end the meeting?
13:56:57 <gongysh__> sure
13:57:10 <EinstCrazy> sure
13:58:00 <Liuqing_> if we have other topic we can talk in channel #openstack-evoque , i will end meeting
13:58:06 <Liuqing_> #endmeeting
13:59:04 <Liuqing_> #endmeeting
14:00:17 <Liuqing_> #endmeeting