#edge-computing-group: edge-computing-group

Meeting started by csatari at 16:01:15 UTC (full logs).

Meeting summary

  1. Roll Call (csatari, 16:01:39)
    1. Mark Beierl (Dell EMC) (mbeierl, 16:02:04)
    2. Gergely Csatari (Nokia) (csatari, 16:02:23)
    3. This is a discussion of https://wiki.openstack.org/wiki/Image_handling_in_edge_environment (csatari, 16:02:52)

  2. One Glance with multiple backends (csatari, 16:10:42)
    1. Multiple backend support was added during Rocky as an FFE. It is an experimental API. We should go and play with it. (csatari, 16:11:36)
    2. Support for multiple active backends is ongoing. Allowing multple backends of the same type is also ongoing. (csatari, 16:12:58)
    3. Used backend is defined by the user. Glance have a default backend configured, this will be used when the user does not define a backend. (csatari, 16:14:21)
    4. It will be possible to run a Glance API server in every edge cloud instance. Each Glance would be able to access each others images, but could be configured to use their own backends as default. (csatari, 16:16:21)
    5. When acessing each others images the Glance API would stream the image from the remote backend and chache it. (csatari, 16:17:18)
    6. For this we need a datapath between the backends. (csatari, 16:18:04)
    7. Optionally it is possible to set up CEPH synchronisation, but for this some hooks are needed to write to the Glance databese when an image synchronisaiton were finished. (csatari, 16:19:51)
    8. Q: How about invalidation of an image in the local cache. A: As the cache is really cache there is no invalidation served. (csatari, 16:21:53)
    9. ACTION: Add API servers to the figure, add a database replica to the figure. (csatari, 16:27:56)
    10. Glance supports multiple backends with all Glance backups except http (csatari, 16:31:05)
    11. Image properties are synchronised via the Glance database. (csatari, 16:34:58)
    12. Glance does not care about the details of synchronisation. As long as all the Glance API services access the same database the metadata synchronisation will work. (csatari, 16:36:56)
    13. Flavor synchronisation should be discussed with Nova. (csatari, 16:40:50)
    14. Question: Does Nova checks if the image fits info the flavor? (csatari, 16:41:38)
    15. If there is a Glance API runnig in a site we need to have the database credentials there. (csatari, 16:50:40)
    16. Q: Can the OpenStack services running in the edge cloud instances use the images from the local Glance? There is a worry that OpenStack services (e.g. nova) still need to get the direct URL via the Glance API which is ONLY available at the central site. A: It is a special case when CEPH is used by both Glance and Nove. This can be avoided by allowing Glance to access all the CEPH instances as backends but (csatari, 16:53:38)
    17. Q: Is CEPH backend CEPH block of CEPH RGW in the figure? A: Glance talks directly to the CEPH block. It is possible to configure CEPH RGW via Swift. (csatari, 16:55:04)
    18. In case the Swift + CEPH RGW in a cluster mode the image replicaiton is automatic. In this case the Nova direct access to CEPH should be disabled and everything should be via Glance API. (csatari, 16:56:15)
    19. Glance metadata is always in Glance. Even if Swift is used as a backend. (csatari, 16:57:57)
    20. 70% of Glance users are using CEPH as a backend. (csatari, 16:59:50)

  3. Finishing notes (csatari, 17:00:11)
    1. We should have some more discussions like this. (csatari, 17:01:08)
    2. csatari will update the wiki and send the result around. (csatari, 17:01:55)


Meeting ended at 17:06:28 UTC (full logs).

Action items

  1. Add API servers to the figure, add a database replica to the figure.


People present (lines said)

  1. csatari (30)
  2. openstack (3)
  3. mbeierl (1)


Generated by MeetBot 0.1.4.