09:00:58 <oanson> #startmeeting Dragonflow
09:00:59 <openstack> Meeting started Mon Sep 12 09:00:58 2016 UTC and is due to finish in 60 minutes.  The chair is oanson. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:03 <openstack> The meeting name has been set to 'dragonflow'
09:01:06 <oanson> Hello
09:01:10 <xiaohhui> hi
09:01:11 <oanson> Who's here for the meeting?
09:01:22 <lihi> Hi
09:01:23 <oanson> xiaohhui, hi.
09:01:35 * xiaohhui is Xiao Hong Hui
09:01:47 <oanson> nick-ma, you here?
09:02:16 <oanson> All right, we have a lot to cover.
09:02:22 <oanson> #topic Roadmap
09:02:32 <oanson> Let's start with the good news
09:02:38 <oanson> I went over some of the blue prints.
09:02:43 <oanson> It looks like we were busy :)
09:02:51 <oanson> I want to close the following blue prints as complete.
09:02:59 <oanson> MAC Spoofing
09:03:08 <oanson> SeparatePublish-Subscribe Module for DB changes
09:03:16 <oanson> and Floating IP
09:03:31 <oanson> Any objections?
09:03:57 <oanson> All right!
09:04:17 <oanson> #action oanson close blue prints for MAC Spoofing, DNAT, and Separate pub/sub
09:05:03 <oanson> The gate now also tests the fullstack on the ML2 module. There are a few reviews that have to be merged.
09:05:09 <oanson> Once that is done, I think it should be stable
09:05:34 <oanson> That means that it has to be watched when reviewing. We should make an effort not to merge patches that break the gate CI.
09:05:59 <oanson> That's includes the security groups issues we were having.
09:06:04 <oanson> including*
09:06:32 <oanson> About port status notification - I will upvote the spec today.
09:07:08 <oanson> I would be happy if during review, we could also stress modularity - in that we will be able to change the implementation later for performance testing
09:07:25 <oanson> It is a big feature, with many possible implementations, and I would like to be able to test a few options.
09:07:42 <oanson> We already have some pluggable parts of our code, and I think it is working in our favor.
09:08:07 <oanson> There is still little progress on my end for the packaging.
09:08:28 <oanson> I think nick-ma mentioned he is working on kolla in parallel.
09:09:16 <oanson> About VLAN and flat networking in L2
09:09:26 <nick-ma> hi
09:09:33 <oanson> nick-ma, hi.
09:10:03 <oanson> I think the patch is incomplete without noting the provider:physical_network parameter.
09:10:21 <oanson> I was hoping LiuHaiXia would be here so we can discuss it. Is she here?
09:10:42 <nick-ma> I haven't started kolla integration yet. because network restriction, I cannot access docker repo successfully. The setup of kolla took days and finally failed every time. I'm looking for solutions :-(
09:11:36 <oanson> :(
09:11:52 <xiaohhui> LiuHaiXia is own her way
09:12:03 <xiaohhui> on her way
09:12:20 <oanson> liuhaixia, hi
09:12:24 <liuhaixia> hi
09:12:37 <oanson> We were just discussing the VLAN and flat network L2 patches
09:13:22 <oanson> I wanted to ask about the provider:physical_network parameter, and if there are plans to use it?
09:14:22 <liuhaixia> I think if this is neccessary ,we can do it in another patch.
09:14:42 <oanson> I think it is necessary. I think the feature is incomplete without it.
09:14:51 <liuhaixia> Yeah , I know.
09:15:06 <xiaohhui> without the feature, is there a default provider:physical_network ?
09:15:13 <oanson> Another patch is good. But I want to wait for it before merging this patch.
09:15:17 <liuhaixia> yes
09:15:24 <oanson> xiaohhui, currently the default is to egress via br-ex.
09:15:49 <oanson> liuhaixia, is this acceptable?
09:16:15 <xiaohhui> vlan provider network might not use br-ex usually.
09:16:29 <liuhaixia> It's acceptable in another patch, I think.
09:16:33 <nick-ma> actually for our deployments, we always use physical network parameter. it is useful. without it, the patch is incomplete.
09:16:45 <nick-ma> ok. that's awesome.
09:17:00 <liuhaixia> Yes, Now we just support one provider network.
09:17:00 <oanson> All right. We're waiting for it :)
09:17:35 <liuhaixia> If I am free, I will do it after the current patch is merged.
09:17:53 <liuhaixia> But if other volunteers, I am happy :)
09:18:05 <xiaohhui> I can help to complete it.
09:18:15 <oanson> liuhaixia, I don't want to merge this patch before the patch to support the physical network parameter is added.
09:18:39 <oanson> It doesn't have to be merged, but I think it is too incomplete without it.
09:18:53 <oanson> xiaohhui, thanks. Once you upload something, we can merge the patch.
09:19:09 <oanson> (patches. There are 2 (: ).
09:19:22 <xiaohhui> Yeah, vlan and flat.
09:19:36 <oanson> Great.
09:19:38 <nick-ma> thanks a lot.
09:19:42 <oanson> Thanks!
09:19:50 <xiaohhui> :)
09:20:02 <liuhaixia> If it's done in the current patch, the patch will be get bigger.
09:20:05 <liuhaixia> :(
09:20:36 <xiaohhui> That is true
09:20:41 <oanson> liuhaixia, doing it in another patch is great. I just want to make sure it isn't forgotten
09:21:05 <liuhaixia> It will not forgotten, I promise.
09:21:08 <oanson> I think in another patch is the correct way to do it. I just want to wait for that patch.
09:22:22 <oanson> Anything else for roadmap?
09:22:58 <oanson> Since yuli_s isn't here, and he is the one running the performance tests, I think we'll skip it
09:23:03 <oanson> #topic Bugs
09:23:40 <nick-ma> the ml2 seems not working in the ci.
09:24:19 <oanson> nick-ma, I think this patch solves the issue: https://review.openstack.org/#/c/366035/
09:24:39 <oanson> I see you already voted on it. Once others review it, it can be merged.
09:24:54 <nick-ma> and i'm not seeing hujie recently. he submitted several big patches including remote port and part of db consistency.
09:24:56 <oanson> (I don't feel comfortable voting +2 on my own patches (: )
09:25:25 <xiaohhui> I saw the package is uninstalled before install
09:25:37 <xiaohhui> so what is the --upgrade for?
09:26:03 <nick-ma> It's ok. I'm always doing so if I think it is working and you also give one of +2, oanson.
09:26:11 <oanson> xiaohhui, the uninstall doesn't completely remove the package. I think that's because it is installed via ubuntu's package manager and not via pip.
09:26:21 <oanson> the --upgrade verifies that it is indeed the latest version.
09:26:42 <nick-ma> --upgrade is a guarantee.
09:26:53 <xiaohhui> It might be good to add a comment in case others has the same confusion as me
09:27:13 <oanson> nick-ma, then I will go over them and merge them. Then the ml2 should work and all tests should pass.
09:28:24 <oanson> xiaohhui, there already is a comment. Do you think more is needed?
09:29:06 <xiaohhui> I just checked, it is fine what it looks now
09:29:20 <oanson> xiaohhui, great. Thanks.
09:29:28 <oanson> About bugs: It looks like all the critical and high bugs are assigned.
09:29:50 <oanson> So I think we can move on.
09:29:54 <oanson> Any other issues for bugs?
09:30:23 <oanson> #topic Open Discussion
09:30:33 <xiaohhui> https://bugs.launchpad.net/dragonflow/+bug/1619101
09:30:35 <openstack> Launchpad bug 1619101 in DragonFlow "secgroup ofperror flooding in the fullstack ci" [Critical,In progress] - Assigned to Hong Hui Xiao (xiaohhui)
09:31:07 <xiaohhui> I want you guys to review this one https://review.openstack.org/#/c/367070/
09:31:11 <oanson> xiaohhui, isn't that solved by the patches you uploaded last week?
09:31:36 <xiaohhui> yeah, it is resolved for fullstack, but I have another patch for it
09:31:53 <xiaohhui> this is another solution, I want to make sure if it is needed
09:32:53 <oanson> xiaohhui, I think it is needed.
09:33:41 <oanson> See bug 1555001
09:33:42 <openstack> bug 1555001 in DragonFlow "stack.sh isn't working after using VxLAN" [Medium,In progress] https://launchpad.net/bugs/1555001 - Assigned to Omer Anson (omer-anson)
09:34:40 <oanson> The changes in stop_ovs_dp might solve this bug
09:34:43 <xiaohhui> nick-ma has given a comment, but I think it is out of the scope of bug 1619101. I can take a further look in bug 1555001
09:34:45 <openstack> bug 1619101 in DragonFlow "secgroup ofperror flooding in the fullstack ci" [Critical,In progress] https://launchpad.net/bugs/1619101 - Assigned to Hong Hui Xiao (xiaohhui)
09:34:46 <openstack> bug 1555001 in DragonFlow "stack.sh isn't working after using VxLAN" [Medium,In progress] https://launchpad.net/bugs/1555001 - Assigned to Omer Anson (omer-anson)
09:35:04 <nick-ma> I'm removing my down vote. xiaohhui
09:35:38 <xiaohhui> Thanks nick-ma
09:35:44 <oanson> xiaohhui, I'll review the patch. I may have some comments. But at a first glance it looks good.
09:35:52 <xiaohhui> Thanks~
09:36:40 <oanson> We're in open discussion. The floor is for the taking.
09:36:44 <nick-ma> do we have release schedule, i just wonder?
09:37:05 <oanson> I think we plan to release with Newton cycle.
09:37:24 <xiaohhui> is there any topic in summit about dragonflow?
09:37:27 <oanson> New features will go into O cycle. important bug fixes will be back-ported.
09:37:34 <nick-ma> seems a little bit tight. some big patches are still on the way.
09:37:52 <nick-ma> do you guys go to spain?
09:38:04 <oanson> nick-ma, yes. We will have to decide were we draw the feature freeze.
09:38:16 <oanson> Yes, I'll be in Spain.
09:38:30 <xiaohhui> No plans for now...
09:38:35 <nick-ma> me too...
09:39:54 <nick-ma> is there any schedule on time slot of design summit for df?
09:40:21 <oanson> Yes. There should be 1 fishbowl, and 4 smaller sessions
09:40:41 <oanson> (Workrooms)
09:40:52 <nick-ma> great.
09:41:20 <oanson> The plan is here: https://etherpad.openstack.org/p/dragonflow-barcelona
09:41:29 <oanson> If anyone wants to make suggestions.
09:41:29 <nick-ma> I see.
09:42:55 <nick-ma> any general sessions around df?
09:43:39 <oanson> nick-ma, I don't know. I haven't read through the schedule yet.
09:43:45 <nick-ma> me too.
09:44:10 <oanson> I'll be ready for next week's meeting :)
09:44:42 <oanson> Any other topics?
09:46:13 <oanson> All right.
09:46:15 <nick-ma> no
09:46:19 <oanson> Thanks everyone for coming.
09:46:26 <nick-ma> thanks. see you next week.
09:46:29 <oanson> Keep up the great work!
09:46:33 <oanson> #endmeeting