09:00:16 <oanson> #startmeeting dragonflow
09:00:17 <openstack> Meeting started Mon Jul 25 09:00:16 2016 UTC and is due to finish in 60 minutes.  The chair is oanson. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:20 <openstack> The meeting name has been set to 'dragonflow'
09:00:24 <oanson> Hi.
09:00:32 <oanson> Who's here for the Dragonflow weekly meeting?
09:00:38 <yuli_s> Hello
09:00:45 <oshidoshi> o/
09:01:12 <oanson> Looks like a skeleton crew.
09:01:19 <oanson> #info yuli_s, oshidoshi in meeting
09:01:32 <oanson> Let's wait another minute to see if others join.
09:02:02 <yuli_s> ok, i will be back in a minute
09:02:14 <oanson> yuli_s, I'm counting 59 seconds
09:02:57 <oanson> All right, let's start
09:03:03 <oanson> #topic Newton Features
09:03:14 <oanson> Firstly, DB consistency.
09:03:36 <oanson> hujie uploaded a patch. Patchset 19. It has to be reviewed.
09:03:44 <oanson> ML2 and L3 Service Plugins
09:04:09 <oanson> The patches were merged. Last week we discussed adding a gate job for the ML2 configuration.
09:04:12 <oshidoshi> what's  the patch #?
09:04:24 <oshidoshi> (refering to the db consistency)
09:04:24 <oanson> DB consistency:
09:04:30 <oanson> #link https://review.openstack.org/#/c/336377/
09:04:44 <yuli_s> oanson, ;)
09:04:57 <oanson> I suggest waiting another week with the gate job, since it currently fails. I'll get to that in the bugs section.
09:05:20 <oanson> Packaging - this one was on me. There was no progress, but I promise to have something for next week.
09:05:33 <oanson> VALN networking - liuhaixia uploaded a patch
09:05:36 <oanson> VLAN*
09:06:00 <oanson> It should be reviewed as well. While we're at it, she also uploaded a flat networking patch.
09:06:03 <oanson> Links in a second:
09:06:36 <oanson> #link spec: https://review.openstack.org/#/c/288270/
09:06:48 <oanson> #link VLAN: https://review.openstack.org/#/c/340789/
09:07:09 <oanson> #link flat: https://review.openstack.org/#/c/340846/
09:07:33 <oanson> I'll also have the metadata service updated for next week.
09:07:54 <oanson> #link metadata https://review.openstack.org/#/c/309746/
09:08:05 <oanson> #topic performance testing and bugs
09:08:09 <oanson> yuli_s, take it away
09:08:25 <yuli_s> ok,
09:08:46 <yuli_s> I assigned one bug to myself
09:08:50 <yuli_s> related to redis
09:08:53 <yuli_s> https://bugs.launchpad.net/dragonflow/+bug/1597332
09:08:53 <openstack> Launchpad bug 1597332 in DragonFlow "df dropall doesn't work for redis" [Medium,New] - Assigned to Yuli (stremovsky)
09:09:02 <oanson> #link https://bugs.launchpad.net/dragonflow/+bug/1597332
09:09:05 <yuli_s> we have few more bugs needed to take care
09:09:25 <oanson> Last week we said bug owners need to verify their bugs.
09:09:25 <yuli_s> but they are not that high priority
09:09:30 <yuli_s> Check geneve and vxlan
09:09:30 <yuli_s> https://bugs.launchpad.net/dragonflow/+bug/1571551
09:09:30 <openstack> Launchpad bug 1571551 in DragonFlow "Kernel module vport_geneve.ko fails to load on ubuntu" [High,New]
09:09:36 <oanson> I doubt that happened, but I guess we can say that for this week as well.
09:09:52 <oanson> #action everyone Verify assigned bugs. Close invalid bugs.
09:09:54 <yuli_s> another bug:
09:09:56 <yuli_s> Check that unstack works correctly:
09:09:57 <yuli_s> https://bugs.launchpad.net/dragonflow/+bug/1582122
09:09:58 <yuli_s> https://bugs.launchpad.net/dragonflow/+bug/1597568
09:09:58 <openstack> Launchpad bug 1582122 in DragonFlow "unstack couldn't unload openvswitch module" [Medium,New] - Assigned to lei zhang (zhang-lei)
09:09:59 <openstack> Launchpad bug 1597568 in DragonFlow "Devstack can not start openvswitch when it is running" [Medium,In progress] - Assigned to wang jian (wangjian011)
09:10:07 <yuli_s> Bug related to instllation command sequence:
09:10:08 <yuli_s> https://bugs.launchpad.net/dragonflow/+bug/1605839
09:10:08 <openstack> Launchpad bug 1605839 in DragonFlow "devstack starts NB DB driver between ova_init and ovs_start" [Medium,New]
09:10:13 <oanson> yuli_s, what about these bugs? Are they new? Are they without owners?
09:10:22 <oanson> Are they critical?
09:10:23 <yuli_s> without owners
09:10:48 <oanson> 1582122 and 1597568 are assigned to lei zhang and wang jian
09:11:06 <oanson> bug 1605839 has an open review
09:12:09 <oanson> (but I can't find it now)
09:12:26 <yuli_s> ok,
09:13:16 <oanson> #link https://review.openstack.org/#/c/342530/
09:13:23 <oanson> yuli_s, anything else?
09:13:34 <yuli_s> nop
09:13:40 <oanson> Great. Thanks!
09:13:47 <oanson> I have an update about the fullstack tests.
09:13:59 <oanson> They appear to fail in gate due to the selective topology distribution
09:14:17 <oanson> I see the ports created in q-svc and ovs, but the dragonflow controller doesn't handle them.
09:14:33 <oanson> I also see that the relevant flows (table 0, ARP responders) are not installed.
09:14:49 <oanson> I think the issue is that we don't use real VMs, and we need to fool the system.
09:15:08 <oanson> I am still reading the code (Topology.py) but it might take a while longer.
09:15:16 <oanson> #topic Open Issues
09:15:23 <oanson> The floor is for the taking.
09:16:07 <oanson> Anyone?
09:16:33 <oshidoshi> regarding the installation
09:16:40 <oanson> oshidoshi, yes?
09:16:41 <oshidoshi> which tool are you checking?
09:16:48 <oanson> opentack-ansible
09:17:05 <oanson> #link https://github.com/openstack/openstack-ansible
09:17:06 <oshidoshi> did you compare other tools?
09:17:34 <oanson> I looked into fuel, and one other (who's name I forgot), but I think this is the best direction.
09:18:04 <oshidoshi> did you check popularity?
09:18:32 <oanson> oshidoshi, yes. There was a popularity parameter in Austin. openstack-ansible and openstack-puppet were very close together at the top
09:18:38 <oanson> I prefer ansible, since it is agentless.
09:18:59 <oanson> fuel is puppet-based.
09:20:08 <oanson> oshidoshi, anything else?
09:21:07 <oshidoshi> not from me
09:21:13 <oanson> All right. Thanks everyone for participating.
09:21:16 <oshidoshi> cheers
09:21:22 <oanson> Let's do this again sometimes, like next week.
09:21:24 <yuli_s> thanks !
09:21:26 <oanson> #endmeeting