09:00:07 <gsagie> #startmeeting dragonflow
09:00:08 <openstack> Meeting started Mon Jul 18 09:00:07 2016 UTC and is due to finish in 60 minutes.  The chair is gsagie. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:11 <openstack> The meeting name has been set to 'dragonflow'
09:00:21 <gsagie> Hello everyone and welcome to our week's best time
09:00:34 <gsagie> its the Dragonflow meeting
09:00:37 <DuanKebo> Hi
09:00:41 <gsagie> who is here for the merting
09:00:41 <oanson> Hi
09:00:43 <gsagie> meeting
09:00:44 <Shlomo_N> ין
09:00:46 <Shlomo_N> hi
09:00:47 <oshidoshi> o/
09:00:56 <oanson> \o
09:01:04 <gsagie> Just as a side note WSOP day 6 start today, November 9 is going to be selected tommorow
09:01:10 <gsagie> \o/
09:01:54 <gsagie> #info DuanKebo,  oanson, oshidoshi, Shlomo_N in meeting
09:01:58 <oanson> The winnings go to the openstack foundation?
09:02:13 <gsagie> oanson: nice google skills :)
09:02:22 <gsagie> hujie!!!!
09:02:22 <oanson> Cheers
09:02:27 <gsagie> we waited just for you :)
09:02:37 <gsagie> #info hujie in the meeting as well, late, but in the meeting
09:02:53 <gsagie> #topic ML2
09:02:56 <hujie> oh thank you :)
09:03:09 <gsagie> ok, so how was OpenStack china days ? anything to share?>
09:03:43 <oanson> The openstack unified API is cool. It also has a python and ansible frontends.
09:04:07 <gsagie> DuanKebo: any open patches for the ML2 work? i saw your message regarding liuhaxia patch and removed my -1, the patch is merged but as well agreed some fixes are needed in future patches
09:04:10 <gsagie> for simplicity
09:04:35 <gsagie> oanson: what do you mean "unified API" ?
09:04:37 <oanson> Are we planning on adding an ML2 gate job once the feature is stable?
09:04:42 <DuanKebo> Yes, the patch will be submited later
09:05:05 <gsagie> DuanKebo: ok thanks
09:05:07 <oanson> gsagie: That any openstack feature (networking, servers, storage) can be managed from a single command line function, with a naming convention
09:05:18 <oanson> i.e. no confusion between remove and delete, etc.
09:05:58 <gsagie> oanson: understood, sounds interesting
09:06:18 <gsagie> i think we will want to make ML2 the default installation in the gate
09:06:21 <oanson> The python API is done with a library called 'shade'
09:06:25 <gsagie> any objections?
09:06:30 <oshidoshi> +1
09:06:34 <hujie> agree
09:06:37 <oanson> gsagie, maybe keep both until we see it is stable
09:06:50 <oanson> Is there a plan to fade out the core plugin configuration?
09:07:03 <gsagie> oanson: its possible, i think the plan we agreed was to slowly remove the core plugin
09:07:13 <gsagie> and stay only with the ML2, DuanKebo, do you also see it that way?
09:07:22 <DuanKebo> +1, but before that, we need review and merge l3 plugin
09:07:31 <gsagie> yes of course
09:07:36 <gsagie> review the l3 service plugin
09:08:03 <gsagie> okie, so any open issues for the ML2?
09:08:14 <gsagie> DuanKebo, anyone tested this end-to-end ?
09:08:21 <DuanKebo> He shan will focus on updating this patch.
09:08:43 <gsagie> ok
09:08:48 <hujie> link: https://review.openstack.org/#/c/316785/
09:08:51 <DuanKebo> @gal heshan currently
09:09:00 <gsagie> #link https://review.openstack.org/#/c/316785/
09:09:17 <gsagie> #action gsagie,oanson,nick-ma review L3 service plugin patch
09:09:26 <oanson> Will do
09:09:27 <gsagie> anything open on that?
09:09:38 <gsagie> on ML2
09:09:51 <gsagie> #action gsagie add ML2 testing jobs to gate
09:10:16 <gsagie> yuanwei1: i welcome you with the dragon greeting!
09:10:21 <DuanKebo> for plug, we also submit
09:10:34 <DuanKebo> a qos driver for dragonflow
09:10:43 <gsagie> DuanKebo: QoS + ML2?
09:10:46 <DuanKebo> someone can help reviewing it
09:10:47 <gsagie> for the ML2
09:11:08 <DuanKebo> Yes it's qos driver
09:11:24 <DuanKebo> the default one use rabbitmq
09:11:35 <gsagie> DuanKebo: we will take a look, is it changing the pipeline or its just using OVSDB?
09:11:40 <gsagie> to configure it on the ports
09:12:00 <gsagie> so you changed to update and add a new table to the DB right?
09:12:04 <DuanKebo> it uses ovsdb
09:12:14 <gsagie> need to make sure you add it to the other DB's
09:12:17 <DuanKebo> but pipeline also be changed
09:12:25 <gsagie> some has a setup process to create the tables
09:12:45 <gsagie> DuanKebo: any link to the patch review board?
09:13:11 <gsagie> you mean the spec? https://review.openstack.org/#/c/332662/
09:13:40 <gsagie> code: https://review.openstack.org/#/c/337497/
09:13:48 <gsagie> #link qos spec https://review.openstack.org/#/c/332662/
09:13:58 <gsagie> #link qos code https://review.openstack.org/#/c/337497/
09:14:05 <gsagie> ok lets all review them and comment about them
09:14:16 <gsagie> DuanKebo: the spec has a -1 from you btw..
09:14:45 <gsagie> ok, anything else on ML2 ?
09:14:59 <DuanKebo> ok we will update the patch
09:15:12 <DuanKebo> hujie is in charge of it now
09:15:19 <hujie> yes
09:15:56 <gsagie> ok, good job hujie, we will take a look this week
09:16:18 <gsagie> maybe add also a document describing how to enable QoS with Neutron and in your patch
09:16:32 <oanson> Or at least a link to the QoS API
09:16:35 <gsagie> so it will be easier to check it (as i remember you need to add some configuration to Neutron for it)
09:17:13 <gsagie> ok
09:17:19 <DuanKebo> i think we can add a link to qos api
09:17:20 <gsagie> lets move to the next topic
09:17:41 <gsagie> #topic DB - Controller consistency
09:17:52 <gsagie> I think hujie was also working on this, hujie any update?
09:18:12 <hujie> https://review.openstack.org/#/c/336377/
09:18:21 <hujie> please review this patch :)
09:18:21 <gsagie> #action hujie working on QoS patch
09:18:42 <gsagie> #link https://review.openstack.org/#/c/336377/  DB consistency patch
09:19:13 <gsagie> hujie: we will review, please mind that you have some comments from Li Ma
09:19:29 <gsagie> is there anything you would like to discuss about ?
09:19:36 <gsagie> or everything seems closed?
09:20:10 <hujie> I'll review the comments from Li ma:)
09:20:17 <gsagie> okie
09:20:46 <hujie> this patch is the db consistency logic on local controller side
09:21:17 <gsagie> ok
09:21:26 <gsagie> #topic Bugs
09:21:37 <gsagie> anyone know of any critical open bugs?
09:21:43 <gsagie> yuli_s is here?
09:21:59 <gsagie> our famous bug deputy
09:22:34 <oanson> Maybe he;s out on patrol.
09:22:41 <gsagie> :)
09:22:44 <gsagie> probably
09:22:52 <gsagie> #topic Packaging
09:23:02 <gsagie> oanson: any update here
09:23:18 <gsagie> or anyone else is handling this?
09:23:18 <oanson> I was skiving in openstack days china :)
09:23:19 <oanson> So no
09:23:29 <gsagie> okie
09:23:53 <gsagie> #action oanson continue working on packaging possibilities
09:24:13 <gsagie> yuli_s: Any important bugs you would like to share?
09:24:47 <hujie1> sorry, I lost connection just now :)
09:24:55 <gsagie> hujie1: np
09:25:13 <gsagie> okie guess yuli_s is still not here
09:25:17 <yuli_s> sorry
09:25:20 <gsagie> ahh
09:25:34 <yuli_s> i had a bug
09:25:44 <yuli_s> that I failed to recreate
09:26:00 <hujie1> I have a bug patch too: https://review.openstack.org/#/c/336896/
09:26:07 <yuli_s> no flows in table=0 were created in openflow
09:26:21 <yuli_s> i had tried to recreate it several time without success
09:26:41 <yuli_s> i will deeg deeper to find it
09:26:41 <gsagie> hujie1: ok thanks will review
09:26:50 <hujie1> thx
09:26:51 <oanson> yuli_s, this is on a local installation?
09:26:56 <yuli_s> i am concentrating on the control flow tests
09:27:00 <oanson> Did you look for exceptions in the logs?
09:27:07 <yuli_s> oanson, yes, fresh version of everything
09:27:25 <gsagie> yuli_s: ok, i think what we need right now is to go over all the bugs list, make sure they are all assigned and started cleaning old bugs or ask the asignee of the bug whats going on (or move it to someone else maybe from DuanKebo team)
09:27:35 <yuli_s> i had to restarr df-controller
09:27:44 <gsagie> because we have a big list of Open bugs and most of them are probably invalid/old
09:27:50 <yuli_s> and the problem dissapeared
09:28:00 <oanson> yuli_s, did you upload the logs to the bug report? Usually there are indicative exceptions and errors
09:28:14 <oanson> This may be vital information.
09:28:23 <yuli_s> oanson, i will check it and go over all bug and close them
09:28:39 <yuli_s> oanson, I will check for exception
09:28:52 <oanson> Thanks.
09:29:01 <gsagie> thanks yuli_s
09:29:24 <gsagie> #topic performance (control + datapath)
09:29:34 <gsagie> yuli_s, Shlomo_N: any update on this?
09:29:42 <yuli_s> sure
09:30:07 <yuli_s> i created a test with a sliced version of dragonflow in containers
09:30:30 <yuli_s> with 50 sliced version of df-controllers running in containers
09:30:53 <yuli_s> and now I am trying to recreate this test with regular version of dragonflow
09:30:53 <oanson> yuli_s, this is using https://review.openstack.org/#/c/309948/ (DB time testing patch)?
09:31:03 <Shlomo_N_> I have finished the work on the patch, it already generates a report, you can check it at: https://review.openstack.org/#/c/304470/. There is also a readme file: https://review.openstack.org/#/c/304470/16/dragonflow/tests/performance/readme.txt
09:31:16 <yuli_s> oanson, I used it
09:31:35 <gsagie> ok thanks we will check this out
09:31:57 <yuli_s> In new version, I am starting a df-controller to make it write to separate br-int
09:32:00 <gsagie> Have we approched anyone from the Openstack performance team regarding this?
09:32:10 <yuli_s> br-int2, etc..
09:32:14 <Shlomo_N_> No
09:32:18 <yuli_s> I am debugging this now
09:32:19 <Shlomo_N_> I think we should
09:33:05 <gsagie> yuli_s: ok
09:33:13 <Shlomo_N_> I also think we should take it as a separate project from DF
09:33:18 <gsagie> yuli_s: but your OVSDB is still shared
09:33:30 <yuli_s> gsagie, yes
09:33:53 <gsagie> ok
09:34:15 <yuli_s> I use socat proxy to make it available from container
09:35:13 <gsagie> ok thanks yuli_s and Shlomo_N, i think when the control plane testing is close to something we can review maybe its best to review it together
09:35:20 <gsagie> but lets take this offline
09:35:27 <yuli_s> gsagie, sure
09:35:39 <gsagie> DuanKebo: any testing your team is doing for scale/performance at this point?
09:35:45 <gsagie> or still no resources?
09:36:13 <DuanKebo> we are
09:36:31 <DuanKebo> plan to do controll plan test
09:36:47 <DuanKebo> and date plan test has been done
09:37:41 <gsagie> okie, please update us with results :)
09:37:43 <gsagie> #topic roadmap
09:37:46 <DuanKebo> Compareing with neutron referrence implementation, we have 100% imporvement for DVR+SG
09:38:26 <gsagie> besides the ML2 and the QoS, what other features we have in the road map that we need?
09:38:41 <gsagie> DuanKebo, oanson: managed to discuss about this in China by any chance?
09:38:46 <DuanKebo> i think we nee live-migration
09:38:52 <DuanKebo> *need
09:38:59 <gsagie> ok so we have live-migration
09:39:13 <oanson> gsagie, yes, but it's long and I would rather go over it off-line first.
09:39:21 <gsagie> ok np
09:39:45 <gsagie> DuanKebo: beside the live-migration anything else notable?
09:40:06 <DuanKebo> another interesting feature is comunicating between different dvrs
09:40:33 <DuanKebo> this feature is already supported by AWS
09:40:37 <gsagie> DuanKebo: distributed SNAT is something that is important?
09:40:46 <gsagie> or something you want to try and implement?
09:41:16 <DuanKebo> It's interesting also
09:41:24 <gsagie> And you have the requierments ?
09:41:30 <DuanKebo> but we lack a staisfying solution
09:41:32 <gsagie> there are several options to solve it
09:42:05 <gsagie> for example doing the SNAT per compute node, doing it per group of gateways and so on
09:42:08 <DuanKebo> ok we can discuss these soluions
09:42:11 <gsagie> depending on the network architecture
09:42:16 <DuanKebo> *solutions
09:42:42 <gsagie> Ok, so no special requirements restrictions? for example every compute node is connected to the public network?
09:42:50 <DuanKebo> we also care about VM grade QoS
09:42:52 <hujie1> what about the solution of the qos for several shared ports, not just for one single port in current patch?
09:43:12 <gsagie> But is this something that currently exposed in API?
09:43:24 <gsagie> in Neutron API
09:43:28 <gsagie> probably not
09:43:31 <DuanKebo> @gal, no apis curreently
09:43:52 <hujie1> the HWS need the feature
09:43:57 <DuanKebo> we can consider submit one
09:44:33 <gsagie> DuanKebo: ok, maybe its best to first try to submit the API part, is there a problem with implementing it?
09:45:04 <DuanKebo> yes, we are still working on the solution
09:45:13 <DuanKebo> there are problems.
09:45:42 <gsagie> DuanKebo: ok, feel free to consult with us, maybe schedule a meeting
09:45:45 <hujie1> we need a valid and simple solution for the feature, after provided the solution, we can consider the APIS
09:45:55 <gsagie> i think with some OVS and tc queue work we can get it to work :)
09:46:13 <gsagie> you mean for several ports for one VM right?
09:46:51 <hujie1> yes Gal
09:46:53 <DuanKebo> yes, you can work on the api part
09:47:11 <gsagie> ok, i will try to look at it and help you out
09:47:13 <gsagie> if possible
09:47:22 <gsagie> ok
09:47:29 <gsagie> #topic open discussion
09:47:39 <gsagie> Anything else anyone?
09:47:50 <gsagie> Remember the Dragon always hear you..
09:48:09 <oanson> I have a request.
09:48:21 <gsagie> oanson: yes..
09:48:21 <oanson> There are many patches. And many of them aren't short.
09:48:30 <oanson> We could use any help we can get when it comes to reviews.
09:48:44 <oanson> It will also speed-up the review-cycle and process
09:48:46 <gsagie> oanson: The Dragon heard you my son, and you shall be answered
09:49:02 <gsagie> :)
09:49:12 <oanson> Thank you, oh Dragon Speaker
09:49:14 <oshidoshi> documentation
09:49:25 <gsagie> Ok, so please everyone make sure to review the patches
09:49:36 <gsagie> the review process is not limited for cores, we wait for your +1
09:50:01 <hujie1> of course :)
09:50:20 <gsagie> and the review process is important, we dont want to add un stable code to master branch
09:50:30 <gsagie> another part is documentation
09:50:46 <gsagie> as oshidoshi mentioned, our features increase and we need to make sure its easy to configure and use
09:50:58 <gsagie> so please lets make sure we add documentations on new features
09:51:25 <gsagie> even links to other Neutron documentation or instructions how to enable these features in Dragonflow, its very important to who ever that doesnt work on the actual patch
09:51:32 <gsagie> and want to test it
09:51:33 <gsagie> or try it
09:51:44 <gsagie> Anything else anyone?
09:51:47 <oanson> Links to Neutron are especially important.
09:52:26 <gsagie> Ok, lets take the rest we discussed about offline, thanks all for attending and Let the Dragon be with you!
09:52:37 <oshidoshi> thanks
09:52:55 <gsagie> bye!
09:52:58 <oanson> Thank you.
09:52:58 <gsagie> #endmeeting