09:00:16 <gsagie> #startmeeting dragonflow
09:00:17 <openstack> Meeting started Mon Jun  6 09:00:16 2016 UTC and is due to finish in 60 minutes.  The chair is gsagie. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:20 <openstack> The meeting name has been set to 'dragonflow'
09:00:35 <gsagie> Hello everyone,
09:00:36 <gampel> Hi
09:00:38 <vikasc> hi
09:00:41 <oanson> Hi
09:00:43 <hujie> Hi
09:01:12 <gsagie> Hello
09:01:33 <gsagie> #info gampel, oanson, vikasc, hujie, gsagie in meeting
09:01:42 <gsagie> Any other lost dragons out there?
09:01:54 <gsagie> #info guest of honor saggi
09:02:11 <gampel> @eshed will join soon
09:02:22 <gsagie> cool, lets wait for him
09:02:31 <oanson> gsagie, that's another guest of honour
09:02:43 <gsagie> indeed, i will announce it upon his arrival!
09:02:46 <Shlomo_N> hi
09:03:01 <gsagie> #info Shlomo_N in meeting, yuli_s suppose to be in meeting..
09:03:04 <hujie> Eran, I'll miss you :)
09:03:42 * yamamoto_ peeking
09:03:43 <gsagie> ohhh, hujie you heard the news?
09:03:49 <gampel> yes I will still be around in DF
09:03:52 <gampel> thx
09:04:00 <gsagie> #info yamamoto is in the meeting and our 2nd guest of honor
09:04:12 <oshidoshi> ola!
09:04:13 <gsagie> #info oshidoshi has entered the room and is our 3rd guest of honor
09:04:26 <hujie> best wishes :)
09:04:31 <oshidoshi> the honorable oshidoshi, please
09:04:43 <gsagie> hujie: byran munich is having hard times..
09:05:00 <gsagie> anyway i see DuanKebo is not here?
09:05:02 <gsagie> nick-ma?
09:05:10 <gsagie> #topic open patches
09:05:33 <gsagie> We were presenting Dragonflow in OpenStack Israel day last week thats why we were a bit busy
09:05:40 <hujie> yes, I expect it good perform next year :)
09:06:11 <gsagie> It really got alot of interest locally from Israeli companies and hopefully we can start some more collaborations soon
09:06:32 <gsagie> hujie: thats because they didnt take Yossi Benayun
09:06:49 <hujie> benayun is very good player
09:07:00 <gsagie> hujie, vikasc: any open patches that needs our review?
09:07:02 <gsagie> in Dragonflow?
09:07:09 <hujie> yes
09:07:11 <oanson> I have two patches I'd be happy for review.
09:07:14 <hujie> my db consistency patch
09:07:15 <vikasc> only one patch I have
09:07:17 <oanson> https://review.openstack.org/#/c/309746/ - Metadata service
09:07:29 <gsagie> #link https://review.openstack.org/#/c/309746/ - Metadata service
09:07:34 <hujie> https://review.openstack.org/#/c/300877/
09:07:34 <oanson> and https://review.openstack.org/#/c/322493/ - OVS RPM installation
09:07:35 <gampel> oanson: i will complete my review on it today
09:07:39 <gsagie> #action gsagie, gampel review open patches
09:07:41 <oanson> Thanks
09:07:47 <hujie> thx
09:07:48 <gsagie> #link https://review.openstack.org/#/c/322493/ - OVS RPM installation
09:07:57 <gsagie> #link https://review.openstack.org/#/c/300877/
09:08:15 <gsagie> #action gsagie, gampel, oanson review Redis HA patch
09:08:26 <oanson> Will do.
09:08:28 <gampel> For the RPM patch we actually have two one by omer  and one by
09:08:30 <gsagie> also got this in email, its been some time now and we need to also make sure its merged
09:08:33 <hujie> and I commit a cascading scenario patch: https://review.openstack.org/#/c/325651/
09:08:49 <oanson> gampel, they are not mutually exclusive.
09:08:57 <oanson> I have tested my patch on both master and 2.5 branches
09:08:58 <gsagie> hujie: can you explain more about this patch?
09:09:30 <gampel> so we want to move to the master  branch  of the OVS
09:09:57 <gampel> I think it will be best to stay on the 2.5 branch
09:10:20 <hujie> it describe the communication between two VMs which belong to independent Openstack system
09:10:32 <gsagie> why do we want to move to OVS master?
09:10:42 <gsagie> hujie: So you mean with Tricircle project?
09:11:00 <gsagie> hujie: what is the extra work that we are going to add for Dragonflow for that? as this is not "standard" yet
09:11:10 <gsagie> will take a look at the patch
09:11:27 <gsagie> #link https://review.openstack.org/#/c/325651/ - Dragonflow and Tricircle integration spec
09:11:32 <gampel> There is a patch submitted to do that  but i think we should  stay on 2.5 unless there are new features we need on master
09:11:59 <gsagie> gampel: agree
09:12:15 <gsagie> gampel: wondering if there was any special reason to do it
09:12:31 <hujie> it's a cascading patch :)
09:12:49 <gsagie> vikasc: i saw the patch for turning Redis into the default DB at gate is still failing, any help needed on that?
09:12:59 <vikasc> yes gsagie
09:13:29 <gsagie> vikasc: ok, i will take a look today hopefully
09:13:30 <vikasc> i am not able to figure out why its not able to detect redis, though it is installed successfully
09:13:41 <vikasc> gsagie, thanks
09:13:51 <gsagie> vikasc: what do you mean "detect redis" ?
09:14:35 <oanson> gsagie, the devstack log shows that redis gem (ruby) is installed
09:14:45 <oanson> but when the code tries to import the library, it fails.
09:14:56 <vikasc> gsagie, 2016-06-04 11:53:22.952 | /usr/local/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- redis (LoadError)
09:14:59 <hujie> gsagie you mean we do not consider the thicircle or cascading patch?
09:15:39 <gsagie> hujie: we will take a look but i think we need to do a design talk about this more closely, we will need to understand the work that is needed in Dragonflow and how it effect users that might not use Tricircle, but i havent seen the patch yet, so need to read it first
09:16:05 <hujie> ok, thx :)
09:16:19 <gsagie> vikasc, oanson: maybe installed in the wrong place then the import?
09:16:33 <gampel> hujie: I will go over the patch, but we need to make sure we do it in a standard way and not "special" tags
09:16:40 <vikasc> http://logs.openstack.org/38/320838/6/check/gate-dragonflow-dsvm-fullstack-nv/72e7d10/logs/devstacklog.txt.gz#_2016-06-05_16_45_29_467
09:16:43 <oanson> I don't know ruby well enough. I will have to test it on my environment.
09:17:05 <vikasc> gsagie,  oanson , it works fine on my local machine
09:17:08 <hujie> gampel: ok, I see
09:17:50 <vikasc> gsagie, oanson , I mean if try devstack with committed changes.
09:18:59 <gsagie> vikasc: you try it on fresh VM?
09:19:05 <vikasc> sure
09:19:08 <gsagie> i will try to look at it today as well hopefully
09:19:22 <vikasc> gsagie, meanwhile i will try on fresh vm also
09:20:41 <gsagie> you try it on Fedora btw?
09:20:45 <gsagie> or Ubuntu?
09:20:51 <vikasc> ubuntu
09:21:03 <gsagie> ok, we will take a look and let you know if i find anything
09:21:16 <gsagie> any other open patch that needs look?
09:21:19 <gampel> maybe it is a different  version
09:21:46 <gampel> I think that we need to back port few patches to the Mitaka branch
09:22:04 <gsagie> #topic bugs backporting
09:22:19 <gsagie> gampel: which ?
09:22:28 <gampel> one sec
09:23:09 <gampel> #link https://github.com/openstack/dragonflow/commit/c98fdb402197fcbac65cb587a58168f9f1d4f2fd
09:23:27 <gampel> #link https://github.com/openstack/dragonflow/commit/fcab5671047855f4d3c0f676dfc15a851ec107c2
09:23:45 <gsagie> oshidoshi: welcome back :)
09:23:53 <yuli_s> gsagie, u released version on Jun 1 right ?
09:24:08 <gsagie> yuli_s: dont remember the date, but you can see it on github
09:24:51 <oanson> Yes, 1st June.
09:24:58 <gampel> i think this one too https://github.com/openstack/dragonflow/commit/ae0e0f796081e32459311f99611825a3b49428d7
09:25:01 <yuli_s> oanson, thanks !
09:25:51 <gsagie> gampel: ok, i think anyone can suggest to backport it and we just need to merge it
09:26:06 <gampel> I will do it
09:26:36 <gsagie> okie
09:26:48 <gsagie> #topic bugs
09:26:52 <gampel> Yuli: any other patches you think we should include ?
09:26:54 <gsagie> anything on that anyone?
09:27:16 <yuli_s> gampel, my bug fixed were merged on 31
09:27:26 <gsagie> gampel: we need to make sure that these patches are not based on any other patches
09:27:30 <gsagie> that are not included
09:27:30 <yuli_s> so, I suppose they should be in code
09:27:40 <gampel> yes I will check that
09:27:43 <gsagie> or change the backport a bit
09:27:55 <gampel> Ok
09:29:01 <gsagie> yuli_s: you can check in the git log
09:29:16 <gsagie> okie, so i guess nothing special on bugs
09:29:21 <yuli_s> gsagie, i am looking here:
09:29:22 <yuli_s> https://review.openstack.org/#/q/status:merged+dragonflow
09:29:52 <yuli_s> i personally do not have any active bugs
09:29:59 <gampel> what about this BUG https://bugs.launchpad.net/dragonflow/+bug/1585535 I think it is just testing framework problem
09:29:59 <openstack> Launchpad bug 1585535 in DragonFlow "When using zmq, every event is processed two times" [Critical,New]
09:29:59 <yuli_s> the system works ;)
09:30:27 <yuli_s> i will take it
09:30:54 <gsagie> ok
09:30:59 <gampel> I think we are publishing twice in one of the  testing
09:31:11 <gsagie> #action yuli_s to look at bug #1585535
09:31:11 <openstack> bug 1585535 in DragonFlow "When using zmq, every event is processed two times" [Critical,New] https://launchpad.net/bugs/1585535 - Assigned to Yuli (stremovsky)
09:31:22 <gsagie> thanks yuli_s
09:31:26 <yuli_s> np
09:31:44 <gsagie> #topic control and data plan performance and testing
09:31:55 <gsagie> yuli_s, Shlomo_N: any update on this?
09:32:24 <yuli_s> gsagie, i started to return to this project today
09:32:43 <yuli_s> I will have the results next meeting
09:32:55 <Shlomo_N> the environment setup is ready and the bandwidth testing is ready as well
09:33:05 <Shlomo_N> working on adding more tests and the reporting
09:33:30 <yuli_s> (i was talking about control path testing)
09:33:52 <Shlomo_N> I think we missed this potential bug - https://bugs.launchpad.net/dragonflow/+bug/1538124
09:33:52 <openstack> Shlomo_N: Error: malone bug 1538124 not found
09:34:05 <Shlomo_N> also this one: https://bugs.launchpad.net/dragonflow/+bug/1571551
09:34:05 <openstack> Launchpad bug 1571551 in DragonFlow "Kernel module vport_geneve.ko fails to load on ubuntu" [Undecided,New]
09:34:38 <gsagie> anyone interested to look at this bug?
09:34:51 <Shlomo_N> and seems that no one really working on this one: https://bugs.launchpad.net/dragonflow/+bug/1582122
09:34:51 <openstack> Launchpad bug 1582122 in DragonFlow "unstack couldn't unload openvswitch module" [Undecided,New] - Assigned to lei zhang (zhang-lei)
09:35:42 <Shlomo_N> I propose taking it offline
09:35:46 <gsagie> okie
09:35:50 <gsagie> lets take this offline
09:35:53 <Shlomo_N> and continue the meeting
09:35:55 <gsagie> #topic open discussion
09:36:01 <gsagie> anything else anyone?
09:36:12 <Shlomo_N> nop
09:37:17 <oanson> I have nothing
09:37:43 <gsagie> gampel ?
09:37:47 <gsagie> hujie ?
09:37:53 <gampel> we need to continue working on the roadmap etherpad
09:37:53 <gsagie> yuli_s ?
09:38:00 <gsagie> ohhh yes
09:38:02 <hujie> I have nothing thx
09:38:11 <gsagie> the roadmap etherpad, need to prioritize the actions there
09:38:11 <yuli_s> sorry
09:38:21 <gsagie> nice one gampel :)
09:38:29 <gsagie> you have the memory of a lion
09:38:31 <yuli_s> the system works preatty good
09:38:49 <gampel> we can do it next week
09:38:56 <oanson> gsagie, elephant
09:39:20 <gsagie> okie lets go over it next week, saggi would like to finish the meeting
09:39:27 <oshidoshi1> gsagie: can you share the link to etherpad roadmap pls
09:39:30 <gsagie> and He is the guest of honor after all..
09:39:36 <gsagie> oshidoshi: sure, sec
09:39:50 <gsagie> #link https://etherpad.openstack.org/p/dragonflow-newton
09:40:01 <oshidoshi1> gsagie: god bless you
09:40:08 <gsagie> we do need to discuss about it when nick-ma and DuanKebo are here anyway
09:40:26 <hujie> I could not find duankebo
09:40:51 <gampel> Sure lets do it next week or in the Df channel
09:40:53 <gsagie> hujie: np, we will do it next week
09:41:00 <hujie> ok
09:41:18 <gsagie> ok everyone, unless anyone has anything else to share
09:41:20 <gsagie> ...
09:41:30 <gsagie> Its time to let the dragon flow
09:41:32 <gsagie> ;)
09:41:38 <oshidoshi1> (:
09:41:39 <gsagie> saggi: ? anything to add
09:42:14 <gsagie> ok thanks everyone for attending
09:42:21 <Shlomo_N> bye bye
09:42:21 <gsagie> and see you next week or in #openstack-dragonflow
09:42:24 <oanson> Thanks. Bye.
09:42:27 <gampel> bye thx
09:42:30 <hujie> bye
09:42:34 <gsagie> #action gsagie look at redis as default DB in gate patch
09:42:37 <yuli_s> bye
09:42:40 <vikasc> bye
09:42:40 <gsagie> #endmeeting