09:00:28 <gsagie> #startmeeting dragonflow
09:00:30 <openstack> Meeting started Mon Apr 18 09:00:28 2016 UTC and is due to finish in 60 minutes.  The chair is gsagie. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:34 <openstack> The meeting name has been set to 'dragonflow'
09:00:36 <gsagie> ok, who is here for the meeting
09:00:40 <oanson> I am
09:01:07 <nick-ma> hi all
09:01:23 <gsagie> #info oanson, Frank__, hujie, hshan1, nick-ma, Shlomo_N, todin_ in meeting
09:01:32 <gsagie> Hello everyone
09:01:36 <Shlomo_N> hi
09:01:58 <gsagie> Shlomo if you can please ask yuli_s to also join
09:02:16 <gsagie> #topic security groups
09:02:25 <Shlomo_N> NP
09:02:30 <yuli_s> Hello !
09:02:56 <gsagie> Frank__ : the last major feature that we wanted for this release has merged, there are still two missing important parts:
09:03:05 <gsagie> 1) connecting security groups to DNAT tables
09:03:12 <gsagie> 2) supporting port updates
09:03:20 <gsagie> and security rules updates
09:03:53 <Frank__> yes
09:04:22 <gsagie> okie so yuanwei will start working on this in different patches right?
09:04:39 <Frank__> Yes
09:04:45 <gsagie> ok thanks
09:05:03 <gsagie> another point is port security (for example ARP spoofing) this was started by dingobo and i dont think he sent code for it
09:05:05 <Frank__> But for the second one, it is not limited to sg, i think
09:05:27 <gsagie> Frank__: i agree, we havent tested updates enough so it could be that we only notice it nowe
09:05:29 <gsagie> now
09:05:54 <Frank__> but we can start from updating sg of ports.
09:06:04 <gsagie> okie
09:06:26 <nick-ma> yes, just for df.
09:06:28 <nick-ma> Df
09:06:31 <nick-ma> Sg
09:07:16 <gsagie> for port security i will write this on me then in the meantime and we can discuss later if there is anyone free to complete it
09:07:28 <gsagie> #action gsagie work on port security
09:07:48 <gsagie> oanson, yuli_s: anything else to add on security groups as you tested it?
09:08:01 <oanson> Nothing to add.
09:08:04 <gsagie> maybe you noticed anything else and need to report to Frank/yuanwei
09:08:17 <gsagie> okie
09:08:29 <gsagie> #topic release - feature freeze
09:08:53 <gsagie> okie, so basically we are at feature freeze, all the major features that we wanted for this release are merged
09:09:01 <gsagie> now its time to test and stable the version
09:09:31 <nick-ma> Okie. Great work during these days.
09:10:10 <gsagie> yep, good work for completing everything
09:10:21 <gsagie> so i think right now we should only merge bug fixes and tests
09:10:26 <gsagie> until the summit
09:11:06 <gsagie> Frank: is it ok? there is anything else you need to get merged or your team can start with release stable and testing all features
09:11:07 <gsagie> end to end
09:11:18 <nick-ma> Agree.
09:11:23 <Frank__> Ok for me
09:11:31 <Shlomo_N> I found 2day a new bug, we need prioritize it: https://bugs.launchpad.net/dragonflow/+bug/1571551
09:11:33 <openstack> Launchpad bug 1571551 in DragonFlow "Kernel module vport_geneve.ko fails to load on ubuntu" [Undecided,New]
09:11:49 <Shlomo_N> With a great help from oanson
09:12:09 <gsagie> Shlomo_N: okie i will look at that
09:12:19 <gsagie> In the mean time we can use VXLAN for testing
09:12:25 <Shlomo_N> #action ? :)
09:12:43 <gsagie> #action Shlomo_N, gsagie look at bug 1571551
09:12:44 <openstack> bug 1571551 in DragonFlow "Kernel module vport_geneve.ko fails to load on ubuntu" [Undecided,New] https://launchpad.net/bugs/1571551
09:12:48 <Shlomo_N> :)
09:13:27 <gsagie> i think that in the summit we will decide when is the best to tag the release
09:13:57 <gsagie> we still need to do more testing/bug fixes
09:14:28 <gsagie> I think that after the summit we should all meet and disucss the future roadmap
09:14:32 <gsagie> and new features
09:14:32 <yuli_s> i found another bug today
09:14:51 <gsagie> yuli_s: which one?
09:14:55 <yuli_s> sec.
09:15:10 <gsagie> #topic testing/performance
09:15:24 <yuli_s> https://bugs.launchpad.net/dragonflow/+bug/1571541
09:15:25 <openstack> Launchpad bug 1571541 in DragonFlow "exception in port delete" [High,New]
09:15:50 <gsagie> Shlomo_N: we do need to start doing performance testing on the version with security groups
09:16:03 <yuli_s> it should be also addressed. I had it yesterday too.
09:16:06 <Shlomo_N> Is it ready to testing?
09:16:29 <gsagie> Shlomo_N: as long as you dont update port security, yes :)
09:16:43 <gsagie> yuli_s, oanson: i think oanson is looking at this
09:16:49 <gsagie> its from Neutron side i believe
09:17:07 <Shlomo_N> :)
09:17:20 <Shlomo_N> I'm planning to start the perf. testing 2day.
09:17:22 <gsagie> ahh sorry wrong use case
09:17:37 <oanson> gsagie, I thought that this was resolved.
09:17:46 <oanson> This looks like a new issue. I can look into it
09:18:07 <gsagie> Frank: can someone from your team please look at yuli_s bug
09:18:16 <gsagie> yuli_s: please help them reproduce it
09:18:29 <yuli_s> ok, np. it is very easy to reproduce
09:18:30 <Frank__> yes
09:18:41 <gsagie> okie thanks! :)
09:18:43 <Frank__> I already take it.
09:18:53 <gsagie> #action Frank__ look at bug https://bugs.launchpad.net/dragonflow/+bug/1571541
09:18:55 <openstack> Launchpad bug 1571541 in DragonFlow "exception in port delete" [High,New] - Assigned to Duan Kebo (duankebo)
09:19:12 <gsagie> nick-ma: any topic you would like to raise?
09:19:27 <gsagie> We are going to meet in the summit
09:19:29 <nick-ma> Nip
09:19:33 <nick-ma> Nop
09:19:41 <gsagie> oanson: any update?
09:19:55 <oanson> Nothing worth mentioning
09:20:07 <gsagie> Frank__: anything else to add ?
09:20:13 <Frank__> no
09:20:22 <gsagie> #topic open discussion
09:20:43 <gsagie> anyone else would like to add/discuss about something? i am sorry that the meeting is short but we are getting ready for the summit
09:21:08 <gsagie> and i think after the summit and after we have some more performance results and stable version we can decide our next moves
09:21:31 <gsagie> Frank__: i dont know if Eran shared with you but we got some very good results for ZeroMQ pub/sub as opposed to Redis pub/sub
09:21:47 <Frank__> Yes
09:21:51 <gsagie> so we will need to meet and discuss all our options and testing
09:21:51 <Frank__> I know it
09:22:25 <gsagie> okie, so lets take this week to mostly concentrate on bugs fixing everyone, feel free to update in #openstack-dragonflow if you find anything
09:22:30 <scsnow> hi, I'd like to take https://bugs.launchpad.net/dragonflow/+bug/1562966. is someone working on it?
09:22:32 <openstack> Launchpad bug 1562966 in DragonFlow "Subnets in fullstack tests collide and collisions are resolved manually." [Wishlist,New]
09:23:03 <gsagie> scsnow: you are welcome to take it
09:23:16 <gsagie> #action scsnow look at https://bugs.launchpad.net/dragonflow/+bug/1562966
09:23:20 <gsagie> Welcome to the team :)
09:23:30 <gsagie> And please let me know if you need any help or assistant
09:23:37 <gsagie> will you be in the summit in Austin?
09:23:48 <yuli_s> scsnow, it is yours now !
09:25:41 <gsagie> okie everyone, thanks for attending! we will not have a meeting next week due to the summit so talk to you all the week after!
09:25:49 <hshan1> I file a bug just now, I'll discuss it with nick_ma
09:25:49 <hshan1> https://bugs.launchpad.net/dragonflow/+bug/1571565
09:25:50 <openstack> Launchpad bug 1571565 in DragonFlow "after restart neutron-server, create network hung up" [Undecided,New]
09:26:07 <hshan1> :)  sagie
09:26:12 <nick-ma> Ok
09:26:15 <gsagie> hshan1: okie np
09:26:26 <gsagie> hshan1: if you two need any help please let me know
09:26:32 <nick-ma> Ok
09:26:36 <hshan1> Ok
09:26:45 <Shlomo_N> thank you and good luck in the summit every1
09:26:51 <gsagie> #endmeeting