09:01:20 <oanson> #startmeeting dragonflow
09:01:21 <openstack> Meeting started Mon Apr  4 09:01:20 2016 UTC and is due to finish in 60 minutes.  The chair is oanson. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:22 <nick-ma> hello
09:01:25 <openstack> The meeting name has been set to 'dragonflow'
09:01:43 <oanson> #info gampel Shlomo_N yuli_s1 zenoway scsnow oanson nick-ma In meeting
09:02:09 <oanson> #topic Redis Driver
09:02:14 <oanson> #link https://review.openstack.org/#/c/274340/
09:02:32 <gampel> I tried to install it via devstack and it failed on fedora
09:03:03 <oanson> I managed to run it, but it seems unstable. Not all the tests pass.
09:03:11 <gampel> I mean the devstack patch not this one
09:03:26 <oanson> #link https://review.openstack.org/#/c/297916/
09:03:38 <gampel> is feipeng here ?
09:04:23 <oanson> Anyone can comment on this patch?
09:04:48 <oanson> In that case, I will communicate with feipeng when he becomes available.
09:04:52 <gampel> is duankebo here ?
09:04:52 <oanson> Let's move on.
09:05:05 <gampel> Ok
09:05:17 <oanson> #topic Security groups and port security
09:05:28 <oanson> #link https://review.openstack.org/#/c/280538/
09:06:00 <gampel> dingbo is here   ?
09:06:52 <oanson> Guess not.
09:07:02 <gampel> I know gal tested this patch
09:07:10 <gampel> nut i am not sure whats the status now?
09:07:27 <oanson> This patch still has many review comments on it. And it is missing a fullstack test
09:08:08 <gampel> Ok i will talk with dingbo we need to put priority on this one
09:08:21 <gampel> it is critical for the release and we do not have much time
09:08:33 <oanson> Ok
09:08:50 <nick-ma> Ok
09:08:54 <oanson> #action gampel dingboopt to push SG app forwards.
09:09:07 <oanson> #topic Distributed DNAT
09:09:19 <oanson> #link https://review.openstack.org/#/c/289148/
09:09:25 <oanson> #link https://review.openstack.org/#/c/294374/
09:09:33 <oanson> Is raofei here?
09:09:52 <oanson> yuli_s1, I understand you and gsagie tried to test this patch?
09:09:58 <gampel> I think that it is in a good state , I know that nick-ma and yuli tested it
09:10:13 <yuli_s1> dnat, yes
09:10:18 <gampel> yuli: whats the status of your tests
09:10:37 <yuli_s1> i have a problem now pinging the VM from the outside world
09:10:37 <gampel> I think that the only issue is the GW MAC update
09:10:40 <yuli_s1> using the fip
09:10:41 <nick-ma> Yes, generally working. but it seems not completed. Like gateway ip update.
09:10:45 <yuli_s1> I am checking this now
09:10:47 <nick-ma> Ok, Mac
09:11:00 <oanson> yuli_s1, do you know more or less what's the issue?
09:11:10 <yuli_s1> in addition, I found a problem here: https://bugs.launchpad.net/dragonflow/+bug/1548725
09:11:12 <openstack> Launchpad bug 1548725 in DragonFlow "It's not possible to assign a FIP for a VM on the default private network" [High,New] - Assigned to Eran Gampel (eran-gampel)
09:11:13 <gampel> I understand that raofei is adding a periodic arp to the GW
09:11:52 <yuli_s1> i see a packet comming to VM
09:11:55 <gampel> but for this phase we could merge it even with configuring the GW mac in mt opinion
09:12:04 <yuli_s1> i do not see a response,
09:12:22 <oanson> I don't feel comfortable with setting the MAC in configuration.
09:12:33 <gampel> Yuli i will look at this two problem today but please send an email to raofei about it
09:12:38 <oanson> There is supported for gratuitous arp, and support to responding to arp replies from the gateway
09:13:01 <oanson> the question is, if we don't filter by dest IP, will it be good enough, or do we still want to allow MAC configuration?
09:13:02 <yuli_s1> i think raofei already fixed the periodic update code
09:13:03 <gampel> So we need to check whats the status with raofei and see how long it will take
09:13:28 <yuli_s1> and I am working with his patches from yesterday
09:14:03 <oanson> It looks like the periodic arp has already been uploaded
09:14:10 <oanson> yuli_s1, could you please test with the new code?
09:14:18 <yuli_s1> i am using new code
09:14:28 <gampel> Ok so yuli could you communicate with raofei about your test
09:14:34 <yuli_s1> yes, sure
09:14:42 <gampel> you could add it to the patch
09:15:20 <oanson> yuli_s1, is there a way to make your test automatic?
09:16:05 <yuli_s1> yes,
09:16:13 <oanson> great!
09:16:49 <yuli_s1> with the "ovs-appctl ofproto/trace" command probably
09:17:09 <oanson> #action yuli_s1 raofei to verify distributed DNAT status
09:17:25 <oanson> yuli_s1, that means the trace output has to be parsed.
09:18:18 <oanson> Any more comments on this topic?
09:18:25 <yuli_s1> nop
09:18:31 <gampel> no
09:18:34 <oanson> #topic local controller reliability
09:18:49 <oanson> Is heshan here?
09:19:27 <gampel> it seem that all  group is not here
09:19:33 <oanson> Looks like it.
09:20:00 <gampel> oanson: we can discuss what you suggested on the notify
09:20:12 <nick-ma> :-) national holiday
09:20:22 <gampel> Ohh I see thx
09:20:24 <oanson> Ah. That explains it :)
09:20:37 <oanson> All right. the OVSDB notify is the next topic
09:20:42 <nick-ma> I am in the airport
09:20:43 <oanson> #topic OVSDB Monitor - Notifications
09:21:39 <yuli_s1> we have anasigned bug here:
09:21:41 <yuli_s1> https://bugs.launchpad.net/dragonflow/+bug/1563708
09:21:42 <openstack> Launchpad bug 1563708 in DragonFlow "OVSDB monitor reports events on tunnel ports" [Undecided,New]
09:21:47 <oanson> I was looking into the OVS IDL code to fix https://bugs.launchpad.net/dragonflow/+bug/1564766
09:21:48 <openstack> Launchpad bug 1564766 in DragonFlow "When add a vm, flow entries are not installed because ovs port online event is filtered by ovsdbmonitor," [Undecided,New] - Assigned to Omer Anson (omer-anson)
09:22:04 <oanson> Which I guess can be used to also fix https://bugs.launchpad.net/dragonflow/+bug/1563708
09:22:16 <yuli_s1> ok, great
09:22:31 <oanson> It looks like the OVS db connection (Idl in OVS) already has a mechanism for notifications from the OVS db
09:22:32 <yuli_s1> i will assign it to you
09:22:37 <oanson> yuli_s1, thanks
09:22:55 <yuli_s1> np ;)
09:23:08 <oanson> I was hoping maybe hujie can explain why he re-wrote that piece, but I don't think he's here
09:23:43 <gampel> oanson: i  agree we should reuse the ovs code
09:24:01 <oanson> gampel: I agree.
09:24:23 <oanson> I will talk to hujie to try and understand why this is the method he chose to do it
09:24:39 <gampel> will you write an email to hujie about it , as it is 200 line of code and we see some unsuitability there
09:24:47 <oanson> Once that is clear, I, or hujie, can re-write it
09:24:54 <gampel> great
09:25:06 <oanson> I have an ongoing discussion with him. That shouldn't be a problem. :)
09:25:46 <oanson> #topic Bugs
09:26:01 <yuli_s1> we have another anasigned bug:
09:26:02 <oanson> yuli_s1: Any other new bugs, except the new one I just got? :)
09:26:16 <yuli_s1> https://bugs.launchpad.net/dragonflow/+bug/1559841
09:26:17 <openstack> Launchpad bug 1559841 in DragonFlow "dhcp rpc is not handled at plugin side" [Medium,New]
09:26:39 <yuli_s1> and I wnat to take this bug: https://bugs.launchpad.net/dragonflow/+bug/1548725
09:26:39 <openstack> Launchpad bug 1548725 in DragonFlow "It's not possible to assign a FIP for a VM on the default private network" [High,New] - Assigned to Eran Gampel (eran-gampel)
09:26:49 <yuli_s1> and assign it to me, i have a solution for it
09:27:08 <oanson> yuli_s1, why is 1559841 set to medium?
09:27:17 <gampel> i will take the dhcp it seem
09:27:27 <gampel> non critical due
09:28:04 <nick-ma> The rpc to dhcp agent is unnecessary. It is not important, I think.
09:28:07 <yuli_s1> ok,
09:28:14 <gampel> i agree
09:28:18 <yuli_s1> may be we will move it to wishlist ?
09:28:18 <oanson> Then the issue is just the log?
09:28:24 <gampel> yes
09:28:32 <oanson> I think to 'low'
09:28:41 <oanson> It's still a bug, not a feature request
09:28:49 <gampel> sure
09:29:00 <yuli_s1> ok, I made it low
09:29:08 <oanson> Great. yuli_s1 are there any more?
09:29:25 <yuli_s1> https://bugs.launchpad.net/dragonflow/+bug/1536868
09:29:26 <openstack> Launchpad bug 1536868 in DragonFlow "Dragonflow should prevent IP spoof" [Low,New]
09:29:37 <yuli_s1> we have a spec on this subject
09:30:01 <oanson> Will we have time to add it before the feature freeze?
09:30:56 <gampel> I am not sure
09:31:11 <gampel> this is for sure wish list
09:31:32 <oanson> Sounds good.
09:31:45 <nick-ma> I don't suggest to add new features. It is in the wish list.
09:31:50 <yuli_s1> ok
09:31:56 <oanson> yuli_s1, next please.
09:32:03 <gampel> whats the status of the OVS service
09:32:16 <yuli_s1> probably ok with bugs
09:32:19 <gampel> oanson:i see you have comments form gal
09:32:23 <oanson> It's waiting for review here: https://review.openstack.org/296897
09:33:05 <yuli_s1> and hear: https://bugs.launchpad.net/dragonflow/+bug/1563901
09:33:06 <openstack> Launchpad bug 1563901 in DragonFlow "fullstack: testL3App failed" [High,New]
09:33:15 <oanson> I will address his comments.
09:33:33 <gampel> nick-ma : will you be able to review  it as well
09:33:49 <nick-ma> Of course.
09:33:52 <gampel> the OVS  service patch
09:34:19 <gampel> And we have some other patches that i think that we could merge once we get another +2
09:35:00 <oanson> Once these are merged, the system should be a bit more stable
09:35:15 <oanson> Then we can re-review 1536868 and see if it is still happening
09:35:27 <gampel> #link: https://review.openstack.org/#/c/297167/ is in a good  state in my opinion
09:35:48 <oanson> Since the patch https://review.openstack.org/#/c/298121/ to bug 1560927 should have resolved it (And it didn't)
09:35:49 <openstack> bug 1560927 in DragonFlow "add router interface: TypeError in l3_proactive_app" [Medium,In progress] https://launchpad.net/bugs/1560927 - Assigned to Omer Anson (omer-anson)
09:36:59 <oanson> yuli_s1, any more?
09:37:04 <yuli_s1> nop
09:37:11 <oanson> All right.
09:37:19 <oanson> #topic Testing
09:37:46 <oanson> I remind that we plan a feature freeze for 7th of April. That's this Thursday.
09:37:56 <gampel> Shlomo do you want  to share your control path testing
09:38:05 <gampel> data plane sorry
09:38:07 <Shlomo_N> Sure
09:38:27 <Shlomo_N> There is not much new from the email I have send yesterday
09:38:39 <Shlomo_N> So you can
09:38:46 <Shlomo_N> stop me anytime :-)
09:38:58 <Shlomo_N> I able to produce 10Gb/s (line rate) between the compute-nodes.
09:39:17 <Shlomo_N> Also managed to produce 7.5 Gb/s SNAT scenario from 3 VMs that resides on same CN.
09:39:41 <Shlomo_N> But I found two issues that I am still investigating: ...
09:40:05 <Shlomo_N> 1) I can’t produce near line rate bandwidth from VMs that resides on same CN.
09:40:32 <Shlomo_N> 2) On the destination CN, there is a process ksoftirqd that gots to 100% cpu on core #5 only.
09:41:12 <oanson> Shlomo_N, about 2), what tunnel type did you use?
09:41:18 <Shlomo_N> VxLan
09:41:44 <oanson> Does it reproduce with geneve or gre?
09:41:46 <nick-ma> 2) need to enable multi queue for nic to take advantage of multi core.
09:42:21 <Shlomo_N> oanson: I didn't so far.
09:42:34 <oanson> I think nick-ma is closer to the mark :)
09:42:36 <Shlomo_N> nick-ma: sound like a good idea
09:42:38 <oanson> I'd try that first
09:43:21 <oanson> All right, anything else in this topic?
09:43:49 <Shlomo_N> nick-ma: can you send me any link that exaplains how I can do it?
09:44:35 <Shlomo_N> I am using fedora
09:44:41 <nick-ma> I will find it for you tomorrow.
09:44:49 <Shlomo_N> great, thanks!
09:44:52 <gampel> oanson: whats the status on the DB scale automatic testing scripts ?
09:45:08 <oanson> I only started looking into it.
09:45:18 <gampel> :) ok
09:45:23 <oanson> It shouldn't be too difficult to apply it to our system.
09:45:33 <oanson> I hope I'll have something more interesting to say next week. :)
09:45:39 <gampel> great
09:46:04 <oanson> Anything else on this topic?
09:46:21 <oanson> #topic Open Discussion
09:46:25 <gampel> so we have any patches with high review priority ?
09:46:49 <oanson> The patches linked in this meeting are all high review priority
09:46:59 <oanson> These are all features we want merged before Thursday.
09:47:23 <oanson> Additionally, reviews related to bugs marked as High are also important
09:47:33 <gampel> will do
09:47:44 <nick-ma> will do
09:47:49 <gampel> whats the problem with the ping pong test is it fixed
09:48:11 <oanson> It still appears to be unstable.
09:48:27 <oanson> I will look at it during the week. I think some of the other bugs are making it unstable.
09:48:34 <gampel> Ok
09:48:58 <oanson> I remind that we want to reach Feature Freeze on the 7th April.
09:49:01 <oanson> That's this Thursday.
09:49:08 <oanson> We want to reach code freeze on the 18th.
09:49:22 <gampel> nick-ma: is tomorrow working day in china ?
09:49:24 <oanson> That's Monday, exactly two weeks from now
09:49:30 <nick-ma> Yes
09:49:35 <scsnow> hi, how to get involved into df dev? i've read almost all blog posts about df in Gal's and Eran's blog. can someone point on easy bug/blueprint, that i could start to look into, to get familiar with df code?
09:50:05 <gampel> yes sure lets tack it offline after the meeting
09:50:13 <scsnow> thanks
09:50:31 <gampel> omer yuli is there an easy bug you have on the list
09:51:33 <oanson> I can look through the list and find something interesting.
09:52:19 <gampel> ok i will do i as well lets help @scsnow to kick start
09:52:49 <oanson> scsnow, looking through some of the shorter reviews is also a great way to get familiar with the code.
09:53:19 <gampel> I agree we need allot of help with the patch review
09:54:06 <oanson> Anyone wants to discuss anything else?
09:54:28 <gampel> Nop thank you everyone
09:54:32 <oanson> All right.
09:54:34 <Shlomo_N> thanks
09:54:36 <oanson> Thanks everyone.
09:54:39 <oanson> #endmeeting