#openstack-meeting-4: dragonflow

Meeting started by gsagie at 09:00:20 UTC (full logs).

Meeting summary

    1. gampel, Shlomo_N, yuli_s, oanson, gsagie in meeting (gsagie, 09:00:53)

  1. security groups (gsagie, 09:01:36)
    1. dingboopt in meeting as well :) (gsagie, 09:01:59)
    2. ACTION: dingboopt update design for security groups with improvments and conjunction (gsagie, 09:04:39)
    3. DuanKebo in meeting as well :) (gsagie, 09:05:31)
    4. ACTION: dingboopt, raofei, yuanwei to start splitting work on security groups after spec is merged (gsagie, 09:08:05)
    5. kexiaodong in meeting (gsagie, 09:09:07)

  2. port security (gsagie, 09:11:10)
    1. ACTION: gsagie update port security spec with latest comments (gsagie, 09:12:02)
    2. ACTION: dingboopt implement port security spec once merged (gsagie, 09:12:46)

  3. DB consistency (gsagie, 09:12:59)
    1. ACTION: gsagie write email with the detailed transaction id solution for DB consistency (gsagie, 09:21:56)
    2. ACTION: Hujie upload spec for DB consistency (gsagie, 09:22:06)
    3. ACTION: gsagie add dinboopt/nick-ma to the conversation of course (gsagie, 09:23:12)

  4. publish-subscribe abstraction (gsagie, 09:24:11)
    1. https://review.openstack.org/#/c/263322/ (gampel, 09:25:03)
    2. working pub-sub with zeromq https://review.openstack.org/#/c/263322/ (gsagie, 09:25:21)
    3. ACTION: gampel verify if zeromq filters topics on server side or client side (gsagie, 09:26:51)
    4. https://review.openstack.org/#/c/263733/ pub-sub spec (gsagie, 09:27:42)
    5. ACTION: gampel update pub-sub spec and add reliability ideas (gsagie, 09:27:56)

  5. Redis DB driver (gsagie, 09:29:13)
    1. ACTION: feipeng upload spec and start work on redis driver integration with dragonflow (gsagie, 09:31:04)

  6. testing (gsagie, 09:32:05)
    1. ACTION: dingboopt update for next meeting regarding lab in Hangzhou (gsagie, 09:33:56)
    2. ACTION: Shlomo_N write spec about performance test scenarios and plan (gsagie, 09:37:24)
    3. https://review.openstack.org/265642/ (yuli_s, 09:41:39)
    4. ACTION: Zhu weiqiong send documents regarding control plane testing plan and scenarios for DB and for pub/sub (gsagie, 09:42:55)
    5. ACTION: gampel, yuli_s work on improving the current OVS flows tests (gsagie, 09:46:05)

  7. selective proactive (gsagie, 09:46:14)
    1. ACTION: DuanKebo write spec about selective proactive (gsagie, 09:47:40)

  8. distributed DNAT (gsagie, 09:51:45)
    1. ACTION: raofei working on distributed dnat implementation (gsagie, 09:55:55)

  9. controller reliability (gsagie, 09:56:34)
    1. ACTION: heshan upload spec regarding controller reliability (gsagie, 09:57:04)

  10. open discussion / bugs (gsagie, 09:57:34)
    1. ACTION: everyone to review Dragonflow patches (gsagie, 09:57:54)
    2. ACTION: yuli_s working on cloud-init support for dragonflow (gsagie, 10:01:09)


Meeting ended at 10:01:57 UTC (full logs).

Action items

  1. dingboopt update design for security groups with improvments and conjunction
  2. dingboopt, raofei, yuanwei to start splitting work on security groups after spec is merged
  3. gsagie update port security spec with latest comments
  4. dingboopt implement port security spec once merged
  5. gsagie write email with the detailed transaction id solution for DB consistency
  6. Hujie upload spec for DB consistency
  7. gsagie add dinboopt/nick-ma to the conversation of course
  8. gampel verify if zeromq filters topics on server side or client side
  9. gampel update pub-sub spec and add reliability ideas
  10. feipeng upload spec and start work on redis driver integration with dragonflow
  11. dingboopt update for next meeting regarding lab in Hangzhou
  12. Shlomo_N write spec about performance test scenarios and plan
  13. Zhu weiqiong send documents regarding control plane testing plan and scenarios for DB and for pub/sub
  14. gampel, yuli_s work on improving the current OVS flows tests
  15. DuanKebo write spec about selective proactive
  16. raofei working on distributed dnat implementation
  17. heshan upload spec regarding controller reliability
  18. everyone to review Dragonflow patches
  19. yuli_s working on cloud-init support for dragonflow


Action items, by person

  1. dingboopt
    1. dingboopt update design for security groups with improvments and conjunction
    2. dingboopt, raofei, yuanwei to start splitting work on security groups after spec is merged
    3. dingboopt implement port security spec once merged
    4. dingboopt update for next meeting regarding lab in Hangzhou
  2. DuanKebo
    1. DuanKebo write spec about selective proactive
  3. gampel
    1. gampel verify if zeromq filters topics on server side or client side
    2. gampel update pub-sub spec and add reliability ideas
    3. gampel, yuli_s work on improving the current OVS flows tests
  4. gsagie
    1. gsagie update port security spec with latest comments
    2. gsagie write email with the detailed transaction id solution for DB consistency
    3. gsagie add dinboopt/nick-ma to the conversation of course
  5. raofei
    1. dingboopt, raofei, yuanwei to start splitting work on security groups after spec is merged
    2. raofei working on distributed dnat implementation
  6. Shlomo_N
    1. Shlomo_N write spec about performance test scenarios and plan
  7. yuli_s
    1. gampel, yuli_s work on improving the current OVS flows tests
    2. yuli_s working on cloud-init support for dragonflow
  8. UNASSIGNED
    1. Hujie upload spec for DB consistency
    2. feipeng upload spec and start work on redis driver integration with dragonflow
    3. Zhu weiqiong send documents regarding control plane testing plan and scenarios for DB and for pub/sub
    4. heshan upload spec regarding controller reliability
    5. everyone to review Dragonflow patches


People present (lines said)

  1. gsagie (151)
  2. gampel (37)
  3. DuanKebo (34)
  4. dingboopt (25)
  5. yuli_s (21)
  6. raofei (5)
  7. Shlomo_N (3)
  8. openstack (3)
  9. oanson (1)


Generated by MeetBot 0.1.4.