22:17:36 <JRobinson__> #startmeeting docuserguides
22:17:36 <openstack> Meeting started Wed Feb 17 22:17:36 2016 UTC and is due to finish in 60 minutes.  The chair is JRobinson__. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:17:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:17:40 <openstack> The meeting name has been set to 'docuserguides'
22:17:49 <JRobinson__> Morning all o/
22:18:04 <JRobinson__> This is a shorter meeting,
22:18:57 <gmolson> Hello!
22:19:06 <JRobinson__> gmolson, o/ hello there
22:19:20 <JRobinson__> sorry I was running late today as well.
22:19:38 <JRobinson__> #topic action items from last meeting
22:20:04 <JRobinson__> There were a few points, and so far I've had a look at the dashboard point -
22:20:20 <JRobinson__> Moving the Admin guide dashboard items to the Cloud admin dashboard chapter.
22:20:47 <gmolson> No worries. I understand.
22:20:50 <JRobinson__> Unfortunately that's all - I still need to speak to the Oslo team on config reference consistency efforts going on.
22:22:04 <gmolson> Ok - I looked a bit more at the original spec for the mitaka reorg. https://review.openstack.org/#/c/238770/
22:22:46 <gmolson> so just checking - is the End User Guide remaining intact?
22:23:22 <JRobinson__> gmolson, that's right. The End User Guide is not going to change ye
22:23:27 <JRobinson__> yet^
22:23:32 <gmolson> ok
22:23:44 <JRobinson__> There may be changes this year, depending on the next release goals.
22:24:24 <JRobinson__> #topic Dashboard Chapters
22:24:41 <gmolson> so from your perspective, there will be dashboard content and openstack command-line content in both the Admin Guide (currently cloud admin guide) and the End User Guide?
22:24:44 <gmolson> for mitaka
22:25:29 <JRobinson__> gmolson, Yes that sounds like a good summary of what I was thinking of for the Mitaka release
22:26:50 <gmolson> ok - I received a query from a colleague on a dashboard related item. She was wondering about the reorg and stating that a lot of the dashboard access is being controlled by policy files and not necessarily the hard coded admin role...
22:27:14 <gmolson> but it sounds like for now, we're going to do our best to split it out by admin / end user
22:27:53 <JRobinson__> gmolson, that is interesting, I had not heard that point -
22:28:01 <JRobinson__> #info A lot of the dashboard access is being controlled by policy files
22:28:38 <gmolson> I can follow up with her more to understand whether this is new for mitaka or bau
22:28:40 <JRobinson__> thanks for bringing that up, something to look into with the mailing list for more insights into the admin role moving forward.
22:29:40 <gmolson> so related to the dashboard conent existing in both the admin guide and end user guide... I did a quick check to see if there is reuse of the content...
22:30:03 <JRobinson__> gmolson, if you have time to confirm that would be great.
22:30:16 <gmolson> I didn't get to check extensively, but it looks like there is just one section of common information that is mainly the login content. Does that sound correct?
22:30:41 <JRobinson__> There is some reuse iirc re: comparing the admin and end user guide,
22:30:47 <JRobinson__> but yes that sounds right
22:31:54 <gmolson> ok
22:32:46 <JRobinson__> Any further dashboard topics?
22:33:21 <gmolson> only related to the task list...
22:34:22 <gmolson> If we are going to update the task list with a list of files to move, etc... do you just want that directly under the Up to Date tasks heading?
22:34:23 <JRobinson__> That's fine, I added the dashboard task discussed at the last meeting - I thought splitting the merge into two halves to reduce patch size would be a good first step
22:35:13 <gmolson> ah - I think I missed that you added that. I saw that you updated it, but wasn't able to figure out what changed. Ha.
22:35:31 <gmolson> oh, I see it now - thanks!
22:36:07 <JRobinson__> gmolson, np, file names should ideally go under the chapter heading - the list follows the chapter title structure of the cloud admin guide.
22:36:35 <gmolson> gotcha. I agree that the section info makes sense and is adequate for my purposes.
22:37:47 <JRobinson__> I also considered a table, after the 'Up to Date tasks' section. This might be easier to track, and keep the task list relatively more easy-to-read
22:38:30 <gmolson> JRobinson__ - ok, sure. I think as long as we can tell what section you decide to work on in part 1, that's fine with me.
22:39:29 <JRobinson__> The columns would be |Cloud Admin Chapter|Admin Guide File| . This would show a bit more clearly what files have been copied to the cloud admin guide, and where they are now.
22:40:28 <gmolson> and just indicate that when the file is in the table, it's transferred, or something along those lines
22:40:47 <JRobinson__> ^yes, that's right.
22:40:51 <gmolson> ok
22:41:20 <JRobinson__> gmolson, I'll put that together. Thanks for listening to my ramblings on this point! :)
22:41:32 <gmolson> of course ;)
22:41:48 <JRobinson__> #action add a table for Admin Guide file tracking.
22:42:31 <JRobinson__> The only other action item I had was moving the Command Line chapters to the Cloud Admin Guide.
22:43:52 <gmolson> ok
22:44:35 <JRobinson__> #topic Command Line Chapters
22:44:36 <gmolson> I noticed in your agenda, "match with the OpenStack service, and add to the start of the chapter?"
22:46:16 <JRobinson__> gmolson, My thoughts were to add a command line section to the start of each chapter so Admins looking for a reminder on what the common admin-related commands are will be easy to locate
22:47:19 <gmolson> I can see your rationale of splitting it out by service. I wonder if like the Dashboard content it would be helpful to keep it all together...
22:47:23 <JRobinson__> iirc, the cli chapters in the admin user guide describe commonly used admin commands, with some background on when admin users can run the commands.
22:48:11 <JRobinson__> gmolson, A good alternative - I did not suggest that as unlike the dashboard chapter, there is not a Command Line Chapter
22:48:27 <JRobinson__> Creating one did not occur to me though. That is a good point.
22:48:29 <gmolson> in the end user guide, the CLI info will still be colocated. Not sure if it's helpful for the two guides (Admin and End User) to be somewhat parallel?
22:48:55 <gmolson> right - We'd have to add it, and it's not parallel with the other services...
22:50:18 <gmolson> we would have to have a common section somewhere in the Cloud Admin Guide anway, for content like this chapter, Install the OpenStack command-line clients
22:51:48 <JRobinson__> Making the new Admin Guide parallel with the End User Guide is a good move, I think
22:53:34 <gmolson> At this point, my thought would be to add OpenStack command-line clients section after Orchestration in the Cloud Admin Guide
22:54:53 <JRobinson__> Ok, and looking through the guides again, my action item about matching with the OpenStack Service was not clear
22:55:36 <JRobinson__> #info Potentially add an OpenStack command-line clients section after the orchestration chapter of the Cloud Admin Guide
22:55:49 <JRobinson__> gmolson, Adding the idea to the minutes.
22:56:08 <gmolson> ok
22:56:14 <JRobinson__> I think handling the dashboard content first
22:56:30 <JRobinson__> and then return to the CLI content after that task is complete for now
22:56:38 <gmolson> works for me
22:56:58 <JRobinson__> Ok,
22:57:08 <JRobinson__> #topic Open Discussion
22:57:19 <JRobinson__> If that's all then I might close the meeting
22:57:42 <gmolson> thanks, Joseph. Helpful discussion. Thanks again for meeting early in your day!
22:58:14 <JRobinson__> gmolson, np, the meeting time is now in the OpenStack infra team calendar, so no danger of clashes
22:58:30 <gmolson> thumbs up. thanks!
22:59:04 <JRobinson__> So there should also be a meeting next week, but then after that the fortnightly schedule will return, unless we need more meetings leading up to the summit.
22:59:41 <gmolson> ok
22:59:51 <JRobinson__> #endmeeting