14:01:52 <annegentle> #startmeeting DocTeamMeeting
14:01:53 <openstack> Meeting started Tue Nov 26 14:01:52 2013 UTC and is due to finish in 60 minutes.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:57 <openstack> The meeting name has been set to 'docteammeeting'
14:02:00 <EmilienM> o/
14:02:07 <annegentle> hey EmilienM
14:02:27 <chandankumar> hello all!
14:02:28 <annegentle> our agenda is here:
14:02:30 <annegentle> #link https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting#Agenda_for_next_meeting
14:02:40 <annegentle> Hm, need to think about which action items to review
14:03:05 <annegentle> I'll review the ones from last week
14:03:08 <annegentle> Loquacity to begin working on a proposal for config-reference and cloud admin guide IA
14:03:15 <annegentle> Not sure how she's doing there, but she has started it
14:03:21 <annegentle> and
14:03:22 <annegentle> fifieldt to organise a doc bug day
14:03:28 <annegentle> The selected doc bug day is Dec 20
14:03:31 <annegentle> follow the sun
14:03:59 <annegentle> #info Doc Bug Day scheduled for Dec 20 2013
14:04:19 <summerlong> annegentle, just do as much as you can in that one day?
14:04:22 <annegentle> #topic Announcement Google Hangout
14:04:26 <annegentle> hee hee summerlong
14:04:42 <annegentle> I'd been meaning to get this scheduled, and it'll be next week
14:04:48 <annegentle> #info Google Hangout Monday, December 2, 2013 at 03:00:00 (that's 7:00 PM PST, 9:00 PM CST, 10:00 PM EST)
14:05:01 <annegentle> Pretty excited to do some higher fidelity talking :)
14:05:27 <annegentle> summerlong: oh sorry reread your question, yes, do as much as you can in one day, triage, fix
14:05:37 <chandankumar> annegentle, for me it is about 08:30 a:m in the morning. :)
14:05:41 <summerlong> :), ta
14:06:21 <annegentle> hey shaunm
14:06:26 <shaunm> morning annegentle
14:06:42 <annegentle> doc bug day is more for already contributing people
14:06:52 <annegentle> not for new contributors per se
14:07:18 <annegentle> since onboarding takes a while and we want efficiency
14:07:27 <annegentle> oh I'll skip to onboarding in the agenda
14:07:32 <annegentle> any other Qs on doc bug day?
14:08:01 <annegentle> #info doc bug day for bugs in openstack-manuals and openstack-api-site
14:08:18 <annegentle> #info idea for doc bug day is to get numbers down, not necessarily onboard new contributors
14:08:25 <annegentle> #topic Onboarding doc contributors
14:08:29 <annegentle> Speaking of which
14:08:47 <annegentle> I've asked Nick Chase to help out with onboarding, so I've been emailing him on CC when I get new people who want to help with docs
14:08:53 <annegentle> Two in the past two weeks I want to say?
14:09:00 <annegentle> So that's AWESOME and thank you Nick!
14:09:08 <annegentle> #info Nick Chase to help with onboarding doc contributors
14:09:31 <annegentle> So copy Nick if you get anyone reaching out with questions, you can always help also, but I thought it would be nice to have one point of contact
14:09:39 <annegentle> Which also leads into another topic
14:09:45 <annegentle> #topic Educating devs on what goes where
14:10:01 <annegentle> So I've had a few conversations lately and the TC is working on better definitions for incubation and integration graduation
14:10:17 <annegentle> And there are teams going for incubation who would bring a writer with them, which is nice
14:10:28 <annegentle> so I'm working on definitions for doc requirements for each stage
14:10:39 <annegentle> for incubation, I think dev docs are the only requirement
14:10:48 <summerlong> annegentle, great idea!
14:10:49 <annegentle> for graduation, projects would have to show they are supporting users with their docs
14:11:09 <chandankumar> annegentle, +1
14:11:11 <annegentle> Also, I don't think devs are as familiar with our titles as I'd like, so I want to do some sort of education campaign around "what goes where"
14:11:18 <annegentle> Any thoughts on this?
14:11:34 <annegentle> To me, the main titles where we'd want integrated projects to "plug in" are install, config, admin, ops
14:11:39 <annegentle> Security and HA seem secondary
14:11:49 <annegentle> Input? Ideas on how to educate?
14:11:54 <summerlong> in the dev session, we were wanting to do a HowTo page for devs?
14:12:11 <annegentle> summerlong: yes, that's right, Diane is working on a page about the API docs specifically
14:12:27 <annegentle> summerlong: I think we can expand that (or slice it into a second page, here's the titles for deployers/operators)
14:12:33 <annegentle> summerlong: but that's the idea
14:12:39 <summerlong> cool
14:12:50 <annegentle> summerlong: I wonder if a podcast/ screencast would help? What do you think?
14:13:14 <annegentle> Stephen Spector at HP cloud asked for that and I think it's a great idea
14:13:35 <summerlong> annegentle, for devs? Basic steps, places would work, I'd think.
14:13:47 <annegentle> I think we have to have the wiki page at a minimum, looking for more ideas too.
14:14:01 <annegentle> summerlong: yeah, for devs who want to write and for people looking for info, might work for both.
14:14:16 <annegentle> I could tweet a title a day for a week :) LOL
14:14:19 <annegentle> Oh twitter.
14:14:31 <annegentle> blog post maybe?
14:14:37 <summerlong> annegentle, I meant that the dev personality is not as much a video walkthrough.
14:14:46 <annegentle> I didn't get a ton of input on the blog post about docimpact but people are reading it
14:14:51 <annegentle> summerlong: yeah that's a good point
14:15:01 <annegentle> summerlong: match to the personality
14:15:07 <summerlong> annegentle, a blog sounds good
14:15:23 <annegentle> summerlong: maybe a few edits in READMEs scattered throughout the repos would help?
14:15:44 <summerlong> annegentle, shotgun effect
14:16:03 <chandankumar> summerlong, ;)
14:16:14 <annegentle> #action Anne to write a blog post describing all the titles and their priorities (we'd want integrated projects to "plug in" are install, config, admin, ops; security and HA are secondary)
14:16:14 <EmilienM> annegentle: Security & HA are secondary but we also need more contributions on it
14:16:21 <annegentle> EmilienM: very true
14:16:47 <annegentle> #action Anne to follow up with HP Cloud's Spector for a podcast/screencast
14:17:16 <annegentle> Anyone want to draft a parallel page to Diane's page?
14:17:33 <annegentle> wiki page that is
14:17:54 <annegentle> it's ok if no one can :)
14:17:58 <summerlong> annegentle, any work items for me will have to wait for a bit until our release in Dec.
14:18:04 <annegentle> summerlong: got it, yeah
14:18:08 <annegentle> hey sgordon
14:18:10 * sgordon slinks in
14:18:18 <annegentle> #topic Cancel regular office hours now that we meet weekly
14:18:18 <sgordon> sorry was on another call till 9 and totally forgot
14:18:23 <annegentle> sgordon: no worries
14:18:39 <annegentle> So, I had something else scheduled the last two weeks during office hours, and it seemed okay
14:18:50 <annegentle> now that we're meeting weekly is it okay to cancel "office hours" for docs?
14:18:54 <summerlong> +1
14:19:01 <annegentle> I think it was a good experiment, but not really necessary any more
14:21:01 <annegentle> ok, I'll call it agreed :)
14:21:12 <annegentle> #agreed Cancel regular office hours now that we meet weekly
14:21:12 <chandankumar> yes
14:21:24 <annegentle> #topic Doc Boot Camp?
14:21:52 <annegentle> I left it as a question mark to see what the interest is, do we want another boot camp this release? Do we still call it a boot camp if it's more of what nova and other projects are calling a mid-release meetup?
14:22:10 <annegentle> Would the goals change if we don't call it boot camp?
14:22:30 <summerlong> annegentle, what timeframe are you thinking then?
14:22:32 <annegentle> Really just put it on the agenda to get people thinking about it. At the last one our energy was high and we really wanted to get together again.
14:22:45 <annegentle> summerlong: to be similar to last time, it'd be Feb.
14:22:53 <annegentle> summerlong: like end of Feb?
14:23:41 <annegentle> I'll just throw it out there, for discussion, and discuss next week too.
14:23:49 <summerlong> Feels very soon after the summit
14:23:52 <annegentle> I'm still just kind of pondering it, you can probably tell :)
14:24:17 <annegentle> summerlong: and I want to figure out what we'd do, for how many days, etc
14:24:37 <annegentle> goals for it
14:24:52 <summerlong> The two-day span felt right
14:24:55 <annegentle> we really had great outcomes from last time, the number of contributors has grown
14:24:55 <sgordon> yeah - i personally wonder if remote activities might not be a better use of time/resources mid cycle for us - like the bug day for example
14:25:25 <annegentle> sgordon: yeah that's good input, travel and all is such a time loss in some ways. Esp. if we can all get together at the summit in April
14:25:33 <sgordon> yah
14:25:42 <annegentle> let's talk about it and keep it in the agenda for discussion
14:25:43 <annegentle> cool
14:25:45 <annegentle> ok
14:25:50 <annegentle> #topic Operations Guide workflow
14:26:32 <annegentle> So mordred (Monty), jeblair (Jim) and I met with our O'Reilly project manager and editor and technical rep about how to maintain master while enabling a developmental edit and copy edit and indexing on the Operations Guide
14:26:46 <mordred> I didn't do it
14:26:48 <annegentle> that meeting was yesterday and I just wanted to report back some progress
14:27:00 <annegentle> mordred: you didn't sign me up for merging, I did :)
14:27:05 <mordred> :)
14:27:36 <annegentle> so what we'll do is as late as possible, like next Jan, create a branch for O'reilly to do copy edits and such in, and I'll backport to master branch
14:27:45 <annegentle> mordred: keep me honest in case I'm not 'splainin' it right
14:28:01 <annegentle> so we can keep editing master branch of openstack/operations-guide as much as possible
14:28:07 <annegentle> and also get the benefits of the custom edit
14:28:08 <sgordon> annegentle, what is the plan for that guide target wise?
14:28:13 <sgordon> i.e. havana/icehouse ?
14:28:15 <annegentle> sgordon: havana
14:28:17 <sgordon> right
14:28:43 <annegentle> Also, in Jan/Feb, we're gonna do a mini 2-day sprint with the original authors
14:28:58 <annegentle> I'm still working out details there
14:29:30 <summerlong> annegentle, RH is still trying to find an Ops person to help. I need to bug them again.
14:29:32 <annegentle> I'm happy we can keep working in master and not freez
14:29:34 <annegentle> freeze
14:29:42 <annegentle> summerlong: great
14:29:52 <annegentle> I keep asking around at Rackspace too
14:30:00 <annegentle> really they can update master any time
14:30:10 <summerlong> true
14:30:16 <annegentle> I don't know if the sprint will be all that useful to people new to it, ya know? Not sure.
14:30:28 <annegentle> 2 days, havana updates
14:30:49 <annegentle> also, a lot of our planning depends on another meting with O'Reilly so I understand their developmental edit
14:30:58 <annegentle> possibly a big rewrite is around the corner and I just don't know it yet
14:31:04 <annegentle> not to make people nervous but who knows
14:31:18 <annegentle> so the next meeting is next Thurs. or Fri. and I'll report what I know then
14:31:27 <annegentle> Ok, last but not least,
14:31:31 <annegentle> #topic Doc tools updates
14:32:24 <annegentle> #info The Clouddocs-maven-plugin is now in Stackforge
14:32:26 <annegentle> #link http://git.openstack.org/cgit/stackforge/clouddocs-maven-plugin/
14:32:30 <sgordon> summerlong, cant convince graeme to be volunteered?
14:32:36 <sgordon> ;)
14:32:52 <summerlong> :)
14:32:56 <annegentle> This enables all openstack contributors to work on the maven plugin that builds our HTML and PDF and api-ref output
14:33:13 <annegentle> spread the word to all your friends :)
14:33:37 <chandankumar> annegentle, sure
14:34:02 <annegentle> chandankumar: it should make it easier for you to research the Disqus replacement (and find others to help!)
14:34:13 <annegentle> (well, easier is relative, that's a BIG project)
14:34:29 <chandankumar> annegentle, yes
14:34:37 <annegentle> I'll have to ask reed or fifieldt if they know anything about the ask.openstack.org integration, I don't have any further updates on that.
14:35:18 <annegentle> We've updated nearly all of the repos to use 1.12.0
14:35:21 <chandankumar> annegentle, yes
14:35:32 <annegentle> that takes care of a pair of XSS vulnerabilities reported
14:35:36 <annegentle> that's all I've got!
14:35:41 <annegentle> #topic Open discussion
14:36:07 <annegentle> So yesterday we announced our selections for the GNOME Outreach Program for Women, and I'm pleased to say we got 4 interns starting Dec. 10th!
14:36:20 <chandankumar> annegentle, how to test maven cloud plugin locally in my machine?
14:36:20 <summerlong> wow!
14:36:32 <chandankumar> Wow!
14:36:47 <annegentle> #link https://wiki.gnome.org/OutreachProgramForWomen/2013/DecemberMarch#Accepted_Participants
14:37:03 <annegentle> Miranda Zhang will work with Diane as her mentor on the API documentation.
14:37:30 <annegentle> HP really stepped up and helped out here, for the whole OPW program. (thanks mordred for that lead!)
14:37:38 <summerlong> Another pair of eyes just for the API docs, far out.
14:37:56 <annegentle> so, keep an eye out for Miranda and welcome her, help her with reviews, patches, and so on
14:38:27 <annegentle> summerlong: oh the API docs are sooooo underserved :)
14:38:56 <summerlong> Indeed, Diane slaving away out in the wilderness
14:39:05 <annegentle> summerlong: hee
14:39:46 <annegentle> I did talk through a few incubation ideas with Doug Hellman on IRC yesterday. One idea, and I like it, is to create a sample "wrapper" book that people can use to write easily-pluggable content for later integration
14:40:09 <annegentle> so, set up a set of sample generic books for install, for config, that would fit in easily later
14:40:25 <annegentle> I think that if a project applies now for incubation, the soonest they'd get in to integration is the J release
14:40:51 <annegentle> and as a doc team, we're not really fully resourced for all integrated projects, so I want to find ways for them to bootstrap
14:41:06 <annegentle> maybe write up how to create pluggable content and also how to use pandoc to convert content
14:41:27 <annegentle> anyway
14:41:43 <annegentle> we can quit early if there's no other open discussion items
14:42:18 <annegentle> Hope you all have a happy Thanksgiving if you gobble turkey in your corner of the world!
14:42:29 <summerlong> Happy Thanksgiving!
14:42:49 <annegentle> Thanks all!
14:42:52 <annegentle> #endmeeting