16:01:40 <pkovar> #startmeeting docteam
16:01:40 <openstack> Meeting started Wed Dec 13 16:01:40 2017 UTC and is due to finish in 60 minutes.  The chair is pkovar. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:43 <openstack> The meeting name has been set to 'docteam'
16:02:04 <pkovar> #topic roll call
16:02:11 <pkovar> who's around this time? :)
16:02:16 <jamesmcarthur> o/
16:02:24 <pkovar> \o
16:02:27 <chason> o/
16:02:35 <pkovar> \o
16:03:50 <AJaeger> o/
16:04:39 <jamesmcarthur> cha cha cha
16:06:02 <pkovar> o\
16:06:11 <pkovar> that was moving on
16:06:21 <pkovar> #topic Docs retention policy changes
16:06:27 <pkovar> #link http://specs.openstack.org/openstack/docs-specs/specs/queens/retention-policy.html
16:06:47 <pkovar> we links to relevant reviews in
16:06:49 <pkovar> #link https://blueprints.launchpad.net/openstack-manuals/+spec/retention-policy
16:06:56 <pkovar> #info Good progress, waiting on changes to be merged
16:07:26 <pkovar> zuul was acting up yesterday, not sure if we need to recheck?
16:07:34 <pkovar> AJaeger: do you know? ^
16:08:34 <pkovar> we have two outstanding reviews to finish implementing the spec
16:09:12 <AJaeger> pkovar: yes, recheck is needed if you have no results or strange ones
16:09:13 <pkovar> (unless something breaks again, heh)
16:09:25 <pkovar> okay, will do
16:09:58 <pkovar> we might need to push a trivial change too to eol branches to trigger republishing
16:10:17 <pkovar> i think that's what was needed last time when we resurrected mitaka
16:10:57 <pkovar> anything else about this topic?
16:11:13 <pkovar> actually
16:11:15 <pkovar> #info Flagging deprecated releases
16:11:21 <pkovar> #link http://lists.openstack.org/pipermail/openstack-dev/2017-October/123381.html
16:11:52 <pkovar> not sure what's the progress there? jamesmcarthur do you know?
16:12:02 <jamesmcarthur> Hi - we have started work on this. Expect something to be up for review within a week.
16:12:09 <jamesmcarthur> (i hope)
16:12:35 <pkovar> sounds great, hope to have the guides for newton and ocata republished this week too
16:13:03 <jamesmcarthur> We're working on modifying the yaml to include some additional variables based on the state of the release.
16:13:21 <jamesmcarthur> Which will give us a dynamic message box that we can attach to the top of any release.
16:13:54 <pkovar> something like devel/latest/old stable/unsupported?
16:14:09 <pkovar> s/latest/latest stable/
16:14:54 <jamesmcarthur> using the status under SERIES_INFO: http://git.openstack.org/cgit/openstack/openstack-manuals/tree/tools/www-generator.py#n43
16:15:50 <pkovar> good good
16:15:53 <jamesmcarthur> my proposal will be to add a couple of new variables like: bannercolor, bannermessage, bannerlink that can be modified by anyone
16:16:03 <jamesmcarthur> per series
16:16:14 <pkovar> sounds great
16:17:50 <pkovar> okay, thanks for the update, moving on...
16:17:59 <pkovar> #topic Rocky PTG
16:18:06 <pkovar> #link https://www.openstack.org/ptg/
16:18:13 <pkovar> #info Planning etherpad for docs+i18n created
16:18:19 <pkovar> #link https://etherpad.openstack.org/p/docs-i18n-ptg-rocky
16:18:26 <pkovar> #info Sign up and tell us your preference wrt parcel time into small chunks or have full-day focus on one team agenda?
16:18:51 <pkovar> #info ... on the eherpad
16:19:36 <pkovar> #info we will be joined by people involved in the contrib guide effort
16:20:07 <pkovar> #info ... and upstream institute
16:20:30 <pkovar> #link Contributor Guide https://docs.openstack.org/contributors/
16:21:05 <pkovar> #action add your own topics to the planning etherpad
16:21:47 <pkovar> so far, we have redoing docs tags, reviewing actions items from the past, restoring builds
16:21:54 <pkovar> and contrib guide
16:23:10 <pkovar> related to that, and mostly fyi
16:23:11 <pkovar> #topic removed unused docs:follows-policy tag
16:23:18 <pkovar> #link https://review.openstack.org/#/c/524217/
16:23:24 <pkovar> #info new docs tags to be discussed at PTG
16:24:12 <pkovar> okay, next topic
16:24:14 <pkovar> #topic changes to the docs core team
16:24:31 <pkovar> #info Anne Gentle stepped down from the core team
16:24:37 <pkovar> #info thanks Anne for your leadership and involvement in the docs project since the very beginning!
16:25:58 <pkovar> #topic Project Liaisons for  First Contact SIG
16:26:06 <pkovar> #link https://wiki.openstack.org/wiki/First_Contact_SIG
16:26:12 <pkovar> #info Anyone interested in being the docs project liaison?
16:26:27 <pkovar> if so, please go ahead and sign up
16:26:36 <pkovar> and maybe let me know .)
16:27:16 <pkovar> this is a recent effort trying to attract more contributors to the community
16:28:18 <pkovar> as we all know, it's challenging to find new docs writers so attracting newcomers to start writing docs is the way to go
16:28:39 <pkovar> (in a coordinated fashion)
16:29:22 <pkovar> #topic PDF builds
16:29:30 <pkovar> #link https://review.openstack.org/#/c/509297/
16:30:11 <pkovar> still work to do also in terms of figuring out what to do about eol docs pdf builds
16:30:22 <pkovar> ianychoi gave us an update yesterday
16:30:35 <ianychoi> hi
16:30:46 <pkovar> o/
16:31:05 <pkovar> any comments, ianychoi? :)
16:32:22 <ianychoi> For the spec, would there be some ways to continue conversation from http://lists.openstack.org/pipermail/openstack-dev/2017-November/124863.html ?
16:32:43 <pkovar> #link http://lists.openstack.org/pipermail/openstack-dev/2017-November/124863.html
16:33:07 <pkovar> #action follow up on the pdf build thread
16:34:51 <ianychoi> And.. for pdfs for Mitaka, I found that Sphinx < 1.3 is used for build environment
16:35:49 <ianychoi> Not much sure whether old version of Sphinx is fine with pdf builds. I will more see on this.
16:36:25 <pkovar> if that version is too old, we can follow up with infra?
16:36:57 <pkovar> though mitaka is eol, so not sure if we want to spend too much time on that
16:37:37 <AJaeger> pkovar: infra has nothing to do with that.
16:37:48 <AJaeger> It's test-requirements - and that's what we control.
16:38:07 <pkovar> ah, so just update that? cool
16:38:19 <ianychoi> pkovar, after Mitaka, there have been some requirement changes. Such changes are fine with eol branches?
16:38:20 <AJaeger> Past experience has shown that newer sphinx needs changes to RST files as well, so if you update, you'll need to fix some files as well
16:38:50 <pkovar> good point
16:38:58 <ianychoi> And some bindep.txt modification
16:39:20 <pkovar> a test build would be need to assess the volume of editing work required
16:39:39 <pkovar> to tweak the RSTs
16:40:13 <pkovar> ianychoi: if it's under our control, i think it's fine
16:41:00 <ianychoi> pkovar, aha good :)
16:44:07 <pkovar> okay, if there are more comments, lets discuss here later or in -dev
16:44:08 <pkovar> #topic Bug Triage Team
16:44:21 <pkovar> #link https://wiki.openstack.org/wiki/Documentation/SpecialityTeams
16:44:41 <pkovar> thanks goes to chason who volunteered for this week
16:44:43 <ianychoi> Nothing more currently - ah https://review.openstack.org/#/c/525187/ - thank u chason
16:45:25 <pkovar> if more people are interested in bug triaging, please sign up
16:45:36 <chason> pkovar Hahah
16:45:54 <pkovar> or file bugs :)
16:46:24 <chason> pkovar ianychoi yw :)
16:46:50 <chason> pkovar BTW, I have signed up this position, https://wiki.openstack.org/wiki/First_Contact_SIG#Project_Liaisons
16:47:06 <pkovar> excellent, thanks chason
16:47:33 <pkovar> #info chason signed up for  https://wiki.openstack.org/wiki/First_Contact_SIG#Project_Liaisons
16:47:50 <ianychoi> +1 :)
16:48:10 <pkovar> #action file bugs, triage bugs, repeat
16:48:27 <chason> pkovar np. I'd really like more people join us. :)
16:49:34 <pkovar> yes, but if more people don't sign up, we can always rethink how we want to deal with bugs
16:50:14 <pkovar> #topic Open discussion
16:51:10 <pkovar> any objections if we cancel the meeting of Dec 27? :)
16:51:36 <pkovar> we would meet on Jan 10
16:52:28 <pkovar> i take it as a no then :)
16:52:46 <pkovar> #info next meeting scheduled for Jan 10 2018
16:53:02 <pkovar> any other business to discuss?
16:54:07 <pkovar> if not enjoy your holidays and happy new year!
16:54:23 <pkovar> thanks, everybody
16:54:34 <ianychoi> pkovar, happy new year early :) BTW
16:54:49 <chason> thanks pkovar
16:54:51 * AJaeger wishes all happy holidays as well
16:54:54 <pkovar> i know, it' just for us folks in the mtg :)
16:55:14 <ianychoi> pkovar, hmm I can ask to u later :)
16:55:19 <jamesmcarthur> thanks pkovar!
16:55:37 <pkovar> #endmeeting