16:01:09 <pkovar> #startmeeting docteam
16:01:10 <openstack> Meeting started Thu Oct 19 16:01:09 2017 UTC and is due to finish in 60 minutes.  The chair is pkovar. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:13 <openstack> The meeting name has been set to 'docteam'
16:01:26 <pkovar> welcome to the docs team meeting
16:01:47 <eumel8> welcome too :)
16:01:54 <mguiney> o/
16:02:03 <pkovar> \o
16:02:56 <pkovar> meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting
16:03:16 <bsilverman> \o
16:03:21 <pkovar> let's start in 3 mins
16:03:28 <jamesmcarthur> \o
16:04:24 <dhellmann> o/
16:06:09 <pkovar> okay, let's get started
16:06:12 <pkovar> #topic Docs meeting time?
16:06:43 <pkovar> Chason pointed out in the docs ml that the meeting time is not very asia-friendly
16:07:13 <pkovar> what are people's thought on changing the meeting time?
16:07:23 <pkovar> closer to noon UTC
16:07:57 <pkovar> (that might make the time less friendly for the us, though)
16:08:11 <bsilverman> that's 5am here
16:08:20 <bsilverman> and 5am in California
16:08:28 <pkovar> yeah, that wouldn't worl
16:08:31 <pkovar> work, even
16:08:55 <pkovar> alternatively, we could rotate between us-friendly and asia-friendly
16:09:17 <jamesmcarthur> I've found that alternating ends up with one set of people on one meeting and another on the other.
16:10:01 <pkovar> good point
16:10:35 <pkovar> anyone in this mtg in favor of changing the mtg time?
16:10:59 <pkovar> probably not the right audience to ask that Q, but anyway :)
16:11:04 <dhellmann> we could also try to do more coordination via the mailing list
16:11:19 <pkovar> I'll start sending meeting minutes to ML
16:12:07 <dhellmann> ++
16:12:11 <jamesmcarthur> We could do 12:00 UTC
16:12:21 <jamesmcarthur> Which is 7am Beijing and 6pm Central
16:12:44 <jamesmcarthur> oh sorry
16:12:53 <jamesmcarthur> that was terrible time reading on my part
16:12:58 <dhellmann> I think that's 7:00 central?
16:13:01 <dhellmann> it's 8:00 EST
16:13:24 <bsilverman> and 5am MST/MDT
16:13:35 <pkovar> yep, too early
16:14:07 <jamesmcarthur> I was looking at midnight. Seriously ignore me. On first cup of coffee :|
16:14:09 <dhellmann> 6 MST, but yeah
16:14:20 <pkovar> still, i think i'll initiate a poll re: meeting time so that we get a better idea wrt how many ppl would be interested in an earlier time
16:14:28 <jamesmcarthur> +1
16:14:33 <bsilverman> dhellmann: Nope, right now we're 3 hours behind EST
16:14:46 <dhellmann> get with the program, MST!
16:14:47 <eumel8> rotating time slots would be better as a bad timeslot for everyone
16:15:27 <pkovar> good point
16:16:13 <pkovar> #action pkovar to initiate a mtg time poll
16:16:40 <pkovar> any other ideas wrt mtg time?
16:17:14 <dhellmann> I haven't attended a lot of doc team meetings. What sort of conversations happen in the meeting that can't happen asynchronously?
16:17:59 <eumel8> decisions?
16:18:02 <pkovar> it's mostly just summarizing what happened in past two weeks
16:18:14 <pkovar> or that
16:18:29 <pkovar> if there's enough ppl attending
16:19:40 <dhellmann> ok. maybe by emphasizing the use of the mailing list for those decisions we can alleviate the issues with meeting time and make rotating meetings successful (or drop them entirely)
16:20:16 <dhellmann> publishing status messages to the mailing list will also make the work this team is doing more visible outside the team, which will help with recruiting and getting input from other people
16:20:28 <dhellmann> that's the primary reason I suggested moving to the -dev list instead of a separate -docs list
16:20:52 * dhellmann wishes that was the -contrib list instead of -dev, but that ship has sailed
16:21:23 <pkovar> feel free to resurrect that thread about retiring the docs ml
16:21:27 <eumel8> interesting
16:22:02 <jamesmcarthur> yeah, i inadvertently posted to the docs list a couple of weeks ago. Didn't realize it was deprecated.
16:22:08 <jamesmcarthur> Would be good to just remove it if it's not in use.
16:22:22 <pkovar> though i hope it is possible to decommission a ml without losing archives, for example
16:22:58 <dhellmann> you should be able to have the moderator turn off anyone's ability to post or join without deleting the list
16:23:05 <pkovar> #info reconsider removing the docs ML
16:23:15 <pkovar> good to know
16:23:42 <pkovar> #info decisions to be made in ML (-dev, preferably)
16:23:43 <dhellmann> according to http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-docs pkovar and asettle are the list admins
16:24:39 <pkovar> #info consider sending status updates
16:25:10 <pkovar> good, i'll have a look around the mailman admin. love the interface, btw :)
16:25:57 <pkovar> ready to move on?
16:26:08 <dhellmann> ++
16:26:21 <pkovar> next topic is...
16:26:24 <pkovar> #topic Docs team vision document
16:26:34 <pkovar> #link https://etherpad.openstack.org/p/docs-i18n-ptg-queens-mission-statement
16:26:51 <pkovar> that's the draft edited by jamesmcarthur, thank you
16:27:02 <jamesmcarthur> happy to help!
16:27:28 <pkovar> unless there are objections, i'll submit it to be included in https://etherpad.openstack.org/p/docs-i18n-ptg-queens-mission-statement
16:27:29 <dhellmann> yes, big thanks!
16:27:40 <pkovar> sorry, i meant the doc contrib guide
16:27:57 <dhellmann> either there or specs makes sense to me
16:27:58 <pkovar> https://docs.openstack.org/doc-contrib-guide/
16:28:27 <pkovar> what would the folks prefer? specs or doc contrib guide?
16:29:28 <pkovar> looks like nobody has a strong opinion :)
16:29:40 <bsilverman> contib guide
16:29:45 <bsilverman> contrib
16:29:46 <jamesmcarthur> Doc contributor guide
16:29:56 <eumel8> +
16:30:04 <pkovar> good, good
16:30:50 <pkovar> #action pkovar to add the vision doc to doc contrib guide
16:31:08 <pkovar> anything else?
16:31:27 <pkovar> next topic is
16:31:29 <pkovar> #topic Docs retention policy changes
16:31:39 <pkovar> We've just approved this spec. Thanks dhellmann for putting this together!
16:31:47 <pkovar> #link https://review.openstack.org/#/c/507629
16:32:06 <dhellmann> weird, I don't see that on specs.o.o
16:32:34 <dhellmann> looks like we need to trigger a republish in that repo
16:33:09 <pkovar> hm, will submitting a trivial change do?
16:33:09 <dhellmann> I've signed up to do the mitaka work, and I hope to at least start that before the summit in a couple of weeks
16:33:15 <dhellmann> pkovar: yes
16:33:34 <pkovar> will try to find a typo or something :)
16:33:53 <pkovar> now, the spec calls for action wrt badges which is something jamesmcarthur has been looking into
16:34:06 <jamesmcarthur> si
16:34:17 <pkovar> badges to clearly identify outdated unsupported content
16:34:37 <jamesmcarthur> I'd like to partner up with someone b/c there are some programming questions I have.
16:34:42 <pkovar> or having a number of different badges to identify different content statuses?
16:34:58 <jamesmcarthur> pkovar: right that was dhellman's idea
16:35:01 <dhellmann> jamesmcarthur : you'll also want something like https://review.openstack.org/#/c/491868/ so the series name can be derived by the theme
16:35:02 <jamesmcarthur> And I think it's doable
16:35:27 <dhellmann> I can give you advice and code reviews
16:36:03 <jamesmcarthur> dhellman: thanks! My goal is to have this in ahead of Sydney. But I'm pretty buried with other Foundation work.
16:36:22 <dhellmann> that's fairly ambitious, but we can get it started
16:36:38 <pkovar> #link https://review.openstack.org/#/c/491868/ to derive series name by the theme
16:36:48 <dhellmann> we also need to figure out how to apply the new theme to older doc builds
16:37:16 <dhellmann> we should coordinate with tonyb and the stable team to make sure they aren't planning to close any stable branches before we can add the badges to the docs produced from them
16:38:48 <jamesmcarthur> got it
16:39:05 <dhellmann> let's start an etherpad to track all these little details
16:39:37 <pkovar> #info coordinate with tonyb and the stable team to avoid closing stable branches before adding badges to docs
16:40:20 <jamesmcarthur> https://etherpad.openstack.org/p/docs-i18n-ptg-queens-release-badges
16:40:32 <dhellmann> ++
16:40:43 <pkovar> #link  https://etherpad.openstack.org/p/docs-i18n-ptg-queens-release-badges
16:41:08 <pkovar> #chair jamesmcarthur dhellmann
16:41:08 <openstack> Current chairs: dhellmann jamesmcarthur pkovar
16:41:33 * dhellmann cackles maniacally
16:41:46 <dhellmann> I don't think chair privs are needed to #info, I'm just out of practice
16:42:05 <pkovar> good to know!
16:42:10 <jamesmcarthur> Did I just make some sort of pact?
16:42:12 <jamesmcarthur> I'm nervous.
16:42:16 <pkovar> but it doesn't hurt either
16:42:21 <dhellmann> sure
16:42:44 <pkovar> i like democracy, err, i mean meritocracy
16:42:47 <pkovar> anyhow
16:42:56 <dhellmann> do-ocracy
16:43:03 <pkovar> or that
16:43:22 <pkovar> next topic?
16:43:46 <pkovar> #topic Contributor Portal
16:43:55 <pkovar> A new specialty team led by thingee
16:44:03 <pkovar> #link http://lists.openstack.org/pipermail/openstack-dev/2017-October/123740.html
16:44:38 <pkovar> there are three different resources with similar names:
16:44:44 <pkovar> Contributor Portal
16:44:50 <pkovar> #link https://www.openstack.org/community/
16:44:55 <pkovar> Contributor Guide
16:45:01 <pkovar> #link https://docs.openstack.org/contributors
16:45:08 <pkovar> Documentation Contributor Guide
16:45:13 <pkovar> #link https://docs.openstack.org/doc-contrib-guide/
16:45:16 <pkovar> just that you know
16:45:20 <eumel8> specialty ... ok
16:45:27 <pkovar> details in thingee's mail
16:45:32 <pkovar> linked above
16:46:05 <pkovar> is that an americanism? i dunno
16:46:35 <dhellmann> maybe? "specialist" might be a better form of the word for that case
16:47:05 <eumel8> 2 years in OpenStack Community and now I'm a specialty ;)
16:47:10 <pkovar> /me nods
16:47:26 <dhellmann> all our contributors are special, eumel8 :-)
16:47:34 <pkovar> 12 mins, lets move on
16:47:39 <pkovar> #topic sitemap automation suggestions
16:47:48 <pkovar> #link http://lists.openstack.org/pipermail/openstack-dev/2017-October/123228.html
16:47:51 <eumel8> thats true, dhellmann :)
16:48:07 <pkovar> i think this thread is still open for suggestions
16:48:13 <pkovar> re scope etc.
16:48:29 <dhellmann> we should figure out what exactly we want to have included in the sitemap
16:48:43 <dhellmann> because it seems like we could generate that as part of publishing, instead of crawling the site later
16:49:09 <jamesmcarthur> yeah, that's another option. We just need something to trigger it.
16:49:11 <dhellmann> I'm not sure about logging the missing pages or redirects; that's probably better done by crawling but I don't know what we'd do with the results
16:49:45 <dhellmann> the sitemap file format isn't that complicated. we could have a sphinx extension generate it for most cases and extend the template generator to handle the non-sphinx pages
16:49:45 <jamesmcarthur> dhellman: the point of that is to start putting in the appropriate redirects and making sure those pages are removed from sitemap
16:50:08 <dhellmann> ah
16:50:31 <dhellmann> how much content do we publish that isn't managed by sphinx?
16:50:41 <jamesmcarthur> I suggested Google Webmaster tools b/c they used to do that for you. But it was so useful Google took it away.
16:50:46 <dhellmann> if it's a lot, maybe that's why a separate scraping tool was used?
16:51:19 <jamesmcarthur> dhellman: not sure. I would love to get some history behind using scrapy.
16:51:22 <dhellmann> I'm skeptical of anything that requires a person to sit down and do the work by hand
16:51:30 * mguiney nods
16:52:00 <jamesmcarthur> +1. Anything we do should be automated.
16:52:28 <thingee> o/
16:52:31 <jamesmcarthur> BUT, I think initially we're going to have a lot of cleanup to do and it might take some manual intervention.
16:52:51 <dhellmann> do we have pages in our sitemap that are 404s?
16:53:21 <dhellmann> I mean, initially we'll have to do work by hand, but we need to be doing that as part of automating things
16:53:35 <jamesmcarthur> We have lots of indexed pages that are 404s.
16:53:48 <dhellmann> that's not the same thing, though, right?
16:54:03 <jamesmcarthur> correct. just another piece of the puzzle.
16:54:21 <dhellmann> sure. so infra has a list of 404 responses on docs.o.o now showing us pages that people are actually visiting
16:54:28 <dhellmann> and google may have a list of indexed 404 pages somewhere
16:54:37 <dhellmann> and we can build the sitemap based on files we know we're actually publishing
16:54:50 <dhellmann> dealing with the first 2 of those is separate from the third
16:54:55 <dhellmann> at least it seems like it
16:54:59 <jamesmcarthur> yes, agreed
16:55:24 <dhellmann> which is most important?
16:55:43 <dhellmann> and which is "easiest"? :-)
16:55:52 <jamesmcarthur> from a Docs team management perspective, it seems the most important is getting the sitemap automated. And likely the easiest.
16:56:15 <dhellmann> do we have someone who wants to work on that?
16:56:30 <jamesmcarthur> mguiney has volunteered (i think) :)
16:56:55 <mguiney> yup!
16:56:57 <dhellmann> yay!
16:57:31 <mguiney> i would love to work on that, theres a couple of good cleanups that should be pretty easy to do, given the cycles (which i happen to have)
16:57:35 <pkovar> #action mguiney volunteered to help with sitemap automation, thanks
16:57:41 <dhellmann> so if we narrow the focus just to how we generate site maps, what's the next thing to do?
16:58:20 <mguiney> I believe it would be to get it running automatically
16:58:29 <dhellmann> "it"?
16:58:37 <mguiney> the current utility set
16:58:50 <pkovar> folks, do you want to move the conversation to #openstack-doc?
16:59:01 <dhellmann> is that the best tool for the job?
16:59:01 <mguiney> oh dang. hour is up
16:59:02 <dhellmann> oh, sure, it's the top of the hour
16:59:06 <pkovar> yep
16:59:10 <pkovar> thank you :)
16:59:11 <mguiney> sure
16:59:41 <pkovar> the renaming topics from https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting
16:59:44 <pkovar> we can discuss next time
16:59:57 <pkovar> thanks, everybody
17:00:10 <pkovar> #endmeeting