16:00:25 <asettle> #startmeeting docteam
16:00:25 <openstack> Meeting started Thu May 18 16:00:25 2017 UTC and is due to finish in 60 minutes.  The chair is asettle. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:30 <openstack> The meeting name has been set to 'docteam'
16:00:39 <ianychoi> o/
16:00:42 <asettle> Hey ianychoi :)
16:00:45 <rluethi> hey
16:00:52 <ianychoi> asettle, rluethi: hello!
16:01:03 <asettle> rluethi: hooray! Glad you made it :)
16:01:12 <rluethi> so am I :)
16:01:39 <asettle> AJaeger: hey pal!
16:01:58 * AJaeger is just lurking, need to cycle home and want to read backscroll
16:02:10 <asettle> Okay AJaeger :)
16:02:18 <ianychoi> Haha
16:02:19 <rluethi> welcome all lurkers!
16:02:22 <asettle> We'll wait until 5 past for quorum :)
16:02:22 <AJaeger> ;)
16:03:42 <asettle> I know annegentle is around, but double booked
16:04:19 <annegentle> o/
16:04:33 <ianychoi> annegentle, hello!
16:04:36 <annegentle> hi!
16:05:22 <asettle> Okay we're at 5 past
16:05:27 <asettle> Should we continue?
16:05:31 <asettle> The agenda is pretty short anyway :)
16:05:44 <annegentle> go for it!
16:05:54 <ianychoi> +1 Let's go
16:06:00 <asettle> Okay.
16:06:08 <asettle> #link https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting#Agenda_for_next_meeting
16:06:14 <asettle> #topic Action items from the last meeting
16:06:42 <asettle> I don't believe we had any again \o/
16:06:43 <asettle> So, nice!
16:06:51 <asettle> #topic Summit recap
16:07:00 <asettle> #link https://etherpad.openstack.org/p/docs-summit
16:07:11 <asettle> This is our etherpad from the summit - linked to all other etherpads!
16:07:13 <asettle> Universe of pad
16:07:23 <asettle> There was a lot going on at the summit, a full on week, as always.
16:07:37 <asettle> I'm currently writing up my summit recap email which has some more indepth information
16:07:46 <asettle> But we'll be looking at some fairly radical changes with how the doc team is structured.
16:07:54 <asettle> As it stands, the group has been going up and up and up, which is great.
16:08:04 <asettle> But now we're at a stage where we are unable to maintain the content that we have
16:08:16 * AJaeger thanks asettle for driving all these discussions!
16:08:27 <asettle> dhellmann has been working with me to come up with new action items for the future.
16:08:29 <asettle> You can view them here
16:08:31 <asettle> #link https://etherpad.openstack.org/p/doc-planning
16:08:35 <asettle> thanks AJaeger :) I appreciate your support
16:09:03 * dhellmann checks his calendar
16:09:05 <rluethi> wow, that's a lot of action items.
16:09:09 <asettle> One of the biggest concerns at the moment (and always has been, who am I kidding) is the Installation Guide
16:09:13 <asettle> rluethi: sure is :( we have a *lot* of stuff
16:09:33 <asettle> dhellmann: meeting time change ;)
16:09:45 <asettle> If anyone has any questions about that, please ping me
16:09:50 <asettle> I'm happy to walk it through with you all
16:10:40 <dhellmann> asettle : ah, I guess I missed the notice of that. I'll talk to you later about how to keep up to date on these things :-)
16:10:48 <rluethi> I am glad to see that we haven't got any items :).
16:10:48 <asettle> dhellmann: meeting minutes?
16:10:57 <asettle> rluethi: none so far
16:11:00 <asettle> But, It would be good to talk about that
16:11:09 <asettle> And figure out where you want to take the training-labs and guides
16:11:14 <dhellmann> asettle : well, I thought I'd try to attend until this transition is completed
16:11:26 * AJaeger adds some action items for rluethi ;)
16:11:27 <rluethi> asettle: was that with a threatening voice?
16:11:33 <asettle> rluethi: hahahhaa not at all
16:11:59 <asettle> I'll phrase with more smileys next time - I'm sorry. I do genuinely think we should chat about what you are thinking for the future :)
16:12:02 <ianychoi> asettle, I want to follow the changes regarding some changes on translation (I18n) activities
16:12:06 <rluethi> no, ajaeger, stay good.
16:12:15 * AJaeger will
16:12:19 <asettle> ianychoi: of course. Definitely a prioritiy
16:12:21 <asettle> priority*
16:12:48 <annegentle> thanks dhellmann
16:12:48 <rluethi> asettle: sure, no problem. (maybe _I_ should have used more smileys)
16:13:08 <asettle> Hahhaha perfect :) we'll sync up sometime soon
16:13:09 <annegentle> more smileys all around!
16:13:18 <asettle> #action asettle to chat to rluethi about training-labs and guides future
16:13:31 <asettle> #action asettle and ianychoi to discuss planning changes with translation activities
16:14:21 <ianychoi> asettle, please try to reach out matjazp for training-guides :) If no, then I would like to propose it as an agenda for next IRC meeting (May 30).
16:14:55 <asettle> ianychoi: good point! Please update the agenda for next week :)
16:15:33 <ianychoi> :)
16:16:06 <asettle> Okay, sorry, distracted all over hte hsop
16:16:07 <asettle> the shop*
16:16:32 <annegentle> hop, shop, all good :)
16:16:35 * AJaeger will enjoy the sunshine with his bike now - bbl
16:16:42 <annegentle> cya!
16:16:45 <asettle> I will be sending out an email to the dev ML regarding my concerns with the installation guide
16:16:48 <asettle> cya AJaeger !
16:16:53 <ianychoi> cya AJaeger :)
16:16:54 <asettle> Please everyone keep your eyes out for that
16:16:57 <asettle> I would love your support and thoughts
16:17:47 <annegentle> asettle still need more context on discussions, need to read read read
16:18:02 <asettle> annegentle: yep. there's more coming out too. After this meeting I will be sending out my summary email :0
16:18:03 <asettle> :) *
16:18:09 <asettle> Hopefully that'll add some more context, and we can go further
16:18:12 <asettle> I'm always happy to answer questions
16:18:19 <annegentle> ok, good
16:18:45 <asettle> It is hard to communicate everything when it all happens so fast! But hopefully I'll clarify evrything
16:18:58 <ianychoi> annegentle, aha that's how to increase English - good writing is based on more more reading
16:19:26 <annegentle> so true!
16:19:31 <ianychoi> :)
16:19:40 <asettle> Hahaha
16:19:48 <asettle> Well, annegentle you're going to love this reading :p
16:19:51 <asettle> Anyway. MOving along :)
16:19:59 <asettle> #topic Specialty team reports
16:20:09 <asettle> annegentle: API :)
16:20:25 <annegentle> asettle on it!
16:20:55 <annegentle> #info Looking for better ways to indicate "nesting" on request parameters
16:21:10 <annegentle> #link https://review.openstack.org/#/c/464255/
16:21:54 <asettle> Looking :)
16:21:56 <annegentle> And then also saw that bug report on the developer landing page that the CLI section wraps badly, thanks dhellmann for reporting
16:22:10 <annegentle> otherwise, mostly looking for info on what came out of the Forum
16:22:15 <annegentle> that's all I have
16:22:46 <asettle> Awesome :) thanks annegentle
16:22:52 <asettle> Do you have any more reports on the theme, btw?
16:22:58 <asettle> Lots of people are really interested in it
16:23:24 <annegentle> asettle interested in it how? I had hoped to get help with it at Write the Docs, I can't quite figure out how to bring in inherited pieces.
16:23:33 <annegentle> asettle any input on what they can't live without?
16:24:30 <asettle> annegentle: none so far. Mostly that people are just mega excited for consistency.
16:24:34 <annegentle> and it's what we had identified before, that the openstackdocstheme doesn't "inhereit"
16:24:35 <asettle> That's a sentence I never htought I'd say
16:24:41 <annegentle> asettle oh that's encouraging, yay
16:24:51 <asettle> Very encouraging :D
16:25:07 <annegentle> I do need to make a 1.9.0 release for the header breakage (404s in links in drop-down menus)
16:25:25 <annegentle> #info Working on a 1.9.0 release of openstackdocstheme for bug fixing
16:25:30 <dhellmann> annegentle : it looks like sphinx 1.6.1 breaks the oslosphinx theme inheritance, so keep an eye out for that in the work you're doing.
16:25:46 <annegentle> dhellmann ok, thanks
16:25:56 <dhellmann> I just hit that yesterday, and we've been blocking 1.6.1 until we have a fix
16:26:03 <dhellmann> that release broke builds all over the internet :-
16:26:05 <annegentle> asettle any input from infra team about their deliverables specifically or shall I reach out individually?
16:26:06 <dhellmann> :-/
16:26:10 <annegentle> dhellmann boo
16:26:26 <asettle> annegentle: I've had no specifics, I"m sorry :(
16:26:38 <annegentle> asettle no worries, I'll reach out
16:26:39 <asettle> I'll reach out and try and get some more info for you annegentle
16:26:49 <asettle> At least, people that are putting in requests, I'll ask what they want ;)
16:27:27 <annegentle> asettle I'm sure consistency is a huge win :)
16:27:42 <asettle> Hhahaha well, it was pretty exciting considering all I'd ever herad before was 'grumble grumble i hate change'
16:27:58 <annegentle> asettle ha!
16:28:07 <asettle> Anyway!
16:28:08 <annegentle> consolidate for the win
16:28:12 <asettle> Hahhaha yes
16:28:19 <asettle> Okay, I don't see Matjaz?
16:28:22 <asettle> Pranav?
16:29:27 <ianychoi> It seems that matjazp is offline
16:29:39 <asettle> Okay :)
16:29:46 <asettle> Well, rluethi up to you then for Training labs
16:29:50 <asettle> Anything happy-happening?
16:29:58 <rluethi> We have started development work for Pike. Small bug fixes, refactoring, ramping up for a few new features that we hope to introduce during this cycle.
16:30:03 <asettle> Oh neato :)
16:30:17 <rluethi> This will give you a rough idea: #link https://review.openstack.org/#/q/status:open+project:openstack/training-labs
16:30:41 <ianychoi> Cool
16:30:57 <asettle> rluethi: do you need a second core on any of those?
16:31:22 <rluethi> I think I will first try to wack one of those that we have :).
16:31:50 <asettle> Hahha okay :)
16:32:24 <rluethi> But yeah, we are spread thin as well.
16:33:12 <asettle> rluethi: definitely worth us having that conversation then :)
16:33:24 <rluethi> sure
16:33:48 <asettle> I want to make sure we're all coming together as a team, rather than being so silo'd. It definitely worked in the past, but as rluethi said, we're all spread pretty thin
16:33:56 <mpranjic> o/
16:34:00 <mpranjic> sorry for being late
16:34:00 <asettle> mpranjic: yo yo
16:34:02 <asettle> That's okay :)
16:34:04 <annegentle> hey mpranjic
16:34:06 <asettle> Thanks for joining
16:34:13 <mpranjic> thanks for having me :)
16:34:19 <asettle> No worries, we're just at the end here
16:34:20 <ianychoi> mpranjic, hello!
16:34:28 <asettle> #topic Bug triaging
16:34:37 <asettle> #link https://wiki.openstack.org/wiki/Documentation/SpecialityTeams#Bug_Triage_Team
16:34:41 <asettle> Olena is our current bug triage liaison (I am stepping in while she is PTO). Nothing notable.
16:34:45 <asettle> Thanks to Chason to filling in the remaining slot!
16:34:54 <asettle> Next up is bsilverman for the 22 May - 5 Jun
16:35:50 <ianychoi> Aha... Olena triaged my recent bug submission - https://bugs.launchpad.net/openstack-manuals/+bug/1691058 :)
16:35:52 <openstack> Launchpad bug 1691058 in openstack-manuals "Old EOL-ed release landing pages have master (up-to-date) document links" [Low,Confirmed]
16:36:22 <asettle> ianychoi: ahhh jeez, good catch
16:37:06 <asettle> #topic Open discussion
16:37:12 <asettle> Alright, that's the end of this one folks!
16:37:23 <ianychoi> Good
16:38:04 <asettle> Any questions, concerns, comments, feelings?
16:38:17 <ianychoi> During Docs/I18n project onboarding session, one tempest contributor applied openstackdocstheme by changing from oslosphinx: https://docs.openstack.org/developer/tempest/
16:38:32 <asettle> Ah, was that Matt?
16:38:40 <annegentle> huzzah
16:38:41 <ianychoi> asettle, Masayuki :)
16:38:42 <asettle> I know a lot of people were like 'why are we still using oslo.sphinx?!'
16:38:48 <asettle> And I was like 'uhhhh, cause you choose to?'
16:38:57 <ianychoi> And I18n team also now uses openstackdocstheme: https://docs.openstack.org/developer/i18n/
16:38:59 <mpranjic> :)
16:39:24 <annegentle> look at that cool parrot
16:39:46 <annegentle> oh I sat next to a tech writer at Pivotal who LOVES and I mean LOVES our fox mascot!
16:39:57 <asettle> Hhahahaha that's cute
16:40:04 <ianychoi> annegentle, haha thanks! :) I also love FOX mascot!
16:40:06 <annegentle> definitely nearly took my fox sticker off my laptop (not really)
16:40:22 <annegentle> I'll mail her one if I can find one!
16:40:35 <asettle> annegentle: I have about forty billion, no joke
16:40:39 <asettle> Let me send you some
16:40:44 <asettle> I don't know what to do with them
16:40:51 <annegentle> also, there's a writer at F5 who presented about treating docs like code who has some OpenStack patches to do, so that's cool.
16:41:05 <annegentle> presented at Write the Docs in Portland Tuesday, I mean
16:41:26 <asettle> Oh wonderful :D
16:41:29 <annegentle> i also attempted to onboard six people at once on Sunday!
16:41:33 <asettle> I'm glad there's people still out there paying attention to us
16:41:37 <annegentle> Hence my patches over the weeeknd.
16:41:37 <asettle> How'd that go annegentle ? :)
16:41:41 <asettle> I got your email late, I'm so sorry!
16:41:49 <annegentle> grateful to you all helping me merge those :)
16:41:55 <annegentle> also how I found the broken links in the header
16:41:59 <annegentle> so yeah, went really well
16:42:20 <ianychoi> annegentle, great! I sometimes see you on "Write the Docs" slack :)
16:42:23 <annegentle> all the usual onboarding headaches with identities and ssh keys
16:42:26 <annegentle> ianychoi yeah!
16:43:41 <asettle> annegentle: ugh noooo. One day we'll have to make that better
16:43:46 <asettle> Guess that isn't going to happen tomorrow :P
16:43:51 <annegentle> heh, nope
16:44:38 <asettle> Alright, well, I think we're pretty much done here
16:44:41 <asettle> ANything else folkks?
16:44:47 <asettle> Pass on the word that this is the new improved meeting time
16:44:52 <asettle> How does this work for people?
16:44:57 <rluethi> improved indeed.
16:46:09 <rluethi> asettle: thanks for the review :)
16:46:19 <annegentle> great except for double (was triple) booking... heh
16:46:20 <asettle> Not a problem :) made sense!
16:46:25 <asettle> Hahaha :)
16:46:50 <ianychoi> I can sleep now haha
16:47:43 <asettle> ALright
16:47:44 <asettle> BYE GUYS
16:47:48 <asettle> #endmeeting