14:06:12 <annegentle> #startmeeting docteam
14:06:13 <openstack> Meeting started Wed Aug 26 14:06:12 2015 UTC and is due to finish in 60 minutes.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:06:16 <annegentle> hi all, welcome
14:06:17 <openstack> The meeting name has been set to 'docteam'
14:06:29 <annegentle> I'm starting the meeting for Shilla
14:06:37 <annegentle> Agenda is here: https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting#Agenda_for_next_meeting
14:07:04 <annegentle> let's look at any action items from last time
14:07:41 <annegentle> Seeing none, I move we move on :)
14:07:45 <AJaeger> HI annegentle
14:07:51 <annegentle> hey AJaeger
14:07:58 <annegentle> anyone else here, raise your hand for doc team meeting?
14:08:28 <gpocentek> I'm more or less here
14:08:32 <AJaeger> hi gpocentek !
14:08:50 <gpocentek> hey Andreas :)
14:08:56 <annegentle> hey gpocentek!
14:09:03 <annegentle> we'll take the more or less :)
14:09:14 <gpocentek> hi Anne, ok :)
14:09:42 <annegentle> #topic #Liberty specs in review
14:09:46 <annegentle> I think there are two left
14:10:06 <annegentle> The API docs one with the updates for "narrative" or conceptual topics merged
14:10:20 <annegentle> #link http://specs.openstack.org/openstack/docs-specs/specs/liberty/api-site.html
14:11:00 <annegentle> Third party driver docs still has a task assignment,for purging
14:11:02 <annegentle> #link https://review.openstack.org/#/c/191041/
14:11:44 <annegentle> And I think there's a fairly fresh one to improve the Arch Design Guide
14:11:47 <AJaeger> The arch-design RST conversion spec merged
14:12:08 <annegentle> Oh I still see it with two +2s but no merge
14:12:14 <annegentle> #link https://review.openstack.org/#/c/216106/
14:12:29 <annegentle> Ah, awaiting Shilla's approval
14:13:36 <annegentle> #info Arch Design doc updates spec awaiting Shilla's review and approval
14:13:50 <annegentle> next topic
14:13:52 <annegentle> #topic Speciality teams
14:13:58 <annegentle> Any report on HA Guide?
14:14:20 <annegentle> #info HA Guide - RST migration complete, need help with updating content.
14:14:21 <annegentle> Next team
14:14:32 <annegentle> Install Guides, anyone reporting? Looks like they had a calendar snafu.
14:14:50 <AJaeger> HA guide team is not clear how to continue with publishing - keeping current content or publishing RST one.
14:15:15 <annegentle> #info Install Guides - RST migration complete, testing for Liberty now, content works for keystone, glance, nova, and neutron (but he didn't say which distro)
14:15:27 <annegentle> AJaeger: did the content change?
14:15:45 <annegentle> AJaeger: meaning, it's not updated enough to publish?
14:15:54 <AJaeger> annegentle: on in small areas, so to me it looks like it's not worse than what we have ;)
14:16:13 <AJaeger> But I got no response from the team in the last few days
14:16:18 <annegentle> AJaeger: ah ok
14:16:36 <annegentle> #action HA Guide team needs to determine whether to start publish RST version
14:17:01 <annegentle> Anyone here for Networking Guide team?
14:17:26 <annegentle> They meet on Fridays, not sure if they met last week.
14:17:31 <ShillaSaebi> hello!
14:17:33 <ShillaSaebi> sorry I'm late
14:17:37 <annegentle> hey ShillaSaebi!
14:17:47 <annegentle> Just going through specialty teams now, up to networking
14:17:52 <ShillaSaebi> awesome
14:18:01 <annegentle> Anyone here from security team?
14:18:03 <sicarie> hello
14:18:11 <annegentle> hey sicarie got any updates for Networking?
14:18:18 <sicarie> No, but I can speak to Security :)
14:18:22 <annegentle> sicarie: sounds good
14:18:30 <ShillaSaebi> I was at the ops mid cycle meetup and it was mentioned for people to go through the Networking guide and review it if possible
14:18:42 <sicarie> We completed the RST migration about two weeks ago (thanks again AJaeger!)
14:19:04 <sicarie> Right now we're scoping what we'd like to do for the next paper version - we'd like to get it updated before the Summit
14:19:16 <AJaeger> sicarie: you and the team did the major work, I just pushed you over the edge ;)
14:19:33 <sicarie> And then there should be a discussion on how the paper version should be maintained - on what cadence
14:19:39 <sicarie> AJaeger, but they were great pushes!
14:19:40 <AJaeger> sicarie: we currently do not build PDFs, somebody needs to evaluate this.
14:19:47 <sicarie> Yes
14:19:50 <annegentle> sicarie: right
14:20:02 <sicarie> Right now we're trying to determine if anything is 'missing' that woudl be critical from a security perspective
14:20:02 <AJaeger> sicarie: there's rst2pdf and it worked locally - give it a try.
14:20:12 <annegentle> sicarie: so the team does want printed available on Lulu?
14:20:38 <sicarie> anngentle: If we don't, we need to take that option down
14:20:44 <sicarie> Though I'm not sure i've seen it since the RST migration
14:21:05 <sicarie> The current lulu copy is 1.0, which is ... very old and is now very inaccurate
14:21:09 <annegentle> AJaeger: if you do evaluate, you need the Lulu requirements for PDF.
14:21:12 <annegentle> AJaeger: let me dig them up
14:21:19 <annegentle> sicarie: I can take it down
14:21:28 <sicarie> annegentle: thanks!
14:21:35 <AJaeger> annegentle: I won't have time to evaluate ;(
14:21:53 <annegentle> #action annegentle to remove PDF of Security Guide from lulu.com
14:22:03 <annegentle> I think that's the right way forward
14:22:28 <annegentle> and done
14:22:39 <annegentle> Anything else on security or networking?
14:22:47 <sicarie> Nope - just focusing on current bugs
14:22:53 <annegentle> How about User Guides - and Cloud Admin Guide
14:23:04 <annegentle> #info User Guides - Cloud Admin Guide RST migration complete, work starting on reorganisation.
14:23:34 <AJaeger> We still have some old URLs...
14:23:57 <annegentle> AJaeger: with /content right?
14:24:06 <AJaeger> annegentle: yeah ;(
14:24:07 <annegentle> #link http://docs.openstack.org/admin-guide-cloud/
14:24:12 <annegentle> it's really beautiful though :)
14:24:18 <annegentle> AJaeger: and redirects are in place?
14:24:33 <AJaeger> annegentle: redirects to index.html
14:24:46 <AJaeger> not to single pages - each URL is different ;(
14:25:12 <annegentle> AJaeger: ah, right.
14:25:32 <annegentle> Ok anything else on user guides?
14:26:00 <annegentle> Ok onward to Ops Guide and Arch Design Guide
14:26:07 <ShillaSaebi> ok
14:26:15 <annegentle> #info Ops/Arch Guides - Arch Guide swarm was a success. Plans for reorganisation in Mitaka.
14:26:15 <ShillaSaebi> #Info Two specs have been drafted for the Architecture Design Guide: #link https://review.openstack.org/#/c/214949/ and #link https://review.openstack.org/#/c/216106/
14:26:21 <annegentle> And that's the spec yup
14:26:26 <annegentle> ShillaSaebi: Lana asked for your approval
14:26:38 <ShillaSaebi> Ok I will make sure I take care of that today
14:26:48 <ShillaSaebi> The corresponding blueprints: #link https://blueprints.launchpad.net/openstack-manuals/+spec/archguide-mitaka-reorg  and #link https://blueprints.launchpad.net/openstack-manuals/+spec/archguide-mitaka-rst
14:26:56 <annegentle> thanks
14:27:26 <annegentle> Nice work on the swarm, I heard it was a great time and I'm so glad we have more cores on that side of the world
14:27:29 <annegentle> :)
14:27:39 <ShillaSaebi> for the Ops guide, we discussed having a doc day maybe 1 day after or before the next mid cycle meetup to have people update the guides
14:27:40 <annegentle> In the ops guide there are upgrade instructions.
14:28:09 <annegentle> Wanted to point to comments in https://bugs.launchpad.net/openstack-manuals/+bug/1486250
14:28:10 <openstack> Launchpad bug 1486250 in openstack-manuals "Add upgrade path for Juno to Kilo" [Undecided,Won't fix]
14:28:20 <annegentle> intending to change the way we document upgrades
14:28:31 <ShillaSaebi> ok
14:28:39 <annegentle> Thought this is a good place to communicate that
14:28:55 <annegentle> Anything else on those?
14:29:13 <ShillaSaebi> ok
14:29:14 <ShillaSaebi> nope
14:29:44 <annegentle> ok
14:29:55 <annegentle> on to API docs
14:30:00 <annegentle> I sent out a status update last week
14:30:37 <ShillaSaebi> still looking for Python dev to help out?
14:30:40 <ShillaSaebi> devs*
14:30:44 <annegentle> #link http://lists.openstack.org/pipermail/openstack-dev/2015-August/072557.html
14:31:03 <annegentle> team by team there are joiners :)
14:31:21 <ShillaSaebi> ok I think I have someone in mind that may be able to help, will send them your way
14:31:22 <annegentle> another update is that there's a lot of activity on this thread about generating requests and responses
14:31:23 <annegentle> #link http://lists.openstack.org/pipermail/openstack-dev/2015-August/072743.html
14:32:15 <annegentle> Also, if you're interested in the Compute 2.1 api, see this etherpad
14:32:17 <annegentle> ##link https://etherpad.openstack.org/p/nova-v2.1-api-doc
14:32:25 <annegentle> ShillaSaebi: thanks :)
14:32:33 <ShillaSaebi> cool!
14:32:40 <annegentle> That's it for API docs
14:33:04 <annegentle> Anything on config ref?
14:33:08 <annegentle> gpocentek: any news?
14:33:21 <gpocentek> annegentle: not much no :(
14:33:49 <annegentle> gpocentek: ok fair enough, no news may be good news :)
14:33:55 <ShillaSaebi> heh
14:34:02 <annegentle> I want to say "nothing is on fire" for the notes :)
14:34:11 <ShillaSaebi> thats a good thing
14:34:16 <ShillaSaebi> no complaints here!
14:34:22 <annegentle> #info Config Ref No news to report
14:34:33 <annegentle> Anyone here from training labs?
14:34:55 <AJaeger> Pranav is working on setting up the new repository
14:34:56 <annegentle> Want to make sure you all know we have the training labs specialty team and looks like we'll also add the training guides specialty team
14:34:59 <annegentle> AJaeger: great
14:35:07 <ShillaSaebi> oh so they will be separate
14:35:13 <annegentle> #info training labs contact person is Pranav Salunke
14:35:26 <ShillaSaebi> ok good to know, I thought they were still going to be bundled into 1
14:35:34 <ShillaSaebi> and Majtaz will be the contact for training guides right?
14:35:45 <annegentle> #info training guides contact person is Matjaz Pancur
14:35:58 <AJaeger> ShillaSaebi: yes for now
14:36:01 <annegentle> Should have an email to the list this week
14:36:09 <annegentle> Sean has stepped down from training guides
14:36:14 <AJaeger> Give loquacities an action item ;)
14:36:15 <annegentle> so I think it's pretty well sorted!
14:36:24 <ShillaSaebi> cool
14:36:33 <annegentle> AJaeger: it's Matjaz's comm to make I believe
14:37:04 <annegentle> Ok any other specialty team reports or news?
14:37:18 <annegentle> ShillaSaebi: can I hand over the note taking and topic making? :)
14:37:29 <annegentle> ShillaSaebi: you can go through the rest of the agenda
14:37:31 <ShillaSaebi> sure thing, thanks a lot for stepping in today
14:37:37 <annegentle> np!
14:37:40 <ShillaSaebi> missing my exit set me back 20 minutes hah
14:37:50 <AJaeger> we released openstack-doc-tools 0.30.0 and I have 0.30.1 to release: https://review.openstack.org/#/c/217028/ to fix Japanese Debian Install Guide
14:38:08 <AJaeger> openstackdocstheme 1.2.1 was released as well
14:38:42 <ShillaSaebi> nice
14:38:59 <ShillaSaebi> #topic Countdown to Liberty
14:39:27 <ShillaSaebi> #info We are getting closer to the summit #link http://www.timeanddate.com/countdown/launch?iso=20151015T00&p0=1440&msg=OpenStack+Liberty+Launch+Date&font=hand
14:39:31 <AJaeger> annegentle: I think only you as starter of the meeting can use the magic #topic etc.
14:39:44 <annegentle> ahh
14:39:56 <dbite> annegentle: Im here
14:39:56 <annegentle> #topic Countdown to Liberty!
14:40:01 <annegentle> Now with more exclamation points!
14:40:05 <ShillaSaebi> ahhhh the torch is handed back
14:40:06 <annegentle> hey dbite!
14:40:09 <ShillaSaebi> hi dbite
14:40:18 <dbite> hello
14:40:20 <annegentle> anything to report?
14:41:05 <dbite> We have decided to have two meetings every alternating Thrus, I will announce it in the ML, some part of repo migration is done, some is remaining.
14:41:15 <annegentle> #info 46 days until liberty release
14:41:30 <annegentle> excellent
14:42:02 <ShillaSaebi> time is flying by
14:42:03 <annegentle> #info training labs will have meetings alternating Thursdays, look for ML post with details. Migration nearly complete, work remains.
14:42:07 <annegentle> #link http://www.timeanddate.com/countdown/launch?iso=20151015T00&p0=1440&msg=OpenStack+Liberty+Launch+Date&font=hand
14:42:11 <annegentle> I know, crazy.
14:42:21 <annegentle> Today people should find out if their Summit talks are accepted
14:42:27 <dbite> annegentle: training labs is renamed as OpenStack Labs too.
14:42:28 <ShillaSaebi> great, looking forward to it!
14:44:11 <annegentle> #link https://www.openstack.org/summit/tokyo-2015/tokyo-and-travel/#visa
14:44:24 <AJaeger> dbite, annegentle : Can you really name it "OpenSTack Labs" ? I thought it needs offiical blessing by the foundation
14:44:30 <amandap> annegentle: Great, everyone I know is eager to hear if they were picked
14:44:46 <annegentle> AJaeger: dbite: we discussed in their meeting this week
14:44:56 <annegentle> dbite: using openstack in the repo name isn't needed
14:45:05 <annegentle> and, using OpenStack is a trademark and requires brand permission
14:45:15 <annegentle> dbite: I think you had a poor net connection but can read the logs
14:45:52 <annegentle> https://review.openstack.org/#/c/201160/
14:46:47 <annegentle> dbite: hope that helps
14:46:52 <annegentle> naming, it's tough :)
14:48:34 <annegentle> Any one need help with ATC passes? Another round will go out.
14:48:46 <annegentle> That's it for Liberty release and Summit news I believe.
14:48:59 <annegentle> #topic APAC Meetups
14:49:09 <annegentle> Thanks to Suyog for organizing the swarm! And to the contributors
14:49:17 <annegentle> #topic Spotlight bugs
14:49:26 <annegentle> Look for these in the weekly What's up doc?
14:49:45 <annegentle> #link https://bugs.launchpad.net/openstack-manuals/+bug/1257018
14:49:47 <annegentle> still unassigned
14:49:51 <dbite> Sorry, I lost connection for a bit. Ok, I will remove the name openstack and just keep it labs then. WIll need to edit the spec too.
14:49:52 <openstack> Launchpad bug 1257018 in openstack-manuals "VPNaaS isn't documented in cloud admin" [Medium,Confirmed]
14:49:55 <annegentle> dbite: thanks
14:50:09 <annegentle> #link https://bugs.launchpad.net/openstack-manuals/+bug/1257656
14:50:11 <openstack> Launchpad bug 1257656 in openstack-manuals " VMware: add support for VM diagnostics" [Medium,Confirmed]
14:50:26 <annegentle> This one has an assignee, woo!
14:50:26 <annegentle> #link https://bugs.launchpad.net/openstack-manuals/+bug/1261969
14:50:27 <openstack> Launchpad bug 1261969 in openstack-manuals "Document nova server package (WAS: Enable remote debugging for nova)" [Low,Confirmed] - Assigned to Atsushi SAKAI (sakaia)
14:50:33 <annegentle> #topic Open discussion
14:50:40 <annegentle> want to be sure to leave plenty of time for discussion if there's anything
14:50:57 <annegentle> You all know stackforge is retiring, right?
14:52:12 <AJaeger> annegentle: better say: stackforge namespace is retiring.
14:52:36 <AJaeger> repos can be created in openstack namespace with some rules like stackforge today
14:52:41 <AJaeger> s/some/same/
14:53:27 <dbite> I have a weird question, not sure if this is the right place, but is there HP in the license name of setup.py's? I was under the impression that all the licenses should have openStack Foundation  http://git.openstack.org/cgit/openstack/openstack-manuals/tree/doc/contributor-guide/setup.py
14:53:42 <amandap> AJaeger: Is that being planned or just something that could happen?
14:54:23 <AJaeger> amandap: already announced, read the posts on openstack-dev by James Blair
14:59:19 <AJaeger> time to close the meeting?
15:01:29 <AJaeger> annegentle: ?
15:01:43 <Helimaniac> Seconded
15:02:10 <AJaeger> Helimaniac: seems we lost our chair, I'm sorry ;(
15:02:40 <annegentle> #endmeeting