14:00:48 <annegentle> #startmeeting docteam
14:00:49 <openstack> Meeting started Wed Apr  8 14:00:48 2015 UTC and is due to finish in 60 minutes.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:52 <openstack> The meeting name has been set to 'docteam'
14:01:03 <annegentle> Okay, let's review last action items
14:01:05 <nickchase> hey all
14:01:10 <annegentle> hey nickchase
14:01:13 <annegentle> #topic Action items from the last meeting
14:01:38 <annegentle> ah there was a question without an assignee
14:01:39 <annegentle> For RST conversion: How to address converting audience profiling in Dockbook?
14:02:08 <annegentle> we've addressed audience profiling with the end user guide already, let me look for more context on that question.
14:02:28 <AJaeger> annegentle, see this change I6849989a8ae34638935f76efc174ff909a7a441c
14:02:33 <AJaeger> It's using ":only:"....
14:02:53 <annegentle> yeah I think this is addressed, I can follow up with Darren to make sure he has a deep understanding
14:03:05 <AJaeger> So, "scope" and "only"
14:03:14 <annegentle> I think he and Joseph figured it out though
14:03:44 <annegentle> ok and the action item from meeting before that was "annegentle to FTP delete the XML published networking guide"
14:03:46 <annegentle> that's done
14:04:10 <annegentle> Okay, next topic
14:04:12 <annegentle> #topic Publishing the End User Guide and Admin User Guide from RST
14:04:25 <AJaeger> Looking at https://wiki.openstack.org/wiki/Documentation/Migrate#Publishing_User_Guides
14:04:31 <AJaeger> I'd like to call a stop for patch to the "old" user guides in preparation for publishing: So, let's not touch doc/user-guide, doc/user-guide-admin and doc/hot-guide anymore. I'll remove them tomorrow...
14:04:39 <AJaeger> Who wants to help with step 9? I've signed up for the first two tasks.
14:04:46 <AJaeger> annegentle, do you want to bulk approve all patches yourself?
14:05:00 <AJaeger> other than that we look fine IMHO
14:05:17 <AJaeger> still, I'm sure we'll find issues and can fix them as usual
14:05:19 <annegentle> AJaeger: we are in REALLY good shape, thank you very much!
14:05:34 <annegentle> AJaeger: yeah I can take the rest of step 9
14:05:49 <annegentle> AJaeger: did we have an "update sitemap" task? I can do that
14:06:04 <AJaeger> annegentle, please add to the list, it's not there yet
14:06:20 <annegentle> AJaeger: ok added and signed up
14:06:22 <annegentle> woo!
14:06:25 <annegentle> this is exciting!
14:06:30 <AJaeger> thanks, annegentle !
14:06:39 <AJaeger> Do you want to approve all patches together?
14:06:51 <annegentle> AJaeger: oh like with cascading dependencies?
14:06:54 <annegentle> or
14:06:59 <annegentle> tell me what you mean
14:07:31 <annegentle> will the gate be slow
14:07:33 <AJaeger> I mean: Approve at a specific time together - so that we can approve the patches at the same time...
14:07:38 <annegentle> on April 9?
14:07:39 <AJaeger> no problem with the gate
14:07:42 <annegentle> ok
14:07:43 <AJaeger> yes, tomorrow
14:08:03 <annegentle> ok, yep, let's do all the approvals and switchover tomorrow
14:08:15 <AJaeger> please #action it ;)
14:08:24 <annegentle> #link https://wiki.openstack.org/wiki/Documentation/Migrate#Publishing_User_Guides
14:08:41 <annegentle> #info Anne and Andreas to pick up remaining tasks for publishing User Guides from RST
14:08:45 <annegentle> ok!
14:08:57 <annegentle> well action will be double-checked too late to matter :)
14:09:05 <AJaeger> ;)
14:09:08 <annegentle> hee
14:09:19 <annegentle> #topic Docs specs in review
14:09:26 <annegentle> #link https://review.openstack.org/#/c/170413/
14:09:39 <annegentle> Any chance we have a sc68cal around? I bet he's still sleeping at this hour.
14:10:02 <annegentle> Basically just want to make everyone aware of the incoming First App Tutorial. Sorry about the lack of communication about it.
14:10:15 <annegentle> Please review the spec linked
14:10:33 <annegentle> Any questions? Any other specs we know are coming?
14:10:49 <annegentle> nickchase: We still want a spec to review for the ha-guide.
14:11:01 <annegentle> nickchase: I know we got a TOC update, that's a good start.
14:11:11 <annegentle> nickchase: want to hear more about why it needs to move
14:11:20 <annegentle> any other specs?
14:11:40 <annegentle> I think loquacities was going to write one for the user guide/admin user guide structure
14:11:50 <annegentle> the other specs in review are all from training team
14:12:10 <AJaeger> annegentle, there'Re some for training guides where I don't know what'S going on with them
14:12:28 <annegentle> AJaeger: yeah I don't know either but I expect they're reviewing in their weekly meeting
14:12:33 <annegentle> expect, hope
14:12:34 <annegentle> :)
14:13:03 <annegentle> ok let's move on
14:13:06 <annegentle> #topic Next migration project
14:13:13 <annegentle> So I've compiled some data
14:13:17 <nickchase> I'm sorry, I got called away for a moment
14:13:19 <annegentle> #link https://docs.google.com/spreadsheets/d/10HD6iW1CtfB1qT2wVODYiHdC0ysr4xw392VCqHB-aaY/edit?usp=sharing
14:13:20 <nickchase> I'll be right back
14:13:26 <annegentle> nickchase: ok
14:13:46 <annegentle> I'm still filling in translation info, and added rows for documents that aren't published yet but are being authored.
14:14:04 <annegentle> honestly the readership and authorship surprised me on some of these.
14:14:20 <annegentle> Well the correlation of many readers means more authors wasn't surprising
14:14:30 <AJaeger> ;)
14:14:34 <annegentle> but that the CLI ref isn't highly read gave me pause
14:14:59 <annegentle> And also in this exercise I discovered only docs.openstack.org/developer/nova and /swift even HAVE tracking
14:15:10 <annegentle> so I've logged a bug to investigate https://bugs.launchpad.net/oslosphinx/+bug/1441315
14:15:11 <openstack> Launchpad bug 1441315 in oslosphinx "Web Analytics not being tracked in developer content" [Undecided,New]
14:15:13 <AJaeger> interesting
14:15:22 <sc68cal> annegentle: i'm up
14:15:25 <annegentle> AJaeger: yeah that stinks for any kind of analysis
14:15:28 <annegentle> welcome sc68cal!
14:15:36 <annegentle> Did you have any questions on the spec review?
14:15:38 <sc68cal> annegentle: reading scrollback
14:16:34 <annegentle> sc68cal: sure, go ahead. I'll keep talking about the "next rst" analysis and we can come back to any questions.
14:16:58 <annegentle> So looking at combo of most read and most written, would that be a good measure for "migrate next?"
14:17:10 <annegentle> or if a guide has a lot of contributors already, does that mean it can stay docbook longer?
14:17:36 <annegentle> There's also guides like the Virtual Machine Image Guide that are useful but don't need a lot of maintenance
14:17:48 <annegentle> so a "quiet" book might be okay to migrate quietly, you know?
14:17:50 <annegentle> thoughts?
14:18:30 <AJaeger> migrating is a large task, let's not take too many at once
14:18:39 <annegentle> Also, I couldn't really "count" well for the Glossary since no one seems to read it "standalone" and I don't know how to count links to it, yet.
14:19:13 <annegentle> AJaeger: agreed... I think we can only do 1-2 in any given release if we're realistic. Unfortunately, that means we
14:19:20 <annegentle> we're years from completion
14:19:25 <annegentle> a couple of scenarios
14:19:42 <annegentle> we could focus on install guide since it has a decent reason for splitting (distros, etc)
14:19:51 <AJaeger> we have the newly written network-guide in RST and there'S a proposal to rewrite the HA guide completely
14:19:56 <annegentle> right
14:19:59 <AJaeger> So, that's already two moving forward
14:20:18 <annegentle> and I don't htink we can get ha-guide, install-guide, and networking-guide without hiring contractors or something. nickchase any ideas?
14:20:28 <annegentle> I wish Matt was here.
14:20:52 <annegentle> or Karin to give us insight for priority for install guide
14:21:14 <annegentle> Here's my take. We need to be realistic about what we can really get done.
14:22:04 <annegentle> another scenario would be to leave the install guide alone for another release, migrate Image Guide.
14:22:31 <annegentle> Another scenario would be to migrate the Security Guide since they "win" number of contributors with more than 2 patches. :)
14:22:39 <nickchase> one more moment, I'm sorry
14:22:40 <sicarie> :)
14:22:51 <Sam-I-Am> hello
14:22:54 <annegentle> hey Sam-I-Am
14:23:01 <sicarie> I'd definitely be open to that - would probably want to try to wait until after Liberty
14:23:05 <AJaeger> I think we should also ask which team wants to move forward...
14:23:05 <nickchase> OK, I'm off my call
14:23:09 <nickchase> what did you need fro me?
14:23:22 <nickchase> OK, so ha-guide:
14:23:24 <annegentle> nickchase: wanted to discuss "next RST"
14:23:29 <nickchase> ok, that first
14:23:38 <annegentle> nickchase: yeah we can circle back on other topics
14:23:39 <nickchase> so when we first started talking about ha guide...
14:24:00 <nickchase> we said that we wanted to do it in RST because we were doing so much rewriting that it seemed silly to put it in docbook just to convert it later
14:24:09 <nickchase> this was a few months ago
14:24:15 <nickchase> and I thought we were agreed on it
14:24:34 <AJaeger> nickchase, fine with me - but let's finally write a spec and sign up on it.
14:24:36 <nickchase> I'm putting together the spec today after getting a final look over by Bogdan Dobrelya
14:24:44 <AJaeger> nickchase, great!
14:24:44 <nickchase> agreed.
14:24:51 <nickchase> From there....
14:25:02 <nickchase> we actually already have a list of writers who will tackle topics
14:25:20 <annegentle> I do need to interject, even 3 months ago there were 4-5 fewer projects in OpenStack. so that's why we need specs for agreement
14:25:20 <nickchase> Sam-I-Am has done a great job of prioritizing
14:25:27 <nickchase> that's fine
14:25:31 <nickchase> don't have a problem with it
14:25:33 <annegentle> ok good
14:25:35 <nickchase> just didn't know it was expectedc
14:25:43 <annegentle> we have to adjust with the growth
14:25:43 <nickchase> not a problem
14:25:48 <nickchase> agreed
14:25:50 <annegentle> ya
14:25:53 <nickchase> ok, so that's the HA guide.
14:26:04 <annegentle> so, how important is RST for ha guide and install guide together?
14:26:14 <annegentle> I don't know if that's actually possible.
14:26:15 <nickchase> install guide I can't speak to
14:26:16 <Sam-I-Am> we could use bodies to convert the networking guide stuff from my repo
14:26:23 <Sam-I-Am> that is way way way way behind schedule
14:26:29 <nickchase> Some of it's already converted
14:26:30 <Sam-I-Am> and almost a laugh
14:26:38 <annegentle> Sam-I-Am: but if we assign bodies to that we are deprioritizing other things. That's why we need to discuss it all
14:26:42 <sc68cal> Sam-I-Am: I plan on taking on converting more
14:26:43 <nickchase> I went to do it last night and found a lot of it was already there
14:26:49 <AJaeger> annegentle, let'S not add further conversions, instead concentrate on networking in RST...
14:27:06 <sc68cal> since the provider networking piece was merged
14:27:08 <nickchase> So sam-I-am let's you and I get together later today and decide who's doing what
14:27:13 <annegentle> AJaeger: that's fair, Install Guide remains in Docbook then?
14:27:22 <AJaeger> annegentle, yes IMHO
14:27:24 <Sam-I-Am> the install guide will need to wait until L
14:27:27 <nickchase> ajaeger: and ha guide
14:27:34 <nickchase> because that's not really converting
14:27:36 <AJaeger> nickchase, sure ;)
14:27:37 <nickchase> it's rewriting
14:27:39 <nickchase> thanks. :)
14:27:45 <annegentle> Sam-I-Am: I'd like that to be taken back to the specialty team to make sure it's okay with the team
14:28:30 <AJaeger> so, for Install Guide: No decision to convert yet. If we convert, it will be for Liberty - and needs feedback from speciality team. AGrreed?
14:28:35 <Sam-I-Am> sure.
14:28:37 <annegentle> Don't want to make a big decision either with the transition to a new PTL. So I'd like to have someone write a spec for HA Guide and update the Ntworking Guide one. Then we'll use those reviews.
14:28:40 * AJaeger can't type anymore
14:28:45 <annegentle> heh me neither
14:28:50 <Sam-I-Am> i dont see karin in here
14:29:14 <annegentle> I think the agreement has to be "write specs" at this point.
14:29:22 <annegentle> or "update specs" as it may be
14:29:43 <AJaeger> annegentle, so, three specs: Update Networking, new HA, new First Application
14:29:45 <annegentle> what other blueprints do we expect to see for L?
14:29:49 <nickchase> I'm ok with "updating the networking spec" as long as...
14:29:58 <nickchase> we're not talking about long debates over what goes in it.
14:30:14 <nickchase> As long as it's just "Here's what's in the TOC.  +2. Go."
14:30:21 <annegentle> nickchase: I think we just have to communicate what's going on. Specs are the best way to do that.
14:30:21 <AJaeger> nickchase, does the current spec mention RST? If not, let's add that...
14:30:52 <nickchase> annegentle: that's fine, and the wiki has been public and referenced the whole time we've been doing that, so we haven't been hiding what we're doing.
14:31:02 <nickchase> AJaeger: Not sure but we can add it if it doesn't.
14:31:05 <AJaeger> nickchase, there are many implicit assumptions, let'S bring them out so that we can all help you properly because we know each other'S plans
14:31:16 <annegentle> nickchase: not saying that, not at all.
14:31:30 <annegentle> nickchase: just want to stop the assumptions
14:31:38 <nickchase> I'm fine with that.
14:31:47 <nickchase> Let's just be clear, however that ....
14:32:04 <nickchase> these "assumptions" are what we used to call "agreements" in a less formal environment.
14:32:05 <nickchase> :)
14:32:16 <nickchase> Moving on?
14:32:22 <annegentle> sure
14:32:28 <nickchase> :)
14:32:39 <annegentle> #topic Specialty teams
14:32:45 <annegentle> leads nicely into specialty team reports
14:32:56 <annegentle> We covered ha guide sufficiently I believe
14:33:06 <annegentle> anyone here from training? We want to know what you're doing about your spec review backlog
14:33:20 <annegentle> Also I'd like to hear more about what Training is looking for in space at the Summit.
14:33:28 <annegentle> Really that goes for all specialty docs teams
14:33:46 <annegentle> We should have a preliminary space / time schedule by Friday
14:33:52 <annegentle> so I'll know more then
14:34:40 <annegentle> I've read through the Install Guide meeting notes, nice work you all
14:34:47 <Sam-I-Am> its been... fun.
14:34:50 <Sam-I-Am> and sort of blocked.
14:35:04 <nickchase> We did get the Debian stuff unblocked -- temporarily, at least
14:35:08 <annegentle> Sam-I-Am: seems like you're all the way that you can do
14:35:08 <Sam-I-Am> reasons i'm tired of using packages, #103
14:35:24 <Sam-I-Am> nickchase: debian stuff?
14:35:29 <annegentle> Sam-I-Am: heh. write a blueprint for review if you want it discussed
14:35:38 <annegentle> it being "install from source"
14:35:54 <Sam-I-Am> yeah. i wish we had more response from packagers. or at least people we know we can talk to.
14:35:59 <Sam-I-Am> feels like i'm working in a vacuum
14:36:10 <Sam-I-Am> we're presenting them with useful pre-release feedback
14:36:13 <nickchase> There was the whole debian thing where it was removed from the Install guide pending changes, and then we got the changes, then they were blocked by an OpenStack bug so it does't work
14:36:15 <sc68cal> I could reach out to zigo , he does packaging for debian
14:36:21 <annegentle> Sam-I-Am: yeah I'm surprised there's little response from Chuck
14:36:34 <annegentle> nickchase: can you be more specific?
14:36:53 <zul> what?
14:36:54 <nickchase> zigo has delegated writing for the install guide to Alex Adamov
14:36:58 <nickchase> I spoke to Alex
14:37:03 <annegentle> nice thanks nickchase
14:37:09 <nickchase> He did the changes that he supposedly needed to make
14:37:21 <Sam-I-Am> nickchase: debian was removed because the combo of install guide and debian packages was completely broken and was waiting on a plan to fix all the things
14:37:21 <nickchase> he then ran into a bug that needs to be resolved before his instructions work
14:37:23 <AJaeger> AFAIR annegentle asked for a plan forward - and I have not seen any plan
14:37:25 <annegentle> nickchase: I had asked Alex the same, but hadn't seen many patches, is he unblocked?
14:37:25 <nickchase> but it's a neturon bug
14:37:26 <nickchase> right
14:37:33 <Sam-I-Am> nickchase: i -2'd that patch, because it would break the install guide
14:37:36 <annegentle> nickchase: really really really need communications on that
14:37:39 <nickchase> he was unblocked, then reblocked
14:37:55 <annegentle> nickchase: ok ideally he'd be letting us know, could have avoided the removal of that guide
14:38:05 <nickchase> this was post-removal.
14:38:10 <Sam-I-Am> i have not seen a plan/spec for fixing the debian stuffs
14:38:11 <annegentle> nickchase: ok good
14:38:14 <nickchase> and post- me nagging alex and zigo.
14:38:18 <Sam-I-Am> i saw one patch from alex yesterday and i -2'd it
14:38:22 <nickchase> right
14:38:24 <annegentle> nickchase: is this time too late for alex? I'd love to hear from him too
14:38:31 <annegentle> ah ok, nag away :)
14:38:42 <nickchase> let me see what I can find out
14:38:51 <KLevenstein> (I’m here, btw, just in two meetings at once)
14:38:57 <annegentle> ok
14:39:01 <annegentle> hey KLevenstein :)
14:39:13 <KLevenstein> nickchase: if we can get Alex in on the next install guide team meeting, that’d be cool.
14:39:17 <annegentle> KLevenstein: I think we have the latest status on Install Guide
14:39:28 <nickchase> when is it?  I'll see what I can do.
14:39:31 <KLevenstein> annegentle: the notes from yesterday should sum it up.
14:39:33 <annegentle> One other note about specialty teams.
14:39:48 <annegentle> The Security Guide repo is moving under the new Security project
14:40:02 <KLevenstein> nickchase: details here: https://wiki.openstack.org/wiki/Documentation/InstallGuide#Meeting_information
14:40:03 <annegentle> So it doesn't need to be goverened by docs any more, though we will certainly provide support.
14:40:14 <nickchase> much obliged.
14:40:25 <sicarie> And that support is greatly appreciated
14:40:27 <annegentle> #link https://review.openstack.org/#/c/170172/
14:40:30 <annegentle> sicarie: you got it
14:40:42 <KLevenstein> (I need to switch gears to this other meeting, so ping me if you need me)
14:40:46 <nickchase> that says next meeting is yesterday.  is it weekly?
14:40:58 <annegentle> weekly, yes
14:41:02 <nickchase> k. thx
14:41:17 <annegentle> anything else from specialty teams?
14:41:32 <sicarie> yeah, if I could jump in while still under the umbrella :)
14:41:37 <annegentle> sure sicarie
14:41:41 <annegentle> what's up
14:41:54 <sicarie> I see 'automation' as a column in the Google doc
14:42:02 <AJaeger> annegentle, you need to send a patch to governance to move the repos, 170172 does not change "ownership" of security-guide yet
14:42:11 <sicarie> and that has actually come up in our meetings - we'd like to create a 'security checklist' of sorts
14:42:25 <sicarie> Is there a good resource on docbook automation?
14:42:34 <annegentle> AJaeger: ah yes
14:42:42 <AJaeger> sicarie, not really - see what we do with openstack-doc-tools
14:42:44 <annegentle> #action annegentle to patch openstack/governance to show move
14:43:05 <annegentle> #link https://github.com/openstack/openstack-doc-tools
14:43:08 <sicarie> AJaeger: thanks, I'll take a look
14:43:18 <annegentle> sicarie: really it's just building blocks and then build automation/CI
14:43:28 <sicarie> Also, we have seen the physical copy pop up a few time,so we'd like to push a new lulu version
14:43:38 <annegentle> sicarie: oh good point
14:43:44 <sicarie> annegentle: got it, that might work very well for what we want to do
14:44:09 <annegentle> sicarie: would it be okay for me to somehow give that task to the Foundation? The PDF update?
14:44:11 <sicarie> which ties into my space request at the summit - would be just a sit-down for 10-15 min on a good approach to get that set
14:44:28 <annegentle> With a PTL transition there's all sorts of things that I do that I don't think have to be the docs PTL necessarily.
14:44:31 <sicarie> annegentle: sure - I don't know what it would take to get the current doc ready
14:44:49 <annegentle> sicarie: my thinking is we'd just take today's PDF and upload to Lulu
14:45:11 <annegentle> #action annegentle to give latest Security Guide PDF link to Foundation to upload to Lulu
14:45:23 <sicarie> annegentle: how much time once we give hte pdf will it take for the lulu version to be updated?
14:45:28 <annegentle> it's honestly easier for me to just do it but I'd better training someone
14:45:30 <sicarie> because I might want to wait on that
14:45:39 <annegentle> sicarie: we've been waiting this release. How about we pick a date.
14:45:53 <sicarie> annegentle: sounds good - we've been targeting Liberty with our work
14:46:03 <annegentle> sicarie: say April 30th?
14:46:15 <sicarie> the case studies are a mess, the identity and horizon chapters need quite a bit of work, and I'd like a good review of networking as well
14:46:29 <annegentle> sicarie: are we better off just uploading a better PDF?
14:47:01 <sicarie> annegentle: I would think so - once we get the four sections above taken care of we'll be in MUCH better shape
14:47:40 <annegentle> sicarie: ok, so upload one now or wait?
14:48:10 <sicarie> annegentle: wait - I have two really good contributors I hope to bring on as cores in a little bit, and they're doing very good material work
14:48:27 <sicarie> I think if we target May/June we'll have a significantly better guide
14:48:33 <annegentle> sicarie: okay, sounds good
14:48:38 <sicarie> (though I suppose we can just upload it again)
14:48:48 <annegentle> true.
14:49:09 <sicarie> I don't know if there is cost associated with that, so I'll defer to you guys!
14:49:38 <annegentle> if it's a new edition, then there's cost, and I'd say it's probably a new edition
14:49:43 <annegentle> well, I'll investigate
14:49:47 <annegentle> hard to say
14:49:53 <AJaeger> let the foundation investigate ;)
14:49:57 <annegentle> yes :)
14:49:59 <sicarie> +1
14:50:00 <AJaeger> you wanted to train them ;)
14:50:06 <annegentle> #topic Doc tools update
14:50:17 <annegentle> Okay, Im working on a 2.1.4 of clouddocs-maven-plugin for the Kilo release
14:50:34 <annegentle> should have it ready by next week, then we'll need to update the pom.xml to pick it up.
14:50:57 <annegentle> It has a fix to the Ops Guide output, new links in the API reference, and korean fonts
14:51:11 <annegentle> that's about it. That tool will be retired as soon as we can...
14:51:31 <annegentle> And for the openstackdocstheme (Sphinx theme) we should freeze on 1.0.7 for Kilo.
14:51:36 <annegentle> That's it for tools I believe.
14:51:58 <annegentle> any questions?
14:52:24 <annegentle> #topic Open discussion
14:53:24 <AJaeger> no questions? Good, then I can go home ;)
14:53:34 <annegentle> I have a list of topics started for the summit, I'll share that after we get done with some focused items for the release itself.
14:53:45 <annegentle> This week is the week we should see a lot of driver docs, thanks for keeping up with those reviews.
14:53:45 <nickchase> great.  thanks, all
14:53:55 <annegentle> AJaeger: :) yes!
14:54:00 <annegentle> Okay, thanks all for making it
14:54:02 <annegentle> #endmeeting