15:01:24 <annegentle_> #startmeeting docteam
15:01:25 <openstack> Meeting started Wed Jan 14 15:01:24 2015 UTC and is due to finish in 60 minutes.  The chair is annegentle_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:27 <annegentle_> whew
15:01:28 <openstack> The meeting name has been set to 'docteam'
15:01:37 <annegentle_> welcome to 2015
15:01:44 <annegentle_> #topic Action items from last meeting
15:01:47 <annegentle_> that was sooo long ago :)
15:01:49 <Sam-I-Am> been a while
15:02:05 <annegentle_> no actions from last time
15:02:13 <annegentle_> way back in 2014
15:02:22 <annegentle_> moving on
15:02:25 <annegentle_> #topic Specs ready
15:02:29 <zigo2> hi
15:02:35 <annegentle_> hi zigo2
15:02:42 <annegentle_> we'll get to install guide in a few
15:02:51 <annegentle_> I approved the web design spec
15:03:02 <annegentle_> So the remaining spec for "just" docs is the driver docs
15:03:11 <annegentle_> doesn't look like we have Andreas here
15:03:24 <annegentle_> but he sounded like he was hesitant that we hadn't talked to enough driver doc owners
15:03:34 <annegentle_> my sense is that we need to go forward with the spec and we've shopped it enough
15:03:46 <annegentle_> so I hope to check in with Andreas and approve it this week
15:04:01 <annegentle_> #link https://review.openstack.org/#/c/133372/
15:04:03 <annegentle_> that is the spec
15:04:21 <annegentle_> ah, it's Tom who's hesitant
15:04:38 <annegentle_> he has a 2-phase approach that seems reasonable
15:04:46 <annegentle_> hopefully Andreas can circle back on that
15:04:57 <annegentle_> Other specs in review are for training, anyone from training want to speak to those?
15:05:01 <Sam-I-Am> i havent seen him much lately
15:05:18 <annegentle_> yeah me neither
15:05:22 <annegentle_> just on epiphany
15:05:33 <annegentle_> No sarob, surely too early for him
15:05:49 <annegentle_> Any other discussion on specs for this release?
15:06:15 <annegentle_> There's also the networking guide spec from last release being worked this release, I'll leave that for the specialty team reports
15:06:24 <annegentle_> #topic Specialty teams reports
15:06:36 <Sam-I-Am> networking is here
15:06:43 <annegentle_> Networking, want to go ahead with the latest? I do appreciate the mailing list posts.
15:06:47 <annegentle_> go ahead Sam-I-Am
15:06:49 <Sam-I-Am> sure
15:06:58 <Sam-I-Am> we're back to weekly meetings again and met last friday.
15:07:11 <Sam-I-Am> i finished the neutron dvr scenario and sent it to the SMEs for review mid-december
15:07:24 <Sam-I-Am> i received comments and applied some, but still looking for more details on some issues
15:07:37 <Sam-I-Am> meanwhile, sean collins has started the provider networking scenario
15:07:54 <Sam-I-Am> phil is working on converting his L3 HA scenario to the structure used by the other scenarios
15:08:08 <Sam-I-Am> i'm working on the classic/legacy neutron scenario
15:08:25 <Sam-I-Am> hopefully most of not all of these scenarios will be ready for conversion to docbook by the end of january
15:08:31 <annegentle_> ok great
15:08:33 <Sam-I-Am> or at least ready for sme review
15:08:45 <annegentle_> and you have good sme support?
15:08:48 <Sam-I-Am> next steps include the generic content which i've seen a few patches for
15:08:52 <Sam-I-Am> it comes and goes
15:09:09 <Sam-I-Am> a lot of the work has been more or less reading code and reverse engineering
15:09:22 <Sam-I-Am> at least with the new/experimental stuff like dvr and l3ha
15:09:24 <annegentle_> yah
15:09:45 <annegentle_> I know trystack pulled DVR back after deploying it
15:09:50 <Sam-I-Am> we sort of built from 0 on those, whereas provider networks and classic neutron are somewhat documented
15:10:11 <Sam-I-Am> i think the scenarios will be very useful since they describe functional environments
15:10:12 <annegentle_> right
15:10:20 <annegentle_> yup
15:10:25 <Sam-I-Am> hopefully all of this is done and published by kilo
15:10:34 <Sam-I-Am> where l3ha and dvr should be more prod ready
15:10:43 <annegentle_> fingers crossed. you all have a plan and work to the plan so that's ideal
15:10:51 <Sam-I-Am> pretty much. that's all from me!
15:11:14 <annegentle_> okay, high availability team, anyone?
15:11:33 <Sam-I-Am> they're not highly available yet?
15:11:40 <Sam-I-Am> hi andreas
15:11:41 <annegentle_> welcome AJaeger :)
15:11:46 <annegentle_> So, there's this review: https://review.openstack.org/#/c/143910/
15:11:50 <annegentle_> that needs work
15:12:10 <AJaeger> sorry for beeing late...
15:12:24 <annegentle_> and they do have a weekly meeting time now
15:12:27 <annegentle_> no worries
15:12:30 <annegentle_> #link https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update
15:12:52 <annegentle_> And they're hanging out in #openstack-haguide
15:13:15 <annegentle_> also see
15:13:29 <annegentle_> #link https://etherpad.openstack.org/p/openstack-haguide-update
15:13:48 <annegentle_> Anyone here from Security team?
15:13:57 <annegentle_> I don't know much about their latest status
15:14:04 <annegentle_> And anyone from Training?
15:14:11 <annegentle_> Their weekly meeting is on Mondays
15:14:28 <annegentle_> ok that's it for specialty teams
15:14:29 <annegentle_> Let's move on
15:14:35 <annegentle_> #topic Install Guide discussion
15:14:57 <annegentle_> thanks AJaeger Sam-I-Am and zigo for being here even with the time change
15:15:07 * annegentle_ hangs head in time shame
15:15:15 <Sam-I-Am> it happens
15:15:27 <AJaeger> no worries, annegentle_
15:15:47 <Sam-I-Am> i think we left off just before the debian stuff last meeting
15:15:47 <annegentle_> we had a good discussion last month about hte current state of each install guide
15:16:04 <annegentle_> got some overall agreement on what the goals are for install guides that are in docs.openstack.org domain
15:16:34 <annegentle_> so wanted to talk through possible solutions
15:16:55 <annegentle_> Here's an etherpad with the ideas so far
15:17:19 <annegentle_> #link https://etherpad.openstack.org/p/install-guides-upstream
15:17:34 <annegentle_> right now, Ubuntu/Debian has differences. We could just continue the way things are.
15:17:50 <annegentle_> We could make those two completely consistent
15:17:58 <annegentle_> We could stop publishing Debian version until it's consistent
15:18:01 <Sam-I-Am> annegentle_: right now the debian guide is broken
15:18:02 <annegentle_> or
15:18:07 <Sam-I-Am> based on the bugs i'm seeing
15:18:24 <annegentle_> Maintain debconf/Debian outside of docs.openstack.org with a matching one for docs.openstack.org
15:18:28 <annegentle_> or something else I haven't thought of
15:18:36 <phil_h> My belief is that we should make them consistent
15:18:49 <annegentle_> phil_h: that's great, are you able to do that?
15:19:13 <phil_h> sigh - yes
15:19:25 <Sam-I-Am> annegentle_: i think it would just mean un-debconfing the debian stuff
15:19:36 <phil_h> I know SAM-I-AM is smiling
15:19:37 <annegentle_> phil_h: Sam-I-Am: I do think it's pretty straightforward
15:19:42 <Sam-I-Am> among other stuff (like packaging bugs i'm seeing)
15:19:47 <annegentle_> zigo: but where will you publish your debconf one?
15:20:11 <zigo2> please don't remove the debconf stuff from the docs.
15:20:14 <annegentle_> let's make sure zigo2 and zigo can keep up on his phone
15:20:32 <zigo2> sorry, I' back home soon.
15:20:34 <annegentle_> zigo2: but what do we do about the technical debt? I need solutions.
15:20:41 <Sam-I-Am> zigo2: the debian part of the guide has been broken since at least the juno release
15:20:42 <annegentle_> zigo2: no worries, I'm impressed you can type on your phone :)
15:20:48 <zigo2> coulld we talk about debian in 15 minz?
15:20:53 <Sam-I-Am> it keeps getting more and more bugs that no one triages
15:21:18 <phil_h> And the continual need for maintenance
15:21:18 <annegentle_> AJaeger: was there another technical solution with a conditional chapter we thought of?
15:21:33 <annegentle_> zigo2: absoluletly, we have other agenda items
15:21:35 * AJaeger doesn't remember anything
15:21:44 <annegentle_> ok, tabling the Install Guide topic for now
15:21:48 <Sam-I-Am> mmkay, guess we'll wait
15:22:00 <annegentle_> #topic Doc tools latest
15:22:33 <annegentle_> So, clouddocs-maven-plugin will not have a patch with a "split" like I had thought, so that only OpenStack branding is in the stackforge repo
15:22:48 <annegentle_> Unless I identify someone to do the split, it'll remain where it is.
15:23:15 <Sam-I-Am> what?
15:23:15 <annegentle_> I'd like to do a 2.1.4 release to get a couple of bug fixes in (there's a nasty one in the Ops Guide) then set it on maintenance only
15:23:25 <annegentle_> with releases only about every year if we need it
15:23:31 <Sam-I-Am> who's working on that these days?
15:23:39 <annegentle_> Sam-I-Am: no one, that's the point.
15:23:46 <annegentle_> Sam-I-Am: we have our Sphinx redesign coming
15:23:58 <Sam-I-Am> right
15:23:59 <annegentle_> Sam-I-Am: so the only output we need clouddocs-maven-plugin for is the API reference
15:24:25 <annegentle_> I just want to make sure the doc team knows we have a maintenance plan and the migration plan to Sphinx is what we
15:24:29 <annegentle_> we're planning on
15:25:00 <Sam-I-Am> i'm trying to wrap my head around the sphinx thing
15:25:13 <rromans> roughly what's the timeframe for that migration?
15:25:23 <annegentle_> rromans: the plan of record is in the blueprint
15:25:39 <annegentle_> rromans: just End User Guide and Admin User Guide will be migrated by May 2015
15:25:52 <rromans> annegentle_: tnx!
15:26:10 <annegentle_> #link http://specs.openstack.org/openstack/docs-specs/specs/kilo/migrate-to-new-web-design.html
15:26:37 <AJaeger> annegentle_, let's make that RST move a separate topic, plesae
15:26:42 <annegentle_> AJaeger: sure
15:26:58 <annegentle_> I dont' have anything else on clouddocs-maven-plugin
15:27:16 <annegentle_> Next topic for Doc tools is Sphinx new theme
15:27:21 <annegentle_> #topic Sphinx new theme
15:27:43 <annegentle_> The plan is to create a parallel theme to the "openstack" theme that exists in oslosphinx
15:27:45 <annegentle_> I'm working on that now
15:27:52 <annegentle_> it'll be named openstack-doc or some such
15:28:06 <annegentle_> To ensure we get output like this:
15:28:07 <annegentle_> #link openstack-homepage.bitballoon.com/docs/book
15:28:20 <annegentle_> huh. http
15:28:26 <annegentle_> #link http://openstack-homepage.bitballoon.com/docs/book
15:28:43 <annegentle_> I've just started the work based on the landing page
15:28:55 <AJaeger> thanks, annegentle_ !
15:29:02 <annegentle_> Tom is talking to the Foundation about when/whether to announce a new landing page for docs or not
15:29:25 <AJaeger> last comment by him was: Announce after elections
15:29:51 <annegentle_> AJaeger: ah, was just looking that up
15:30:05 <annegentle_> thanks
15:30:14 <annegentle_> AJaeger: do you want to talk about https://review.openstack.org/#/c/142437/ -- the RST conversion?
15:30:25 <AJaeger> annegentle_, sure
15:30:45 <AJaeger> I started with a proof of concept in a separate directory to see how it looks
15:31:04 <AJaeger> Unfortunately I do not have as much spare time as I had hoped ;(
15:31:15 <annegentle_> AJaeger: what was the makefile for?
15:31:23 <annegentle_> AJaeger: I can help, just want to be sure I understand the approach
15:31:33 <AJaeger> There're not enough good tools to do the conversation, so it's a basic conversation and then cleaning up afterwards - incl. adding content that was thrown away
15:31:40 <AJaeger> The makefile can be deleted.
15:31:52 <annegentle_> AJaeger: my approach was https://wiki.openstack.org/wiki/Documentation/Migrate -- lots of manual cleanup
15:31:56 <AJaeger> That was added by sphinx automatically, we don't need it anymore
15:31:59 <annegentle_> AJaeger: when I did the API docs
15:32:22 <annegentle_> AJaeger: basically, it's XHTML > RST using pando
15:32:24 <annegentle_> pando
15:32:28 <annegentle_> pandoc with a c!
15:32:31 <AJaeger> annegentle_, wasn't aware of that page
15:32:37 <AJaeger> Yeah, I used pandoc as well ;(
15:32:43 <annegentle_> :)
15:32:52 <annegentle_> AJaeger: well do you want me to take the same approach?
15:32:58 <annegentle_> AJaeger: it seems to work
15:33:10 <annegentle_> AJaeger: then we'll have to figure out what to do about duplicate files, reuse.
15:33:21 <AJaeger> let me read the page and then come back. I think it's the best approach.
15:33:40 <annegentle_> AJaeger: okay
15:34:01 <AJaeger> Question is : Do we copy over to some "temp" directory (like my playground) in smaller steps, or do one large conversion?
15:34:24 <AJaeger> and we need to figure out translations
15:34:26 <annegentle_> AJaeger: It's always nice to make smaller pieces put together but for the publish we'd need it all at once
15:34:29 <annegentle_> AJaeger: yes
15:34:36 <AJaeger> playground gets excluded from translations
15:34:40 <annegentle_> AJaeger: ah ok
15:34:55 <AJaeger> WE can use playground for step-by-step and then do a final big switch at the end.
15:35:03 <AJaeger> playground does not get published either ;)
15:35:13 <annegentle_> AJaeger: so I envision it's "Playground to get migrated content, then move to new folder for publish"
15:35:15 <AJaeger> so, once we're happy, we can publish
15:35:22 <AJaeger> annegentle_, exactly
15:35:29 <annegentle_> AJaeger: so should we just merge bits and pieces in playground? I'm good with that approach
15:35:45 <AJaeger> annegentle_, that's what I'm proposing
15:35:49 <zigo> I'm back home now.
15:35:50 <annegentle_> AJaeger: sounds good
15:35:58 <annegentle_> zigo: great timing
15:36:00 <AJaeger> this allows us to work together on it.
15:36:02 <annegentle_> ok, to wrap up on doc tools
15:36:12 <zigo> Sorry, but I planned today for the meeting at 2pm UTC as planned previously.
15:36:15 <annegentle_> #info playground is where we can all work on migrating content
15:36:23 <Sam-I-Am> hi zigo
15:36:33 <AJaeger> annegentle_, any directory starting with playground ;)
15:36:49 <annegentle_> #info merge in pieces to playground-, then publish end-user guide once oslosphinx theme is done
15:36:54 <annegentle_> Seems like we can do that this release
15:37:02 <annegentle_> Anything else for doc tools? Questions?
15:37:06 <alexadamov> Hi Anne and Andreas, I'm from the Mirantis doc team and can help with RST conversion if needed at playground :)
15:37:17 <AJaeger> alexadamov, great!
15:37:27 <annegentle_> alexadamov: excellent! Have you seen https://review.openstack.org/#/c/142437/?
15:37:38 <AJaeger> how do we coordinate work? Should we have a wiki page where people sign up for each file?
15:37:47 <alexadamov> have no permissions
15:37:49 <annegentle_> We could use https://wiki.openstack.org/wiki/Documentation/Migrate
15:38:19 <AJaeger> annegentle_, whatever works ;)
15:38:26 <alexadamov> Wiki looks good!
15:38:27 <annegentle_> AJaeger: ok cool
15:38:38 <annegentle_> AJaeger: alexadamov: thanks for the help!
15:38:41 <KLevenstein> also interested, btw
15:38:46 <annegentle_> KLevenstein: excellent thanks
15:39:04 <annegentle_> Okay let's be sure to leave time for the install guide discussion
15:39:08 <annegentle_> #topic Install Guide
15:39:49 <annegentle_> #link http://eavesdrop.openstack.org/meetings/docteam/2014/docteam.2014-12-03-19.02.log.html
15:39:55 <annegentle_> I also link to last time we met
15:40:07 <Sam-I-Am> i think so too. wheee.
15:40:37 <annegentle_> wow we even talked about ceph last time. whew.
15:40:51 <annegentle_> oh and you got into ansible too hehe
15:41:15 <Sam-I-Am> yeah. we covered just about everything except the debian situation.
15:41:25 <annegentle_> Okay so we also talked about how there's no Canonical doc site
15:41:33 <annegentle_> so the upstream install guide is all that there is for Ubuntu too
15:41:57 <Sam-I-Am> yeah. our guide is more or less the ubuntu guide. rh/suse are probably supplemental in some way, although a lot of people seem to like our guide.
15:41:58 <annegentle_> and we all agree, it's important to have ubuntu and debian in upstream
15:42:05 <zigo> Same for Debian, no other docs out there but the official docs.openstack.org
15:42:12 <annegentle_> the fiddly bit is that it's maintenance
15:42:26 <annegentle_> so, zigo doesn't currently agree with the ubuntu simplified way
15:42:36 <annegentle_> and Sam-I-Am isn't amenable to maintenance of debconf
15:42:41 <annegentle_> is that accurate?
15:42:54 <Sam-I-Am> imho, ubuntu and debian could be really similar and maintained mostly together... except the debconf problem. that and the pile of debian docs and packaging bugs that don't get fixed.
15:42:58 <Sam-I-Am> yeah
15:43:02 <Sam-I-Am> right now the debian guide is unusable
15:43:04 <annegentle_> and I'm not making this a sumo wrestling match, just making sure we know who's where
15:43:07 <annegentle_> :)
15:43:07 <Sam-I-Am> and thats just a bad thing
15:43:09 <zigo> So far, I'm the only person who did the work on the Debconf side, and I don't see it as a big burden.
15:43:15 <phil_h> My belief is they should be as similar as possible and if someone wants to maintain debconf stuff put it in an appendix
15:43:29 <phil_h> that makes maintanence easier
15:43:39 <annegentle_> I do think in my head I have some "debconf solution" that involves a separate chapter
15:43:43 <zigo> Sam-I-Am: Could you tell which part is unuseable?
15:43:48 <annegentle_> but is that okay with zigo?
15:43:56 <annegentle_> and yes, please talk thorugh the details
15:44:02 <Sam-I-Am> zigo: if you want to be responsible for the debian install guide w/ debconf, thats fine. but as it stands, there's a pile of blocker bugs and no one has tested the install guide with juno.
15:44:03 <annegentle_> Sam-I-Am: can you pull a bug list easily?
15:44:11 <Sam-I-Am> http://tinyurl.com/mpjsqpl
15:44:12 <annegentle_> let's size this
15:44:19 <Sam-I-Am> thats a quick search
15:44:20 <zigo> Sam-I-Am: So far, I've been doing all the work, and I'm ok to do more.
15:44:40 <zigo> The only issue is that I'm not sure how to pull a relevant bug list.
15:44:43 <Sam-I-Am> in most cases i've either invalidated them because they're packaging bugs, or assigned them to zigo
15:45:02 <Sam-I-Am> some are minor issues, but there's a few that completely break installations
15:45:19 <zigo> Sam-I-Am: Nothing that I'm aware of ... :(
15:45:27 <zigo> Sam-I-Am: I'll make sure to work on them asap.
15:45:30 <Sam-I-Am> i cant verify these because i dont have a debian installation, but based on what i know about installing openstack, they're big issues.
15:45:33 <zigo> (when I know)
15:45:33 <AJaeger> zigo, when I assign a bug in launchpad to you, I don't remember seeing you followup on them.
15:45:42 <annegentle_> so invalid is when it's a packaging problem that docs can't fix?
15:45:51 <AJaeger> Don't you get notified about the issues?
15:45:51 <Sam-I-Am> annegentle_: thats generally what i do
15:45:58 <Sam-I-Am> annegentle_: and then hope zigo can triage them elsewhere
15:46:10 <zigo> How do I list all bugs assigned to me?
15:46:24 <Sam-I-Am> zigo: advanced search, put you in as the assignee
15:46:27 <zigo> Do I have the access rights to close bugs too?
15:46:33 <Sam-I-Am> yes
15:46:34 <annegentle_> zigo: yes
15:46:36 <zigo> k
15:46:39 <Sam-I-Am> bugs are automatically closed with patches
15:46:40 <zigo> I'll try then.
15:46:42 <AJaeger> zigo, if not - join the documentation bug team
15:46:57 <annegentle_> zigo: but is it realistic to ask you? Is there anyone else with interest?
15:47:03 <AJaeger> zigo, if you need help on how to administer bugs, just ask...
15:47:09 <annegentle_> zigo: I'd be intimidated by doc bugs in the double digits
15:47:13 <annegentle_> zigo: and want a back up person
15:47:21 <AJaeger> annegentle_, +1
15:47:27 <zigo> FYI, I've been busy moving from China to France, which may explain my lower activity on the doc over the last months.
15:47:34 <Sam-I-Am> if we're going to keep the debian-specific content, we need more debian people committed to testing and documentation
15:47:39 <annegentle_> Sam-I-Am: also, does eliminating debconf really fix most of these doc bugs?
15:47:43 <Sam-I-Am> one person for docs and packaging isn't enough
15:48:02 <zigo> I can ask to find someone else.
15:48:16 <zigo> FYI, Mirantis is moving to Debian, so I'm sure I'll find help.
15:48:21 <zigo> alexadamov: Could you help?
15:48:21 <annegentle_> zigo: yeah moving is time-sucking. I could swear, okay, affirm, there is someone else interested.
15:48:22 <Sam-I-Am> annegentle_: most of the bugs i see with debian are debconf not setting something, or setting something wrong, etc. things we can fix by editing config files.
15:48:32 <alexadamov> Yes for sure
15:48:43 <annegentle_> alexadamov: it was you! Maybe. I'm not sure. :)
15:48:44 <zigo> Ok, then you got another Mirantis person to help! :)
15:48:52 <annegentle_> alexadamov: ok, great, thanks.
15:49:00 <alexadamov> I'm the right person :)
15:49:05 <annegentle_> alexadamov: how much onboarding do you need for docs? Do you understand our conditionals?
15:49:23 <annegentle_> I'm happy to set up a meeting for training you on the install guide, not a problem alexadamov
15:49:25 <Sam-I-Am> the other issue with debconf is not a technical one. its the fact that debconf removes a lot of the teaching aspect of the guide.
15:49:41 <zigo> Sam-I-Am: I don't agree with that.
15:49:44 <alexadamov> No yet. I need to get into
15:50:02 <annegentle_> Sam-I-Am: zigo yeah I think that's why I'd like to move debconf into an appendix, for the philosophical matchup
15:50:03 <zigo> Sam-I-Am: If there's some missing information within the debconf chapter explaining what Debconf changes, then we can add some more there.
15:50:17 <annegentle_> zigo: and maybe it already is in a separate chapter
15:50:24 <annegentle_> Sam-I-Am: but we can't be TOO pendantic here.
15:50:33 <annegentle_> Sam-I-Am: I'm a pragmatist also
15:50:39 <annegentle_> Sam-I-Am: some people want the easy button
15:51:00 <Sam-I-Am> annegentle_: without any openstack experience, easy ends in disaster
15:51:09 <Sam-I-Am> annegentle_: sitting in #openstack has told me that
15:51:29 <phil_h> I agree with Sam-I-AM
15:51:54 <Sam-I-Am> people *really* need to understand all the gory details about openstack before automating it
15:52:01 <annegentle_> Sam-I-Am: phil_h sure, but we still have to be working in community on community docs.
15:52:10 <phil_h> I think moving the debconf to an appendix is the best fix for this
15:52:14 <zigo> Sam-I-Am: Again, if you want more explanation of what Debconf does, we can do that.
15:52:17 <annegentle_> phil_h: that's where I'm at too
15:52:33 <phil_h> Ann - I agree, don't interpert this as not wanting to help
15:52:33 <Sam-I-Am> annegentle_: i think it makes sense to eventually say "ok, lets do this with ansible now", but first-timers need to slog up the hill manually
15:52:33 <zigo> Sam-I-Am: Mostly, it just edits things which users would do again, again and again, and avoids typoes.
15:52:35 <annegentle_> alexadamov: Let's set up a meeting time for me to show you the install guide ropes so to speak
15:52:41 <annegentle_> alexadamov: what time zone are you in?
15:52:45 <zigo> Sam-I-Am: It doesn't mean you don't need to understand what you do.
15:52:52 <alexadamov> UTC+2
15:52:55 <phil_h> I want us to move forward and not repeat mistakes of the past
15:53:00 <annegentle_> alexadamov: ok
15:53:08 <Sam-I-Am> zigo: thats fine, as long as the documentation provides meta for what's actually going on... perhaps tells people which config files are being edited, etc.
15:53:09 <alexadamov> thanks!
15:53:34 <annegentle_> phil_h: I want us to work in the community on docs where multiple opinions are allowed and tested. I think moving debconf to a separate chapter enables that
15:53:36 <zigo> Sam-I-Am: Please open bugs for things you think are missing, and I'll edit them.
15:53:44 <Sam-I-Am> unfortunately, typos are a right of passing :)
15:53:57 <annegentle_> #action alexadamov and annegentle to meet to understand Install Guide conditionals
15:53:57 <phil_h> annegentle_: I agree
15:54:06 <zigo> Sam-I-Am: As much as I know, there's enough in the debconf chapter to understand what happens.
15:54:12 <zigo> Sam-I-Am: For example: http://docs.openstack.org/trunk/install-guide/install/apt-debian/content/debconf-dbconfig-common.html ...
15:54:21 <zigo> Sam-I-Am: Do you think there's missing stuff over there?
15:54:29 <zigo> That it's not clear what dbconfig-common does?
15:54:29 <annegentle_> zigo: do you have time to test the current install guide?
15:54:41 <annegentle_> zigo: I think that's what's concerning to Sam-I-Am and us, is the lack of testing
15:54:44 <Sam-I-Am> zigo: i'd have to look through it all again. first thing, though, if we're going to keep debconf... the guide needs testing.
15:54:50 <AJaeger> Isn't it more chapters like http://docs.openstack.org/trunk/install-guide/install/apt-debian/content/keystone-install.html ?
15:55:00 <zigo> annegentle_: I will, yes, but I've been stuck with a libvirt issue over ehre, preventing me from starting instances on my Xen PV VM.
15:55:02 <AJaeger> Where debconf automates everything - compared to other distros?
15:55:18 <Sam-I-Am> AJaeger: yeah, and it doesn't really say whats going on
15:55:24 <Sam-I-Am> like... why are we doing this
15:55:50 <Sam-I-Am> compared to the ubuntu version:
15:55:50 <annegentle_> AJaeger: yes
15:55:52 <Sam-I-Am> http://docs.openstack.org/trunk/install-guide/install/apt/content/keystone-install.html
15:56:09 <Sam-I-Am> "here's what we're doing and why, and here's a look at the config file"
15:56:19 <Sam-I-Am> debconf cant automate production environments
15:56:30 <Sam-I-Am> people need to understand those config files
15:56:35 <Sam-I-Am> so eventually you have to look at them
15:56:48 <phil_h> SAM-I-AM is correct
15:57:00 <annegentle_> Sam-I-Am: or phil_h: who can do a patch that shows the separation?
15:57:03 <annegentle_> that'll let us all review
15:57:13 <annegentle_> by separation, I mean, making parallele.
15:57:18 <Sam-I-Am> annegentle_: what do you mean shows the separation?
15:57:18 <zigo> Sam-I-Am: I can look again at the debconf chapter and add what directives in the config files it's changing.
15:57:18 <annegentle_> which sounds quite the opposite :)
15:57:28 <annegentle_> phil_h: do you really have time to do it?
15:57:33 <annegentle_> I'd like a patch to look at
15:57:48 <annegentle_> zigo: I think it's better if we look at phil_h and Sam-I-Am's idea in a patch
15:57:57 <annegentle_> zigo: and you spend your time testing when you get libvirt working
15:58:03 <phil_h> Not sure about time availability
15:58:03 <annegentle_> wow, 3 minutes remaining.
15:58:09 <annegentle_> zigo: does that make sense?
15:58:10 <Sam-I-Am> zigo: basically, prior to each debconf section, there would be a page saying what all is going on here and why... mention the config files edited, services touched, databases created, etc.
15:58:26 <annegentle_> phil_h: heh. I knew it sounded too easy :)
15:58:30 <zigo> Sam-I-Am: I fully agree with that.
15:58:31 <phil_h> yes
15:58:33 <Sam-I-Am> annegentle_: by patch, you mean disable debconf and make it work like ubuntu?
15:58:37 <zigo> And I do want to spend time doing so.
15:58:45 <zigo> alexadamov: Do you think you could work out patches to do that?
15:58:51 <annegentle_> honestly phil_h and Sam-I-Am seems like we need a patch -- yep Sam-I-Am, make the debian install guide look like ubuntu
15:58:53 <zigo> alexadamov: It'd be a huge help if you do.
15:59:04 <annegentle_> or alexadamov could do it with help
15:59:20 <phil_h> SAM-I-AM - lets talk about what we can get done
15:59:36 <annegentle_> Okay one minute.
15:59:47 <annegentle_> How about I meet with alexadamov, we map out what a patch looks like
15:59:50 <annegentle_> then everyone can review
15:59:56 <annegentle_> the patch
15:59:58 <AJaeger> annegentle_, go for it ;)
15:59:58 <annegentle_> yeah?
16:00:04 <Sam-I-Am> annegentle_: is this the debian-like-ubuntu patch, or the fixes-the-debian-guide patch?
16:00:11 <zigo> Sam-I-Am: There's something you don't understand, "make it work like ubuntu" doesn't work here, it's 2 different distro and 2 different set of packages. I started doing a separate distro install-guide because there was too many "Notes for debian users:"
16:00:29 <zigo> Sam-I-Am: The differences are not only at the debconf vs non-debconf level.
16:00:53 <annegentle_> Cool
16:01:10 <annegentle_> zigo: Sam-I-Am: that's where a patch will help
16:01:12 <Sam-I-Am> zigo: ubuntu and debian shouldnt be very different from a packaging perspective.
16:01:14 <annegentle_> us all see it
16:01:17 <zigo> Sam-I-Am: For example, there's no plugin packages for Neutron in Debian, all is in neutron-common. There's only a single "nova-consoleproxy" package, nothing specific for noVNC, the Xen console or the Spice one.
16:01:22 <annegentle_> Okay sorry I have to end it
16:01:31 <annegentle_> Continue in #openstack-doc please :)
16:01:37 <annegentle_> #endmeeting