03:04:36 <loquacities> #startmeeting docteam
03:04:37 <openstack> Meeting started Wed Mar  5 03:04:36 2014 UTC and is due to finish in 60 minutes.  The chair is loquacities. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:04:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:04:40 <openstack> The meeting name has been set to 'docteam'
03:04:45 <loquacities> heya everyone :)
03:04:48 <Sam-I-Am> hi
03:05:03 <dnavale> hey
03:05:06 <radsy> hi
03:05:14 <loquacities> #topic Action items from the last meeting
03:05:21 <loquacities> i believe we didn't have any :)
03:05:31 <loquacities> #topic Style Guide for config strings going into HACKING.rst
03:05:41 <loquacities> anyone willing to speak to that?
03:06:02 <sgordon> -ve
03:06:10 <loquacities> i think we decided andreas was the guy we needed for that last week
03:06:14 <loquacities> moving on ...
03:06:18 <sgordon> classic andreas
03:06:23 <loquacities> indeed
03:06:28 <loquacities> #topic Operations Guide edits from O'Reilly, master and feature/edits branches
03:06:42 <loquacities> i've seen a bunch of o'reilly edits come through
03:06:46 <Sam-I-Am> seems like anne was working on the last round
03:06:58 <sgordon> well there's none open in the queue
03:07:01 <sgordon> so that's good ;)
03:07:05 <Sam-I-Am> i think she sent it off to publication yesterday
03:07:05 <loquacities> she might be done, then
03:07:10 <loquacities> oooh
03:07:12 <loquacities> exciting :)
03:07:15 <Sam-I-Am> yes
03:07:16 <sgordon> #link https://review.openstack.org/#/q/project:openstack/operations-guide+status:open,n,z
03:07:36 <loquacities> looks promising
03:07:50 <loquacities> #topic Design Summit proposal system will open up this Thurs/Fri
03:08:02 <loquacities> i haven't seen a note about that, has it opened up?
03:08:55 <sgordon> doubt it
03:09:06 <loquacities> i'm sure there would be shouting if it had
03:09:07 <sgordon> everyone is drowning in feature freeze related work
03:09:12 <loquacities> yep, i hear you
03:09:25 <loquacities> #topic API Docs blueprint updated: https://wiki.openstack.org/wiki/Blueprint-os-api-docs
03:09:35 <sgordon> typically it's a little more relaxed than the general cfp
03:09:39 <loquacities> that's more of an FYI at this point
03:09:45 <loquacities> sgordon: true
03:09:46 <sgordon> PTLs have the flexibility to rearrange right up until summit
03:10:02 <loquacities> yep
03:10:14 <loquacities> #topic Giveaways: Oxygen licenses are available, Travel Program for Summit, and Write the Docs in Budapest
03:10:31 <loquacities> not sure if all the oxygen licences are spoken for or not, but email anne if you're interested
03:11:22 <loquacities> and i assume the write the docs ticket is still up for grabs
03:11:37 <loquacities> #topic Installation guide updates for Icehouse
03:11:45 <loquacities> Sam-I-Am: would you like to do the needful, please?
03:11:52 <Sam-I-Am> yes!
03:11:57 <loquacities> :)
03:12:31 <Sam-I-Am> phil hopkins and i have been trying to get icehouse with ML2 working on ubuntu and rhel derivatives
03:12:38 <Sam-I-Am> sgordon has been helping out with the rhel stuff too
03:12:59 <loquacities> neat
03:13:03 <Sam-I-Am> so far ubuntu works
03:13:18 <Sam-I-Am> the rdo packages have some issues with ml2
03:13:26 <Sam-I-Am> i also have ubuntu with nova-net working
03:13:55 <Sam-I-Am> meanwhile, i filed a plethora of bugs today regarding other services that need attention in the install guide
03:14:02 <loquacities> cool
03:14:06 <Sam-I-Am> feel free to confirm them... and fix them :)
03:14:11 <loquacities> will do
03:14:22 <loquacities> i've been slack on reviews the past couple of days
03:14:28 <slong> apologies for my tardiness, and hello
03:14:32 <loquacities> heya slong
03:14:33 <Alexandra> 'ola
03:14:36 <loquacities> glad you could make it :)
03:14:40 <slong> :D
03:14:44 <Sam-I-Am> i'm working with the neutron team to determine the best configs before posting those bugs
03:14:52 <Sam-I-Am> er,  best configs for neutron/ml2
03:14:53 <loquacities> ok, excellent
03:15:10 <Sam-I-Am> seems each milestone changes a bunch of stuff
03:15:16 <loquacities> welcome to open source :)
03:15:25 <Sam-I-Am> i also started working on architecture diagrams for the install guide
03:15:36 <slong> what new ones?
03:15:51 <Sam-I-Am> slong: hi summer
03:15:54 <Sam-I-Am> slong: the diagrams?
03:15:59 <slong> Sam-I-Am: hello :)
03:16:01 <slong> yes
03:16:47 <Sam-I-Am> we decided that having concise, detailed diagrams explaining the requirements for a nova-net install and a neutron-install would be helpful
03:16:58 <Sam-I-Am> the current stuff seems to confuse people
03:17:03 <slong> ah, ta
03:17:11 <loquacities> +1, fwiw
03:17:27 <Sam-I-Am> trying to come up with an extensible theme we can use consistently throughout the install guide
03:18:09 <slong> just curious, what tool are you using to create?
03:18:10 <Sam-I-Am> example... what services run on each node, how many net interfaces, sample IPs that make sense, etc.
03:18:22 <Sam-I-Am> slong: omnigraffle
03:19:21 <Sam-I-Am> so...
03:19:25 <sgordon> mmmm
03:19:25 <Sam-I-Am> making a lot of progress
03:19:30 <loquacities> excellent
03:19:34 <sgordon> is it going to be a problem for people who need to update it later
03:19:34 <loquacities> thanks Sam-I-Am :)
03:19:41 <sgordon> that it is os/x only and proprietary?
03:19:45 <slong> just looked, exactly.
03:19:48 <sgordon> we have a lot of problems with consistent visual style
03:19:58 <sgordon> because nobody can ever get the same tool(s) to use when updating
03:20:00 <Sam-I-Am> sgordon: its osx. it exports svg though. not sure what else to use.
03:20:07 <loquacities> inkscape?
03:20:14 <sgordon> inkscape would be the most accessible
03:20:18 <Sam-I-Am> i thought the main issue was exporting in something vectorized
03:20:20 <loquacities> not that that really helps with consistency of style
03:20:59 <loquacities> an images library would be helpful
03:21:11 <Sam-I-Am> i only really used omnigraffle because i've used it for years and it makes professional-looking stuff
03:21:35 <Sam-I-Am> i can probably re-do them in inkscape
03:22:02 <Sam-I-Am> omnigraffle is kind of like visio
03:22:02 <slong> If it's an svg, inkscape can use it.
03:22:24 <Sam-I-Am> i can connect things, group stuff, etc.
03:23:14 <Sam-I-Am> does inkscape support those things?
03:23:31 <sgordon> yeah, i have used it relatively successfully
03:23:43 <Sam-I-Am> cool. i'll take a look at it tomorrow.
03:23:48 <sgordon> as loquacities says a library of templates would be handy though
03:24:03 <sgordon> stuff like "this is the representation we are going to use for a compute node, always"
03:24:12 <Sam-I-Am> yeah
03:24:22 <loquacities> yeah
03:24:27 <Sam-I-Am> trying to figure out the best way to go about that...
03:24:46 <loquacities> you could just put something on the wiki, in the first instance
03:25:19 <Sam-I-Am> that might work
03:25:29 <loquacities> can i give you an action item?
03:25:54 <Sam-I-Am> loquacities: yeah... i'll see what i can do. is this for general standardization of diagrams?
03:26:16 <loquacities> maybe just starting a wiki page for now?
03:26:28 <loquacities> start small ;)
03:26:44 <sgordon> Sam-I-Am, ideally if we have the bits you use to build these ones in a wiki we can then ensure they are used for future image updates
03:26:49 <sgordon> and continue to build it out
03:26:53 <loquacities> what sgordon said
03:27:03 <Sam-I-Am> or i just live forever :)
03:27:09 <Sam-I-Am> in the cloud, of course
03:27:16 <sgordon> ideally we would convince the UX group to get interested ;)
03:27:25 <loquacities> #action Sam-I-Am to add the image elements he is using to a wiki page, as the beginnings of an image library
03:27:44 <loquacities> we all live forever in the cloud :P
03:27:50 <loquacities> sgordon: +1
03:28:00 <loquacities> ok, moving on ...
03:28:02 <Sam-I-Am> there's a UX group?
03:28:06 <loquacities> #topic Docs core, docs team
03:28:22 <sgordon> #link https://plus.google.com/communities/100954512393463248122
03:28:25 <loquacities> this was discussed at the last APAC meeting with annegentle, and i'm not sure there's been progress since then
03:28:52 <Sam-I-Am> i havent heard anything
03:29:00 <sgordon> yeah
03:29:06 <Sam-I-Am> and as y'all know, i never sleep :)
03:29:09 <slong> :)
03:29:10 <loquacities> lol
03:29:18 <loquacities> ok, let's leave it at that, then
03:29:26 <loquacities> #topic Next APAC F2F
03:29:37 <loquacities> so i really enjoyed the f2f we had last meeting
03:29:44 <slong> Twas good
03:29:46 <loquacities> and it was discussed there that we should do it regularly
03:29:59 <slong> Every other month?
03:30:03 <slong> Every third month?
03:30:17 <loquacities> yeah, i like the idea of every other month
03:30:41 <martinlopes> +1
03:30:42 <brucer> evry 2nd month - cool
03:30:43 <loquacities> which makes the next one either the 9th or the 23rd of april, i think
03:30:44 <dnavale> +1 to that
03:30:47 <ddomingo> +1
03:30:59 <loquacities> are red hat happy to host again?
03:31:16 <slong> sure
03:31:20 <loquacities> awesome
03:31:27 <loquacities> any preferences for the 9th or the 23rd?
03:31:36 <Alexandra> *raises hand* can we has pizza?
03:31:42 <martinlopes> indubitably
03:31:45 <Alexandra> Super :D
03:31:46 <ddomingo> i vote for a later date
03:31:55 <loquacities> that's a vote for the 23rd
03:32:01 <loquacities> anyone else have an opinion?
03:32:05 <ddomingo> oh wait
03:32:08 * slong looks at calendar
03:32:15 <Alexandra> I go for the 23rd.... Rooki-o, loquacities ?
03:32:15 <loquacities> ddomingo: ...
03:32:26 <loquacities> that'd be earlier, Alexandra
03:32:28 <slong> 9th would be better
03:32:37 <Alexandra> loquacities, I know, hence, i'd like the 23rd.
03:32:37 <loquacities> but that's not finalised yet
03:32:38 <slong> Couple of people gone on the 23rd
03:32:43 <Alexandra> loquacities, no, it's not.
03:32:43 * Sam-I-Am feels left out
03:32:44 <ddomingo> +1 for the 9th, i think we have... things.
03:32:56 <slong> Sam-I-Am: should come over here
03:32:56 <loquacities> ok, i think we're tending towards the 9th
03:33:05 <dnavale> wat ddomingo said..
03:33:06 <Sam-I-Am> slong: i told you i'd trade spaces
03:33:07 <loquacities> which might mean Alexandra and i have a conflict, but that's not confirmed yet
03:33:07 <martinlopes> 9th ++
03:33:15 <loquacities> ok, let's run with the 9th for now, then
03:33:19 <martinlopes> ddomingo: truth
03:33:29 <slong> Sam-I-Am: and we're moving into autumn, lovely in Brisbane.
03:33:42 <loquacities> #action loquacities and slong to organise an APAC f2f for 9 April at Red Hat
03:33:44 <Sam-I-Am> slong: think its going to snow cats and dogs here
03:33:52 <loquacities> that sounds painful
03:33:53 <sgordon> Sam-I-Am, +1
03:33:54 <slong> furry...
03:34:00 <sgordon> weather is stuck in a loop, needs a reboot
03:34:03 <loquacities> #topic Open discussion
03:34:07 <Sam-I-Am> sgordon: lol
03:34:10 <loquacities> anything else?
03:34:15 <loquacities> we have the room for another 25 minutes
03:34:39 <sgordon> ciao
03:34:44 <Sam-I-Am> not much here. trying to get things done before the icehouse release.
03:34:51 <ddomingo> just one quick question
03:34:57 <martinlopes> yes ddomingo?
03:35:05 <brucer> lets haveit
03:35:10 <ddomingo> are there any steps being taken to rouse more core reviewers/approvers?
03:35:12 <brucer> don?
03:35:13 <Alexandra> I'm after dommmmm
03:35:21 <Alexandra> don*
03:35:27 <Alexandra> keyboard.
03:35:29 <loquacities> ddomingo: not that i'm aware of
03:35:32 <Sam-I-Am> wasnt that one of the topics in here?
03:35:38 <slong> yes, the voting thing
03:35:49 <slong> Anne was going to look into it.
03:35:50 <ddomingo> all of my latest merges have been approved only by Tom F and Andreas J
03:35:55 <loquacities> yes, annegentle is undecided as to whether we should move to voting for core
03:36:07 <brucer> lets vote about voting
03:36:11 <slong> loquacities: would you like to ask where she's at with that?
03:36:13 <loquacities> afaik, she's also taking steps to weed out unresponsive core members
03:36:21 <loquacities> slong: i'm happy to email her about it
03:36:27 <slong> ta
03:36:36 <loquacities> so, right now she's kind of pruning the list
03:36:42 <ddomingo> ^ +1
03:36:51 <brucer> where is the list of members?
03:36:54 * Sam-I-Am needs more hours in the day to work on content, triage bugs, fix bugs, and review patches :/
03:37:03 <loquacities> and then she'll make a decision about whether to stick with the existing process, or move to a voting system
03:37:16 <loquacities> #action loquacities to chase annegentle about core team changes
03:37:24 <slong> Sam-I-Am: a clone would be good
03:37:26 <ddomingo> thanks loquacities
03:37:30 <loquacities> brucer: i'm not sure if that's public anywhere
03:37:32 <loquacities> np ddomingo
03:37:34 <Sam-I-Am> slong: isn't there a nova command for that?
03:37:35 <brucer> ok
03:37:45 <slong> lol
03:37:45 <loquacities> but i can ask that too :)
03:38:11 <slong> Anybody going to the Tech Girls are Superheroes in Brisbane?
03:38:12 <loquacities> Alexandra: you had a q?
03:38:22 <loquacities> slong: no, it seemed really expensive
03:38:32 <loquacities> although i would have liked to have gone
03:38:33 <slong> Down now to $20
03:38:37 <loquacities> oh!
03:38:40 <loquacities> that changes things
03:38:41 <loquacities> i'll check it out
03:38:44 <slong> Yes, was at 75, don't know what they were thinking
03:38:47 <Alexandra> Yeah, the RH'ers. When I was there, before I left... some of the QE guys did a Git talk. I think it was Marco? But I"m blanking hardcore.
03:38:49 <loquacities> amen
03:38:57 <Alexandra> Any chance someone could find out and see if I can get the slides?
03:39:22 <brucer> Peter Hutterer?
03:39:29 <Alexandra> brucer, was it Peter?
03:39:34 <slong> It was Peter
03:39:39 <brucer> Alexandra: yeah, he did one
03:39:43 <Alexandra> Oh cool! Is he in freenode?
03:39:44 <brucer> and Siopn Baird did one too
03:39:53 <brucer> Simon
03:39:55 <Alexandra> Hahahha
03:39:56 <Alexandra> Siopn
03:39:58 <martinlopes> Alexandra: yeah as whot
03:40:02 <loquacities> sounds celtic
03:40:04 <Alexandra> I was there for Simon's i'm fairly sure.
03:40:13 <brucer> Alexandra: thats Simon in Gaelic
03:40:20 <Alexandra> Could someone do me a huge favour and grab their slides for me?
03:40:29 <Alexandra> I wrote notes, but can't seem to find them.
03:40:33 <brucer> OK, can do
03:40:44 <Alexandra> Thanks brucer!
03:40:59 <loquacities> cool, ok, was there any other business?
03:41:30 <ddomingo> i'm good
03:41:42 <slong> nope
03:41:54 <loquacities> ok, thanks everyone :)
03:41:58 <Sam-I-Am> thanks!
03:42:03 <slong> thx :)
03:42:08 <loquacities> #endmeeting