13:01:15 <berendt> #startmeeting docinstallteam
13:01:15 <openstack> Meeting started Tue Nov 24 13:01:15 2015 UTC and is due to finish in 60 minutes. The chair is berendt. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:19 <openstack> The meeting name has been set to 'docinstallteam'
13:01:26 <Sam-I-Am> its not too bad
13:01:58 <berendt> #topic open action item from last meeting
13:02:13 <Sam-I-Am> was there a meeting last week?
13:02:14 <berendt> meeting times were changed, we should now have the old meeting times
13:02:17 <Sam-I-Am> or was it 2 weeks ago
13:02:25 <berendt> 2 weeks ago, we skipped the last apac meeting
13:02:32 <Sam-I-Am> ok thats what i thought
13:02:52 <Sam-I-Am> i didnt see an updated agenda for today, so i updated it
13:03:19 <berendt> Sam-I-Am: thanks, I want to propose to move the agenda to an etherpad later in the meeting
13:03:35 <berendt> an other open action item was https://wiki.openstack.org/wiki/Documentation/InstallGuide, bmoss worked on it
13:03:46 <Sam-I-Am> yeah
13:04:02 <berendt> I will review the page until the end of this week
13:04:11 <berendt> #action berendt review of https://wiki.openstack.org/wiki/Documentation/InstallGuide
13:04:56 <berendt> https://review.openstack.org/#/c/241320 was abandoned and we started the discussion on the list how to integrate the training lab into the install guide
13:05:03 <berendt> so I think this action item is also completed
13:05:16 <Sam-I-Am> yeah, thats moving in the right direction i think
13:05:35 <berendt> okay, so I think there are no more open items from the last meeting
13:06:05 <berendt> #topic AODH content
13:06:08 <berendt> #link https://review.openstack.org/#/c/230123/
13:06:38 <Sam-I-Am> yep
13:06:43 <berendt> missing packages for rdo and suse at the moment
13:06:50 <Sam-I-Am> looks like rdo finally got packages
13:06:56 <Sam-I-Am> i just dont know about suse
13:07:12 <berendt> #action berendt ask opensuse packaging for the status of AODH packages
13:07:25 <berendt> I will drop them a mail and add a comment to the review request
13:07:34 <Sam-I-Am> need someone to check on that. if suse has packages, we can improve/test the patch on all distros, merge, and consider it for backport
13:07:54 <Sam-I-Am> the ubuntu packages have a nasty bug, but i can work around it
13:07:57 <berendt> I can test the packages on suse if they are there, I will check this
13:08:23 <Sam-I-Am> which reminds me - one thing i also wanted to put on the agenda - getting support from each distro somehow.
13:08:55 <berendt> ok let's discuss this after the other topics
13:08:58 <berendt> #topic Backport Debian patches to Liberty?
13:09:19 <Sam-I-Am> zigo asked this yesterday
13:09:21 <Sam-I-Am> not sure he's here
13:09:26 <berendt> I do not have a strong opinion on this point
13:09:32 <berendt> will zigo do the backports?
13:09:37 <Sam-I-Am> i hope so
13:09:54 <berendt> I think it is fine if somebody takes care of the backports, I will not backport it
13:10:01 <Sam-I-Am> question is do we think debian will work in liberty or should it wait until mitaka?
13:10:14 <Sam-I-Am> i dont tend to like huge backports going into stable
13:10:22 <berendt> +1
13:10:53 <Sam-I-Am> so thats your call, but either way zigo needs an answer (and he should be here)
13:10:54 <berendt> let's wait until we merged all pending review requests for Debian into master, then somebody has to test it for Liberty, if it works for Liberty we can discuss the backports again
13:10:56 <zigo> berendt: I will yes, unless someone works on it.
13:11:19 <zigo> I'll cherry-pick master patches.
13:11:22 <berendt> zigo: can you test Liberty on Debian until the next meeting?
13:11:33 <zigo> berendt: When is the next meeting?
13:11:50 <zigo> Also, all of my patches haven't been reviewed.
13:12:00 <berendt> Wednesday in one week at 0100 UTC
13:12:24 <zigo> Sam-I-Am: Could you remove your -1 on https://review.openstack.org/#/c/241175/ and https://review.openstack.org/#/c/241182/ ?
13:12:38 <zigo> It was my understanding they were due to the "soon freeze" state ...
13:12:49 <zigo> berendt: I wont have time to do that before tomorrow, no>
13:12:49 <berendt> let's try to review and merge pending requests for Debian until the end of this week
13:12:51 <Sam-I-Am> my issue was not addressed on 241175
13:12:54 <Sam-I-Am> so the -1 stays
13:13:05 <berendt> zigo: Wednesday in 1 week, not tomorrow
13:13:25 <Sam-I-Am> i'll look at the other one here in a bit
13:13:51 <zigo> Sam-I-Am: oh, got you now, I'll address it ASAP.
13:14:10 <zigo> berendt: Seems doable then. I'll try, though no promise.
13:14:23 <berendt> okay, let's make two action items, first one to address pending review requests until the end of this week, second one to test Liberty/Debian until the next team meeting
13:14:33 <berendt> zigo: just drop me a line if you cannot handle it
13:14:39 <Sam-I-Am> the entire debian guide will need testing by other people before we publish it
13:14:44 <zigo> berendt: Would you be able to test?
13:14:56 <Sam-I-Am> but its not ready yet best i can tell
13:15:04 <zigo> Hopefully, i'll be able to upload all of Liberty to official jessie-backports by next week! :)
13:15:08 <berendt> zigo: I am not familiar with Debian, I will drop a mail on our list
13:15:18 <zigo> berendt: Cool !
13:15:23 <Sam-I-Am> can probably go piece-by-piece and update the liberty testing wiki page as services work
13:15:29 <berendt> #action take care of pending review requests for Debian
13:15:44 <berendt> #action berendt Write a mail to the mailing list to find somebody who can test Liberty on Debian.
13:16:09 <berendt> #action zigo Test Liberty on Debian until (if possible) the next team meeting.
13:16:47 <berendt> that's fine?
13:18:06 <berendt> let's go forward
13:18:09 <berendt> #topic General feedback on Liberty guide
13:18:18 <Sam-I-Am> so far seems pretty good
13:18:35 <Sam-I-Am> no critical bugs, lots of success in #openstack
13:18:50 <berendt> great :)
13:18:57 <Sam-I-Am> anyone else hearing anything?
13:19:13 <berendt> I do not know about any bugs at the moment
13:19:43 <Sam-I-Am> there's a few in the queue and we should all be trying to discuss/triage them
13:19:56 <Sam-I-Am> it might make sense for us to have a bug triage agenda item
13:20:05 <berendt> #info Liberty install guide: no critical bugs, lots of success in #openstack
13:20:09 <berendt> Sam-I-Am: yes, makes sense
13:20:10 <Sam-I-Am> hit the ones that are more difficult
13:20:26 <Sam-I-Am> guess that needs an #action
13:20:57 <berendt> #action berendt Add bug triage as a permanent item to our agenda.
13:22:09 <berendt> more for liberty? if not i want to discuss mitaka, then we can have a look at open bugs
13:22:16 <Sam-I-Am> nothing here
13:22:23 <berendt> #topic Potential changes for Mitaka guide
13:22:42 <berendt> I think we should write a spec here like for the Liberty and Kilo release.
13:23:03 <Sam-I-Am> yeah, needs a spec. i dont have anything particular in mind outside of mandatory/recommended config changes
13:23:14 <Sam-I-Am> no major architectural changes at least
13:23:19 <berendt> we can add the training lab there
13:23:36 <berendt> Sam-I-Am: do you want to write the spec? you did it the last times.
13:23:52 <Sam-I-Am> sure
13:23:58 <Sam-I-Am> it'll be pretty basic at the start
13:24:19 <berendt> yes of course, then we can extend it over the time and merge it prior to mitaka release
13:24:27 <berendt> I think we did it this way the last times?
13:24:43 <Sam-I-Am> yup
13:24:55 <berendt> #action Sam-I-Am create a basic spec for mitaka
13:25:10 <berendt> more for mitaka at the moment?
13:25:21 <Sam-I-Am> not here
13:25:27 <berendt> #topic bug triage
13:26:09 <berendt> Sam-I-Am: do you want to discuss specific bugs or our bug triage process at all?
13:26:24 <berendt> Sam-I-Am: I think we (at least myself) should spend more time on the bug reports
13:26:36 <Sam-I-Am> https://bugs.launchpad.net/openstack-manuals/+bug/1517970
13:26:36 <openstack> Launchpad bug 1517970 in openstack-manuals "Configure the Block Storage service in OpenStack Installation Guide for Ubuntu 14.04 - kilo" [Undecided,New]
13:26:43 <Sam-I-Am> that one needs testing
13:26:56 <Sam-I-Am> the ceilometer devref says one thing, cinder says another
13:27:03 <Sam-I-Am> i've never seen a problem there, but who knows
13:27:18 <Sam-I-Am> some of these bugs are hard to triage because the problem is not necessarily what it looks like
13:28:22 <Sam-I-Am> i look over the bugs daily and try to triage what i can
13:28:49 <Sam-I-Am> then there's things like this - https://bugs.launchpad.net/openstack-manuals/+bug/1519339
13:28:49 <openstack> Launchpad bug 1519339 in openstack-manuals "Create OpenStack client environment scripts in Installation Guide CentOS 7" [Undecided,New]
13:29:02 <berendt> what about creating a backlog of open bug report in a etherpad? this way it is easier to track the progress of them
13:29:10 <Sam-I-Am> obviously if our doc didnt work, none of the centos testing would work... so this person has a typo somewhere
13:29:15 <Sam-I-Am> most likely
13:29:29 <Sam-I-Am> but it helps to have a lab running to test bugs when you're not sure
13:29:51 <Sam-I-Am> i think the agenda etherpad could also contain a list of open bugs
13:30:02 <berendt> that's good
13:30:41 <berendt> i will change the topic to open discussion and propose the agenda etherpad
13:30:58 <berendt> i think we cannot do more on pending bugs at the moment, we have to spend more time on them to resolve them
13:31:28 <Sam-I-Am> sure
13:31:34 <berendt> #topic open discussion
13:31:41 <berendt> so agenda etherpad is fine?
13:31:44 <Sam-I-Am> yes
13:31:48 <Sam-I-Am> just link to it somewhere
13:31:56 <Sam-I-Am> also, i normally wont make this meeting
13:32:01 <Sam-I-Am> because its 6 AM local
13:32:08 <berendt> #action berendt use an etherpad instead of a wiki page for the agenda (create review request for irc-meetings)
13:32:13 <Sam-I-Am> i just happen to me one time zone over this week
13:32:15 <Sam-I-Am> be
13:32:24 <Sam-I-Am> when DST comes back i can be here
13:32:38 <Sam-I-Am> i was also hoping to see more people here
13:32:42 <berendt> I will try to join the APAC meetings, but this is around 2 am here :(
13:32:45 <Sam-I-Am> now that the meeting is irc
13:32:53 <Sam-I-Am> but i'm guessing that wasn't really the problem
13:33:09 <Sam-I-Am> i'm usually around for the apac meetings
13:33:14 <berendt> #action track pending bug reports in the agenda etherpad
13:33:32 <berendt> #link https://etherpad.openstack.org/p/docinstallteam-agenda
13:34:10 <berendt> anything more?
13:34:14 <Sam-I-Am> not here
13:35:04 <berendt> thank you, let's go back to #openstack-doc
13:35:10 <Sam-I-Am> thanks
13:35:14 <berendt> #endmeeting