01:03:04 <Sam-I-Am> #startmeeting docinstallteam
01:03:05 <openstack> Meeting started Wed Nov 11 01:03:04 2015 UTC and is due to finish in 60 minutes.  The chair is Sam-I-Am. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:03:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:03:08 <openstack> The meeting name has been set to 'docinstallteam'
01:03:12 <Sam-I-Am> i think thats it
01:03:26 <Sam-I-Am> first thing - meeting time, actually date
01:03:31 <fifieldt> matches http://eavesdrop.openstack.org/meetings/docinstallteam/
01:03:40 <Sam-I-Am> yep
01:04:11 <Sam-I-Am> in liberty, the apac and us meeting were swapped so that the apac general docs meeting (30 minutes before now) wouldn't conflict
01:04:21 <Sam-I-Am> i suggest we swap these meetings back
01:04:34 <Sam-I-Am> if nothing else, respond to the existing ML thread
01:05:02 <Sam-I-Am> any thoughts?
01:05:03 <bmoss> I think that makes sense, so long as it doesn't conflict for anyone else.
01:05:10 <Sam-I-Am> well yeah
01:05:10 <bmoss> Current:
01:05:11 <bmoss> Every two weeks (on even weeks) on Wednesday at 0100 UTC in #openstack-meeting-3
01:05:12 <bmoss> Every two weeks (on odd weeks) on Tuesday at 1300 UTC in #openstack-meeting-3
01:05:26 <Sam-I-Am> hence why it'd go to the list. probably just an oversight.
01:05:28 <bmoss> so swap the even and odd weeks there
01:05:40 <Sam-I-Am> also, christian instead of me would be chairing thee first meeting for mitaka :)
01:06:21 <Sam-I-Am> #action suggest week swap on existing mailing list thread
01:06:23 <bmoss> I'll respond to the ML. If anyone else wants to pile on with an opinion, that's good too.
01:06:45 <Sam-I-Am> err, #topic meeting time
01:06:50 <Sam-I-Am> #topic meeting time
01:06:55 <Sam-I-Am> #action suggest week swap on existing mailing list thread
01:06:59 <Sam-I-Am> my brain hurts
01:07:08 <Sam-I-Am> moving on?
01:07:12 <bmoss> yep
01:07:21 <Sam-I-Am> #topic https://review.openstack.org/#/c/241320/
01:07:42 <Sam-I-Am> i'm on the fence about such things for reasons described in the patch
01:08:54 <Sam-I-Am> long story short, we see a lot of people doing first installs in VMs, but supporting a specific semi-commercial hypervisor and then having to test the guide using it in addition to bare metal... lots of overhead.
01:09:18 <Sam-I-Am> content is good, but content in the install guide needs a lot of love to keep it working
01:09:26 <bmoss> could we make this an appendix or something? I.e. make it seem less official, but keep it as information that might help some people get going?
01:09:35 <Sam-I-Am> then comes questions like which version of virtualbox do we support and how do we deal with virtualbox problems?
01:09:44 <Sam-I-Am> sure, except it'll go stale
01:10:01 <fifieldt> I like it as an appendix, if it can be kept up to date
01:10:14 <Sam-I-Am> this might be different if we had some people willing to maintain and test it every cycle... along with triaging bugs
01:10:27 <Sam-I-Am> we'd also have to ask questions in bugs like "is this on a vm?"
01:10:33 <Sam-I-Am> unless the issue was obvious
01:11:19 <Sam-I-Am> anything else?
01:11:28 <Sam-I-Am> do we need to take this to the list?
01:11:36 <fifieldt> I thought the purpose of this patch was to show how to setup the basic vms/nets for the hypervisor, ya?
01:11:41 <bmoss> I wonder if we can get some stats about where people install using the Install Guide
01:11:45 <Sam-I-Am> it is
01:12:10 <fifieldt> it's something that you kinda follow first if you need a bit of help
01:12:16 <fifieldt> but after that it's all install guide
01:12:26 <fifieldt> so I'm not sure it would lead to "is this on a vm?" bugs?
01:12:53 <Sam-I-Am> well, thats why i liked our generic hypervisor comments... "you may need to do these things to your hypervisor... its up to you to figure out the details"
01:13:14 <Sam-I-Am> vs "heres how you do this on virtualbox" which leads to "i did X on virtualbox, and my stuff isnt working"
01:13:31 <Sam-I-Am> and since we 'support' it, we have the burden of triaging the bug or supporting something thats not openstack
01:13:48 <fifieldt> naw, I don't think that changes our triage
01:13:54 <fifieldt> we'd still send those folks to virtualbox for help
01:14:38 <Sam-I-Am> we'll still need testers and maintainers, and probably some limit on versions that work
01:14:40 <fifieldt> perhaps a few more links to virtualbox docs from the proposed patch would be good?
01:14:44 <Sam-I-Am> and concerned about translating screen shots
01:14:56 <fifieldt> yeah, I think the screenshots could go away
01:15:07 <Sam-I-Am> except there's really no other way to show how you configure vbox
01:15:22 <fifieldt> except words :P
01:15:53 <Sam-I-Am> other option is trying to provide pre-configured files
01:15:55 <fifieldt> the patch doesn't seem terribly unmaintainable
01:15:57 <Sam-I-Am> if such a thing exists
01:16:03 <fifieldt> oh yeah, that totally exists for KVM
01:16:05 <Sam-I-Am> in kvm, that'd be ab xml file
01:16:08 <fifieldt> ya
01:16:08 <Sam-I-Am> an
01:16:35 <Sam-I-Am> so, if were supporting vbox, does that mean we also need to support kvm and vmware?
01:16:41 <Sam-I-Am> those are the main three i see people using
01:16:58 <fifieldt> I think that depends on people who want to write and maintain 'em ;)
01:17:02 <fifieldt> this is a "nice to have"
01:17:53 <bmoss> This sounds like something that needs more discussion on the ML. Sam-I-Am, do you mind starting the discussion with your reservations?
01:17:53 <Sam-I-Am> alright... so....
01:18:05 <Sam-I-Am> sure. my reservations are in the patch comments too.
01:18:29 <bmoss> good point. Then maybe just a short email pointing to the patch?
01:18:39 <fifieldt> sounds good to me
01:18:40 <bmoss> see if we can get some more eyes on it
01:18:40 <Sam-I-Am> sure
01:18:58 <Sam-I-Am> #action place issue on mailing list for a wider audience
01:19:09 <fifieldt> it might be that this should just live somewhere more rough and ready :)
01:19:37 <fifieldt> could consider asking osops
01:19:51 <Sam-I-Am> osops?
01:20:06 <fifieldt> the loose collective of ops doing interesting things :)
01:20:15 <fifieldt> they have config snippets, scripts etc at the moment
01:20:26 <fifieldt> doc snippets could be of interest, but *shrug*
01:20:43 <Sam-I-Am> want to take that on?
01:20:47 <Sam-I-Am> get your feet wet agai with docs? :)
01:21:12 <fifieldt> hehe :) sadly I can't commit time for this
01:21:30 <Sam-I-Am> sleep less?
01:22:30 <Sam-I-Am> aight,  moving on
01:22:37 <Sam-I-Am> #topic liberty status
01:23:17 <Sam-I-Am> another wave of annoying but easy to fix bugs came in over the last week or so. i just triaged a bunch and we should try to get to as many as we can prior to the stable/liberty cut in a few days.
01:24:08 <Sam-I-Am> most of these issues seem related to packaging, so its easier to add workarounds than solve them the right way, but we should also open parallel bugs for the packages
01:24:50 <bmoss> I'm starting to have adverse reactions to the word 'packages'
01:25:05 <Sam-I-Am> sounds about right
01:25:31 <Sam-I-Am> for all that the install guide does for packagers, you'd think we would have some hotline to them when we come across a problem
01:25:45 <bmoss> not the worst idea
01:25:51 <fifieldt> indeed
01:25:55 <Sam-I-Am> so far it hasnt happened
01:25:59 <Sam-I-Am> and we've asked, many times
01:26:06 <Sam-I-Am> ubuntu has gotten a bit better
01:26:11 <bmoss> but yeah, let's try to get those done. I'll take a look at the list today. Maybe also advertise on the ML? In the context of getting it done before the cut?
01:26:17 <loquacities> i've got a draft in my email of what a source install would look like
01:26:26 <Sam-I-Am> loquacities: phil's thing?
01:26:30 <loquacities> yeah
01:26:42 <Sam-I-Am> thats a potentially viable option to analyze further
01:26:50 <Sam-I-Am> it fixes one thing at the expense of others
01:26:54 <loquacities> i liked anne's idea of doing an A/B test
01:27:02 <loquacities> yeah, no option is foolproof
01:27:09 <Sam-I-Am> if anything, it would be added to the existing guide
01:27:13 <bmoss> could be worth doing the A/B
01:27:15 <Sam-I-Am> rather than replace
01:27:30 <Sam-I-Am> see how many takers we get. but even to get to that level requires testing and maintenance
01:27:34 <bmoss> loquacities, how much effort do you think it would take to put the source install bit together?
01:27:48 <loquacities> i haven't looked that closely yet
01:28:01 <loquacities> the guide he sent me looks more or less complete as it stands, though
01:28:10 <Sam-I-Am> source installs have come up for almost as long as i've been here. we get some initial content, but no ones willing to test/maintain it.
01:28:33 <fifieldt> hard to get maintainers for something that few use :(
01:29:21 <Sam-I-Am> well, i'd hope people would see the light about source
01:29:49 <Sam-I-Am> anyway, not really enough quorum here to decide anything
01:29:54 <Sam-I-Am> another mailing list thread i guess
01:30:06 <Sam-I-Am> or more of these meetings
01:30:27 <fifieldt> just not how the vast majority are doing their infrastructure, and therefore not a good learning experience :)
01:30:43 <Sam-I-Am> kind of surprised people are using upstream packages
01:30:57 <fifieldt> those who are advanced enough to work with source use it to make their own packages :)
01:31:04 <Sam-I-Am> thats what i figured
01:31:09 <fifieldt> yeah
01:31:15 <Sam-I-Am> but the ultimate source is... source
01:31:21 <Sam-I-Am> not packages from the distros
01:31:23 <fifieldt> feel the source, luke
01:31:31 <bmoss> tautology FTW!
01:31:49 <Sam-I-Am> aight, this drifted a bit off-topic...
01:32:00 <Sam-I-Am> #topic debian version of the installation guide
01:32:30 <Sam-I-Am> long story short, not going to be ready for liberty... and some of the patches going in are inadvertently breaking other distros that we've validated.
01:32:38 <fifieldt> damn :|
01:32:47 <loquacities> yeah, it's messy
01:32:54 <loquacities> but there's action, so unwilling to discourage it
01:33:02 <Sam-I-Am> so i suggest we bump these patches until after the stable/liberty cut
01:33:15 <Sam-I-Am> meanwhile i still have some things to fix from one or two that did make it in
01:33:52 <Sam-I-Am> that was easy
01:33:58 <Sam-I-Am> #topic bug triage process
01:34:37 <Sam-I-Am> just a reminder... please only patch triaged bugs. if you're triaging bugs, make sure you can verify the problem somewhere. most of the bugs we see are not actual bugs, but they get "fixed" and break the guide.
01:35:26 <Sam-I-Am> along those lines... if you're doing a patch review and it adds/changes/modifies/deletes conditionals, make sure the patch doesn't inadvertently mess up rendering of content for other distros
01:35:58 <bmoss> Andreas sent a timely reminder to the ML about that.
01:36:02 <Sam-I-Am> we've taken great leaps to make content less distro-specific, but debian insists on using debconf and that's causing a lot of problems to come back
01:36:16 <bmoss> tbh, not checking the rendered output is a not uncommon problem.
01:36:51 <Sam-I-Am> sure. and the install guide is unique in that respect.
01:36:58 <Sam-I-Am> if you're not used to it, you dont do it
01:37:11 <bmoss> yep. Gotta check all the versions!
01:37:19 <Sam-I-Am> yep
01:37:38 <Sam-I-Am> last topic
01:37:45 <Sam-I-Am> #topic update the wiki page
01:37:51 <Sam-I-Am> apparently this needs an update
01:37:57 <Sam-I-Am> #link https://wiki.openstack.org/wiki/Documentation/InstallGuide
01:38:15 <bmoss> yeah, it is just a bit out of date now.
01:38:19 <bmoss> I can fix it up.
01:38:22 <Sam-I-Am> i'll just assign it to christian since he's not here
01:38:38 <fifieldt> :D
01:38:45 <bmoss> ha!
01:38:51 <Sam-I-Am> or you :)
01:39:11 <bmoss> I've heard fifieldt has a lot of free time.
01:39:20 <Sam-I-Am> he does
01:39:32 <Sam-I-Am> #topic open discussion
01:39:36 <fifieldt> so very much
01:39:44 <Sam-I-Am> anything else?
01:39:59 <bmoss> #action bmoss to update https://wiki.openstack.org/wiki/Documentation/InstallGuide
01:40:28 <bmoss> nope. I'm good.
01:40:35 <Sam-I-Am> aight, time to go drink some tabasco for this fever
01:40:49 <fifieldt> nice
01:40:50 <Sam-I-Am> burn it out!
01:41:07 <Sam-I-Am> thanks everyone
01:41:09 <Sam-I-Am> #endmeeting