13:02:14 <annegentle_> #startmeeting Doc/Web Team Meeting
13:02:15 <openstack> Meeting started Tue Oct  8 13:02:14 2013 UTC and is due to finish in 60 minutes.  The chair is annegentle_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:18 <openstack> The meeting name has been set to 'doc_web_team_meeting'
13:02:20 <annegentle_> hey glad to see everyone
13:02:38 <annegentle_> Agenda is here
13:02:41 <annegentle_> #link https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting#Agenda_for_next_meeting
13:02:47 <EmilienM> o/
13:02:48 <annegentle_> First item up is the action items from last time
13:03:21 <annegentle_> This one's done: AJaeger to remove Networking Admin Guide builds and links
13:03:33 <annegentle_> Thanks Ajaeger! Oh I guess he's not here.
13:03:48 <annegentle_> This one's done too, dianefleming to patch Cloud Administrator Guide for new title
13:04:05 <annegentle_> And I did this one: annegentle discuss Install patches with Shaunm
13:04:44 <annegentle_> And this one: annegentle to add Conventions to the reviewers guidelines
13:04:56 <annegentle_> #link https://wiki.openstack.org/wiki/Documentation/HowTo#Reviewing_Documentation
13:05:10 <annegentle_> That's it for action items
13:05:49 <annegentle_> Oh I should've set the topic to reviewing action items. Ah well.
13:05:53 <annegentle_> Next item: Install guides
13:05:58 <annegentle_> #topic Install guides
13:06:13 <annegentle_> #link https://review.openstack.org/#/c/50118
13:06:30 <annegentle_> it passes the gate now but definitely needs the rest of the outline filled in
13:06:55 <annegentle_> Looks like shaunm isn't here to fill in details but he did write to the mailing list with details
13:06:59 <annegentle_> ah, welcome AJaeger!
13:07:07 <nermina> anything we can do, annegentle_?
13:07:50 <annegentle_> #link http://lists.openstack.org/pipermail/openstack-docs/2013-October/002936.html
13:07:50 <nermina> like repurposing the old material?
13:07:55 <AJaeger> annegentle_, sorry, mixed up times
13:07:56 <annegentle_> here's the latest status ^^^
13:07:59 <annegentle_> AJaeger: no worries
13:08:15 <annegentle_> I am considering just pushing through the install guide patch we have and parceling out the work, what do you all think?
13:08:35 <sgordon> yes...
13:08:38 <nermina> +1
13:08:40 <annegentle_> AJaeger: did say he'd take the OpenSUSE
13:08:42 <sgordon> it really needs to be merged so we can all play
13:08:46 <annegentle_> sgordon: yep
13:08:48 <summerlong> +1
13:08:48 <NickChase> +1
13:08:51 <annegentle_> I'm good with that too
13:08:54 <annegentle_> Okay.
13:08:58 <AJaeger> annegentle_, if you mean openSUSE with lowercase "o" - yes, I do.
13:09:02 <sgordon> :)
13:09:11 <annegentle_> AJaeger: hee hee yes I do yes :)
13:09:18 <nermina> the bullets could be turned into bugs, annegentle_
13:09:18 <AJaeger> and I'm fine with pushing it through. That'S the only way for us to work together on it.
13:09:30 <annegentle_> AJaeger: ok, you and me +2 it and it's done
13:09:58 <annegentle_> Who would like to take the Overview and Sample Arch? What has happened in past releases is Ken Pepple has given us the diagrams for the release, but not usually until the summit
13:10:20 <annegentle_> kpepple: happen to be around? Are you doing Havana arch diagrams?
13:10:35 <nermina> don't we have that in ch_getstarted?
13:10:39 <annegentle_> I can take the short conceptual overview of Glance
13:10:42 <annegentle_> nermina: yeah I think so
13:10:48 <annegentle_> nermina: just didn't know the state of the diagram
13:10:52 <nermina> mirantis updated the graphic
13:10:59 <annegentle_> nermina: oh fantastic
13:11:01 <summerlong> I have an updated diagram with heat/ceilometer
13:11:13 <annegentle_> summerlong: oh very good, let's use that
13:11:16 <summerlong> was in the last RH install guide.
13:11:23 <annegentle_> #action Merge in install guide as-is
13:11:24 <summerlong> when they were still tech preview.
13:12:05 <annegentle_> summerlong: is it like this? (conceputal) http://docs.openstack.org/grizzly/openstack-compute/admin/content/conceptual-architecture.html
13:12:16 <annegentle_> summerlong: or logical? http://docs.openstack.org/grizzly/openstack-compute/admin/content/logical-architecture.html
13:12:57 <nermina> http://docs.openstack.org/admin-guide-cloud/content/ch_getting-started-with-openstack.html
13:13:10 <nermina> for conceptual
13:13:13 <summerlong> hmm, components rather.
13:13:38 <annegentle_> I think we need both, eventually, but at least components for release
13:13:52 <nermina> components are already there in ch_getstarted
13:13:53 <summerlong> yes, conceptual then
13:14:02 <annegentle_> nermina: ok looks good
13:14:08 <summerlong> looks like that can be used.
13:14:30 <nermina> we need to update the logical still and i'll push for it
13:14:35 <annegentle_> looks like there's a need for cinder install chapter
13:14:41 <annegentle_> there is stuff in grizzly for that
13:15:07 <annegentle_> and we will need to know how Solly Ross is getting along with Neutron, anyone know him?
13:15:28 <annegentle_> I would also be willing to take the Swift chapter
13:15:38 <nermina> need someone to move the stuff from the old, annegentle_? i could do it.
13:15:45 <annegentle_> #action annegentle to work on glance conceptual intro, and swift install
13:15:59 <annegentle_> nermina: well also need to test the old, is that do-able?
13:16:02 <AJaeger> annegentle_, should we use some etherpad/wiki for documenting what needs to be done and who sigend up?
13:16:03 <koolhead17> annegentle_: i can help you too with that
13:16:27 <nermina> won't be done by release, but it could be a continuous work
13:16:30 <annegentle_> AJaeger: yes, let's use https://etherpad.openstack.org/havanainstall
13:16:32 <annegentle_> #link https://etherpad.openstack.org/havanainstall
13:16:38 <NickChase> annegentle_: we can test
13:17:14 <annegentle_> NickChase: ok, cool
13:17:36 <annegentle_> Ok adding names next to items in that etherpad
13:17:48 <NickChase> (At least, I think we can.  If we run into issues I'll let you know. :))
13:17:50 <annegentle_> nermina: are you able to take in the KVM config?
13:17:57 <nermina> yes
13:18:13 <annegentle_> NickChase: yep, understood! :) Shaun bought two laptops and 2 USB NICs for testing
13:18:47 <annegentle_> Ok let's have Shaun do the basic network stuff to allow access to booted images
13:19:12 <annegentle_> koolhead17: do you have Cinder setup and can you test those instructions from Grizzly?
13:19:33 <koolhead17> annegentle_: i have swift + ubuntu 12.04 grizzly
13:19:41 <koolhead17> swift+keystone
13:19:49 <summerlong> annegentle: Can look at the Cinder chapter, have havana
13:19:49 <annegentle_> koolhead17: oh! Ok cool, can you review my patch then?
13:19:54 <koolhead17> sure
13:20:27 <koolhead17> annegentle_: we need to sync the keystone user/pass when we are adding it to other components
13:20:29 <annegentle_> Ok, anyone want to do a patch for the booting and playing around with images?
13:20:41 <annegentle_> koolhead17: oh good point
13:21:18 <annegentle_> Anyone want the Cinder chapter? There is grizzly stuff, just a matter of testing and patching
13:21:31 <nermina> i'll take cinder
13:21:45 <annegentle_> nermina: thanks!
13:21:48 <nermina> np
13:22:24 <annegentle_> oh nermina can you also take the Overview using the Getting Started stuff you did?
13:22:31 <koolhead17> annegentle_: so someone has to come up with keystone deployment chapter first & let us know the convention he/she is using
13:22:32 <annegentle_> nermina: might be just an xi:include really
13:22:33 <nermina> yes
13:22:39 <nermina> indeed
13:22:40 <koolhead17> so we can use same with other component
13:22:42 <summerlong> annegentle: can do the Images check.
13:22:58 <annegentle_> koolhead17: keystone is in https://review.openstack.org/#/c/50118/ so yeah just make sure you check what's there
13:23:05 <annegentle_> summerlong: awesome thanks
13:23:20 <koolhead17> annegentle_: let me go through it
13:23:33 <annegentle_> koolhead17: okie
13:23:58 <annegentle_> alright anything else? I know that leaves Neutron kind of in the hands of someone not here, but, what else should we do to mitigate that risk?
13:24:02 <nermina> annegentle_ confirming
13:24:34 <AJaeger> btw. current install guide has 38 pdf pages
13:24:44 <koolhead17> AJaeger: ^^
13:24:59 <annegentle_> AJaeger: ee, lightweight, is that good or bad?
13:25:00 * AJaeger will go through all 38 pages and check that we didn't miss anything
13:25:04 <nermina> i saw a team come across the launch pad wanting to correct neutron, annegentle_
13:25:16 <nermina> follow up, perhaps?
13:25:32 <annegentle_> nermina: oh for sure, were they logging bugs in launchpad or were they on the list or?
13:25:37 <AJaeger> annegentle_, the basic install guide had the same amount, so it looks a bit light - but there's also some stuff missing as we discussed
13:25:49 <nermina> list, i believe. need to check.
13:25:50 <annegentle_> AJaeger: yeah okay
13:25:57 <annegentle_> nermina: ok thanks
13:26:09 <annegentle_> shall we meet again next week to stay on top of the install guide and release?
13:26:12 <koolhead17> annegentle_: i don`t have RHEL to test.
13:26:28 <NickChase> +1
13:26:29 <koolhead17> so the redhat part needs to be reviewed someone else
13:26:39 <annegentle_> koolhead17: ok
13:26:48 <annegentle_> NickChase: good, will put it on the calendar
13:26:48 <nermina> +1
13:26:58 <AJaeger> can we ask sgordon to look at RHEL?
13:27:08 <koolhead17> AJaeger: yups sounds perfect
13:27:08 <annegentle_> or summerlong?
13:27:15 <sgordon> or both ;)
13:27:21 <radsy> I have RHEL here
13:27:42 <annegentle_> ok yes all the testers we can get!
13:27:43 <sgordon> probably worth building a PDF and linking it from the RDO forum
13:27:47 <annegentle_> thanks radsy
13:27:52 <annegentle_> sgordon: good idea
13:27:56 <summerlong> I have RHEL :), just trying to see what needs doing by koolhead17
13:28:04 <AJaeger> sgordon, the PDF is ready - justdownload it from docs.o.o/trunk
13:28:25 <annegentle_> I know it still feels a long way off but we are in much better shape for havana install than we were with grizzly
13:28:29 <koolhead17> summerlong: the commands/pkgs i would assume :D
13:28:36 <radsy> is this for the basic install guide?
13:28:53 <annegentle_> koolhead17: it sounds like shaun tested fedora first
13:29:03 <annegentle_> koolhead17: and is looking for ubuntu testing
13:29:11 <annegentle_> but yeah to testing all of it :)
13:29:13 <AJaeger> radsy, there'S no basic install guide anymore, only *the* Install Guide
13:29:19 <koolhead17> annegentle_: sgordon is fedora/RDO pkg same?
13:29:20 <AJaeger> See docs.openstack.org/trunk for the list of guides
13:29:20 <annegentle_> ok, any questions?
13:29:26 * koolhead17 is confused
13:30:10 * summerlong is too. Lots of input before a once-through testing can be done?
13:30:45 <annegentle_> summerlong: I think a once-through is not yet possible with what landed today
13:31:33 <summerlong> annegentle_: yes, which is why I was asking about specifics?
13:31:57 <annegentle_> summerlong: ah yes. koolhead17 just asks for distro helpers all the time :)
13:32:06 <annegentle_> koolhead17: your wish has come true, look at all the help!
13:32:15 <summerlong> :)
13:32:24 * koolhead17 is dancing
13:32:43 <koolhead17> summerlong: so RDO & Yum repo for fedora/RH are same correct?
13:32:50 <annegentle_> I would like to know if packaging is the same for rhel and fedora
13:32:59 <koolhead17> ditto
13:33:42 <annegentle_> is it RDO everywhere?
13:33:43 <radsy> koolhead17, http://docs.openstack.org/trunk/install-guide/install/yum/openstack-install-guide-yum-trunk.pdf is the doc? I am happy to help review on a RHEL 6.4 machine.
13:33:48 <summerlong> RDO is the distro.
13:34:19 <AJaeger> radsy, yes that's the pdf
13:34:39 <annegentle_> thanks radsy
13:34:42 <koolhead17> summerlong: radsy so when we are talking about install pkg what should we focus on
13:34:50 <koolhead17> yum repo for openstack
13:35:01 <summerlong> koolhead17: http://repos.fedorapeople.org/repos/openstack/openstack-havana/
13:35:16 <radsy> http://openstack.redhat.com/Quickstart talks about RHEL, CentOS, Fedora, and links to http://rdo.fedorapeople.org/ for all
13:36:01 <radsy> summerlong's link, actually
13:36:03 <koolhead17> summerlong: radsy i would request you guys to double check the patch once it lands so it works for fedora/RH/Centos all 3
13:36:04 <koolhead17> :)
13:36:50 <summerlong> kk, put us on as reviewers?
13:36:58 <koolhead17> annegentle_:  ^^
13:37:02 <annegentle_> sure
13:37:05 <annegentle_> Ok better keep moving, let's move on to the next topic, doc tools.
13:37:11 <annegentle_> #topic Doc Tools Update
13:37:36 <annegentle_> The maven plugin is now at 1.11.0, so we'll try to standardize on that for Havana, but we did just do a sweep for 1.10.0
13:37:49 <annegentle_> But, I'd like to use 1.11.0 to get the "log a bug" link on each page
13:37:52 <annegentle_> Sound good?
13:37:59 <AJaeger> Yes!
13:38:01 <summerlong> +1
13:38:17 <NickChase> +1
13:39:19 <annegentle_> woo! Yet another great outcome from docs boot camp
13:39:53 <NickChase> definitely
13:40:38 <AJaeger> Another note: The gating has changed, we use now tools/test.py. For details see http://jaegerandi.blogspot.de/2013/10/improving-openstack-documentation-build.html
13:40:52 <annegentle_> AJaeger: oh thank you for blogging that!
13:40:58 <annegentle_> #link http://jaegerandi.blogspot.de/2013/10/improving-openstack-documentation-build.html
13:41:21 <annegentle_> AJaeger: you are doing a lot of what we talked about at boot camp, even with out attending, so it's like you're a mind reader
13:41:35 <nermina> thanks, ajaeger
13:41:52 <AJaeger> annegentle_, I'm long enough around in Open Source communities ...
13:42:03 <summerlong> a jaeger, --check-niceness is my new best friend.
13:42:10 <annegentle_> AJaeger: you picked up mind reading from open source, that's a success story :)
13:42:11 <nermina> :)
13:42:24 <AJaeger> annegentle_, a miracle ;)
13:42:39 <koolhead17> AJaeger: nice
13:42:47 <annegentle_> Ok, that's all I had on doc tools
13:42:57 <annegentle_> #topic Bug reports and DocImpact
13:43:01 <annegentle_> #link https://bugs.launchpad.net/openstack-manuals/+milestone/havana
13:43:03 <AJaeger> If you notice anything wrong with the tools, just ping me
13:43:08 <annegentle_> #link https://bugs.launchpad.net/openstack-api-site/+milestone/havana
13:43:39 <annegentle_> Again, here we are in much better shape than last release and I'm comfortable with releasing docs with code, but there are still undocumented features
13:43:43 <annegentle_> I also thought I'd talk about release notes
13:44:03 <annegentle_> Some DocImpact things are also release note items, previously the PTLs did all the release notes on the wiki, and I think that'll continue
13:44:08 <sgordon> release notes also kinds of leads to *shudder* upgrades
13:44:17 <annegentle_> sgordon: ooh shiver
13:44:43 <sgordon> we have a generic process/task in the ops guide obviously but each release their are per-project gotchas we need to beat out of the PTLs
13:44:50 <annegentle_> also ttx makes sure release notes are done
13:45:04 <annegentle_> Examples: https://wiki.openstack.org/wiki/ReleaseNotes/Folsom
13:45:14 <annegentle_> https://wiki.openstack.org/wiki/ReleaseNotes/Grizzly
13:45:27 <annegentle_> #link https://wiki.openstack.org/wiki/ReleaseNotes/Havana
13:45:33 <annegentle_> ^^ those are the ones for this release
13:45:34 <uvirtbot> annegentle_: Error: "^" is not a valid command.
13:45:52 <annegentle_> so far Keystone has the best start
13:46:09 <annegentle_> do you have suggestions for how/if we should help? I sense that we have good data from DocImpact
13:46:57 <annegentle_> I'll let you all read for a bit :)
13:47:21 <nermina> annegentle_, this should be ready for the release, no doubt. we need to try to interview ptls.
13:47:26 <NickChase> I'm actually putting together a "what's new in Havana" piece and having the devil's own time getting information
13:47:41 <AJaeger> annegentle_, shouldn't we add a section about Documentation up there as well and point out the new manuals?
13:47:43 <NickChase> word is the release notes aren't guaranteed until the 17th
13:47:47 <annegentle_> NickChase: yes it's not easy, please do figure out how to use that in the official rel notes
13:47:54 <annegentle_> AJaeger: oh great idea
13:48:00 <annegentle_> NickChase: right not at all
13:48:26 <annegentle_> AJaeger: are you up for that or do you want me to do it?
13:48:45 <AJaeger> What about I'll do the first shot - and you clean up afterwards?
13:48:45 <NickChase> annegentle_: use what in the release notes?  "Whats new" or docimpact?
13:49:04 <annegentle_> NickChase: it's a judgement call, but docimpact is a great starting point to look for new features
13:49:17 <annegentle_> NickChase: blueprints for each project is also a good way to spelunk
13:49:32 <NickChase> blueprints is what we're doing, actually
13:49:35 <annegentle_> NickChase: and mostly it's about new features and pitfalls/gotchas
13:49:40 <NickChase> in fact, I have an update meeting on that in 10 minutes. :)
13:49:44 <annegentle_> NickChase: heh
13:49:58 <NickChase> there were several hundred to wade through. :(
13:50:20 <annegentle_> NickChase: right, I know how it is -- and this release is staggering
13:50:26 <nermina> get on their agendas and let them talk about items point by point
13:51:03 <NickChase> nermina: if necessary; but they're so busy I don't know if we'll even be able to.
13:51:10 <NickChase> but I'll have a better idea fater this next meeting.
13:51:15 <nermina> they do meet on irc :)
13:51:16 <annegentle_> nermina: yes that's always helpful, also an easier catchall is the weekly release meeting on Tuesdays at 4:00 CST
13:51:18 <sgordon> fwiw i have been tasked independently with going through nova blueprints
13:51:18 <NickChase> after, even. :)
13:51:25 <sgordon> there are ~90 of them implemented for havana
13:51:31 <NickChase> nermina:  details, details. :)  good idea, thanks.
13:51:46 <sgordon> but i can probably put together a reasonable "this is what's new" at least for that project
13:51:51 <annegentle_> my sense of the doc bugs is that they could be grouped, like all Xen, all Neutron, and we use tags for that
13:52:10 <annegentle_> so I feel good about the release (other than the usual nervousness about the install guide)
13:52:17 <NickChase> sgordon: I would be eternally grateful
13:52:20 <annegentle_> any questions about doc bugs, docimpact? release notes?
13:52:30 <koolhead17> NickChase: http://status.openstack.org/release/ << this is your friend
13:52:31 <koolhead17> :D
13:52:34 <annegentle_> sgordon: oh there's a good idea
13:53:06 <NickChase> koolkead17: yes, that's what we're using, thanks. :)
13:53:12 <sgordon> annegentle_, perhaps worth picking up a project each if people are free? a lot of the blueprints are low-quality in terms of detail but the groupings quickly become obvious
13:53:23 <annegentle_> koolhead17: it's still intimidating as hell to try to distill :)
13:53:34 <koolhead17> annegentle_: hahaha
13:53:39 <annegentle_> sgordon: yes, great idea
13:53:43 <nermina> sgordon, good idea
13:53:46 <annegentle_> sgordon: which did you already do?
13:53:55 <sgordon> annegentle_, working through nova
13:54:00 <NickChase> great idea
13:54:12 <sgordon> i dumped the list of implemented blueprints and a spreadsheet and am working on grouping them up into areas
13:54:14 <annegentle_> sgordon: oh yeah nova (I need to read better!) :)
13:54:18 <sgordon> like "cells", "scheduler" etc
13:54:20 <annegentle_> sgordon: great idea
13:54:23 <annegentle_> I'll take glance
13:54:28 <NickChase> I think we are doing Neutron
13:54:32 <annegentle_> #action sgordon to share patterns for nova
13:54:45 <annegentle_> #action annegentle to dive into glance new features for release notes
13:54:46 <NickChase> That is, i think that's what I'm going to see shortly
13:55:00 <annegentle_> #action NickChase deep dive into Neutron new features
13:55:03 <annegentle_> I like it
13:55:11 <annegentle_> Ok, let's circle back next week with our findings? Sound good?
13:55:18 <annegentle_> anyone else want swift?
13:55:18 <NickChase> wonderful.
13:55:30 <sgordon> +!
13:55:32 <annegentle_> ceilometer? heat?
13:55:32 <sgordon> +1
13:55:34 <nermina> i could take ceilometer
13:55:42 <summerlong> NickChase: since am working on the Image chapter, will look at those new features
13:55:48 <annegentle_> #action nermina to study ceilometer features for rel notes
13:55:50 <NickChase> summerlong: thank you
13:55:54 <annegentle_> summerlong: ok great
13:56:07 <annegentle_> #action summerlong to look at Glance new features (not annegentle)
13:56:12 <annegentle_> how do I cancel a previous action? Hrmity
13:56:39 <NickChase> maybe #inaction ?  (sorry, jk)
13:56:40 <sgordon> #undo
13:56:42 <sgordon> i think
13:56:54 <annegentle_> #undo #action annegentle to dive into glance new features for release notes
13:56:55 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x332e9d0>
13:56:55 <nermina> lol at nickchase
13:56:59 <annegentle_> NICE
13:57:06 <nermina> indeed
13:57:13 <annegentle_> koolhead17: do you have a list of new Swift featuers already?
13:57:24 <annegentle_> for 1.9.0
13:57:39 <koolhead17> annegentle_: not yet. i will ping notmyname
13:57:44 <annegentle_> koolhead17: ok thanks
13:58:08 <annegentle_> #action koolhead17 to ask Swift PTL notmyname for feature set for release notes
13:58:21 <annegentle_> ok, we're nearing top of the hour and I want to open it up
13:58:30 <annegentle_> wait, summit planning
13:58:33 <annegentle_> #topic Summit planning
13:58:45 <annegentle_> I'll be in Hong Kong, and we have 4 slots for docs
13:59:19 <koolhead17> annegentle_: is there deadline for getting the notes?
13:59:31 <koolhead17> like a day or two brfore 17th correct
13:59:38 <annegentle_> I reserved one for translation, Tom has two in for restructure and automation, then Everett Toews has one about documenting app dev resources
13:59:52 <NickChase> which would be next Tuesday's meeting
14:00:00 <annegentle_> koolhead17: yes, Oct 15th would be grand, most other PTLs sound like they're aiming for Oct 17
14:00:07 <annegentle_> NickChase: yep
14:00:23 <koolhead17> annegentle_: thanks
14:00:37 <annegentle_> so, if you won't be in hong kong, do send blueprints for discussion on the list
14:00:57 <annegentle_> like Diane and AJaeger are doing, those are good examples
14:01:03 <annegentle_> and I'd be glad to get more proposals for the summit
14:01:12 <annegentle_> not to look too far ahead with the release barrelling at us :)
14:01:13 <sgordon> summer and i will both be in hong kong, still working out scheduling myself :)
14:01:26 <annegentle_> sgordon: WOO!
14:01:47 <annegentle_> our slot is first thing after the keynotes Tues
14:02:19 <koolhead17> cool
14:02:21 <annegentle_> Ok, sorry to go over, I'll open it up to discussion in #openstack-doc so that the training team can meet
14:02:24 <annegentle_> #endmeeting