17:59:30 <Kiall> #startmeeting DNSaaS
17:59:31 <openstack> Meeting started Wed Dec 19 17:59:30 2012 UTC.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:59:34 <openstack> The meeting name has been set to 'dnsaas'
17:59:47 <Kiall> Okay.. Hiya!
17:59:57 <Kiall> Agenda: http://wiki.openstack.org/Meetings/DNSaaS
18:00:08 <zykes-> only me and you here or ?
18:00:26 * andrewbogott is lurking :)
18:00:27 <Kiall> CaptTofu's around, JC is away (but I've got some input from him via email)
18:00:44 <Kiall> and simon is about.. but not sure he's realized it's in here just yet ;)
18:00:49 <zykes-> :p
18:01:34 <Kiall> So - Obviously, last weeks meeting never happened. I was with HP in Seattle for the week, and the TZ difference screwed me over!
18:01:41 <CaptTofu> greets
18:01:44 <Kiall> Apologies!
18:01:53 <CaptTofu> I forgive you :)
18:01:57 <CaptTofu> it's all my fault.
18:02:02 <zykes-> hah :p
18:02:05 <Kiall> CaptTofu, you should have remembered :P
18:02:08 <CaptTofu> it was the doughnuts
18:02:19 <zykes-> haha
18:02:29 <Kiall> Yea - lets blame the doughnuts... moving on :)
18:02:46 <Kiall> So the agenda has 2 items on it today..
18:03:01 <Kiall> First up...
18:03:13 <Kiall> #topic Why I haven't released a (kinda) g1 yet
18:03:33 <zykes-> still not out ?
18:03:38 <zykes-> slowy!
18:03:43 <Kiall> So - I've discovered that we don't quite have all the necessary pieces in place to do a release!
18:03:48 <Kiall> #link https://review.openstack.org/#/c/17756/
18:04:14 <Kiall> Without this (or something similar) we're left without the ability to release
18:04:41 <simonmcc> hehe
18:05:03 <Kiall> So.. I've literally just had a chat with mordred / jeblair about this..
18:05:11 <Kiall> and it boiled down to:
18:05:11 <Kiall> <jeblair> Kiall: i think mordred is running behind, but the general idea was maybe we should prototype with moniker how we want to do releases and tarballs for all the core projects
18:05:20 <Kiall> <jeblair> Kiall: mordred's going to write up a plan on his plane flight, so maybe we'll have details then.
18:05:26 <CaptTofu> drivers == agent, correct?
18:05:35 <Kiall> No - thats a launchpad group name
18:05:46 <CaptTofu> ah.
18:05:50 <Kiall> Basically - people with permission to hit the big red button ;)
18:05:58 <CaptTofu> ok.
18:06:55 <Kiall> So .. I'm happy to hold odd and work with jeblair / mordred to get a better system in place for everyone.. Assuming it's sometime soon! I'll find out more when I can
18:06:59 <Kiall> hold off*
18:07:25 <Kiall> Any questions? :)
18:08:03 <Kiall> Guess not...
18:08:07 <Kiall> #topic Reverse DNS
18:08:12 <Kiall> #link http://docs.rackspace.com/cdns/api/v1.0/cdns-devguide/content/ReverseDNS-123456999.html
18:08:34 <zykes-> yeh
18:08:45 <Kiall> So - We have 2 decisions to make re reverse DNS..
18:09:08 <zykes-> question, do we do with handlers for reverse like with forward records, create A + PTR ?
18:09:13 <Kiall> 1) Should we limit reverse DNS records to pre-defined range(s) of IPs, or allow people to create PTR's for any IP space they wish
18:10:00 <Kiall> 2) If the answer to #1 is pre-defined only, what should the API look like? i.e. should the PTR be record be tied to the resource it's actually allocated to.
18:10:50 <Kiall> I had a quick chat with jcmartin last night about this, and I believe he's in favour of a restricted set of ranges, and following the RS API (linked above)
18:11:25 <Kiall> I'm personally in favour of restricting the PTR's to pre-defined ranges, and something kinda similar to the RS API
18:11:38 <Kiall> thoughts?
18:12:07 <Kiall> zykes-, sorry - missed that message
18:12:09 <zykes-> maybe quantum subnet data comes in here or ?
18:12:31 <Kiall> yes - we should, be defaulting records to a sane value as we get notifications from quantum/nova-network
18:12:56 <Kiall> But the end user should be able to change that default if they wish
18:13:10 <zykes-> :)
18:14:00 <Kiall> I'm in favour of allowing that access via something like http://moniker.api.bla.com/rdns/compute/InstanceUUID
18:14:27 <zykes-> how does RS dns stuff look for this?
18:14:30 <Kiall> which is similar to, but not exactly the same as the RS API. (I'm still trying to figure out exactly why they use a full URI rather than just the UUID)
18:14:32 <Kiall> http://docs.rackspace.com/cdns/api/v1.0/cdns-devguide/content/ReverseDNS-123456999.html
18:15:09 <Kiall> The RS API looks like this http://moniker.api.bla.com/rdns/compute/http://nova.api.bla.com/servers/$InstanceUUID
18:15:19 <Kiall> (with some urlencoding thrown in)
18:15:28 <zykes-> hmmm
18:16:07 <Kiall> The end result is something like this: http://dns.api.bla.com/rdns/compute/http%3A%2F%2Fcompute.api.bla.com%2Fservers%2F$InstanceUUID
18:16:11 <zykes-> why is the service passed in ?
18:16:21 <andrewbogott> Why is it useful to restrict the range?  It's just the difference between getting invald vs. not found for a given query, right?
18:16:22 <zykes-> as in the service api
18:16:25 <zykes-> ehm, service url
18:17:02 <Kiall> andrewbogott, yes/no.. we can't allow any random user to create a PTR for 1.2.3.4, since that could be allocated to another tenant
18:17:13 <zykes-> a thing can be if you restrict having duplicate PTR's that if someone goes duplicate ip's you're screwed
18:17:22 <andrewbogott> Oh, you're talking about creating not querying of courseā€¦ nm, dumb question.
18:17:56 <Kiall> andrewbogott, yea.. this is from the REST API point of view
18:18:34 <Kiall> so - the service-url thing bugs me because it's ugly :)
18:18:43 <zykes-> it is indeed
18:18:54 <Kiall> I'm still trying to understand exactly why they chose this route
18:18:57 <zykes-> and do you really need to do like /compute ?
18:19:18 <zykes-> Kiall: shouldn't we restrict creation of ptr's to existing ip's in say quantum / some other source?
18:19:28 <Kiall> I understand that part - it allows us to pick the appropriate python-*client to make a call with
18:19:59 <Kiall> zykes-, yea.. so an end user can only create a PTR record if they have the IP allocated to one of their instances/load balancers/databases/etc
18:20:45 <zykes-> yeh
18:20:55 <Kiall> So.. Can anyone see a reason why RS chose to use a full URL, rather than simply the UUID?
18:21:01 <zykes-> noop
18:21:16 <Kiall> Humm - Actually, I think I just realized why.
18:21:29 <Kiall> What if you have multiple compute regions?
18:21:44 <Kiall> The compute/LB/etc API endpoint would be different
18:22:04 <zykes-> hmm
18:22:17 <zykes-> and ?
18:22:22 <zykes-> isn't DNS / Keystone global ?
18:22:24 <Kiall> DNS, being the odd one out when it comes to multi-region stuff, won't just be dealing with in-region resources
18:23:48 <Kiall> So - with the keystone catalog, we can from a service type and region name, obtain the URL
18:24:04 <zykes-> yeah
18:24:09 <Kiall> Maybe we use http://moniker.api.bla.com/rdns/compute/RegionOne/$InstanceUUID
18:24:18 <Kiall> (or something similar)
18:24:28 <zykes-> how does the Nova url's look like ?
18:24:34 <zykes-> do they use instance regions in the url ?
18:25:03 <Kiall> No, regions are entirely separate stand alone installs with a shared keystone (and moniker)
18:25:25 <zykes-> yeh
18:25:44 <Kiall> So http://RegionOne/servers and http://RegionTwo/servers will return different results..
18:25:51 <zykes-> can't we just put the service + region within the json ?
18:26:27 <Kiall> Maybe for create and update requests, but fetch requests (i.e. a HTTP GET) don't have a entity-body, so no JSON.
18:26:40 <zykes-> k
18:27:31 <Kiall> I'm inclined to go with something like this
18:27:32 <Kiall> http://moniker.api.bla.com/rdns/RegionOne/compute/$InstanceUUID
18:27:43 <Kiall> http://moniker.api.bla.com/rdns/RegionOne/loadbalancer/$BalancerUUID
18:27:43 <Kiall> etc
18:28:29 <zykes-> myeh
18:28:38 <Kiall> was that a "meh" or "yeh" ;)
18:28:39 <zykes-> but should service vs region be in which order?
18:28:57 <Kiall> I think I prefer region first
18:29:11 <zykes-> what does other projects use ?
18:29:20 <zykes-> let's try not to differ too much from others...
18:29:56 <Kiall> None of the other projects need to handle another projects resources over multiple regions
18:30:00 <Kiall> i.e. this is a first
18:30:18 <zykes-> quantum ?
18:31:09 <Kiall> I'd need to double check since I don't use it.. But quantum would live inside a region and not handle other regions
18:31:23 <Kiall> The only cross-region project right now is keystone
18:32:04 <zykes-> yeah, but KS doesn't really care I think for things that is "in" the resource except the svc catalog
18:32:43 <Kiall> Exactly - and it has no need to know about servers etc, so it doesn't provide a precedent for how this should be handled
18:33:01 <zykes-> sorry if i'm a bit "back and forth"
18:33:05 <zykes-> working on Pulp atn :)
18:33:18 <Kiall> so, there is no precedence to follow :/
18:33:34 <zykes-> guess we'll be a first :)
18:34:08 <Kiall> Assuming nobody shouts at me for it, I think http://moniker.api.bla.com/rdns/RegionOne/compute/$InstanceUUID will work and not be totally hideous
18:34:54 <Kiall> Okay.. No shouts..
18:35:26 <Kiall> #action kiall to implement RDNS over the holidays using "http://moniker.api.bla.com/rdns/RegionOne/compute/$InstanceUUID" as the API endpoint
18:35:32 <Kiall> #topic Open discussion
18:35:58 <Kiall> So .. zykes- did you see this? https://review.openstack.org/#/c/18377/
18:36:28 <zykes-> yeh, was planning on doing it post christmas
18:36:28 <Kiall> i.e. don't do any work on the rootwrap ticket you assigned to yourself until that lands :)
18:37:23 <zykes-> ;)
18:37:32 <zykes-> I am working too many angles for openstack alone :p
18:37:56 <Kiall> Okay - So unless anyone else has anything, we'll call it and day and pick this up in 2 weeks after the break?
18:38:08 <zykes-> :)
18:38:09 <zykes-> yeh
18:38:31 <Kiall> (I know CaptTofu and simonmcc are in another meeting right now, so probably have Q's but haven't had time to read the logs ;))
18:39:01 <CaptTofu> sorry!
18:39:13 <Kiall> Okay .. Next meeting is the 2nd of January 18:00 UTC :)
18:39:16 <Kiall> 2nd?
18:39:17 <Kiall> jasus.
18:39:22 <zykes-> i say 3 weeks
18:39:24 <zykes-> rather :p
18:39:25 <Kiall> can I take that statement back!
18:40:27 <Kiall> Okay.. Let's say 3 weeks, or the 9th of Jan. and I'm sure we'll have something impromptu in #openstack-dns between now and then
18:41:13 <Kiall> #endmeeting