18:01:30 <Kiall> #startmeeting dnsaas
18:01:31 <openstack> Meeting started Wed Dec  5 18:01:30 2012 UTC.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:34 <openstack> The meeting name has been set to 'dnsaas'
18:01:39 <Kiall> So - Who's around today?
18:02:02 <andrewbogott> o/
18:02:42 <Kiall> Okay.. So, You may have noticed the agenda on the wiki is "TBD".
18:02:44 <CaptTofu> I's is here
18:03:15 <Kiall> This week has been productive, but no new questions or decisions have been needed
18:03:43 <CaptTofu> what are some of the big things worked on this past week - a good question
18:03:43 <Kiall> Hence - Unless anyone has anything for today, we'll likely just do a quick review of what's landed over the week
18:04:13 <Kiall> #link https://review.openstack.org/#/q/status:merged+project:stackforge/moniker,n,z
18:04:27 <jcmartin> here
18:04:52 <Kiall> So - 17 reviews landed during the week, and I'll get jcmartin's reusable sqla one merged in the next few houts
18:04:54 <Kiall> hours*
18:05:25 <Kiall> The two big server side ones are A) CaptTofu MySQL+Bind backend
18:06:00 <Kiall> and B) the switch to pure .json schemas, giving us much more freedom in how we enforce the rules of the API
18:06:18 <jcmartin> one remark on this
18:06:31 <Kiall> shoot
18:06:31 <jcmartin> you are using a specific verison of jasonschema
18:06:35 <jcmartin> jsonschema
18:06:41 <jcmartin> do you this as a pb ?
18:07:21 <Kiall> I do - We depend on a specific git revision right now
18:07:52 <Kiall> We're making use of a feature from the trunk version, which kinda sucks but saved us a huge amount of code
18:08:09 <Kiall> I've had a chat with the authors, and a new release is due "soon"
18:08:23 <Kiall> At that point, we can depend on >0.8
18:08:47 <jcmartin> ok, as long as it gets into pip before us ...
18:09:25 <Kiall> jcmartin, yea.. if they don't release soon, we will have to figure something  else out
18:10:00 <zykes-> hoiii!
18:10:17 <Kiall> Okay.. and the big client side review that landed is a (90%) working PythonAPI and CLI
18:10:26 <Kiall> #link http://paste.openstack.org/show/27461/
18:10:29 <Kiall> Example usage ^
18:11:02 <jcmartin> cool
18:11:07 <Kiall> The handling of issuing an update API call is currently.. well.. broken
18:11:49 <Kiall> myself and zykes- have gone round in circles trying to figure a solution to 1 part of the that issue.. And I think we have a fix, but simply haven't had time to implement it yet
18:13:01 <Kiall> The other big change that landed is the ability to load a backend straight into the central service, rather than needing to use the agent service
18:13:29 <CaptTofu> yes
18:13:43 <CaptTofu> good for cases where only database updates (powerdns, mysqlbind) are needed
18:13:45 <Kiall> There are still some kinks to be worked out in the current backends, but the changes to moniker-central/moniker-agent should be solid
18:14:35 <Kiall> CaptTofu, yea - combined with jcmartin's patch, we should be good to go for PowerDNS etc
18:14:36 <jcmartin> what's left to be done ?
18:14:56 <Kiall> jcmartin, So.. Right now the bind9 backend agent uses RPC to ask central for some extra data..
18:15:38 <Kiall> But - when it loads straight into central, that triggers a deadlock.. central is blocked waiting for a response, so it can't issue a response
18:16:01 <Kiall> I've not had time to look any further than that into it though :)
18:16:39 <CaptTofu> Kiall: I also need to add slave functionality to bind9
18:16:43 <CaptTofu> pretty trivial really
18:16:50 <Kiall> So - That really covers off what landed this week, and what will land in the next few hours..
18:17:18 <Kiall> My priority list is now pretty small - It basically consists of 1) Tests, 2) Bugfix, 3) Goto 1
18:18:15 <Kiall> I *think* all core features have landed now.. The only remaining feature changes should be in the plugins
18:18:30 <zykes-> :)
18:18:34 <jcmartin> I'll try to write a plugin for our internal dns, this will shake out the new backend
18:18:39 <zykes-> Kiall: I know one that needs landing really
18:18:47 <Kiall> this one?
18:18:49 <jcmartin> what about additional records ?
18:18:49 <zykes-> Floating IP handler for Nova
18:18:52 <CaptTofu> jcmartin: which dns server type?
18:18:57 <Kiall> jcmartin, great..
18:19:02 <jcmartin> nominum
18:19:15 <Kiall> zykes-, did that really not land already? I was sure you did that!
18:19:24 <zykes-> Kiall: Quantum yes :)
18:19:26 <CaptTofu> wow,never heard of that one - is is db or file based?
18:19:27 <Kiall> Ohh
18:19:36 <zykes-> I don't run nova for that part Kiall
18:19:39 <zykes-> since I use Quantum
18:19:50 <Kiall> #action kiall to implement floating IP handler for Nova
18:19:53 <jcmartin> rest api. Most telcos run nominum
18:20:00 <jcmartin> it's has ha masters
18:20:12 <CaptTofu> interesting
18:20:17 <zykes-> what's that written in jcmartin ?
18:21:02 <Kiall> Okay - So does anyone have any other features that think should have landed, but haven't?
18:21:05 <jcmartin> it's an early fork of bind (mockapetris work for nominum)
18:21:29 <jcmartin> kiall: is there any issue supporting all record types ?
18:21:50 <Kiall> I'd like to get all core features 100% done before the end of the week, then cut a (very late) g1 release (ignoring the jsonschema dep issue for g1)
18:22:29 <Kiall> jcmartin, there is.. But I started with a limited set mainly just to have a limited number of records to build a schema for..
18:22:49 <jcmartin> ok
18:22:59 <Kiall> jcmartin, any record types missing that you need?
18:23:01 <jcmartin> this is not urgent anyway
18:23:06 <jcmartin> no
18:23:21 <jcmartin> if I need them, I'll add them ;-)
18:24:09 <Kiall> I can probably open it up to accept anything, while still keeping strict validation for known types (eg A, AAAA, MX etc) in place..
18:24:35 * zykes- suggests adding a bug + a review
18:24:38 <zykes-> should be doable ? : p
18:24:41 <Kiall> The issue with that though, is that a bad record could cause the zone to be ignored by bind (or another backend)
18:25:21 <Kiall> So.. Either we have to accept that if people muck up, their zone may disappear, or we have to try and find a way to detect+correct issues
18:25:37 <Kiall> Hence I chose to start with a limited set :)
18:26:34 <Kiall> #action kiall to file a bug re additional/free for all record types
18:26:52 <zykes-> what's the price for that jcmartin ?
18:27:29 <jcmartin> zykes- for what ?
18:27:36 <zykes-> nominom
18:27:42 <Kiall> Okay.. So, what do people think of shooting for feature complete g1 release on Friday?
18:27:55 <zykes-> Kiall: g2 you mean ?
18:27:56 <jcmartin> it's above 100k, don't remember exactly
18:27:57 <zykes-> g1 is over
18:27:58 <zykes-> :p
18:28:05 <zykes-> holy shitzo
18:28:06 <Kiall> zykes-, yea.. g1 ;)
18:28:34 <jcmartin> zykes- you know what happen when DNS breaks ;-)
18:29:20 <Kiall> I think we can get all the core changes in by then.. Plugins can continue to get features etc for a little longer, but the core will be locked down.
18:29:32 <Kiall> So - Anyone disagree? :)
18:30:01 <jcmartin> agreed
18:30:15 <Kiall> zykes-, CaptTofu, andrewbogott?
18:30:26 <CaptTofu> no disagreement here
18:30:31 <andrewbogott> nope, sounds good
18:30:38 <CaptTofu> the core is pretty straightforward
18:30:51 <CaptTofu> then we can focus on testing, testing, and also testing
18:30:57 <Kiall> CaptTofu, exactly :)
18:31:34 <Kiall> Okay.. So, thats about everything I had to say today. Does anyone have anything else to bring up?
18:32:53 <Kiall> Okay! So - I'll take silence as a no then :)
18:33:53 <Kiall> Okay .. thanks again - And see you next week and/or in #openstack-dns :)
18:33:55 <Kiall> #endmeeting