16:01:35 <carolbarrett> #startmeeting diversity work group meeting
16:01:35 <openstack> Meeting started Thu May 19 16:01:35 2016 UTC and is due to finish in 60 minutes.  The chair is carolbarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:39 <openstack> The meeting name has been set to 'diversity_work_group_meeting'
16:01:45 <spotz> Hey all I also let the OSIC folks know about the meeting
16:02:37 <thingee> o/
16:03:05 <openstack> carolbarrett_: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
16:03:13 <carolbarrett_> #endmeeting
16:03:35 <carolbarrett_> Hi folks
16:03:52 <carolbarrett_> who is here for the diversity work group meeting?
16:03:57 <thingee> o/
16:04:11 <djkonro> Hello
16:04:32 <spotz> \o/
16:04:41 <carolbarrett_> Hi thingee - I'm getting errors from the meetbot and had to log off then on. Now I don't think I can control the meeting - do you know how i can fix this?
16:04:58 <spotz> carolbarrett_: You may need to start the meeting again
16:05:22 <openstack> carolbarrett_: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
16:05:34 <spotz> #endmeeting
16:05:49 <spotz> hrm
16:05:51 <thingee> carolbarrett_: is it still listen to other commands?
16:05:53 <carolbarrett_> #endmeeting
16:06:05 <carolbarrett_> #topic Roll call
16:06:33 <carolbarrett_> it seems to be listening - when I logged back in, it changed my login to carolbarrett_ and won't let me control the meeting
16:07:04 <thingee> yeah it might just be stuck. The last time this happened we just kept doing the meeting and didn't have meet bot. I think after an hour or less it realizes no one is running the meeting and resets.
16:07:34 <thingee> carolbarrett_: try changing your nick back to carolbarrett
16:07:36 <carolbarrett_> thingee: Will it still record?
16:07:59 <thingee> carolbarrett_: I don't think it will, but this channel is probably being recorded regardless.
16:08:22 <spotz> thingee what about booting the bot?
16:08:32 <carolbarrett> #topic roll call
16:09:06 <thingee> spotz: #openstack-infra folks might be able to help there. I don't have access to such things myself.
16:09:15 <spotz> ahh ok thingee
16:09:44 <carolbarrett> I changed my nick and still can't control....let's get going and I'll copy/paste the transcript into an etherpad to make sure we can share with others
16:10:06 <carolbarrett> looks like we have a small turnout for this one
16:10:17 <carolbarrett> You can find the agenda here: https://wiki.openstack.org/wiki/Diversity#Agenda
16:11:26 <thingee> carolbarrett: everything in this channel should be logged here http://eavesdrop.openstack.org/irclogs/%23openstack-diversity/ meeting or not.
16:11:49 <carolbarrett> Anyone here for the meeting who has not chimed in yet?
16:11:52 <carolbarrett> thingee: thanks
16:12:20 <aimeeu> Hi
16:12:34 <carolbarrett> Hi aimeeu
16:12:46 <spotz> hey aimeeu
16:12:47 <carolbarrett> Ok - the 1st agenda topic is Future meeting plans
16:13:29 <carolbarrett> It's been a challenge to find 1 time that works for everyone, and when we've tried having multiple meetings the attendance has been too light to be productive
16:14:05 <carolbarrett> On the ML Roland suggested we might use the ML as the primary vehicle for communication and collaboration
16:14:09 <carolbarrett> What do you all think?
16:15:04 <thingee> carolbarrett: I think this makes sense. For some others where english is not a first language, these real time conversations can be intimidating.
16:15:32 <aimeeu> and for those of us who can't type quickly :)
16:15:52 <spotz> carolbarrett: Either the ML or etherpad. I'm wondering if some folks might not be as open on the ML even though everyone knows the channel is recorded
16:15:58 <carolbarrett> aimeeu: :)
16:16:19 <carolbarrett> spotz: Etherpad is an interesting idea
16:16:59 <carolbarrett> Maybe something like we post the agenda items in an etherpad, and then give folks the week to make comments, etc then summarize and publish?
16:16:59 <thingee> could use a mixture. etherpad for collaboration, and the ML for discovering those etherpads
16:17:26 <carolbarrett> thingee: I like that. Do you know if any other groups have used this approach?
16:17:29 <spotz> thingee or the ML for someone needing to ask a quesion before typing in the etherpad
16:17:37 <aimeeu> thingee +1
16:18:41 <thingee> yeah this a pretty average approach of starting early discussions on the ML of some initiative, then putting those into an etherpad to capture things from the ML.
16:19:42 <carolbarrett> Just a reminder that we don't have our own ML we use is the Foundation ML
16:20:11 <thingee> we could use a tag to identify ourselves in the subject line. that way it's easy to for people to filter messages.
16:20:29 <thingee> [diversity] or something like that
16:20:35 <carolbarrett> thingee: +1
16:20:59 <carolbarrett> #agree Future meetings will be a combination of Foundation ML (with [diversity] tag) + Etherpad
16:21:04 <aimeeu> isn't [Diversity] already being used?
16:21:10 <aimeeu> on the ML?
16:21:29 <carolbarrett> aimeeu: I think most of the time people use that when addressing this WG
16:21:54 <aimeeu> carolbarrett: thanks
16:21:57 <carolbarrett> Anything else on future meetings that we want to discuss?
16:22:07 <thingee> aimeeu: yeah looks like doing a search in the foundation ML, carol has been using it
16:22:17 <spotz> I think it's a good start, maybe try 3 months then re-evaluate?
16:22:38 <carolbarrett> spotz: good idea, check points are good!
16:23:29 <carolbarrett> #agree revisit ML + Etherpad meeting plan in Mid-August
16:23:55 <carolbarrett> OK - Let's move on
16:24:24 <carolbarrett> #topic Ease of on-boarding new community members
16:24:36 <carolbarrett> This was a discussion topic at the session in Austin.
16:24:58 <carolbarrett> You can find the etherpad from the session in austin here: https://etherpad.openstack.org/p/Diversity_WG_AUS
16:25:50 <carolbarrett> The general thinking is that it can be challenging for anyone new to the OpenStack community to get integrated, regardless of their background, etc. So improving this will benefit everyone
16:26:27 <carolbarrett> The OpenStack Foundation is investing resources to improve this and I asked thingee to join and give this team an update
16:26:36 <carolbarrett> thingee - pls take it away!
16:26:42 <thingee> thanks carolbarrett  :)
16:27:01 <thingee> so here's the discussion that happened in austin with the infrastructure team that would be supporting this effort https://etherpad.openstack.org/p/newton-infra-landing-page-for-contributors
16:27:37 <thingee> the goal here is to have a landing page on the org site that the community can contribute to. The landing page assumes you can be contributing to the community in a variety of ways
16:28:39 <thingee> this could be things like translations, meet up organizing, working on defining use cases for features in OpenStack, code, etc.
16:29:50 <thingee> today teams in OpenStack either have their own on-boarding or nothing. It's not easy for both people who are already part of different initiatives to take time to help newcomers that will show up, or for new comers to have the necessary documentation to start.
16:30:26 <thingee> the idea with this that we're envisioning is a portal that gives you a "choose your own adventure" kind of feel
16:30:35 <thingee> what are you interested in contributing to?
16:31:33 <thingee> based on your selected interests of what you want to contribute to the portal will highlight the "essential" on boarding documentation that people need to contribute. communication and setting up accounts needed to be part of the community
16:31:41 <thingee> here are some examples of that documentation...
16:31:49 <thingee> http://docs.openstack.org/upstream-training/irc.html
16:31:55 <carolbarrett> When someone selects how they want to contribute, will someone in a project or wg get an email so they can reach out to the person and offer a helping hand?
16:31:56 <thingee> http://docs.openstack.org/upstream-training/accounts.html
16:33:03 <thingee> carolbarrett: for a first pass, we'd probably have just how the new comer can communicate with the team.
16:33:18 <thingee> carolbarrett: either subject tag on the ML or irc.
16:33:52 <thingee> we could even list off email addresses of who in the team is interested in working with new comers - as a less intimidating approach
16:34:39 <spotz> thingee I like that idea, even if it's someone who can just make introductions to the team
16:34:48 <carolbarrett> thingee: good start. I wonder if we'll need more though, we often hear people are afraid of making mistakes when starting sending emails on ML or making comments in IRC
16:35:09 <thingee> so besides the "essential" documentation for on-boarding, there will be team specific on-boarding documentation
16:35:35 <aimeeu> carolbarrett: would this be a good place to mention the Mentoring program?
16:35:57 <thingee> the goal here with having on-boarding documentation in one place is to not duplicate things. We will have these "essential" docs that will be share across teams, and then some teams might have their own specific tools, or processes they want to talk about
16:36:01 <carolbarrett> aimeeu: good point.
16:36:56 <thingee> one thing we're still figuring out though is how to teams contribute to these docs. Some teams would like a flow like a wiki where they can just add content ... instead of having to learn git and gerrit
16:37:21 <carolbarrett> thingee: could you include a link to the mentoring program page in the info provided to the newcomer?
16:37:30 <thingee> because some teams just aren't doing repo related contributions. e.g. meet up organizers
16:37:49 <carolbarrett> thingee: git and gerrit immediately limits the participation
16:38:50 <thingee> carolbarrett: yeah and unfortunately after our conversation that helped give me ideas, I didn't come up with existing tools that could help us work around people not even knowing gerrit/git was being used.
16:39:01 <thingee> carolbarrett: not sure which page you're referring to.
16:39:58 <thingee> here's an example of git documentation, that is not essential, but might appear as a new comer documentation based on your selections e.g. code, translations ... http://docs.openstack.org/upstream-training/git.html
16:40:17 <carolbarrett> thingee: Here's the link: https://wiki.openstack.org/wiki/Mentors
16:40:30 <thingee> oh got it, the current landing
16:41:10 <aimeeu> thingee: yes, and put it on whatever page would have list email addresses, communicating with a team, etc
16:41:25 <carolbarrett> thingee: at a minimum we need a Windows setup section in the training doc
16:42:06 <thingee> the goal is to have something produced a little before the next conference. we would like to have time to share something somewhat complete through the community so that word spreads and people share it with people they meet at the conference.
16:42:13 <thingee> carolbarrett: +1
16:42:56 <spotz> thingee if you need help just ping
16:43:35 <thingee> currently I have a meeting setup with one of the designers at the foundation to begin ideas of how this will look. Once we have some rough idea to start we will loop in the rest of the community to come up with a final design
16:44:06 <aimeeu> thingee: +1
16:44:06 <thingee> this will be happening last week of june.
16:44:27 <thingee> which is fine, because we need to get community agreement on having shared on-boarding docs anyways.
16:44:46 <thingee> so I'm producing a specification to start this.
16:44:49 <spotz> Or atleast a base for shared on-boarding
16:46:14 <thingee> carolbarrett: that's it for me :)
16:46:39 <carolbarrett> thingee: what ML will you use to communicate about the spec and design?
16:47:53 <thingee> it'll probably be cross-posted. I will likely create the specification in the documentation spec repo.. http://specs.openstack.org/openstack/docs-specs/
16:48:09 <thingee> cross-posted on multiple ML's*
16:48:50 <carolbarrett> sounds good - thanks
16:48:59 <carolbarrett> any other questions or suggestions on this?
16:49:34 <spotz> nope
16:50:26 <carolbarrett> OK - next topic is Review Austin Session notes
16:50:34 <carolbarrett> our time is limited for this one...
16:50:45 <carolbarrett> etherpad is located here: https://etherpad.openstack.org/p/Diversity_WG_AUS
16:51:26 <carolbarrett> I think there are several comments that could get incorporated into the on-boarding work
16:51:35 <spotz> carolbarrett: So is it that people feel we need a general OpenStack welcoming committee?
16:51:51 <carolbarrett> One comment was to create more video content for training/on-boarding/etc and less written documentation
16:52:20 <carolbarrett> spotz: yes, I think that is a good way to capture it!
16:52:58 <aimeeu> I hope the written docs will stay. Videos don't present info fast enough for some people.
16:53:01 <spotz> It's not a bad idea, then that group can pass off to a team greeter?
16:53:11 <spotz> Or bad connections aimeeu
16:53:43 <carolbarrett> spotz: +1
16:53:48 <aimeeu> spotz: +1
16:54:55 <carolbarrett> We would need to figure out how to feed names of people to the welcoming committee - possibly use a similar process that is used for the mentoring matching
16:54:58 <spotz> This is bad I'm getting ideas.... A welcome mailing list folks can contact, folks in shirts at summit, a welcome IRC channel..... HELP!!!!:)
16:55:59 <carolbarrett> spotz: these are great ideas...some of these things are done by the Women of OpenStack.
16:56:03 <aimeeu> spotz:  aack! step away from your monitor! ;)
16:56:24 <carolbarrett> There was discussion in the Women of Openstack meeting this week, about how that group can better interact with the Diversity WG.
16:56:27 <spotz> carolbarrett: So we can definately leverage between the groups
16:57:09 <spotz> But I also don't think the welcoming committee should just be WoO related but open to anyone willing to help. And I know we keep stressing WoO isn't just for Women
16:57:19 <carolbarrett> I wonder if we should look to promote these programs as join activities between WOO and DWG so people view them as open to all comers?
16:58:01 <carolbarrett> spotz: +1
16:58:20 <spotz> +1
16:58:25 <aimeeu> carolbarrett: +1
16:59:09 <carolbarrett> We're down to our last minute...I think we should bring the idea of co-sponsoring events/activities with WOO. I'll add topic to the agenda for the next WOO meeting
16:59:19 <aimeeu> +1
16:59:48 <carolbarrett> I will also publish some notes from this meeting to the ML and outline the future meeting approach and put some timelines around it.
17:00:08 <carolbarrett> pls look for the email and chime in with your thoughts too!
17:00:33 <aimeeu> thanks carolbarret
17:00:39 <carolbarrett> Have a good rest of your day!
17:00:42 <carolbarrett> #endmeeting