15:00:40 <Swami> #startmeeting distributed-virtual-router
15:00:41 <openstack> Meeting started Wed Jan 28 15:00:40 2015 UTC and is due to finish in 60 minutes.  The chair is Swami. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:44 <openstack> The meeting name has been set to 'distributed_virtual_router'
15:01:18 <Swami> #topic agenda
15:01:35 <Swami> 1. Bug review
15:02:06 <Swami> 2. How to get to stable DVR tempest failure rate
15:02:28 <sc68cal> o/
15:02:38 <Swami> 3. Current backlog items that are in progress
15:03:06 <Swami> #topic Announcement
15:03:41 <Swami> Today's meeting will be for just 30 minutes. So we have a hard stop at 15.30
15:04:00 <Swami> #topic Bug review/scrum
15:04:16 <Swami> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=l3-dvr-backlog
15:04:55 <Swami> The link provides the dvr releated bugs.
15:05:58 <Swami> Right now there are 27 bugs in the list
15:06:39 <Swami> Out of which 5 bugs have been already addressed and fix committed
15:07:42 <Swami> There are 5 highs in the list which we will discuss first and then move on to the mediums.
15:08:13 <Swami> Bug number #1369721 - Manual Move
15:09:23 <Swami> This bug has two patches, one was merged and the other one is currently in progress under review.
15:09:50 <Swami> #link https://review.openstack.org/#/c/122024/
15:09:55 <Swami> patch under review.
15:10:14 <Swami> I think it is under good shape and will not have any problems going in.
15:11:03 <Swami> The next one in the highs is #link https://bugs.launchpad.net/neutron/+bug/1374473
15:11:47 <Swami> This bug also has a patch up for review #link https://review.openstack.org/#/c/142674/
15:12:11 <Swami> this bug also has additional patches that addresses some issues with multiple networks.
15:12:58 <Swami> #link https://review.openstack.org/#/c/143567/9
15:13:34 <Swami> #link https://review.openstack.org/#/c/143736/
15:14:34 <Swami> There are some additional changes that are required on the agent side and we are waiting for the FIP Namespace patch to go in #link https://review.openstack.org/#/c/145565/
15:15:20 <Swami> The next bug is #link https://bugs.launchpad.net/neutron/+bug/1394043
15:15:28 <carl_baldwin> Swami:  Do you think any of these bugs are more important than getting a voting dvr job in the gate?
15:16:08 <Swami> carl_baldwin: I would prefer voting to go in first.
15:16:14 * carl_baldwin wonders if we should file a critical bug that the job is not yet deemed reliable enough to vote.
15:16:46 <Swami> These bugs are a result of dvr job non-voting in the gate
15:16:53 <carl_baldwin> Swami: Some of these bugs may address issues related to reliability.  However, many of them are known issues that do not manifest themselves in the dvr job.
15:17:13 <Swami> carl_baldwin: Yes, you are right.
15:17:37 <Swami> Most of the bugs here can be only seen in multi node setup and not in a single node setup.
15:17:59 <Swami> But in the dvr gate job we are not handling any multinode scenario and still we see more instability issues.
15:18:40 <Swami> In most cases in the dvr gate job we see the connection to the VM times out or ssh issue.
15:19:36 <Swami> We need to really identify the base test in dvr that is failing when compared to the core-neutron jobs
15:20:06 <carl_baldwin> Swami: Do we have some data to mine to help us get that?
15:20:10 <Swami> carl_baldwin: Is there a way to identify the actual test that is failing in the dvr job and not failing in the core job.
15:20:39 <Swami> carl_baldwin: I think we both have the same question.
15:21:51 <carl_baldwin> Swami: It is a good question.  I’m not sure of the answer.
15:22:16 <Rajeev> it would be really helpful if we could get participation from folks in the community that have expertise in the test area.
15:22:45 <Swami> carl_baldwin: The reason I ask is, once we identify the most vulnerable test that is failing, then we ca try to add more sub test cases on those areas to figure out if that is a realy dvr issue, timing issue or something else.
15:23:14 <carl_baldwin> The infra guys may have some ideas.  armax may also have some ideas.
15:23:45 <Swami> carl_baldwin: Can we have a meeting to discuss about this issue and how to go forward.
15:23:47 <carl_baldwin> I think the thread between Adolfo, mrsmith, et al. is on the right track.
15:24:00 <Swami> We definitely need some mentors from the infra team.
15:24:19 <carl_baldwin> Swami: Yes, let’s get something set up when we have a critical mass.
15:24:45 <Swami> carl_baldwin: Ok, that would help to speed up the process.
15:24:48 <fredy_n> Hi, would you have a pointer to existing DVR test cases?
15:26:03 <carl_baldwin> fredy_n: There is a tempest test in the gate which enables dvr routers, it is non-voting at the moment.  There are also some functional tests in the test_l3_agent.py file but only a basic set at the moment.
15:27:15 <Swami> fredy_n: check-tempest-dsvm-neutron-dvr this is the tempest test suite that runs the dvr non-voting job
15:27:59 <fredy_n> carl/swami: Thanks, I'll have a look
15:28:13 <Swami> fredy_n: thanks
15:28:24 <carl_baldwin> Swami: Are you taking the action to move this forward?  Or, should I ask on the email thread?
15:28:51 <Swami> carl_baldwin: I will take the necessary action to work on this.
15:29:39 <Swami> carl_baldwin: But what do you suggest, do we get help from the community infra team.
15:30:13 <carl_baldwin> Swami: I think they could be a good resource.
15:30:22 <carl_baldwin> … as much as they’re available to help.
15:30:24 <Swami> #action Swami to work with the dvr team and infra team to find out the issues with the dvr job and fix it.
15:32:27 <Swami> Moving on with other bugs.
15:32:30 <Swami> #link https://bugs.launchpad.net/neutron/+bug/1411883
15:32:44 <Swami> This is another bug with high priority.
15:33:09 <Swami> Patch is up for review #link https://review.openstack.org/#/c/149143/
15:33:19 <Swami> The next bug in the list is
15:33:38 <Swami> #link https://bugs.launchpad.net/neutron/+bug/1413630
15:33:46 <Swami> This one also has a patch for review.
15:33:55 <Swami> I do have some issues with this patch.
15:34:06 <Swami> If anyone here is a "db" expert can help me out.
15:35:06 <Swami> For some reason the router-binding with the agent cannot be deleted in the way this patch is handled. I do see a "DELETE" query send out, but no action.
15:37:11 <Swami> There are couple of other medium bugs that are all in progress.
15:37:56 <Swami> The DVR-HA work is in progress and most of the patches are up for review.
15:38:37 <Swami> Also the functional test for DVR-HA will be posted soon.
15:38:56 <Swami> Ok, that's all I had for now.
15:39:27 <Swami> So for the action item, I will work with the DVR team and the infra team to figure out how we can address the dvr job failures
15:39:39 <Swami> Thanks everyone for joining the meeting.
15:39:53 <Swami> See you all next week.
15:40:03 <Swami> #endmeeting