15:07:16 <Swami> #startmeeting Distributed_virtual_router
15:07:20 <openstack> Meeting started Wed Mar  5 15:07:16 2014 UTC and is due to finish in 60 minutes.  The chair is Swami. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:07:24 <openstack> The meeting name has been set to 'distributed_virtual_router'
15:07:25 <Swami> safchain: hi
15:08:01 <Swami> #info DVR L2 Agent Doc
15:08:23 <Swami> On Monday I have sent out the L2 Agent Design doc for review based on the F2F Meeting Followup.
15:08:35 <ajo> hi :)
15:08:45 <Swami> hi ajo
15:08:49 <Swami> #link https://docs.google.com/document/d/1depasJSnGZPOnRLxEC_PYsVLcGVFXZLqP52RFTe21BE/edit
15:09:14 <Swami> I have also created a Wiki for the L2 work. I need to do some clean up and then I will forward it out.
15:10:09 <Swami> I am still working on the L3 details for the FIP and SNAT, once it is ready I will send i tout for review.
15:11:40 <Swami> safchain: How is your vrrp review moving, is it going to be part of the Icehouse 3 milestone
15:12:39 <safchain> Swami, need reviews on agent side, still have tiny issue with one unit test, will fix it by the end of the day
15:13:08 <amuller> safchain: Can you say what patches need a review the most?
15:13:14 <amuller> or just all of them?
15:13:38 <safchain> all :)
15:14:16 <amuller> Did you get an extension from Mark?
15:14:32 <Swami> Hi folks, it would be great if you all can review the L2 agent doc and provide feedback.
15:14:33 <safchain> here is a doc to test it https://docs.google.com/document/d/1P2OnlKAGMeSZTbGENNAKOse6B2TRXJ8keUMVvtUCUSM/edit#
15:15:02 <ajo> safchain, interesting :)
15:15:02 <safchain> amuller, I asked carl_baldwin about that
15:15:22 <Swami> safchain: Thanks I will take a look at it.
15:15:39 <carl_baldwin> safchain: I brought that up in the neutron meeting.  It will need a risk assessment.
15:15:52 <safchain> the database has to be updated, after applying the patches
15:16:06 <safchain> I will had this remark in the doc
15:16:14 <amuller> safchain: Please do :)\
15:16:21 <ajo> carl_baldwin, safchain then it's critical to get it by icehouse if we ever want it in icehouse (db migrations problem=
15:16:33 <ajo> db migration backport problem
15:17:49 <amuller> safchain: I notice that the conntrackd patch isn't included in the how-to-test doc. If I understand correctly the plan is to try to push the VRRP stuff for Icehouse, and either drop conntrack support or add it in Juno?
15:18:02 <Swami> safchain: we did not see for a while, do you have any questions from our face to face meeting.
15:18:31 <Swami> #topic DVR next steps
15:18:48 <Swami> Hi Folks, I wanted to get to the next steps for the DVR work.
15:18:59 <Swami> We are not targeting the DVR work for Icehouse.
15:19:04 <safchain> amuller, it was to catch comments on a basic implementation, I think we could add conntrack in another patch
15:19:24 <Swami> But will be targeted for the the Juno Milestone 1 .
15:20:15 <safchain> Swami, I will take a look at your doc first, question maybe after
15:20:16 <ajo> Swami, Milestone 1 ?
15:20:29 <Swami> ajo: Yes
15:20:36 <ajo> That means that there is code already working?
15:21:02 <Swami> ajo: some work in progress, East-West.
15:21:14 <ajo> good :-),
15:21:46 <Swami> I have not pushed any WIP code upstream and waiting for all the agent reviews to finish
15:21:54 <ajo> Probably, the earliest you start sharing, the better (for your implementation to get reviewed / approved, etc..,)
15:21:58 <ajo> (IMHO)
15:22:15 <Swami> ajo: I agree with you.
15:22:19 <safchain> ajo, Swami agree with that
15:22:49 <ajo> anyway, Juno is at the doorstep :)
15:22:51 <amuller> Swami: I'll review the L2 design doc early next week... Ajo: I think there's design work to do before going over implementation :)
15:22:56 <ajo> thanks for clarification Swami, safchain
15:23:10 <Swami> carl: What would be the outcome of the L2 agent doc that Mark requested.  Should we have another meeting with Mark to finalize that or will it be all done thorugh the ML.
15:23:32 <amuller> Juno milestone 1 is in 3~ months? With the time it takes for patches to get merged in Neutron I think it's too optimistic
15:24:00 <Swami> amuller: I need to target for Milestone 1 so that, atleast our code ends up by milestone 3.
15:24:33 <ajo> sure, it's a good starting deadline, if it can be for ML1, it's great, if in the end it's for ML3, will get less testing, but should be ok yet
15:24:34 <Swami> From my previous experience, even if you have your code ready milestone 1 sometimes, it takes a long time to review and push it up.
15:25:01 <carl_baldwin> Swami: I imagine Mark will want to see a review by someone from on ML2 perspective.  We should ask if there is someone in particular that he would like to have review it.
15:25:30 <carl_baldwin> I could coordinate that.
15:25:35 <Swami> carl, can you bring up this topic in today's ML2 discussion
15:26:39 <carl_baldwin> Their meeting is next hour, right?  It may be difficult for me to attend that meeting.
15:27:08 <carl_baldwin> Let me see, I can probably do it.
15:27:09 <Swami> Ok, then I will send a reminder to Kyle Mistery to bring up this topic
15:28:33 <carl_baldwin> Swami, I'll take it to their meeting.
15:28:40 <Swami> safchain, amuller: Last week in the L3 meeting I raised this question about the HA for the centralized service node.
15:28:43 <Swami> carl: Thanks
15:29:05 <carl_baldwin> #action carl_baldwin to discuss review of L2 changes in ML2 meeting.
15:29:51 <Swami> safchain: The vrrp implementation that you have for the L3 can this be used for our centralized service node.
15:30:38 <safchain> Swami, yes I think
15:31:21 <Swami> safchain: Thanks, that is one think I need to get clarified, so that we can utilize your work on this.
15:31:40 <Swami> Also amuller had a blueprint on the vrrp with active: active
15:31:57 <amuller> Swami: DVR will use the service node only for SNAT traffic, right?
15:32:04 <amuller> (And for *aaS but we're not talking about that)
15:32:29 <amuller> for the SNAT traffic we can schedule HA routers on the service nodes and that will be a fantastic supplement for DVR
15:32:30 <Swami> amuller: Yes current proposal is to use it for SNAT, any VPN Service and for DHCP.
15:33:24 <carl_baldwin> DHCP?
15:33:31 <Swami> Moving forward, we might have to probably also distributed the DHCP if possible.
15:33:59 <amuller> I think Mark is proposing a distributed DHCP approach usiing OpenFlow and the L2 agent
15:34:09 <amuller> replacing the dnsmasq based DHCP agent
15:34:24 <Swami> Mark who?
15:34:30 <amuller> McClain, I thought, but I may be wrong
15:34:30 <Swami> Is it Mark McClain
15:35:34 <ajo> only openflow + l2 agent?, do we have more details about his proposal?
15:35:49 <amuller> Not yet Ajo
15:35:49 <Swami> I think we should have a follow on proposal to move the DHCP into the compute nodes and leave the service node just  for the SNAT.
15:35:49 <ajo> what'd be actually answering the DHCP requests?
15:36:00 <amuller> ajo: br-int
15:36:07 <ajo> openflow rules?
15:36:10 <Swami> I have not seen any proposal on this, but I will check it out.
15:36:10 <amuller> yep
15:36:22 <amuller> I guess Mark will raise it in Atlanta
15:36:26 <ajo> amuller, doesn't sound bad
15:36:29 <Swami> #topic General Discussons
15:36:31 <amuller> yeah it makes a lot of sense
15:36:52 <Swami> Folks, I have a hard stop around 7.40, so if you have any other questions please let me know.
15:36:58 <ajo> Also, we have the neutron-ns-metadata-proxy that lives with the routers
15:37:04 <amuller> Yeah we've encountered multiple customers saying that when using Neutron and booting 30~ instances some of them don't get IPs
15:37:07 <carl_baldwin> I think a follow on for DHCP will be good.  It is independent of the router.
15:37:09 <amuller> Maybe this distributed approach will solve it
15:37:21 <ajo> converting that into openflow rules, or other approach, would be interesting too
15:37:28 <Swami> yes the metadata-proxy is currently handled by our distributed approach.
15:37:35 <ajo> ah, good to know
15:37:41 <amuller> safchain: I'll make it a priority tomorrow to review your patches
15:37:51 <safchain> amuller, thx a lot
15:37:54 <ajo> Swami, briefly, how is it handled exactly? (i can read the docs)
15:38:06 <ajo> safchain, me too
15:38:11 <Swami> can you send me an email, and I will forward you the details.
15:38:29 <ajo> sure Swami doing it right now.
15:38:36 <Swami> Folks, please review the doc and let me know if you have any questions.
15:38:49 <Swami> Next week, we must be having a clear plan to move forward.
15:39:01 <ajo> Swami, I will
15:39:21 <Swami> If anyone interested please let me know if you would like to part of the contribution.
15:39:35 <amuller> Swami: Is there any way to get rid of the Neutron metadata proxy, and just have the DVR routing on the compute node to forward the traffic to the Nova metadata service? I haven't looked into this too deeply but I still don't get why the Neutron metadata binary even exists
15:39:38 <Swami> As i mentioned I am targeting June milestone 1.
15:39:44 <amuller> Swami: Definitely considering me for the implementation
15:39:48 <Swami> See you all next week.
15:39:53 <ajo> Swami, me too
15:40:13 <Swami> Thanks for your responses. There is lot more work, and need the sub-teams help in there.
15:40:20 <safchain> me too
15:40:22 <ajo> Yes, the neutron-ns-metadata-proxy takes 27MB per qrouter instance atm
15:40:43 <Swami> Next week we will probably highlight the tasks and then probably can assign the tasks.
15:40:46 <Swami> Hope this helps.
15:40:50 <Swami> See you next week.
15:41:01 <Swami> Thanks everyone for joining
15:41:06 <ajo> Thank you  Swami
15:41:12 <safchain> Swami, thx
15:41:17 <Swami> #endmeeting