15:01:22 <Swami> #startmeeting distributed_virtual_router
15:01:23 <openstack> Meeting started Wed Feb 19 15:01:22 2014 UTC and is due to finish in 60 minutes.  The chair is Swami. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:26 <openstack> The meeting name has been set to 'distributed_virtual_router'
15:01:42 <Swami> ping robinwong
15:02:09 <Swami> #topic F2F update
15:02:57 <Swami> Hi folks, last week we had our F2F meeting and there were around 10 audience with us in person and more people dialed in
15:03:31 <Swami> I sent out an email to our sub-team about the meeting minutes.
15:03:50 <Swami> Also it is capture in the L3 meeting minutes wiki
15:04:31 <Swami> If you have any questions please feel free to send me an email.
15:04:57 <Swami> amuller: You mentioned that you wanted to discuss your thoughts.
15:05:35 <amuller> Like we discussed in the meeting, the SNAT configuration value should be True for the service node and False for all the compute nodes
15:05:36 <Swami> I mentioned in my previous meeting that we can discuss in today's meeting.
15:06:01 <amuller> I think that a) It's error prone, and b) You should let the admin choose, so that if he wants to do SNAT at all / some of the compute nodes, he can put an IP on the external net
15:06:05 <amuller> and turn on SNAT at that compute node
15:06:16 <amuller> Carl Baldwin mentioned in the meeting that it can be a follow up blueprint
15:06:17 <Swami> amuller: Yes SNAT boolean will determine the node where it hosts the centralized service node
15:06:17 <amuller> I'm ok with that
15:07:31 <carl_baldwin> A follow up blueprint would be to handle distributed snat specifically.
15:07:38 <amuller> Right
15:07:57 <Swami> amuller: We have listened to the audience and to the PTL and the PTL was ok for now going forward with the single node solution.
15:08:16 <Swami> For multinode solution we can work on it later, after we having something working.
15:08:28 <Swami> Hope this is clear for all.
15:08:40 <Swami> carl: thanks for your input
15:09:17 <Swami> amuller: Do you have anything else that you wanted to discuss.
15:09:43 <amuller> Upstream wise, I would love it if you guys could sent in your code as soon as you could
15:09:47 <amuller> send*
15:10:04 <amuller> As soon as feasible on your end anyway
15:10:16 <Swami> amuller: Thanks for the information, there are more things that need to happen before we push our code.
15:10:38 <amuller> Lastly - I have a draft for the blueprint I talked about before - https://docs.google.com/document/d/1UsmwdNST1Ni_UP8nhewKdKkNre3MkZ9fO481l-fRjnA/edit?usp=sharing
15:10:47 <amuller> It's a follow up to Sylvain's VRRP blueprint
15:10:50 <Swami> As I mentioned in my meeting minutes, we need to get sign off on the agent design for both L2 and L3 from the respective teams and then we will push the code.
15:10:52 <amuller> Providing A/A for each router
15:11:19 <Swami> looking at your doc.
15:12:09 <amuller> You can look at it offline and add comments on it whenever you want :)
15:13:58 <Swami> amuller: I briefly did a walk through on your doc and it seems that is a slight change to the VRRP implementation that sylvain is proposing.
15:14:20 <amuller> yeah it's a follow up / dependant blueprint, where each subnet will now have a list of gateways instead of 1
15:14:35 <amuller> If R1 is scheduled on 3 layer 3 agents, then R1 will have 3 different ip addresses
15:14:40 <amuller> All acting as gateways for different VMs
15:14:53 <amuller> Each VMwill get a different gateway in its dnsmasq record
15:15:33 <amuller> So it improves load sharing between different nodes hosting l3 agent
15:15:53 <Swami> amuller: Can you update the datamodel in the blueprint doc
15:17:17 <Swami> amuller: I will provide more feedback during this week.
15:17:28 <amuller> Swami: Change the data model part to a table?
15:18:02 <Swami> amuller: In the data model section add your table model definitions
15:18:11 <amuller> Swami: ok
15:19:28 <Swami> #topic F2F Meeting Follow up
15:20:26 <Swami> By next week I am planning to add two documents for the L2 agent design and for the L3 agent design to the get the community feedback.
15:20:46 <Swami> As soon as I am done with that I will send a message to all our sub-team members for review.
15:21:14 <Swami> #action Swami to post the Agent design doc
15:21:57 <Swami> #topic L3-agent consolidation
15:22:24 <Swami> recently I found that there was some activity in the L3-agent consolidation by yamahata
15:22:59 <Swami> So for our DVR work, we might have to make sure that we take the L3-agent consolidation work into consideration.
15:23:18 <amuller> I'm not tracking that - Could you post a link please?
15:23:57 <carl_baldwin> I started a review of that work.  Could use more eyes on it.
15:24:24 <carl_baldwin> #link https://review.openstack.org/#/c/57627/
15:24:58 <Swami> carl: thanks
15:25:06 <carl_baldwin> #link https://review.openstack.org/#/c/73520/
15:25:14 <carl_baldwin> ^ Another related review.
15:26:02 <Swami> #topic General discussion
15:26:52 <Swami> This week I don't see sylvain and other folks, I will touch base with them through email.
15:27:14 <Swami> Next week after we have the agent design doc, we can then decide on the next steps.
15:27:17 <carl_baldwin> sylvain is on vacation for two weeks.
15:27:34 <Swami> carl: thanks for the information. I was not aware about it.
15:28:00 <Swami> carl: Do you have anything to cover today
15:28:08 <carl_baldwin> The ML2 sub team meeting is after this meeting.  May want to mention your new L2 doc in their meeting.
15:28:29 <carl_baldwin> Maybe not this week but next week when the doc has been created.
15:28:31 <Swami> carl: Thanks yes, I will sent it out to the ML2 sub team once I have the doc ready.
15:28:43 <carl_baldwin> Great, I don't have anything else.
15:28:44 <Swami> carl: yes that makes sense
15:29:10 <carl_baldwin> I thought the F2F was production.  Thanks for setting that up.
15:29:21 <Swami> Ok, then, if there is nothing to discuss today, I will end the session.
15:29:52 <Swami> carl: Thanks for all your feedback and help. Yes the F2F meeting really helped and provided a clear direction for the sub-team.
15:30:15 <carl_baldwin> Thanks, Swami
15:30:17 <Swami> ok, guys take care. We will meet next week.
15:30:27 <Swami> #endmeeting