15:04:02 <Swami> #startmeeting distributed_virtual_router
15:04:03 <openstack> Meeting started Wed Feb  5 15:04:02 2014 UTC and is due to finish in 60 minutes.  The chair is Swami. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:06 <openstack> The meeting name has been set to 'distributed_virtual_router'
15:04:42 <Swami> #topic F2F Meeting
15:05:34 <carl_baldwin> I'll need to join the f2f virtually.
15:05:49 <Swami> hi folks, as I have mentioned in my previous meeting I am planning to have a face to face meeting on Feb 13th at Palo Alto to get the community feedback on the DVR proposal. The meeting will be from 11.a.m to 1.00p.m
15:06:00 <safchain> I hope I will be able too
15:06:09 <Swami> Carl: Yes I will send out a virtual invite to everyone today.
15:06:33 <Swami> I will also send out a conf. bridge for people to dial in.
15:07:23 <Swami> safchain: Have anything changed on your end for the DVR proposal, have you updated your document or else should I proceed with what you have in the document.
15:07:56 <safchain> Swami, I'm currently doing it, I'll finish to update it by this end of the day
15:08:08 <safchain> so I will send you an email
15:08:08 <Swami> safchain: thanks
15:08:29 <Swami> I will also update my document with some minor changes.
15:09:33 * carl_baldwin will now switch to my other client
15:09:34 <Swami> safchain: As I have mentioned earlier I would like both of our blueprints to be merged to a single blueprint with support for both North-South and East-West without affecting any of the existing services.
15:10:05 <safchain> Swami, sounds good
15:10:28 <Swami> safchain: Currently we are also trying to move the SNAT functionality to a specific node, that can be a Network Node.
15:10:53 <Swami> but retain the floating ip and other routing functionality with the compute node.
15:11:02 <safchain> Swami, great so the two proposals go to same way
15:11:16 <carl_baldwin> safchain: Swami: are you speaking of updating the HA routers document?
15:11:28 <safchain> yes I pointed the blueprint
15:11:29 <Swami> Sorry for not updating the document, I will update it in a couple of days. By thursday I should have updated the document.
15:11:38 <Swami> Once I update I will send a message to everyone.
15:11:57 <Swami> carl: Not the HA routers doc, but the DVR doc.
15:12:00 <safchain> carl_baldwin, Will be used for north-south when VM will not have floating ip
15:12:32 <carl_baldwin> Okay.  Sorry, trying to catch up.
15:13:06 <safchain> carl_baldwin, I will send you the email with the document updated
15:13:14 <Swami> carl: no worries, since the doc is changing constantly
15:13:15 <carl_baldwin> safchain: great
15:13:15 <safchain> to everyone
15:14:07 <Swami> So i think that's all I want to say about the F2F meeting.
15:14:33 <Swami> carl_baldwin: Do you have any update on the L3_agent consolidation, what is the status and who is working on it.
15:14:45 <Swami> topic# L3 cosolidation
15:15:19 <carl_baldwin> I haven't seen much about it lately.  Let me take a look.
15:15:31 <Swami> #topic l3 consolidation
15:15:57 <carl_baldwin> Isaku was working on it.
15:16:22 <Swami> carl: do you tink it is targeted for Icehouse
15:16:30 <carl_baldwin> Looks like the patch has not seen an update since early december.
15:17:12 <carl_baldwin> I will ping Isaku on it.
15:17:33 <Swami> carl: Thanks
15:18:12 <Swami> topic; L3 service framework
15:18:57 <Swami> #topic L3 service framework
15:19:35 <Swami> carl: Is there any L3 drivers today that drives a hardware router.
15:20:21 <carl_baldwin> I'm not sure what they are.
15:21:00 <yamahata> carl_baldwin, yes?
15:21:11 <Swami> carl: The reason I am asking is, there are service framework for other services such as LBaaS and there are vendor drivers to drive a physical or virtual device.
15:21:37 <Swami> similarly is there any driver for L3 to drive the hardware
15:22:00 <Swami> yamahata: hi
15:23:32 <Swami> Does anyone know how we should handle the DVR situation when there is a L3 hardware router or VM based router appliance that does the L3 service
15:25:12 <carl_baldwin> Swami: If there is a hardware router doing L3, I think that DVR would not be possible.  Or, not easy.
15:28:25 <carl_baldwin> If I recall, Mark's former company used a VM to do L3.  It might be a good question to ask him.
15:31:10 <Swami> Sorry folks i got dropped
15:31:18 <Swami> did I miss anything
15:31:33 <safchain> Swami, no
15:31:38 <carl_baldwin> Are we still having problems with free node like the other day?  I don't think you miss anything.  The meeting went idle when you dropped.
15:31:53 <Swami> Yes sometimes it drops our session
15:32:11 <Swami> carl:yes same symptom
15:32:32 <Swami> safchain: How is your L3 HA going?
15:32:59 <safchain> I almost sent all the patches related to this feature
15:33:16 <safchain> amuller, is working on the conntrackd patch
15:33:28 <Swami> safchain:Ok thanks
15:34:20 <Swami> safchain: With respect to the L3 HA, all the services that are owned or tied to the L3 agent will it be saved.
15:34:41 <safchain> Swami, like metadata ?
15:34:55 <Swami> today FWaaS is tied to L3 agent
15:35:05 <Swami> safchain: Yes also metadata.
15:35:55 <safchain> Swami, I have to check for the FWAAS, but if the policies/rules are inserted to each l3, I think it is ok
15:36:32 <safchain> Swami, for the metadata it is ok
15:36:59 <Swami> safchain:Thanks
15:37:34 <carl_baldwin> safchain: Are all of the patches on the bp/l3-high-availability topic?
15:38:20 <safchain> carl_baldwin, yes
15:38:33 <safchain> bp/l3-high-availability-api
15:38:39 <safchain> bp/l3-high-availability-keepalived
15:38:44 <safchain> bp/l3-high-availability-scheduler
15:39:02 <Swami> #topic General discussion
15:39:25 <carl_baldwin> safchain: I see, so there are a few topics.
15:39:34 <safchain> carl_baldwin, yes
15:39:39 <carl_baldwin> ... but they are all named similarly.
15:39:50 <safchain> carl_baldwin, yes same prefix
15:41:09 <trinaths> hi, any topic for discussion on 3rd party test setup..
15:41:09 <Swami> Folks I do have a hard stop at 7.45PST, if you don't have any other items I would like to summarize the action items and will end the session
15:41:17 <carl_baldwin> Sorry I missed the meeting last week, had a conflict.  There was talk about combining presentations or something.  I didn't know what was being combined from the context in the meeting.
15:41:38 <trinaths> wanted to know the requirements and procedure and working of a 3rd party setup
15:41:49 <Swami> #action safchain: Will update the document
15:42:36 <Swami> #action Swami: will update the document and will try to get it into a single doc for the F2F review.
15:42:47 <carl_baldwin> Which blueprints were to be combined?
15:43:17 <Swami> Carl: Right now we have two different blueprints for DVR, one from safchain and one from me.
15:44:01 <Swami> carl: So it would be great if we could come up with a single blueprint to combine the best of both worlds.
15:44:08 <amuller> Swami: There's also https://blueprints.launchpad.net/neutron/+spec/ovs-distributed-router
15:44:54 <carl_baldwin> What is the link to safchain 's blueprint?
15:44:55 <Swami> amuller: Yes Robin wong is already part of our subteam and we are taking into the consideration the East-West.
15:45:17 <amuller> And there will also be a new idea by me soon. I'll make a draft for the next meeting, hopefully we'll be able to discuss/consider it
15:45:40 <safchain> carl_baldwin, no blueprint just a gdoc for now
15:45:44 <amuller> Basically VRRP A/A, which depends on Sylvain's blueprint
15:45:58 <carl_baldwin> safchain: Thanks, I did see the gdoc.
15:46:08 <carl_baldwin> That clears that up for me.  Thanks.
15:46:13 <Swami> amuller: It would be great if you have any idea pitch it to us as early as possible, because it would be usefull to discuss in the F2F
15:46:40 <amuller> ok
15:46:44 <safchain> carl_baldwin, I will update it by the end of the day
15:46:54 <carl_baldwin> safchain: great
15:47:20 <Swami> amuller: The current sub-team that we are working in is based on the Icehouse summit proposals that was done for East-West and North-South, feel free to join the meeting and communicate with the sub team and we can converge.
15:47:37 <carl_baldwin> Swami: I know you have a hard stop.  That is all from me for now.  Thanks.
15:47:44 <Swami> Folks I need to stop.
15:47:56 <Swami> Thanks for all your input and participation
15:47:58 <Swami> Have a nice day.
15:48:04 <Swami> See you all next week.
15:48:08 <Swami> #endmeeting