20:01:19 <ianw> #startmeeting diskimage-builder
20:01:19 <openstack> Meeting started Thu Jul 27 20:01:19 2017 UTC and is due to finish in 60 minutes.  The chair is ianw. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:22 <openstack> The meeting name has been set to 'diskimage_builder'
20:01:45 <ianw> anyone around?
20:05:19 <ianw> ok, i will work on the assumption no news is good news
20:06:04 <clarkb> I don't really have anything
20:06:14 <clarkb> seems like things have been quiet since suse builds mostly work now
20:08:32 <ianw> ok, just stamp some things in the logs
20:08:40 <ianw> #topic Announcements
20:09:18 <ianw> As clarkb mentioned, i think suse is going ok now and working in gate.
20:09:42 <ianw> F26 is working now too.  one minor issue with selinux setting
20:09:47 <ianw> leading to 2.7.2
20:10:46 <ianw> #link https://review.openstack.org/#/c/482942/
20:11:07 <ianw> we can go ahead with that, and start nodepool builds
20:11:27 <ianw> i would like to run f26 as python3 testing going forward
20:11:58 <ianw> #topic Action items from last meeting
20:12:27 <ianw> #action ianw to investigate if any old branch jobs use dib on trusty
20:12:49 <ianw> not done yet; no pressing need but we should clean up
20:13:01 <ianw> will look at as time permits
20:13:20 <ianw> #action ianw setup 3rd party ci group
20:13:35 <ianw> that was done, ppc added to it
20:15:34 <ianw> #undo
20:15:35 <openstack> Removing item from minutes: #action ianw setup 3rd party ci group
20:15:44 <ianw> ok then
20:15:49 <ianw> #topic Review Review
20:16:32 <ianw> I'm not sure there is anything particularly stuck
20:16:50 <ianw> #link https://review.openstack.org/476732
20:17:03 <ianw> is jamielennox's patch to not use du for size
20:17:14 <ianw> that's actually coming into some stuff yolanda and I are looking at for LVM
20:17:34 <ianw> which is why i haven't pushed on that until i fully understand what's happening there
20:18:43 <ianw> #link https://review.openstack.org/#/c/482396
20:18:57 <ianw> probably should have been clearer i want the nit fixed, marked that
20:19:20 <ianw> #link https://review.openstack.org/487304
20:19:29 <ianw> Switch openSUSE to 42.3 by default
20:20:12 <ianw> i guess that's fine.  the CI mirrors are in place
20:20:29 <ianw> #link https://review.openstack.org/482570
20:20:41 <ianw> fedora-minimal to f26 ... i will take on board the notes in there before we merge that
20:21:06 <ianw> #link https://review.openstack.org/#/c/484541/
20:21:11 <ianw> "enable some off by default checks"
20:22:16 <ianw> i am ambivalent ... will comment.  not clear if this is part of something else
20:24:03 <ianw> #topic Open Discussion
20:24:43 <ianw> prometheanfire says "ianw: I may be tasked with making a coreos ironic image and building it into dib seems like the right choice"
20:25:21 <ianw> so if you're googling "coreos" and "diskimage-builder" and read this, reach out
20:26:31 <ianw> yolanda (mostly) and I will continue work on LVM support
20:26:55 <ianw> there has been some discussion around config file format
20:27:23 <ianw> i've been trying to get good unit tests, with mocked out steps, before engaging with that too much
20:27:55 <ianw> the config format seems secondary to actually making the right calls to pv/vg/lv[create] underneath in the right order, etc
20:34:00 <ianw> i think that's enough then
20:34:34 <ianw> next meeting is scheduled for european 15:00 time
20:34:44 <ianw> aug 10
20:34:50 <ianw> #endmeeting