14:23:03 <mugsie> #startmeeting Designate
14:23:04 <openstack> Meeting started Wed Dec  6 14:23:03 2017 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:23:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:23:07 <openstack> The meeting name has been set to 'designate'
14:23:08 <mugsie> #topic Roll Call
14:23:15 <frickler> o/
14:23:22 * mugsie forgot he changed the time, sorry about that
14:23:35 <frickler> np, /me is patient ;)
14:23:37 <mugsie> #action mugsie add new time to all his calenders
14:23:49 <mugsie> #topic Announcements
14:24:13 <mugsie> #info q2 is tomorrow - if there is any "must have" patches please let me know
14:24:34 <mugsie> #info We *will* have a room at the PTG in Dublin
14:24:46 <mugsie> #topic Open Discussion
14:25:15 <mugsie> any issues / thoughts / from anyone?
14:25:28 <frickler> regarding q-2, not sure how the timeframe for deprecations is, might be good to have https://review.openstack.org/526008 in
14:26:11 <frickler> then I noticed that your dashboard seems kinda broken with the new gerrit and zuul stuff
14:26:15 <frickler> #link http://graham.hayes.ie/designate/dashboard
14:26:26 <frickler> did you generate that by hand or do you have a tool?
14:26:29 <mugsie> oh, wow
14:26:33 <mugsie> there is a tool
14:26:40 <mugsie> let me dig out the link
14:27:06 <mugsie> #link https://github.com/openstack/gerrit-dash-creator
14:27:13 <mugsie> I will update the query :)
14:27:19 <frickler> great
14:27:28 <frickler> and then the new requirements-check is choking up on our "doc/reqs.txt" from 2014
14:27:45 <frickler> advice in #-infra was to just remove that file for now
14:28:15 <mugsie> OK, cool - thats the change to the new PTI I assume?
14:28:29 <frickler> yes
14:28:32 <frickler> #link http://logs.openstack.org/53/516753/3/check/requirements-check/766ab1a/job-output.txt.gz#_2017-12-06_13_10_10_454887
14:28:36 <frickler> that is the failure
14:28:42 <mugsie> so I can blame mordred then ... :)
14:28:52 <frickler> #link https://review.openstack.org/522640
14:29:01 <frickler> that is the patch that introduced it
14:29:26 <frickler> I already blamed AJaeger, they both committed guilty ... kind of ;)
14:29:52 <mugsie> :)
14:30:34 <frickler> final one from me would be regarding https://review.openstack.org/524683
14:30:38 <mugsie> #action mugsie remove docs/requirments.txt
14:31:02 <frickler> I'm not sure that the grenade stuff is working properly there
14:31:30 <frickler> is it really switching from manager to worker mode?
14:31:43 <mugsie> nope - I thought I removed that
14:31:45 <mugsie> damn
14:32:14 <mugsie> (we can't do an upgrade test from one to the other, as grenade uses the config file from the old side in the new side)
14:33:46 <frickler> ah, I assumed that this would be the primary scenario, upgrading from a pike deployment in manager mode to worker things
14:33:56 <mugsie> I need to add disable_services to the grenade plugin config
14:35:07 <mugsie> in pike worker model was the default prefered option, in theory
14:36:15 <mugsie> the 2 -manager services are starting there, but are just failing straight away, and exiting
14:38:02 <frickler> but isn't that more or less the upgrade scenario that we want to happen? except that you could disable them so they don't have to fail?
14:38:32 <mugsie> yeah, they fail in the "old" side as well though
14:39:03 <frickler> ah
14:40:02 <mugsie> let me see what I can figure out
14:40:37 <mugsie> when that merges though, we can say we support https://governance.openstack.org/tc/reference/tags/assert_supports-accessible-upgrade.html
14:41:55 <frickler> oh, that's a pretty short list
14:42:14 <mugsie> yea
14:42:44 <mugsie> most people have not implemented the verify_no_api thing, or requre the API to access things
14:44:01 <mugsie> frickler: do you think you will make over to Dublin ?
14:44:42 <frickler> most likely not due to private reasons, sorry
14:45:40 <mugsie> no problem - I will be putting an etherpad together in a week or so with topic ideas, so please help me fill it :)
14:46:00 <frickler> sure
14:46:39 <mugsie> any other topics?
14:46:48 <frickler> none from me today
14:47:16 <mugsie> great - have a good day :)
14:47:22 <mugsie> #endmeeting