17:00:17 <timsim> #startmeeting designate
17:00:18 <openstack> Meeting started Wed Mar  8 17:00:17 2017 UTC and is due to finish in 60 minutes.  The chair is timsim. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:22 <openstack> The meeting name has been set to 'designate'
17:00:23 <timsim> #topic Roll Call
17:00:29 <blancos> o/
17:00:33 <timsim> o/ blancos
17:00:37 <sonuk> o/
17:00:41 <timsim> ping mugsie kiall
17:00:58 <mugsie> o/
17:01:17 <timsim> #topic Announcements
17:01:42 <timsim> I don't have any announcements, if someone else wants to do something, feel free
17:02:08 * timsim was just stalling while he pulled up other things
17:02:12 <mugsie> I have none :)
17:02:14 <mugsie> heh
17:02:17 <timsim> #topic Action Items from last week
17:02:23 <timsim> Doesn't look like we had any
17:02:26 <timsim> #topic Bug Triage
17:02:45 * timsim waits for his slow internet
17:03:40 <timsim> `we are in the middle of an update, Launchpad will be back in a couple of minutes`
17:03:41 <timsim> cool
17:03:48 <mugsie> its back
17:04:30 <timsim> Alright, doesn't look like any new bugs.
17:04:53 <timsim> Just one for me to look at that I failed to. and one for mugsie to close
17:05:03 <mugsie> https://bugs.launchpad.net/designate-dashboard/+bug/1670102
17:05:03 <openstack> Launchpad bug 1670102 in Designate Dashboard "AngularJS unittest with Jasmine and Karma" [Undecided,In progress] - Assigned to anusree (anusree-a04)
17:05:04 <timsim> #action timsim to look at https://bugs.launchpad.net/designate/+bug/1668290
17:05:04 <openstack> Launchpad bug 1668290 in Designate "First call to designate-worker raise error" [Undecided,New] - Assigned to Tim Simmons (timsim)
17:05:14 <timsim> oops
17:06:16 <timsim> Well. I guess it's good to have angularjs unittest with jasmine and karma
17:06:20 <timsim> I don't know what that is
17:06:29 <mugsie> it JSUnit testing frameworks
17:06:36 <timsim> Well I figured that :P
17:06:39 <mugsie> afaik it is the standard horizon way
17:06:49 <timsim> Cool. I guess triaged med then?
17:06:53 <mugsie> I commented on the review
17:06:54 <mugsie> yeah
17:08:14 <timsim> http://paste.openstack.org/show/601968/
17:08:22 <timsim> #topic Stable Backport Triage
17:08:26 <timsim> my god im messing this up big time
17:08:30 <mugsie> :D
17:08:32 <timsim> #link http://paste.openstack.org/show/601968/
17:08:58 <mugsie> mainly docs
17:09:13 <mugsie> which dont get backported
17:09:16 <timsim> Yeah and the gate was wedged for quite a while
17:09:17 <mugsie> (normally)
17:09:20 <mugsie> ++
17:09:21 <timsim> Alright moving on
17:09:25 <Kiall> hacking?
17:09:35 <Kiall> Didn't the build slaves all get the new version?
17:09:42 <mugsie> Afaik, pbr2.0 is pike on
17:09:51 <mugsie> i *think*
17:09:53 <Kiall> K
17:10:33 <timsim> And there should be a stable requirements change if it's needed right?
17:10:39 <mugsie> yeah
17:10:44 <timsim> #topic Open Discussion
17:10:55 <timsim> Anyone want to bring anything up?
17:11:05 <mugsie> I am good
17:11:21 <Kiall> Me too
17:11:23 <mugsie> I want to spend some off time over the next few days continuing on the list we made in ATL
17:11:32 <timsim> We got some new docs/structure happening. Which is pretty cool https://docs.openstack.org/developer/designate/ https://docs.openstack.org/developer/designate-tempest-plugin/
17:11:56 <Kiall> shiny new theme on the tempest plugin>]
17:12:01 <mugsie> yup
17:12:02 <Kiall> ?*
17:12:09 <asettle> mugsie: lemme know if you need anything
17:12:11 * asettle drops in
17:12:14 <timsim> o/ asettle
17:12:20 <mugsie> we are trying to move all docs to that theme afaik
17:12:33 <timsim> Was it the support matrix that made that difficult mugsie ?
17:12:42 <asettle> Yep, I need to get the requirements of that for you guys
17:12:50 <mugsie> nope - it looks a ton better in the new theme
17:13:22 <mugsie> https://review.openstack.org/#/c/299940/
17:13:45 <mugsie> was my last attempt - but timsim pglbut and Kiall didnt like it
17:13:48 <timsim> Well coolio, maybe we try and get that done this week. Is that ^ all that needs to happen?
17:13:57 <mugsie> basically
17:14:05 * timsim has a hard time believing he was that opinionated about it
17:14:15 <Kiall> mugsie: IIRC, it didn't render half the docs correctly at the time ;)
17:14:28 <timsim> oh yeah that rings a bell
17:14:28 <mugsie> I think the TOCs were weird
17:14:36 <timsim> Well let's update it and see what happens
17:14:40 <mugsie> and the H1's were hidden
17:14:54 <mugsie> but I fixed the theme to allow us add in extra css now
17:15:04 <mugsie> so we can tweak it oursleves if need be
17:15:21 <timsim> Neat-o.
17:15:32 <timsim> Alright then, looks like we're about done.
17:15:36 <mugsie> ++
17:15:43 <timsim> blancos, sonuk anything you'd like to bring up?
17:15:58 <timsim> Any way we can help anything you're doing/want to do?
17:16:29 <sonuk> timsim: nothing from my side.
17:16:35 <blancos> timsim Thanks for asking. Unfortunately, internally we've been a little busy but things are slowing down this week so I'll be able to spend more time on Designate
17:16:57 <timsim> Fair enough, ping us if you have any questions at all!
17:17:02 <blancos> Will do :)
17:17:06 <mugsie> blancos: heh - yeah, that balance is tough to get right :)
17:17:20 <timsim> 🔥 alright, let's give folks some time back shall we
17:17:35 <timsim> Anything else going once...
17:17:38 <timsim> twice....
17:17:48 <timsim> #endmeeting