17:01:00 <mugsie> #startmeeting Designate
17:01:01 <openstack> Meeting started Wed Nov 16 17:01:00 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:05 <openstack> The meeting name has been set to 'designate'
17:01:05 <mugsie> #topic Roll Call
17:01:39 <mugsie> ping timsim Kiall federico3 elarson
17:01:55 <timsim> o/
17:02:29 <mugsie> just you an me I think :(
17:02:54 <mugsie> #topic Bug triage - timsim
17:03:03 <sonuk_> o/
17:03:08 * timsim sighs
17:03:09 <mugsie> sonuk_: o/
17:03:22 <timsim> https://bugs.launchpad.net/designate/+bug/1635006
17:03:22 <openstack> Launchpad bug 1635006 in Designate "V1 record create occasionally fails with db error" [Undecided,New]
17:03:36 <mugsie> yurp
17:03:53 <mugsie> eh, needs investiagtion
17:03:56 <federico3> o/
17:03:58 <mugsie> but High
17:04:07 <mugsie> if it is a code based problem
17:04:14 * timsim wonders if it's a replication thing
17:04:40 <mugsie> timsim: you could be on to some thing
17:05:37 <mugsie> OK, mark as high, comment that we need to investigate?
17:05:44 <timsim> k
17:05:58 <timsim> mugsie: You've still got this one https://bugs.launchpad.net/designate/+bug/1627941
17:05:58 <openstack> Launchpad bug 1627941 in Designate "Zone transfer accept is forbidden for the non admin users " [Undecided,New] - Assigned to Graham Hayes (grahamhayes)
17:06:24 <mugsie> yeah ...
17:06:57 <mugsie> OK, I need to find time this week
17:07:04 <timsim> https://bugs.launchpad.net/designate/+bug/1639307
17:07:04 <openstack> Launchpad bug 1639307 in Designate ""record-list" should be case insensitive" [Undecided,New]
17:07:10 <timsim> Looks like this person is using the old client
17:07:43 <mugsie> yeah, but it is an error in our API (I think ?? )
17:08:07 <mugsie> I think that we will have the same issue in openstack client
17:08:14 <mugsie> move it to the client anyway
17:08:21 <timsim> Probably only in filtering v1?
17:08:25 <timsim> yeah
17:08:38 <timsim> https://bugs.launchpad.net/designate/+bug/1639748
17:08:38 <openstack> Launchpad bug 1639748 in Designate "zone pool attribute + fallback filter not working without attributes" [Undecided,New]
17:08:38 <mugsie> yeah - but filtering is just based down to the DB in both APIs
17:08:59 <mugsie> yeah, triagged + Critical - assign to me
17:09:08 <mugsie> I know the line that needs to change
17:09:31 <timsim> k
17:09:33 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1642268
17:09:33 <openstack> Launchpad bug 1642268 in python-designateclient ""openstack recordset set: error: too few arguments" when not specifying --ttl or use --no-ttl" [Undecided,New]
17:09:44 <mugsie> Saw that come in this morning
17:10:00 <mugsie> Needs to be tested - I know we didnt need it in BCN
17:10:12 <mugsie> oh. set
17:10:13 <mugsie> damn
17:10:24 <mugsie> that could be an issue alright
17:10:27 <timsim> What is set?
17:10:38 <mugsie> update
17:10:52 <timsim> hm. Yeah i don't think I've ever tried that with that cli
17:10:59 <mugsie> (osc has defined keywords)
17:11:06 <mugsie> triagged + Med
17:11:19 <mugsie> and moved to the client
17:11:27 <timsim> k
17:11:47 <timsim> Alright, that's all
17:12:03 <mugsie> k
17:12:09 <mugsie> #topic Backpots
17:12:17 <mugsie> #topic Backports
17:12:30 <mugsie> http://paste.openstack.org/show/589482/
17:12:49 <mugsie> #link http://paste.openstack.org/show/589482/
17:12:53 <mugsie> have a read
17:13:31 <mugsie> 754a572 Merge "Fix for allowing user to create zone other than ending with TLD"
17:13:55 <mugsie> thats it afacs
17:14:18 <timsim> Yeah I was just looking at that one
17:14:21 <timsim> Seems legit
17:14:25 <mugsie> yeah
17:14:46 <mugsie> #action mugsie bp 754a572 Merge "Fix for allowing user to create zone other than ending with TLD"
17:14:58 <mugsie> anything else?
17:15:20 <timsim> Sucks that it goes and gets tlds on every zone create, but oh well.
17:15:32 <mugsie> yeah, seems to be the only way :(
17:15:36 <timsim> Probably the only simple thing to do yeah.
17:15:55 <mugsie> yeah - short of etcd / zk
17:16:04 <timsim> Yeah
17:16:22 <timsim> cool, that's it I think
17:16:25 <mugsie> #topic Ocata 1 Release (mugsie)
17:16:37 <mugsie> We need to cut o-1 tomorrow
17:16:58 <mugsie> so, have a look at the outstanding patches and see if there is anything that needs to merge
17:17:22 <mugsie> I have one  - https://review.openstack.org/#/c/395098/
17:17:24 <mugsie> #link https://review.openstack.org/#/c/395098/
17:17:42 <mugsie> thanks to toabctl for ^
17:17:52 <timsim> Yeah that's great
17:17:57 <mugsie> timsim: can you have a look today at some point?
17:18:02 <timsim> I was going to let Kiall have a look at that, but I can.
17:18:21 <mugsie> yeah - I can ping him as well (he is afk right now)
17:18:37 <mugsie> http://graham.hayes.ie/designate/dashboard
17:18:43 <mugsie> #link http://graham.hayes.ie/designate/dashboard
17:19:13 <mugsie> OK.
17:19:19 <mugsie> #topic Open Discussion
17:19:25 <mugsie> One item - PTG
17:19:35 <mugsie> who thinks that they will be able to go?
17:20:04 <mugsie> ttx is asking us to say yay or nay to a slot in Atlanta
17:20:22 <sonuk_> mugsie: I am not sure.
17:20:48 <mugsie> I can probably make it personally. but if it is only going to be 3 / 4 of us, I am not sure about the value of taking a room
17:21:12 <mugsie> and I can just fly in for the 48 hours needed for cross project work
17:21:31 <timsim> I'm honestly not sure.
17:21:49 <mugsie> sonuk_: its a long flight for you isnt it?
17:21:55 <mugsie> timsim: know that feeling
17:21:59 <sonuk_> mugsie: yep.
17:22:02 <timsim> Do you think Kiall could come? Because otherwise it'd just be the two of us, if I could come
17:22:27 <mugsie> well, I will be travelling on airmiles + hotel points
17:23:17 <mugsie> OK. it sounds like its a reluctant no for us then
17:23:44 <timsim> I guess so :( it seems unlikely that we'll be able to get more than one or two there.
17:23:49 <mugsie> yeah
17:23:57 <timsim> If it turns out we can go, we can probably grab a spot somewhere.
17:24:12 <mugsie> yeah - we should be able to
17:24:22 <mugsie> OK - any other topics?
17:24:32 <sonuk_> mugsie: is there any link of barcelona summit recap?
17:24:43 <mugsie> sonuk_: nope - it is still a draft :(
17:24:52 <mugsie> I will try to finish it today / tomorrow
17:25:07 <sonuk_> mugsie: ok.
17:25:08 <mugsie> sorry - there has been a lot of ... change ... internally recently
17:25:30 <mugsie> that it?
17:25:37 <timsim> I think so
17:25:38 <mugsie> who wants 35mins back?
17:25:42 <timsim> o/
17:25:48 <sonuk_> o/
17:25:51 <mugsie> #endmeeting