17:00:58 <mugsie> #startmeeting Designate
17:00:59 <openstack> Meeting started Wed Sep 28 17:00:58 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:02 <openstack> The meeting name has been set to 'designate'
17:01:06 <mugsie> #topic Roll Call
17:01:19 <timsim> o/
17:01:53 <mugsie> elarson: pglass Kiall federico3 sonu ping
17:01:57 <federico3> o/
17:02:15 <mugsie> #topic Announcements
17:02:29 <mugsie> So, my reign of terror continues - :)
17:02:37 <timsim> :)
17:02:49 <mugsie> RC2 is this week
17:03:08 <mugsie> any patches people thing we need, please propose them, or forever hold your peace
17:03:15 <mugsie> #topic Action Items
17:03:44 <mugsie> mugsie bp 97c5ab3 Merge "Use upper constraints for all jobs in tox.ini"
17:03:48 <mugsie> done
17:03:51 <mugsie> mugsie bp 102f1d2 Infoblox backend:Fixed sslverify value from option
17:03:59 <mugsie> was already done by the proposer
17:04:01 <Krenair> the sshfp backport is up for review
17:04:07 <mugsie> yeap
17:04:25 <mugsie> timsim: Kiall you need to +2 that, I can't and elarson does not have the powers to
17:04:44 <mugsie> #action Kiall timsim - review https://review.openstack.org/#/c/374308/
17:04:45 <Kiall> o/
17:04:52 <mugsie> thats it
17:05:02 <mugsie> #topic Bug Triage (timsim - recurring)
17:05:42 <timsim> https://bugs.launchpad.net/designate/+bug/1627695
17:05:44 <openstack> Launchpad bug 1627695 in Designate "User is able to create record set for the secondary zone" [Undecided,New]
17:05:59 <mugsie> not a bug
17:06:08 <Kiall> ehh - yea, it is?
17:06:14 <timsim> isn't it?
17:06:16 <mugsie> it diodnt error
17:06:22 <Kiall> secondary zones should be read only from the APIU
17:06:24 <Kiall> API*
17:06:27 <mugsie> yeap
17:06:32 <timsim> That's what I thought.
17:06:33 <Kiall> exactly - the issue is that it didn't error out
17:06:38 <timsim> So he shouldn't be able to create that rrset.
17:06:43 <mugsie> update it to "API does not reject wroites to secondary zones"
17:06:56 <Kiall> lol
17:07:00 <Kiall> nit and a half ;)
17:07:16 <timsim> lol ok. Then what tags?
17:07:25 <mugsie> api, high, rc2
17:07:34 <timsim> k
17:07:40 <timsim> https://bugs.launchpad.net/designate/+bug/1627941
17:07:41 <openstack> Launchpad bug 1627941 in Designate "Zone transfer accept is forbidden for the non admin users " [Undecided,New]
17:08:16 <mugsie> hum. would need to see the policy and central logs for this
17:08:22 <timsim> no newton rc2 milestone ?
17:08:58 <mugsie> timsim: refresh :)
17:09:45 <timsim> I'm wondering if this person is not changing tenants before accepting?
17:09:51 <mugsie> yeah
17:09:57 <mugsie> I think that is it
17:10:02 <mugsie> I can reply
17:10:55 <timsim> Alright, this one is similar https://bugs.launchpad.net/designate/+bug/1627943
17:10:56 <openstack> Launchpad bug 1627943 in Designate "Zone transfer fails for the targeted project using non admin creds " [Undecided,New]
17:11:07 <Kiall> Sounds like a dup?
17:11:18 <Kiall> same author
17:11:51 <mugsie> yeah
17:12:00 <mugsie> damn launchpad makes this hard to read
17:12:22 <timsim> I _think_ he's saying that using admin creds to accept the transfer isn't working
17:12:46 <timsim> Or that it's transferred to the admin tenant?
17:12:47 <mugsie> it is working, but the zone was transfered to the admin, not user2
17:12:52 <mugsie> sorry, project2
17:13:05 <timsim> Which is a bug
17:13:13 <Kiall> So it was a targetted transfer, but an admin can accept it to a diff project?
17:13:19 <mugsie> no, admins can override the target-projects
17:13:28 <mugsie> yeah - not ure if a bug or not tbh
17:13:30 <Kiall> Sounds like a policy bug IMO
17:13:33 <mugsie> yeah
17:14:00 <mugsie> med, o1
17:14:04 <timsim> Alright
17:14:12 <timsim> https://bugs.launchpad.net/designate/+bug/1627945
17:14:13 <openstack> Launchpad bug 1627945 in Designate "Zone abandon is not allowed using non admin users" [Undecided,New]
17:14:15 <timsim> docs bug in the client
17:14:35 <Kiall> +
17:14:35 <mugsie> yeah
17:14:38 <mugsie> low, o1
17:14:48 <mugsie> tag as low hanging fruit + docs
17:15:03 <timsim> and transfer to the client?
17:15:10 <mugsie> yeap
17:15:14 <timsim> k. That's all
17:15:20 <mugsie> so, no milestone
17:15:30 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:15:38 <Kiall> #link http://paste.openstack.org/show/583349/
17:15:42 <Kiall> you know the drill ..
17:15:58 <mugsie> 81ca0fe Merge "Add PowerDNS 4 driver
17:16:01 <mugsie> :troll:
17:16:16 <mugsie> nothing really I see
17:16:18 <Kiall> 2b69b54 Merge "Resolve description parameter in v2:set floating ip" ?
17:16:36 <Kiall> (That was description either being ignored on incoming data, or being filtered from outgoing.. cant remember which)
17:16:50 <mugsie> yeah
17:17:07 <mugsie> who wants it?
17:17:26 <mugsie> #action mugsie bp ae6e84810033a02a8c4e6d729958333c682e8b4a Resolve description parameter in v2:set floating ip
17:18:00 <mugsie> any else?
17:18:05 <mugsie> others*
17:18:11 <timsim> I don't think so
17:18:16 <mugsie> k
17:18:24 <mugsie> #topic Design Summit Sessions
17:19:12 <mugsie> #link https://etherpad.openstack.org/p/designate-ocata-summit-planning
17:19:26 <mugsie> please put ideas for sessions in ^
17:19:28 <elarson> sorry folks, I've got a bunch of stuff at home I've been taking care of
17:19:40 <mugsie> we will decide what we are doing early next week
17:19:43 <Kiall> elarson: unacceptable :D
17:20:27 <timsim> aw man i was excited for api v3
17:20:32 <mugsie> it should be fairly quite
17:20:36 <mugsie> quiet*
17:20:41 <mugsie> timsim: propose it :)
17:20:52 <Kiall> -2
17:20:54 <Kiall> :D
17:20:59 <Kiall> wow irc lag
17:21:05 <mugsie> heh
17:21:13 <mugsie> So, who is going?
17:21:19 <Kiall> o/
17:21:22 <timsim> o/
17:21:23 <mugsie> o/
17:21:28 * elarson is staying home
17:21:38 * mugsie must remember to book flights
17:21:44 <mugsie> elarson: :(
17:22:05 <mugsie> #topic Open Discussion
17:22:15 <mugsie> any off agenda topics?
17:22:28 <Kiall> CI wedged, ETA on fixes landing? ;)
17:22:45 <mugsie> requirements patch just merged
17:23:07 <mugsie> will need a +2 on https://review.openstack.org/#/c/378653/1 real soon
17:23:42 <mugsie> Kiall: timsim elarson looking at you guys :)
17:24:01 * elarson can +2 stuff all day
17:24:14 <elarson> mugsie: taking a look now
17:24:33 <mugsie> it just blocks dnspython on py3 from going over 1.12
17:24:49 <mugsie> there should be a fix in 1.15
17:25:36 <mugsie> anything else?
17:25:52 <mugsie> I will be pinging folks for RC2 patches ove rthe next day or so
17:26:04 <mugsie> so, keep an eye out
17:26:22 <mugsie> who wants 23mins back?
17:26:26 <mugsie> 35mins*
17:26:47 <mugsie> i will takje that as yes then
17:27:13 <mugsie> #endmeeting