17:00:43 <mugsie> #startmeeting Designate
17:00:44 <openstack> Meeting started Wed Aug  3 17:00:43 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:47 <openstack> The meeting name has been set to 'designate'
17:01:03 <mugsie> #topic Roll Call
17:01:20 <timsim> o/
17:01:37 <sonuk_> o/
17:02:45 <mugsie> anyone else?
17:02:57 <timsim> pglass rsyed
17:03:10 <mugsie> Kiall:
17:03:13 <timsim> elarson is off today
17:03:16 <Kiall> o/
17:03:17 <mugsie> waster
17:03:24 <mugsie> I see jmcbride turned up :)
17:03:36 <timsim> lurker
17:03:38 <mugsie> #topic Action Items
17:03:46 <mugsie> Kiall to figure out a better BP finding command
17:04:06 <Kiall> I've not found anything better...
17:04:18 <mugsie> OK, cool. we will leave it then
17:04:26 <mugsie> mugsie bp 1687df2 Don't hardcode options we pass to oslo.context
17:04:34 * mugsie has a commit open right now
17:04:50 <mugsie> #topic Bug Triage (timsim - recurring)
17:04:54 * jmcbride lurks
17:05:08 <mugsie> timsim: over to you :)
17:05:18 <timsim> I don't see any new bugs :)
17:05:23 <mugsie> \o/
17:05:26 <timsim> I think a couple got handled during the wekk
17:05:27 <mugsie> evcerything is perfect
17:05:36 <mugsie> apart from my typing
17:05:37 <timsim> Then we didn't file for when I broke evrything
17:05:43 <Kiall> mugsie: sure.. keep telling yerserlf that
17:05:44 <timsim> So everything is awesomeeee
17:05:46 <Kiall> yerself*
17:05:51 <timsim> lol
17:06:02 <mugsie> Stable Backport Triage (kiall - recurring)
17:06:08 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:06:16 <Kiall> #link http://paste.openstack.org/show/547812/
17:06:17 <Kiall> 2 weeks of backports, to try catch everything, as usual.. nominate anything in need of BP'ing
17:06:36 <mugsie> 372057b Fix recordset changes so that they preserve object changes fields ?
17:06:40 <mugsie> :troll:
17:06:47 <Kiall> lol - we'll need the revert too so ;)
17:06:55 <timsim> hardy harr harr
17:07:10 <mugsie> nothing else really there IHMO
17:07:13 <Kiall> efa6d23 Change bind -> bind9 in docs, sample configs - mostly for the sample configs?
17:07:20 <timsim> Got that new one up if you wanna go +A it :troll:
17:07:27 <timsim> Yeah it's for stuff that ended up docs
17:07:36 * timsim didn't think we bp'd those
17:07:44 <mugsie> yeah, in the yaml.
17:07:49 <mugsie> we generally dont
17:07:57 <mugsie> but we can
17:08:00 <Kiall> well, docs dont typically.. but sample configs are busted
17:08:04 <mugsie> yeah
17:08:05 <mugsie> true
17:08:12 <mugsie> OK, bp it is
17:08:16 <mugsie> who wants to do it?
17:08:22 <timsim> I'll do it
17:08:40 * Kiall just hit Ctrl+C on a deployment by mistake :'(
17:08:48 <mugsie> #action timsim bp efa6d23 Change bind -> bind9 in docs, sample configs
17:08:55 <mugsie> Kiall: derp
17:09:04 <Kiall> and it was on the final node
17:09:08 <mugsie> ahaha
17:09:24 <mugsie> that it?
17:09:32 <Kiall> yep]
17:09:33 <timsim> `Cherry pick failed: merge conflict` balls
17:09:40 <mugsie> but of course
17:09:49 <mugsie> #topic Open Discussion
17:09:55 <mpbnka_> https://review.openstack.org/#/c/341398/
17:10:04 <mpbnka_> would like you views on that
17:10:15 <mpbnka_> your*
17:10:51 <mugsie> I am kind of with timsim on this one. It might be a better custom out of tree addition
17:11:02 <mugsie> thoughts?
17:11:08 <mpbnka_> no this is not ddns one
17:11:11 <mpbnka_> this is for tenants
17:11:13 <Kiall> mugsie: is that thinking due to the neutron->designate integration?
17:11:45 <mugsie> yeah. and the complexity, an the fact it can only really create "tenant_id.zone.tld"
17:11:58 <mugsie> and the tenant name is not in the notification
17:12:09 <mugsie> as the*
17:12:19 <timsim> The proposal is basically to change the default sink handler behavior to something else, instead of having a new handler, unless i'm missing something (probable)
17:12:20 <Kiall> mpbnka_: have you looked at / seen the designate<->neutron integrations for namings?
17:12:21 <mpbnka_> we have tenant id in context
17:12:36 <mugsie> mpbnka_: but only the ID
17:12:43 <mugsie> mosty users will not want the ID
17:12:47 <mugsie> they will want the name
17:12:57 <mugsie> which we dont have
17:13:20 <mpbnka_> hmm
17:14:04 <mpbnka_> if tenant name is there can we have a go ahead
17:14:33 <Kiall> It sounds like Neutron->Designate stuff would cover this case, and be more reliable due to it's architecture, was using that ruled out?
17:14:51 <mpbnka_> ok
17:15:02 <mpbnka_> what is this Neutron->Designate stuff
17:15:13 <Kiall> let me dig out a link
17:15:17 <mpbnka_> I am not sure I have gone thorugh it
17:16:04 <Kiall> mpbnka_: http://docs.openstack.org/mitaka/networking-guide/adv-config-dns.html
17:16:19 <mpbnka_> ok thanks, will go through that.
17:16:42 <mpbnka_> and comming back to DDNS stuff
17:16:42 <Kiall> If that does cover the use case, great! No new code needed :) If not, can you update the spec with details of how it falls short and we can circle back to it?
17:16:55 <mpbnka_> ok
17:17:44 <mpbnka_> for DDNS i went throug the comment. I was thinking if we can have zone sync and zone create for that how good can this be.
17:17:59 <mugsie> can we have zone create?
17:18:03 <mpbnka_> but this will work for a single domain
17:18:23 <Kiall> No - DDNS has no mechanism for creating/deleting etc zones
17:18:25 <mpbnka_> yeah current bp i porposed will not be having zone create
17:18:40 <mpbnka_> actually nsupdate
17:18:47 <mugsie> it means that there will be only one project that can make changes to DNS entries
17:19:10 <mpbnka_> no
17:19:42 <mpbnka_> and yes. this works with fixed domain so admin will have that access
17:19:44 <mugsie> honestly, my rule is if the backend can pass our tempest tests, I am OK with it. if it can't I do not think it should be in the project as an offical backend
17:19:59 <mpbnka_> yeah I understand that
17:20:18 <mugsie> this backend will never be able to pass unfortunatly.
17:20:21 <Kiall> I see value in being able to have a "ddns" pool as described there, even if it can't create / delete zones entirely by itself
17:20:24 <mpbnka_> :)
17:20:57 <mugsie> I have no issue with it being written, but as an external backend, that we can link to, but not include
17:22:32 <Kiall> I'm on the fence there, I think it would be a good addition that fills requests weve seen over the years if done right - even if it can't create/delete zones by itself
17:22:43 <mugsie> timsim: thoughts?
17:23:18 <timsim> I'm not opposed to it being included in tree if it's clear in docs/etc that you're going to have to do some hackiness to make it work
17:23:28 <mugsie> i dont think it fills the requests - most DDNS requests have been "support incoming nsupdate"
17:23:44 <Kiall> Ideally, it would be multi-zone (e.g. allow a "create zone" API call to succeed if the backend can check the zone exists on the server (SOA query? dummy create/delete record?)
17:23:58 <Kiall> mugsie: we've had both
17:24:10 <mugsie> buty one much more than the other.
17:24:34 <Kiall> maybe.. hard to remember ;)
17:24:54 <mugsie> I think we should be drawing the line at the tempest tests, personally. as we move in OpenStack, we will be asked to define required APIs
17:25:06 <mpbnka_> ok let me come up with a solution, we can circle back on this. but honestly would like to have it as a backend
17:25:12 <timsim> It does seem odd to have a backend that can't create zones.
17:25:13 <mpbnka_> :)
17:25:17 <mugsie> which will be used to determine if products are "openstack"
17:25:30 <mugsie> I would think  "create zone" would be one of them
17:25:44 <mpbnka_> actually my implementation I am using does not create zones, I will include that
17:26:01 <mpbnka_> may be that helps
17:26:02 <mugsie> mpbnka_: it can be hosted outside of the designate repo
17:26:12 <mugsie> even if the spec does not get approved
17:26:37 <mpbnka_> hmm ok
17:26:44 <mugsie> we support external backend code, not just the backends in the repository
17:27:28 <mpbnka_> yeah I know
17:28:05 <mugsie> OK, see if we can come up with a way to support zone create, and we can circle back
17:28:46 <mugsie> it could be as easy as sticking a message on a queue / email / zaquar that gets an admin to create it, and bumpiong the timeouts
17:29:31 <mpbnka_> yeah will try to achieve that
17:29:38 <Kiall> throwing an idea out there, since DDNS does not support zone create, something else would be "required" .. it could have a "execute this shell script/whatever on zone create/delete" option, which could be a noop, or could do something else
17:30:29 <Kiall> then for tempest and so on, a script can be provided to handle the out of band zone create/deletes, allowing everything to work.. But the script wouldn't  be required, allowing for "We have zero control over the target nameservers"?
17:30:32 <mpbnka_> agreed
17:30:59 <mugsie> OK, we have a plan
17:31:10 <mugsie> mpbnka_: you will update the spec with ^ ?
17:31:25 <mpbnka_> yeah
17:31:30 <mpbnka_> will do that
17:31:30 <timsim> Cool
17:31:36 <mugsie> any other topics?
17:31:42 <mugsie> othe than W-Modle
17:31:46 <mugsie> model*
17:31:48 <timsim> lol
17:31:53 <timsim> Still need to go and update the grenade plugin for that
17:32:03 <mugsie> yeah
17:32:13 <mugsie> but the substantive code can be reviewed
17:32:20 <timsim> I fixed that change that broke everything, so that's up again
17:32:27 <timsim> Nothing else from me though :)
17:32:28 <mugsie> cool
17:32:51 <mugsie> we got crocodile as the logo btw
17:33:02 <timsim> Go Crocs
17:33:33 <mugsie> its prehistoric, and bites back. just like dns :)
17:33:40 <timsim> so fire
17:34:27 <mugsie> anyone have anything else?
17:34:34 <Kiall> nope, not me
17:34:44 <mpbnka_> I am done
17:34:45 <mugsie> or we will call a close and give back 25 mins?
17:35:03 <Kiall> Nah, lets keep everyone here for 25 mins. Everyone must sit in silence.
17:35:05 <mugsie> #endmeeting