17:00:27 <mugsie> #startmeeting Designate
17:00:28 <openstack> Meeting started Wed Jul 20 17:00:27 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:31 <openstack> The meeting name has been set to 'designate'
17:00:35 <mugsie> #topic Roll Call
17:00:39 <Kiall> \o/
17:00:46 <rsyed_home> o/
17:00:50 <timsim> o/
17:00:55 <sonuk> o/
17:01:39 <pglass> o/
17:01:40 <mugsie> #topic Announcments
17:01:58 <mugsie> new v2 UI is under way \o/
17:02:04 <timsim> oh neat
17:02:23 <mugsie> #link https://review.openstack.org/#/c/341182/
17:02:36 <mugsie> thats it so far
17:02:42 <mugsie> #topic Action Items
17:02:53 <mugsie> kiall to figure out a better BP finding command ;)
17:03:16 <mugsie> well?
17:03:19 <Kiall> #action Kiall to figure out a better BP finding command ;)
17:03:25 <mugsie> Kiall bp c906060 Add missing zake lib to t-r` if it's needed
17:03:34 <Kiall> I was doing it last week, and it took too long so settled for 2weeks
17:03:39 <Kiall> mugsie: not needed,
17:03:43 <mugsie> ++
17:03:45 <mugsie> mugsie to stop voulentold'ing people while the are AFK
17:03:52 <mugsie> well, thats just not going to happen
17:04:04 <mugsie> #topic Bug Triage (timsim - recurring)
17:04:13 <timsim> https://bugs.launchpad.net/designate/+bug/1602382
17:04:14 <openstack> Launchpad bug 1602382 in Designate "Status not included in recordset notifications" [Undecided,New]
17:04:43 <mugsie> H + n3
17:04:56 <elarson> O/
17:05:03 <timsim> Quick question on these: can we change the format of them mugsie ?
17:05:08 <mugsie> o/ elarson
17:05:16 <timsim> s/these/notifications
17:05:23 <mugsie> format? eh, we shouldnt
17:05:28 <Kiall> timsim: no, and yes. it depends...
17:05:31 <mugsie> but there is no guarewntees
17:05:46 <mugsie> what do you want to chnage them to?
17:05:48 <timsim> That's what I figured. It sucks because right now we just have the result of the func as the paylod
17:05:56 <timsim> Where it'd be ideal to have the payload be a dict that we could put anything in
17:06:09 <mugsie> (searchlight will murder us if we do)
17:06:09 <Kiall> Well - we have the Domain/Recodset rendered to a Dict as the payload?
17:06:19 <timsim> Only the result of the function
17:06:28 <timsim> So you can't get changes or anything
17:06:44 <Kiall> As in changed ttl from 3600 -> 60 ?
17:06:47 <timsim> It's fine, I was just confirming that we probably shouldn't.
17:06:52 <Kiall> That could be added I think
17:06:53 <timsim> Yeah, or ttl changed at all
17:07:15 <timsim> I've got a downstream patch that puts the function args, and the result as primitives, so you get ALL THE THINGS
17:07:19 <timsim> but it's pretty gross
17:07:29 <mugsie> well ... obj_changed_fields could be included in thery
17:07:36 <mugsie> but maybe circle back to that
17:07:39 <timsim> yeah
17:07:44 <timsim> I was just wondering
17:07:50 <timsim> https://bugs.launchpad.net/designate/+bug/1603808
17:07:51 <openstack> Launchpad bug 1603808 in Designate "Designate setup missing several steps" [Undecided,New]
17:08:13 <mugsie> H, no milestone
17:08:33 <timsim> low-hanging-fruit ?
17:08:36 <mugsie> yeah
17:08:38 <Kiall> ++
17:08:51 <timsim> https://bugs.launchpad.net/designate/+bug/1604402
17:08:51 <openstack> Launchpad bug 1604402 in Designate "designate-tempest-plugin has hardcoded keystone v2 code" [Undecided,New]
17:08:52 <Kiall> Also, I'm not sure it's missing from that page
17:08:57 <Kiall> That feels liuke a post-setup thing
17:09:15 <Kiall> vs a setup thing where you create the NS's etc
17:09:27 <Kiall> Which - is actually now handled by pools.yaml
17:09:31 <mugsie> yeah
17:09:32 <Kiall> So - No longer valid?
17:09:40 <mugsie> it is, as the install guide dopesnt have that yet
17:09:43 <timsim> That page needs updaing
17:09:48 <timsim> To use v2
17:09:50 * mugsie needs to fix his patch
17:10:05 <mugsie> and we need to remove all use of the "designate" command
17:10:13 <Kiall> Update for V2 is diff to to that bug tho? ANyway, sidetrack
17:10:22 <mugsie> yeah
17:10:34 <timsim> Didn't pglass fix this?
17:10:37 <mugsie> bug is correct, ran throught the setup with him in #-dns
17:10:42 <mugsie> eh, not yet afaik
17:11:05 <pglass> i have https://review.openstack.org/#/c/341753/
17:11:29 <mugsie> H n3, assign to pglass :)
17:11:53 <Kiall> gate-tempest-dsvm-designate-powerdns-identity-v3-only-nv    SUCCESS
17:11:58 <timsim> alrighty
17:12:00 <timsim> https://bugs.launchpad.net/designate/+bug/1604893
17:12:00 <openstack> Launchpad bug 1604893 in Designate "inequivalent arg 'durable' for exchange 'designate' in vhost '/': received 'false' but current is 'true'" [Undecided,New]
17:12:08 <mugsie> that just came in
17:12:20 <Kiall> and looks looks like a RMQ setup issue
17:12:44 <Kiall> the exchange is setup as non-durable, but designate has been set to expect a durable.. so RMQ barfs.
17:13:01 <timsim> Can you comment on that Kiall ?
17:13:02 <Kiall> I'll handle + Not a bug a
17:13:06 <Kiall> Not a bug it*
17:13:07 <timsim> cool
17:13:14 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1600775
17:13:14 <openstack> Launchpad bug 1600775 in python-designateclient "'openstack ptr record show' command does contain the appropriate decription for the required argument." [Undecided,New] - Assigned to sonu (sonu-bhumca11)
17:13:46 <mugsie> triage low
17:14:04 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1600781
17:14:04 <openstack> Launchpad bug 1600781 in python-designateclient "Some of the floatingip ptr record's clis are not working" [Undecided,New] - Assigned to sonu (sonu-bhumca11)
17:14:22 <mugsie> eh ... yurp
17:14:37 <mugsie> yeah, H
17:14:57 <timsim> cool. Done :)
17:15:03 <RamT> o/
17:15:18 <mugsie> \o
17:15:29 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:15:35 <Kiall> http://paste.openstack.org/show/538882/
17:15:37 <Kiall> #link http://paste.openstack.org/show/538882/
17:15:43 <Kiall> You know the drill
17:15:55 <mugsie> d0b91a2 Merge "Don't hardcode options we pass to oslo.context"
17:15:59 <Kiall> find + nominate anything in that looks like a BP candidate.
17:16:23 <Kiall> mugsie: mmm, I'd say only if necessary on that one
17:16:35 <Kiall> they reverted that change in oslo.context and blocked 1.6.0 (or 2.6.0)
17:16:39 <Kiall> w/e the version was
17:16:52 <mugsie> did they revert it?
17:16:58 <mugsie> the blocked the version
17:17:04 <mugsie> not sure if there was a revert
17:17:06 <Kiall> I thought I saw a revert?
17:17:35 <mugsie> i think it is a good one to BP, as it can happen at any point
17:18:15 <Kiall> I still think only if necessary :)
17:18:33 <mugsie> any reason why?
17:18:59 <mugsie> the thread indicated that thye considered to_dict an internal interface, and it can change in any version
17:19:04 <Kiall> I doubt o.c. 2.6.0 is going to see use with L/M
17:19:47 <mugsie> https://github.com/openstack/designate/blob/stable/mitaka/requirements.txt#L44
17:20:05 <mugsie> unless someone uses upper constraints, it will
17:20:14 * timsim wonders why those aren't pinned
17:20:17 <Kiall> mm, true I suppose.
17:20:21 <Kiall> they are ;')
17:20:27 <mugsie> ish
17:20:38 <mugsie> if you know the special place to get the list to pin to
17:20:40 <timsim> pinned to _a_ version
17:20:49 <timsim> in req.txt
17:20:57 <mugsie> https://github.com/openstack/requirements/blob/stable/mitaka/upper-constraints.txt
17:20:59 <RamT> I had to pin it to a version so that it doesn't cause problems
17:20:59 <Kiall> https://github.com/openstack/requirements/blob/stable/mitaka/upper-constraints.txt#L213
17:21:17 <timsim> lolpenstack
17:21:28 <Kiall> Packagers wanted it that way..
17:21:47 <mugsie> yeah - there is quite a long back story on it
17:21:49 <Kiall> (Loose rather than hard pins in the project.. Debian ships 1 Django, and 500 packages that use it)
17:22:07 <mugsie> it was just not documented for a while
17:22:35 <mugsie> so, any other suggestions?
17:22:45 <mugsie> or are we sticking to the one?
17:22:51 <timsim> nothin else
17:22:59 <mugsie> #
17:23:02 <mugsie> k*
17:23:18 <mugsie> #action mugsie bp 1687df2 Don't hardcode options we pass to oslo.context
17:23:32 <mugsie> #topic Open Discussion
17:23:40 <mugsie> one item - mascot
17:23:52 <mugsie> has anyone had a chance to come up with ideas?
17:24:06 <timsim> What was that etherpad?
17:24:15 <mugsie> #link https://etherpad.openstack.org/p/designate-mascot
17:24:48 <mugsie> and while my bald head my be a thing of natural beauty - i am not sure the foundation will let us :P
17:24:56 <timsim> boooo
17:25:01 <Kiall> If I had my way, it would be a big letter D, in black fixed with font, on a white background.
17:25:10 <Kiall> #info kiall has zero visual design talent
17:25:20 <mugsie> Kiall: we are all aware of your visual skills
17:25:24 <timsim> When is it due mugsie ?
17:25:27 <mugsie> soon
17:25:37 * timsim will think on it
17:25:44 <elarson> I had no ideas
17:26:03 <timsim> and make pglass think about it, he has a special talent for naming things, perhaps they'll extend to this
17:26:12 <mugsie> put on those thijnking caps
17:26:17 <timsim> I have a thing
17:26:23 <timsim> Can we move this meeting back an hour or two?
17:26:29 <elarson> +1000
17:26:30 <timsim> For half of the year, it's at noon
17:26:32 <timsim> for us
17:26:35 <timsim> which is awful
17:26:36 <mugsie> (I kinda want to keeps the stars thing for Kosmos :P)
17:26:53 <RamT> :P
17:26:55 <mugsie> and you want it at 11?
17:27:12 <mugsie> or 1?
17:27:13 <timsim> 11 would be better (10 during DST)
17:27:19 <rsyed_home> +1
17:27:22 <timsim> We'd have to move rooms
17:27:26 <mugsie> OK, I can look for rooms
17:27:30 <timsim> I think os-meeting-1/2 are free
17:27:39 <mugsie> well, they dont exist
17:27:41 <mugsie> so they are
17:27:42 <Kiall> Anyone against the idea of changing the time?
17:27:43 <mugsie> :P
17:27:45 <timsim> :P
17:27:52 <RamT> nope
17:28:07 <sonuk> nop
17:28:46 <mugsie> OK - I will have a look for somewhere to move to
17:28:47 <RamT> I have a blueprint to discuss
17:28:49 <RamT> https://review.openstack.org/#/c/341398/
17:28:58 <RamT> can you guys look into it?
17:29:41 <mugsie> RamT: so this would create a domain based on the tenant ID?
17:29:50 <RamT> yeah
17:30:05 <RamT> we can specify the domain format in .conf
17:30:19 <Kiall> So - where we had foo.hardcoded.com. befoire, it would be foo.<tenand-uuid>.hardcoded.com. ?
17:30:31 <mugsie> OK.... its interesting
17:30:48 <RamT> something like that
17:30:52 <Kiall> and the .<tenand-uuid>.hardcoded.com. zone would be created automatically, and given to the correct tenant?
17:31:03 <RamT> yes
17:31:11 <elarson> RamT: that could be done at runtime too.
17:31:12 <RamT> for them to change if there are any mistakes
17:31:29 <mugsie> can zones be managed?
17:31:32 <Kiall> yea, the whole "can't touch sink managed records" has been an issue for some people
17:31:36 <RamT> with hardcoded domain tenant's won't be able to change the records once created
17:31:43 <elarson> I only say that because I wrote a tool to do things like this when starting up a process 😉
17:31:44 <mugsie> (marked as managed=true_
17:32:27 <RamT> elarson: we have this issue and has to get operations involved in things
17:32:58 <mugsie> #action all review https://review.openstack.org/#/c/341398/1/specs/newton/tenant-domainid-for-designate-sink.rst
17:33:17 <elarson> RamT: Hit me up in irc and I'll send a link of what I have
17:33:26 <mugsie> I think i need to sit on it for a day or 2, and think about the interactions.
17:33:34 <RamT> ok
17:34:10 <mugsie> any other topics?
17:34:17 <timsim> nothing here
17:34:21 <timsim> Review worker model :P
17:34:24 <Kiall> Anyone free to help me with DIY tonight? ;)
17:34:25 <elarson> I'm good
17:34:39 <mugsie> cool
17:34:46 <mugsie> #endmeeting