17:00:05 <mugsie> #startmeeting Designate
17:00:09 <openstack> Meeting started Wed Mar 16 17:00:05 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:13 <openstack> The meeting name has been set to 'designate'
17:00:13 <mugsie> #topic Rall Call
17:00:44 <mugsie> ping Kiall timsim ekarlso- federico3 pglass
17:00:47 <timsim> o/
17:00:59 <timsim> elarson is playing at SXSW, pglass is on vacation
17:01:04 <timsim> rsyed_away
17:01:08 <Kiall> o/
17:01:11 <federico3> o/o/
17:01:21 <mugsie> #topic Announcements (if any)
17:01:23 <timsim> Our stupid daylight savings time has happened so now this is at noon -_-
17:01:31 <mugsie> timsim: hate that :D
17:01:33 <rsyed> o/
17:01:41 <mugsie> So, we will be RC'ing this week
17:01:43 <Kiall> timsim: it's 5pm rather than 6pm for us now - yay :P
17:02:07 <mugsie> when the 2 patches that my and kiall are finishing up right now merge
17:02:22 <Kiall> (assuming no serious issues found ;))
17:02:28 <mugsie> unless there is any strong objections?
17:02:30 <timsim> The DB stuff looks pretty ready, yeah?
17:02:34 <mugsie> yeah - what Kiall said
17:02:40 <mugsie> its very very close
17:02:49 <Kiall> timsim: the add tables patch? or the whole "to db" thing?
17:02:55 <timsim> The former
17:03:02 <mugsie> that should be good to go
17:03:10 <Kiall> Yea, that should be OK - but not worth merging until the next one is +A'd
17:03:25 <mugsie> #topic Action Items from last week
17:03:34 <Kiall> I'm adding 1 more on top, which will get folded into mugsie's before merge for proper DevStack support
17:03:36 <mugsie> gah, hit enter too soon
17:03:42 <mugsie> any other anouncements?
17:03:58 <mugsie> OK - items from last week
17:04:00 <mugsie> mugsie bp 24c957b
17:04:18 <mugsie> I am holding off on this - I am not sure it should be backported
17:04:26 <mugsie> mugsie backport bb10715 Merge "Fix for TCP connections not sending full content"
17:04:29 <mugsie> done
17:04:40 <mugsie> #topic
17:04:42 <mugsie> Bug Triage (timsim - recurring)
17:04:45 <mugsie> -_-
17:04:50 <mugsie> #topic Bug Triage (timsim - recurring)
17:04:51 <timsim> https://bugs.launchpad.net/designate/+bug/1555624
17:04:52 <openstack> Launchpad bug 1555624 in Designate "Getting ImportError: No module named functionaltests.common" [Undecided,New] - Assigned to Bhavna Saini (imbhavnasaini)
17:05:14 <timsim> I think they're just doing it wrong?
17:05:31 <timsim> I think the official path (in the docs) is export tempest_config and tox -e functinonal?
17:05:32 <mugsie> I saw something about a missing enable_admin_api option somewhere
17:05:45 <mugsie> that didnt exist in Kilo afaik
17:06:22 <mugsie> i can reply with a comment
17:06:42 <timsim> Alrighty.
17:06:56 <timsim> https://bugs.launchpad.net/designate/+bug/1557364
17:06:58 <openstack> Launchpad bug 1557364 in Designate "'openstack tld list' command not working and provides meaningless exception" [Undecided,New]
17:07:21 <Kiall> LP failing to open -_-
17:07:24 <mugsie> move to designateclient
17:07:27 <mugsie> and High
17:07:30 <timsim> +1
17:07:40 <mugsie> that is a mess up on my part
17:07:42 <timsim> https://bugs.launchpad.net/designate/+bug/1557576
17:07:44 <openstack> Launchpad bug 1557576 in Designate "Admin API Quotas not working in designate (kilo & liberty)" [Undecided,New]
17:08:06 <Kiall> That's a doc bug in the end
17:08:17 <venkat_> Hi Team.. this issue (1557576) is with documentation
17:08:33 <mugsie> yeah, rc1 + high
17:08:38 <mugsie> it should be an easy fix
17:08:46 <Kiall> Simple fix, lets just get it into the M docs before we branch :)
17:08:50 <venkat_> we raised it to fix the documentation part in http://docs.openstack.org/developer/designate/rest/admin/quotas.html
17:08:55 <timsim> Cool
17:09:29 <timsim> That's it :)
17:09:42 <Kiall> venkat_: thanks :) Your report is pretty clear about where we messed up :D We can update the docs with your suggestion :)
17:09:58 <venkat_> Thanks kiall
17:10:13 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:10:27 <Kiall> #link http://paste.openstack.org/show/490759/
17:10:27 <Kiall> As usual, take a few mins and nombinate changes for backporting to previous releases.
17:10:41 <mugsie> 8fabf5f Add scheduler for pools :P
17:10:44 <mugsie> (JOKE)
17:10:51 <Kiall> lol
17:10:57 <Kiall> e3ce8e0 Strip "\n" character from result
17:11:00 * timsim almost made the same joke
17:11:07 <Kiall> 2ce080d Do not allow GET /resource.json
17:11:14 <mugsie> Kiall: nope
17:11:17 <Kiall> ^ one might be.. yea
17:11:23 <mugsie> to 2ce080d
17:11:51 <timsim> Por que no mugsie? API change?
17:11:54 <mugsie> don't want to anger the stable-main gods :P
17:11:55 <mugsie> yeah
17:12:04 * timsim probably should have added a release note for that one.
17:12:12 <Kiall> So, we have:
17:12:12 <Kiall> a55e0b7 Merge "Add warning to devstack/README.rst"
17:12:12 <Kiall> e3ce8e0 Strip "\n" character from result
17:12:12 <Kiall> Other than that, I don't see anything suitable+worthwhile to backport
17:12:14 <mugsie> timsim can do it now :)
17:12:18 <timsim> I shall
17:12:32 <mugsie> nope - those 2 look good
17:12:45 <mugsie> anyone wnat to do them?
17:13:07 <Kiall> federico3: want to voulenteer? ;)
17:13:08 <mugsie> dont all jump at once
17:13:15 <federico3> ok :)
17:13:18 <mugsie> :)
17:13:20 <Kiall> volunteer*
17:13:38 <mugsie> #action federico3 back port a55e0b7 Merge "Add warning to devstack/README.rst" & e3ce8e0 Strip "\n" character from result
17:13:44 <timsim> *voluntold*
17:13:44 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:13:53 <mlavalle> mugsie: hi
17:14:04 <Kiall> mlavalle: congrats :)
17:14:13 <mugsie> I think we are just about done with this now :)
17:14:21 <mlavalle> Last week we merged the documentation: https://review.openstack.org/#/c/280957/
17:14:33 <mlavalle> Yes, That was the last little bit
17:14:47 <mlavalle> We are done!
17:14:50 <mugsie> #success mlavalle completed the Nova/Neutron/Designate DNS Integration along with docs + clients
17:14:52 <Kiall> \o/
17:14:54 <openstackstatus> mugsie: Added success to Success page
17:14:54 <timsim> That's amazing!
17:15:08 <Kiall> success page?
17:15:22 <mugsie> #link https://wiki.openstack.org/wiki/Successes
17:15:22 <mlavalle> THanks for all the help!
17:15:41 <mugsie> no problem - thanks for all the work :)
17:15:45 <Kiall> Anyway, mlavalle excellent :) Getting everything landed in Neutron/Nova/Clients/Docs etc was no small feat :)
17:16:06 <mugsie> :)
17:16:11 <mugsie> #topic Summit Workshop
17:16:19 <mlavalle> I'll continue attending this meeting to coordinate for the summit
17:16:53 <mugsie> I will be sending out an email to arrange a time to dicuss the workshop - can people ping me their emails?
17:17:21 <mugsie> I think we should use the same base a previouslyt
17:17:24 <mugsie> #link https://github.com/designate-dns/designate-workshop-packer
17:17:40 <mugsie> just not building it in the hotel the night before
17:17:50 <mugsie> and then copying it to 150 drives
17:18:02 <Kiall> ;)
17:18:07 <mugsie> does next week suit for the first sync?
17:18:27 <Kiall> Drives. Who's offering them up this year?
17:18:35 <mlavalle> it suits me
17:18:35 <Kiall> yea, next week suits for me.
17:18:51 <timsim> I think, based on the epicness of them last year, it has to be you guys :P
17:18:56 <mugsie> I will talk to barclac to see if we can get the printed ones again
17:19:05 <mugsie> but, wont hold my breath
17:19:17 <mugsie> anything else on this?
17:19:35 <Kiall> Nope, Other than, flights booked ;)
17:19:42 <mugsie> #topic Open Bug Triage
17:20:01 <Kiall> having one of those days mugsie?
17:20:17 <mugsie> I want to suggest that this meeting next week be entirely dedicated to looking at the open bugs
17:20:20 <mugsie> (all of them)
17:20:22 <Kiall> #topic Open Discussion is what you wanted ;)
17:20:25 <Kiall> Oh
17:20:33 * Kiall goes back into his corner
17:20:40 * mugsie slaps Kiall with a large trout
17:20:52 <timsim> LOL
17:20:52 <mugsie> what do people think
17:20:59 <timsim> Wow, didn't mean to go all caps.
17:21:03 <mugsie> we have a large back log
17:21:03 <Kiall> mugsie: makes sense to do..
17:21:07 <timsim> That sounds good mugsie
17:21:16 <mugsie> and I would guess that 40% are never getting done
17:21:17 <mugsie> cool
17:21:27 <mugsie> #action mugsie sort out bug triage for next week
17:21:29 * Kiall slaps timsim with a larger trout
17:21:39 <mugsie> #topic Summit Sessions https://etherpad.openstack.org/p/newton-design-designate
17:21:45 <mugsie> link https://etherpad.openstack.org/p/newton-design-designate
17:21:49 <mugsie> #link https://etherpad.openstack.org/p/newton-design-designate
17:22:05 <mugsie> can everyone think about what they want to talk about in Tokyo?
17:22:12 <mugsie> s/Tokyo/Austn/
17:22:26 <Kiall> (I wasn't wrong about "one of those days" ;))
17:22:27 <mugsie> and add it to the etherpad
17:22:32 <timsim> workermodelworkermodelworkermodel :troll:
17:22:52 <Kiall> will do, anyone have this etherpad from last year?
17:22:55 <Kiall> (i.e. stuff we bumped)_
17:23:08 <mugsie> timsim: I agree with you. but it will be the difficult questions like "upgrade"
17:23:43 <mugsie> so, I will have a look and colate them next monday or tuesday
17:23:48 <timsim> I've got https://etherpad.openstack.org/p/mitaka-designate-summit-roadmap  ...
17:23:53 <mugsie> #topic Open Discussion
17:24:19 <mugsie> one item from me - PTL Nominations are open.
17:24:22 <Kiall> etherpad needs a pad search ...
17:24:39 <mugsie> if you feel you would be a good PTL, please nominate yourself
17:25:00 <mugsie> as long as you have commited in the last year, you are elegible
17:25:10 <rsyed> setting a high bar there...
17:25:19 * rsyed kids!
17:25:21 <timsim> rsyed for PTL
17:25:24 <mugsie> rsyed: thems the rules :P
17:25:35 <Kiall> rsyed: the rules are the same for all OpenStack projects ;)
17:25:48 <mugsie> anyone else have any of agenda items
17:25:49 <mugsie> ?
17:26:10 <mugsie> and - if you have any questions about the PTL job, just ping me or drop me an email
17:26:19 <Kiall> None from me
17:26:19 <timsim> Nah. Thanks Kiall and mugsie for tackling those big patches that we need.
17:26:28 <mugsie> np
17:26:31 <Kiall> even if it took a while ;)
17:26:34 <rsyed> +1
17:26:34 <mugsie> :)
17:26:48 <timsim> What's a year, really
17:27:00 <mugsie> timsim: 18months even :P
17:27:05 <Kiall> only a year? it was longer ;)
17:27:12 <mugsie> San Jose was the start
17:27:46 <mugsie> so - does everyone want 30 mins back?
17:27:52 <timsim> Always
17:28:02 <mugsie> #endmeeting