17:00:12 <mugsie> #startmeeting Designate
17:00:13 <openstack> Meeting started Wed Feb 17 17:00:12 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:17 <openstack> The meeting name has been set to 'designate'
17:00:18 <mugsie> #topic Roll Call
17:00:20 <rsyed> o/
17:00:31 <elarson> o/
17:00:31 <sonuk> o/
17:00:46 <pglass> o/
17:00:47 <mugsie> federico3: ekarlso Kiall courtesy ping
17:00:50 <federico3> o/
17:01:03 <timsim> o/
17:01:20 <mugsie> #topic Action Items from last week
17:01:44 <elarson> midcycle was last week!
17:02:02 <mugsie> yup - how are the action items coming from that?
17:02:06 <Kiall> heya
17:02:16 <mugsie> :)
17:02:26 <mugsie> i think we can skip this for this week
17:02:38 <mugsie> #topic Bug Triage (timsim - recurring)
17:02:50 <mugsie> is the meetbot dead
17:02:52 <mugsie> ?
17:02:58 <mugsie> #hrlp
17:03:00 <mugsie> #help
17:03:14 <mugsie> i think it might be
17:03:17 <timsim> Oh well
17:03:22 <mugsie> meh - lets continue
17:03:27 * timsim really needs to investigate https://bugs.launchpad.net/designate/+bug/1516355
17:03:27 <openstack> Launchpad bug 1516355 in Designate ""RecordSet not found" while trying to update NS Pool" [Undecided,New] - Assigned to Tim Simmons (timsim)
17:03:46 <timsim> If someone else has time and wants to do that, feel free, but I'll try and do that this week.
17:04:01 <timsim> https://bugs.launchpad.net/designate/+bug/1541603
17:04:02 <openstack> Launchpad bug 1541603 in Designate "No multiple errors returned simultaniously if there is a invalid record type error" [Undecided,New]
17:04:13 <mugsie> triaged, m3, high
17:04:21 <mugsie> assign to me if it is not assigned
17:04:32 <mugsie> I think I knwo where the error is
17:04:36 <timsim> K
17:04:36 <timsim> https://bugs.launchpad.net/designate/+bug/1543729
17:04:37 <openstack> Launchpad bug 1543729 in Designate "CLI requires domain name to be first, rather than anywhere" [Undecided,New]
17:04:50 <mugsie> high, triaged
17:05:02 <mugsie> nothing liuke a live demo to find bugs
17:05:03 <Kiall> Yea, that was embarassing for mugsie ;)
17:05:07 <timsim> Is that a client bug?
17:05:10 <mugsie> yeah
17:05:10 <Kiall> yea
17:05:14 <timsim> I'll move it
17:05:14 <Kiall> I filed in the wrong place
17:05:23 <mugsie> thats embarassing for Kiall
17:05:30 <timsim> https://bugs.launchpad.net/designate/+bug/1544358
17:05:30 <openstack> Launchpad bug 1544358 in Designate "Designate should 400 on a SPF record data with trailing backlash" [Undecided,New]
17:05:30 <timsim> tsk tsk Kiall
17:05:43 <timsim> Not as embarrassing as writing on a wall though right mugsie?
17:05:49 <Kiall> did a fix go in for that?
17:05:51 <mugsie> damn it
17:05:52 <Kiall> I thought I saw one
17:06:06 <Kiall> timsim: <high-five-gif>
17:06:20 <pglass> Kiall: there was a fix, but that bug remains
17:06:22 <timsim> test for it appears to be failing https://review.openstack.org/#/c/278801/
17:06:41 <Kiall> oh, a test but no fix. OK
17:06:49 <mugsie> OK, High, Triaged
17:06:51 <Kiall> High, 3
17:07:15 <timsim> agreed
17:07:19 <Kiall> Also
17:07:27 <Kiall> does it apply to TXT too?
17:07:35 <Kiall> I'd bet it does
17:07:56 <pglass> actually I think it doesn't
17:08:14 <Kiall> Wel- SPF rdata is defined as "go look at the TXT defintion"
17:08:51 <Kiall> So, there's likely a bug somewhere (us or dnspython) if the data is treated differently.
17:08:58 <pglass> ummm, well i had tests using the same dataset for both spf and txt recordsets.
17:09:36 <mugsie> ok - add the potential for issues in TXT to the bug, and whoewver fixes it should test both
17:09:47 <Kiall> +
17:09:55 <timsim> cool
17:10:05 <timsim> This one...https://bugs.launchpad.net/designate/+bug/1546437
17:10:05 <openstack> Launchpad bug 1546437 in Designate "Unable to restart the keystone services" [Undecided,New]
17:10:08 <timsim> https://bugs.launchpad.net/designate/+bug/1546437
17:10:16 <Kiall> lol
17:10:36 <Kiall> Move to keystone?
17:10:43 <timsim> Sure
17:10:48 <mugsie> Its a bug in our contrib/vagrant
17:10:50 <mugsie> so, no
17:10:57 <Kiall> how is it a bug in that?
17:11:11 <mugsie> it breaks in that. not in clean devstack
17:11:25 <mugsie> therefor, a problem in ours.
17:11:26 <Kiall> CentOS?
17:11:32 <Kiall> we dont have CentOS in contrib/vagrant...
17:11:51 <Kiall> It's 100% not us
17:11:58 <mugsie> oh, i have seen it this week in our devstack plugin in anycase
17:12:15 <mugsie> using the contib/vagrant
17:12:27 <Kiall> Yea, we pull in the keystone code..
17:12:28 <elarson> fwiw, I have to comment out the centos bits in the contrib/vagrant Vagrantfile to get it to build
17:12:35 <elarson> not sure if that is releated
17:12:38 <Kiall> Move to keystone ;)
17:12:41 <elarson> related*
17:12:43 <Kiall> elarson: you mean fedore?
17:12:46 <Kiall> fedoar?
17:12:49 <mugsie> its not keystone
17:12:49 <Kiall> wow
17:12:57 <elarson> yeah federer
17:13:17 <elarson> corell linux
17:13:23 <Kiall> keystones requirements are not specifing tightly enough the oslo.config version they need.. the trace is clealy keystone code.
17:14:01 <mugsie> they specify them exactly like us ;)
17:14:06 <mugsie> from global reqs
17:14:29 <stevemar> looks like we should bump the minimum for global requirements
17:14:49 <Kiall> Okay.. I'm still at a loss what we can do about the keystone devstack code and/or keystone code and/or keystone requirements?
17:14:49 <Kiall> It's not a designate issue ;)
17:14:50 <Kiall> stevemar++
17:15:19 <mugsie> we can see why it fails when using our contrib/vagrant and not in openstack-dev/devstack
17:15:28 <stevemar> looks like it should be 3.2.0 at minimum: https://github.com/openstack/oslo.config/commit/f5e2fab3ae5af5bd47fe3526a73f13fbaa27c1f0
17:15:58 <Kiall> mugsie: all we do in vagrant is clone devstack and prep a localrc, it not related.
17:16:03 <stevemar> hmm... global requirements already has a minimum... 3.4.0
17:16:05 <stevemar> https://github.com/openstack/requirements/blob/master/global-requirements.txt#L95
17:16:31 <mugsie> it could tbe the localrc
17:16:47 <mugsie> that is also in the docs, (linked in verbatim)
17:16:49 <stevemar> wha... liberty version...
17:17:01 <stevemar> we didn't use "deprecated_reason" in liberty
17:17:31 <mugsie> ah. we may not be specifiying the brannch in our localrc then
17:17:38 <mugsie> the example localrc
17:18:03 <stevemar> yeah, something mucky going on there
17:18:05 <mugsie> anyway - I will look at it this week
17:18:06 <stevemar> i'll comment
17:18:19 <timsim> Alright, I'll assign to you mugsie
17:18:24 <mugsie> #action mugsie to look at bug/1546437
17:18:30 <mugsie> lets move on
17:18:30 * stevemar remains quiet
17:18:40 <timsim> That's all the bugs
17:18:49 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:18:54 <mlavalle> mugsie: hi
17:18:56 <mugsie> mlavalle: over to you
17:19:01 <mlavalle> thanks
17:19:21 <mlavalle> Last week we merged the code for Nova and its unit tests
17:19:36 <mlavalle> so we are really in the home stretch of this effort
17:19:56 <Kiall> (cake)
17:20:06 <mugsie> great :)
17:20:09 <mlavalle> Last night I pushed for review the chapter I am adding to the OpenStack Networking Guide
17:20:29 <mlavalle> https://review.openstack.org/#/c/280957
17:20:39 <mugsie> i saw that - it is in my reading list :)
17:20:48 <mlavalle> I added Kiall and mugsie to the reviewers
17:21:10 <mlavalle> Last night it passed Jenkins tests and I am already getting reviews
17:21:14 <Kiall> Yea, I saw it pop by this morning, but haven't dig in yet
17:21:18 <Kiall> dug*
17:21:29 <timsim> That's awesome mlavalle
17:21:32 <mlavalle> so, we will make Mitaka
17:21:41 <mugsie> \o/
17:21:46 <mugsie> do we need to add anything to clients ?
17:21:56 <Kiall> yea, mlavalle thats excellent :)
17:22:03 <elarson> w00t. that's right, I just said w00t
17:22:17 <mlavalle> mugsie: I am adding support to the Neutron client
17:22:31 <mugsie> cool - thats all we should need, right?
17:22:37 <mlavalle> it's a minor thing. Excpect a commit over the next couple of days
17:22:44 <mlavalle> mugsie: yeah, that's all
17:22:46 <Kiall> We also exposed a bug in nova ;) It was generating invalid host names for display name inputs..
17:22:59 <mlavalle> Kiall: yeah, that was great
17:23:13 <Kiall> I'm just glad the fix wasn't a revert since it was gate breaking ;)
17:23:28 <mlavalle> Kiall: btw, thanks for your help. I was away on vacation
17:23:31 <mlavalle> that day
17:23:37 <mugsie> yeah, lucky it was only intermitent
17:23:48 <Kiall> I don't think I helped? lol
17:24:04 <mlavalle> that's all I have for today
17:24:04 <Kiall> I don't remember helping!
17:24:18 <mlavalle> Kiall: you were present and rechecked one of the patchsets
17:24:38 <mugsie> any more questions for mlavalle ?
17:24:39 <Kiall> oh, fair enough .. :)
17:24:52 <mlavalle> thanks guys!
17:24:58 <Kiall> Nope, just \o/ - years in the making and nearly wrapped up thanks to mlavalle :)
17:25:09 <mugsie> ok - thanks mlavalle !
17:25:12 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:25:18 <Kiall> http://paste.openstack.org/show/487301/
17:25:25 <Kiall> 2 weeks of changes this week, due to midcycle
17:25:26 * mlavalle runs to another meeting
17:25:50 <Kiall> As usual, take a few.. nominate anything we need to backport
17:25:54 <mugsie> 0022fd8 Ensure ZoneManager emits valid objects
17:26:18 <Kiall> 24c957b Merge "Added Keystone and RequestID headers to CORS middleware"? maybe? did that exist in L?
17:27:09 <mugsie> no, and that is a feature
17:28:03 <mugsie> any others?
17:28:03 <Kiall> Well - CORS middleware landed in L I think
17:28:52 <mugsie> did it?
17:28:56 <mugsie> huh
17:29:00 <mugsie> so it did
17:30:10 <mugsie> eh, it can go back, I am not pushed either way
17:30:18 <Kiall> And, it's broke when you actually try use it
17:30:18 <Kiall> (that fix fixes it..)
17:30:18 <timsim> That it then?
17:30:19 <Kiall> So, any others?Just the 1? the 2?
17:30:21 <Kiall> this thing on?
17:30:33 <Kiall> wow - IRC lag and a half..
17:30:38 <timsim> yeah I'm super lagged
17:30:49 <mugsie> wow
17:31:06 <Kiall> SO.. where were we? lol.. just the 2? just the 1
17:31:08 <Kiall> ?
17:31:08 <mugsie> that just sploded with loads of text
17:31:11 <mugsie> yeah, just 2
17:31:17 <federico3> freenode was netsplitting during the day
17:31:26 <Kiall> #action kiall to BP 0022fd8 Ensure ZoneManager emits valid objects
17:31:37 <Kiall> any takers on the other?
17:31:42 <Kiall> Easier for me to BP my own chnage ;')
17:31:47 <mugsie> yeah, looks like wherever irccloud connects from is dying atm
17:31:53 <mugsie> i will do the cors one
17:31:55 <Kiall> K
17:32:06 <mugsie> #action mugsie bp 24c957b
17:32:16 <Kiall> (not that the bot is recording anything ;))
17:32:25 <mugsie> #topic sonuk: tempest plugin implementation
17:32:33 <mugsie> sonuk: around?
17:32:39 <sonuk> yes
17:32:50 <mugsie> how are you getting on with the tempest plugin?
17:33:04 <mugsie> do you need anything from anyone?
17:33:04 <sonuk> i  did it locally its working fine .
17:33:25 <sonuk> i need to move functional test to plugin
17:34:15 <mugsie> OK, cool
17:34:24 <sonuk> i  did it locally its working fine .
17:34:25 <mugsie> #topic Open Discussion
17:34:27 <Kiall> IRCcloud fail ^
17:34:45 <mugsie> any off agenda items?
17:34:53 <Kiall> yea, small one..
17:34:54 <timsim> Vote for summit talks?
17:34:58 <elarson> +1
17:35:02 <pglass> sonuk: if you can submit the plugin by itself, then I can help move functional tests over
17:35:20 <Kiall> I split some of the non pool conf -> DB specific changes out of that patch, so we can start landing stuff as I write more code/tests etc
17:35:21 <elarson> fyi, I've started passing people on the left in the hallways. thanks hpe
17:35:35 <Kiall> elarson: lol, always pass on the left!
17:36:10 <mugsie> Kiall: cool. there is one there that is failing (and I need :P )
17:36:19 <mugsie> the AttributeList one
17:36:33 <sonuk> pglass: thanks. i can move it as i have done it locally and its working fine
17:36:34 <Kiall> heh, I'll fix.
17:36:56 <mugsie> I should be updating the scheduler today at somepoint
17:37:29 <mugsie> anything else?
17:37:47 <mugsie> or am i just lagged and talking to myself
17:37:47 <Kiall> not me from
17:37:50 <Kiall> WTF
17:37:57 <Kiall> I can't type today at all
17:38:17 <mugsie> I have a real big wall beside me - if I wrote on that would people see it? :P
17:38:31 <Kiall> I would...
17:38:33 <mugsie> might be more effient than freenode right now
17:39:00 <timsim> lol. I think we're all done here.
17:39:05 <mugsie> cool
17:39:09 <mugsie> #endmeeting