17:03:24 <mugsie> #startmeeting Designate
17:03:26 <openstack> Meeting started Wed Jan 13 17:03:24 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:30 <openstack> The meeting name has been set to 'designate'
17:03:30 <mugsie> #topic roll call
17:03:32 <Kiall> o/
17:03:34 <timsim> o/
17:03:41 <elarson> o/
17:03:43 <sonuk> o/
17:03:52 <mugsie> federico3: ekarlso ??
17:03:59 <pglass> o/
17:04:07 <Kiall> the HP folks are all doing double duty, on a all-hands call too.. Sorry for any distraction in advance ;)
17:04:18 <mugsie> #topic Action Items from last week
17:04:24 <federico3> o/
17:04:26 <mugsie> kiall to file bug re update_status unnecessarily calling out to get_serial (see IRC meeting logs)
17:04:40 <mugsie> Kiall: ?
17:04:45 <Kiall> Ehh, nope. totally forgot
17:04:49 <mugsie> #action kiall to file bug re update_status unnecessarily calling out to get_serial (see IRC meeting logs)
17:04:52 <Kiall> (kept typing the same typo over + over)
17:04:55 <mugsie> federico3 look at 1531294
17:05:05 <mugsie> that was done, afaik.
17:05:20 <Kiall> yea, fixed + merged
17:05:28 <mugsie> all review https://review.openstack.org/#/c/258621/
17:05:32 <mugsie> so, some of us did
17:05:40 <timsim> :)
17:05:43 <mugsie> but, please people have a look.
17:05:45 <Kiall> I've read it a few times over
17:05:56 <mugsie> it is important :)
17:05:58 <Kiall> Really need to see the from now -> there path to have anything meaningly
17:06:09 <Kiall> as, I agree with the end state, but am concerned about how we get there
17:06:11 <mugsie> that sounds like a review :P
17:06:34 <mugsie> #topic Bug Triage (timsim - recurring)
17:06:36 <rsyed> o/ (late)
17:06:49 * timsim still needs to investigate https://bugs.launchpad.net/designate/+bug/1516355
17:06:50 <openstack> Launchpad bug 1516355 in Designate ""RecordSet not found" while trying to update NS Pool" [Undecided,New] - Assigned to Tim Simmons (timsim)
17:07:02 <timsim> https://bugs.launchpad.net/designate/+bug/1517839
17:07:03 <openstack> Launchpad bug 1517839 in neutron "Make CONF.set_override with paramter enforce_type=True by default" [Undecided,In progress] - Assigned to caoyue (yue-cao)
17:07:47 <Kiall> Looks reasonable + small
17:07:57 <Kiall> Med -> M2/M3
17:08:02 <mugsie> ++
17:08:07 <timsim> k
17:08:13 <timsim> https://bugs.launchpad.net/designate/+bug/1532802
17:08:14 <openstack> Launchpad bug 1532802 in Designate "Example unti test case run doucment has to be updated" [Undecided,New] - Assigned to naggappan (naggappan)
17:08:22 <federico3> mugsie: is https://bugs.launchpad.net/designate/+bug/1531294 to be backported?
17:08:23 <openstack> Launchpad bug 1531294 in Designate "periodic_sync_seconds cannot be set to None (in order to sync everything)" [Medium,Fix released] - Assigned to Federico Ceratto (federico-ceratto)
17:08:32 <timsim> I think mugsie interacted with the other bug he references there (invalid)
17:08:45 <mugsie> timsim: I did
17:09:01 <Kiall> timsim: re 1532802 - low / m3?
17:09:15 <mugsie> yeah, low m3
17:09:25 <mugsie> and mark it confirmed
17:09:30 <timsim> https://bugs.launchpad.net/designate/+bug/1532852
17:09:31 <openstack> Launchpad bug 1532852 in Designate "[Docs] Example API calls are missing metadata" [Undecided,New]
17:09:56 <mugsie> Med - m3
17:10:01 <Kiall> ^
17:10:17 <mugsie> federico3: i think so - but it will be on the list from Kiall in a sec
17:10:22 <timsim> https://bugs.launchpad.net/designate/+bug/1532925
17:10:22 <openstack> Launchpad bug 1532925 in Designate "Import/Exports have no total_count metadata" [Undecided,New]
17:10:42 <mugsie> H, M3
17:11:00 <Kiall> yea, it seems important to fix that :)
17:11:11 <mugsie> yeah
17:11:13 <timsim> agreed
17:11:27 <timsim> https://bugs.launchpad.net/designate/+bug/1533193
17:11:28 <openstack> Launchpad bug 1533193 in Designate "SQLAlchemy implicit unicode conversion" [Undecided,New]
17:11:38 <mugsie> Med, M3
17:12:00 <Kiall> theres also a patch up, not sure if it's 100% of the implicit conversions tho
17:12:14 <timsim> alright
17:12:15 <mugsie> federico3: is it all of them, or just some?
17:12:18 <Kiall> federico3: is that it all of them, or just some?
17:12:27 <timsim> O.o
17:12:40 <mugsie> ?
17:12:52 <Kiall> he must be AFK again on the all-hands
17:12:55 <federico3> uhm?
17:12:57 <Kiall> any more timsim/
17:12:58 <Kiall> ?*
17:13:01 * mugsie is confused
17:13:02 <timsim> yeah
17:13:04 <timsim> https://bugs.launchpad.net/designate/+bug/1533299
17:13:06 <openstack> Launchpad bug 1533299 in Designate "Wildcard NS records are not allowed by backend like BIND" [Undecided,New] - Assigned to James Li (james-li-3)
17:13:19 <mugsie> I saw a tweet about this
17:13:33 <mugsie> I dont think that they are valid, are they?
17:13:38 <Kiall> Oo, that's .. yea. that's a bug. likely more than just NS records too
17:13:39 <mugsie> Kiall: you are a walking RFC
17:13:50 <Kiall> mugsie: wildcard isn't a RFC thing
17:14:00 <mugsie> C - M3 then
17:14:15 <federico3> mugsie, Kiall: you mean my CR? That fixes other warnings, the Unicode conversions are still to be fixed
17:14:23 <Kiall> federico3: ah
17:14:28 <timsim> https://bugs.launchpad.net/designate/+bug/1533301
17:14:29 <openstack> Launchpad bug 1533301 in Designate "No TTL shown up after a successful record creation" [Undecided,New]
17:14:29 <Kiall> mugsie: ++
17:14:36 * mlavalle joins meeting late :-(
17:14:48 <mugsie> not a bug
17:14:55 <timsim> Re: ^^ some preview users of ours thought this was weird
17:15:00 <Kiall> yea, i want to sat that's a featue?
17:15:05 <mugsie> if ttl is set to null it inherits from the domain
17:15:14 <Kiall> How do you tell if changing the domain TTL will change a record or not?
17:15:17 <timsim> mugsie: Which is also weird
17:15:21 <Kiall> lol
17:15:59 <timsim> It should probably at least show the TTL of the zone, if it inherits?
17:16:11 <mugsie> but, we need to show that it is inherited
17:16:15 <mugsie> some how.
17:16:21 <Kiall> timsim: I guess it's not 100% intuative, though, I'm not sure we can change that field. Maybe add a "inherited_tll: BLA" when it's inherating?
17:16:35 <mugsie> anyway - not a bug, and might be an API change, so I would prefer a spec
17:16:39 <mugsie> personally
17:16:41 <mugsie> :)
17:16:57 <Kiall> Yea, it would be an API change to fix :/
17:17:02 <mugsie> not a bug in the "as-designed" sense
17:17:03 <federico3> what would happen if the domain TTL is changed?
17:17:04 <timsim> I mean, I think we'd be fine if it just showed the TTL. Rather than having a null TTL.
17:17:22 <pglass> yeah, why not just allow a default ttl that's non-null
17:17:28 <Kiall> timsim: but, that means there's no mechanism to see which records will be affected by changing the domains TTL
17:17:37 <mugsie> timsim: but we need a way for users to know what TTLs will change when the zones TTL changes
17:17:50 <Kiall> e.g. if the domain has a TTL = 60, and recordA has TTL=None, and recordB has TTL=60.
17:18:00 <timsim> How about just a default record TTL?
17:18:19 <timsim> ayo jbratton
17:18:21 <Kiall> If we replace the NULL with 60, the user has no way to tell that changing the domain TTL will affect recordA but not recordB
17:18:25 <mugsie> it is a default ttl, on a per zone basis
17:18:34 <jbratton> timsim: what's up?
17:18:34 <federico3> what's the advantage of inheritance over default?
17:18:48 <timsim> jbratton: Would you want a default record TTL to be different from a default zone ttl?
17:18:53 <federico3> if the domain TTL is changed, do we immediatly update all records with TTL=None?
17:18:58 <mugsie> it is the same as a zone file if you do not specify the TTL for the record
17:19:17 <mugsie> federico3: no, we update the zone ttl, and the DNS server will do that
17:19:27 <jbratton> timsim: nope, doesn't matter to me, I'd just like the default to be propagated and visible on the records
17:19:36 <mugsie> http://www.zytrax.com/books/dns/apa/ttl.html
17:20:00 <Kiall> jbratton: makes sense.. timsim maybe we circle back in open discussion at the end ;)
17:20:06 <timsim> Sure.
17:20:13 <mugsie> we are ok, keep it heree IMO
17:20:58 <mugsie> i think the route forward is to spec out a way of showing the value that will be used, and indicating that it is inherited from the zone
17:21:14 <jbratton> it just seemed counterintuitive to me that you could remove the TTL setting from a record to get back to the default
17:21:25 <jbratton> but absolutely agreed on just documenting it out
17:21:28 <mugsie> jbratton: thats how you do it in Bind ;)
17:21:38 <federico3> users might get confused over inheritance VS default
17:21:53 <jbratton> federico3: yeah, that's the part I am concerned with
17:22:03 <mugsie> timsim: you want to organise the effort for that?
17:22:11 <jbratton> I'd say just as long as it is documented and clear
17:22:14 <mugsie> and we can circle back next week?
17:22:31 <timsim> Effort being: figure out what we want to do about this?
17:22:36 <mugsie> yeah
17:22:52 <mugsie> we will have a few options
17:23:05 <timsim> Sure.
17:23:10 <mugsie> starting with docs only update all the way to API change
17:23:31 <timsim> Alright, moving on then.
17:23:31 <timsim> https://bugs.launchpad.net/designate/+bug/1533402
17:23:33 <openstack> Launchpad bug 1533402 in Designate "More record validation is needed" [Undecided,New]
17:23:39 <mugsie> well, that is true
17:23:44 <Kiall> lol
17:24:05 <timsim> These were a couple other things jbratton brought up that BIND9 will reject a zone for
17:24:18 <mugsie> yeah - H, M3
17:24:27 <Kiall> re (3) SSHFP record allowed -0 as fp_type
17:24:44 <Kiall> 0 is reserved, but, not necessarily always invalid.
17:25:00 <timsim> He might mean minus0
17:25:11 <Kiall> i.e. should we have to made a code change for ever new supported algorithm?
17:25:50 <Kiall> Ah, well.. I have no clue how JSON/Python interact with a -0. lol
17:26:15 <jbratton> yeah, I was surprised about the -0 being allowed, and BIND didn't like it :)
17:26:24 <james_li> the validator type is now 'integer', wonder if there is 'non-negative integer' :)
17:26:32 <Kiall> jbratton: oh, it actually goes all the way through?
17:26:38 <jbratton> oh yeah, it tried to send it along
17:26:41 <Kiall> james_li: you add on a min / max valiator
17:26:48 <mugsie> james_li: I diont think there is, but we cna make one
17:26:52 <james_li> its there now
17:26:55 <Kiall> jbratton: nice. That's, heh.
17:27:04 <timsim> But yeah, I mean if there's a certain corpus of valid values, our validation should only let those through.
17:27:09 <jbratton> don't even know what made me think to test that :)
17:27:18 <Kiall> typo? ;)
17:27:23 <jbratton> haha, we'll go with that
17:27:32 <Kiall> Anyway, H->M2/3.. It's clearly no good.
17:27:37 <timsim> cool
17:27:39 <mugsie> M3
17:27:42 <timsim> That's it :)
17:27:51 <mugsie> (m2 is being cooked as we speak)
17:27:54 <Kiall> :)
17:28:06 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:28:14 <mlavalle> mugsie: hi
17:28:16 <mugsie> mlavalle: you were here with time to spare :)
17:28:42 <mlavalle> mugsie: we made good progress this week
17:28:57 <Kiall> (hamster) <-- this looks better in HipChat)
17:29:17 <mugsie> I saw good reviews coming in on the patch alright
17:29:19 <elarson> Kiall: if you could see it in emacs it would blow your mind (emo)
17:29:26 <mlavalle> I moved all the REST calls to designate out of Neutron core plugin transaction, tested all the code and pushed for review
17:30:20 <mlavalle> Yeserday I got a review from carl_baldwin. He was generally pleased. The next big step will be to also move all the REST to designate out of the L3 service plugin
17:30:32 <mlavalle> this service plugin implements floating ips
17:30:58 <mlavalle> this will take 2 or 3 days. After that, I will push again and I think we will be very close to the end
17:31:19 <mugsie> mlavalle: great. thanks for all the work you have put in on this
17:31:27 <Kiall> ^ x2
17:31:38 <mlavalle> glad to be here and be of help :-)
17:31:56 <mugsie> any questions?
17:32:00 <mlavalle> I am really enjoying.
17:32:06 <mlavalle> Learning a lot on top of that
17:32:28 <mugsie> :)
17:32:34 <mlavalle> that's all for me today
17:32:41 <mugsie> OK, thanks mlavalle
17:32:44 <mugsie> #topic sonuk: Blueprint for designate-bandit: https://review.openstack.org/#/c/26092
17:32:54 <mugsie> sonuk: I saw you were here
17:33:01 <sonuk> yep
17:33:20 <mugsie> do you want to give an overview of this spec?
17:33:25 <sonuk> mugsi: I hve submitted some patch
17:33:35 <sonuk> mugsie: I hve submitted some patch
17:33:57 <mugsie> #link https://review.openstack.org/#/c/260925
17:34:20 <Kiall> also
17:34:21 <Kiall> #link https://review.openstack.org/#/c/266671/
17:34:26 <Kiall> #link https://review.openstack.org/#/c/266721
17:34:54 <Kiall> sonuk: so, nobody last week really knew anything about bandit, other than it does some kinda of security testing?
17:35:12 <mugsie> yeah - what does this do to designate to test our service?
17:35:29 <sonuk> kiall: yep its a security analyzer
17:35:44 <timsim> It generates some pretty cool reports...one of our security guys ran it on Designate at some point.
17:36:07 <mugsie> so it does static analysis on the code? cool.
17:36:31 <sonuk> kiall: yes it does it on python code base
17:36:32 <mugsie> OK, if we are all OK with this, and it doesnt break the gate, I say we get it merged asap?
17:36:32 <federico3> it's blacklist based: it applies a set of critearias looking for known code smells, e.g. and hardcoded password, suspicious SQL generation...
17:37:09 <mugsie> timsim: Kiall can we try and merge it by end of week?
17:37:15 <Kiall> sonuk: So, with the set of rules in your patch, is it passing today?
17:37:25 <pglass> i can get ccneil to look at it too
17:37:28 <Kiall> (i.e. if we merge, and merge the gate changes, are we blocked :))
17:37:43 <timsim> http://i.imgur.com/ftrkICC.png
17:37:43 <sonuk> kiall: yes . but i need to work on infra side.
17:37:57 <timsim> But yeah, we should merge
17:38:00 <mugsie> pglass: yeah, he looked at it before from what I remember
17:38:05 <Kiall> Cool, so long as it's passing, OK seeing it go in as a gate
17:38:35 <mugsie> #action cores review bandit patch
17:38:40 <mugsie> #topic sonuk: tempest plugin implementation
17:38:50 <mugsie> and another one for you sonuk :)
17:39:09 <mugsie> was this something you wanted us to talk about, or did you want to put forward an idea/
17:39:12 <mugsie> ?*
17:39:23 <sonuk> mugsie: yep. I am working on that
17:39:42 * mugsie didnt relaise there was a plugin interface till last week :)
17:40:05 <Kiall> Cool, It'd be great to have it tied into tempest properly, now that they have a plugin interface! We keep hitting silly gate issues, which it seems this helps fix
17:40:12 <mugsie> OK, great. do you need anything from us for it? or was this a heads up that is on the way?
17:40:24 <mugsie> it is great to have it :)
17:41:03 <mugsie> ok, any questions for sonuk ?
17:41:24 <mugsie> if not .... thanks for all the work sonuk :)
17:41:26 <Kiall> Nope, happy to see it ;)
17:41:36 <mugsie> #topic Open Discussion
17:41:43 <Kiall> ehem.
17:41:53 <mugsie> ?
17:41:57 <Kiall> #topic Backports ;)
17:42:09 <mugsie> i was just testing you
17:42:14 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:42:15 <Kiall> #link http://paste.openstack.org/show/483788/
17:42:16 <elarson> !m mugsie
17:42:17 <openstack> elarson: Error: "m" is not a valid command.
17:42:19 <Kiall> Sure you were...
17:42:29 <mugsie> 100% ... not
17:42:44 <Kiall> As usual, take a few mins to review changes landed since last week, nominate anything that needs backporting
17:42:59 <Kiall> 6fa134a Merge "Update periodic-sync-seconds help"
17:43:21 <Kiall> 51b4869 Merge "Tox: ignore Rope dirs" - maybe? seems harmless either way.
17:44:30 <mugsie> thats it I think
17:44:34 <mugsie> both look good
17:44:50 <Kiall> both are tiny, and federico3's, mind doing the cherry-picks federico3?
17:44:56 <timsim> agreed
17:44:56 <federico3> no prob
17:45:14 <mugsie> #action federico3 backpoort 6fa134a and 51b4869
17:45:19 <mugsie> ok then
17:45:26 <mugsie> #topic Open Discussion
17:45:29 <Kiall> ehem...
17:45:47 <Kiall> kidding, you didn't forget anything - again ;)
17:45:56 <mugsie> any one have any off agenda items?
17:46:27 <mugsie> going once
17:46:35 <mugsie> .... twice
17:46:40 <mugsie> and .....
17:46:48 <mugsie> gone!
17:47:01 <Kiall> Cya :)
17:47:05 <mugsie> OK, enjoy the rest of the day everyone - have 15 mins back
17:47:08 <mugsie> #endmeeting